aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2005-11-01 00:16:47 +0000
committerPeter Pentchev <roam@FreeBSD.org>2005-11-01 00:16:47 +0000
commit01408def1b030d1fcb240f2b9f1e5cbc15fc8e2a (patch)
tree376f7c9f386129cad8f9702966ec039ded3b88f8 /textproc
parentd5d6dba8e34c16219cf1dffcfccd0abfeb80c55b (diff)
Explicitly specify unzip as a build dependency, do not just hope it will
be left over from the extract stage. [1] Clean up the build/install interaction - remove a slew of files at the build stage, do not modify the work tree during the installation. Reported by: pointyhat via kris [1]
Notes
Notes: svn path=/head/; revision=146874
Diffstat (limited to 'textproc')
-rw-r--r--textproc/s5/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/textproc/s5/Makefile b/textproc/s5/Makefile
index 94fbf38c5b10..5888f9c084d1 100644
--- a/textproc/s5/Makefile
+++ b/textproc/s5/Makefile
@@ -14,6 +14,8 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
MAINTAINER= roam@FreeBSD.org
COMMENT= A simple HTML-based presentation system
+BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
+
USE_ZIP= yes
WRKSRC= ${WRKDIR}
@@ -23,11 +25,11 @@ S5_SUBDIRS= pix primer s5-blank ui
do-build:
cd ${WRKSRC} && ${UNZIP_CMD} s5-blank.zip
${SED} -e "s,/usr/local,${PREFIX}," ${FILESDIR}/s5-blank.sh > ${WRKDIR}/s5-blank.sh
+ ${FIND} ${WRKDIR} -type f -name .DS_Store -delete
do-install:
${MKDIR} ${S5_DIR}
${CP} ${WRKDIR}/*.html ${S5_DIR}/
- ${FIND} ${WRKDIR} -type f -name .DS_Store -delete
.for i in ${S5_SUBDIRS}
${CP} -Rp ${WRKDIR}/$i/ ${S5_DIR}/$i/
.endfor