aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-09-10 13:15:47 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-09-10 13:15:47 +0000
commit4a3bebcae1b693cbd2080fc861c87e36af4f8bc4 (patch)
tree3c6875e1915991a70b5d02b799e17418d20b218a /textproc
parente1bfdfbe5665c963621e06f6bbfbbc2c000a804e (diff)
Add EXAMPLES options to ports that should have one.
Also various fixes related to said option. PR: 230864 Submitted by: mat exp-runs by: antoine
Notes
Notes: svn path=/head/; revision=479407
Diffstat (limited to 'textproc')
-rw-r--r--textproc/apache-solr3/Makefile2
-rw-r--r--textproc/metauml/Makefile2
-rw-r--r--textproc/py-xlwriter/Makefile2
-rw-r--r--textproc/ruby-rdtool/Makefile2
-rw-r--r--textproc/tex2im/Makefile2
-rw-r--r--textproc/xerces-j/Makefile2
-rw-r--r--textproc/xom/Makefile2
7 files changed, 10 insertions, 4 deletions
diff --git a/textproc/apache-solr3/Makefile b/textproc/apache-solr3/Makefile
index 671a9ac0289a..f2f4d4c1fa2e 100644
--- a/textproc/apache-solr3/Makefile
+++ b/textproc/apache-solr3/Makefile
@@ -24,6 +24,8 @@ CPE_PRODUCT= solr
CPE_VENDOR= apache
NO_ARCH= yes
+OPTIONS_DEFINE= EXAMPLES
+
do-install:
cd ${WRKSRC}/dist && ${COPYTREE_SHARE} . ${STAGEDIR}${JAVAJARDIR}
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
diff --git a/textproc/metauml/Makefile b/textproc/metauml/Makefile
index 0037645a2af5..4ab469808690 100644
--- a/textproc/metauml/Makefile
+++ b/textproc/metauml/Makefile
@@ -32,7 +32,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}_lib
PORTDOCS= ${PORTNAME}_manual_${PORTVERSION}.pdf
PORTEXAMPLES= *.1 *.jpg *.mp lop lop.html lop.pdf lop.tex
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS EXAMPLES
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/${MPDIR}
diff --git a/textproc/py-xlwriter/Makefile b/textproc/py-xlwriter/Makefile
index ef0f71606cec..69f028a38eab 100644
--- a/textproc/py-xlwriter/Makefile
+++ b/textproc/py-xlwriter/Makefile
@@ -16,6 +16,8 @@ USE_PYTHON= distutils autoplist
PORTEXAMPLES= *
+OPTIONS_DEFINE= EXAMPLES
+
post-install:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${FIND} ${WRKSRC}/examples -type f -exec ${INSTALL_DATA} {} ${STAGEDIR}${EXAMPLESDIR} \;
diff --git a/textproc/ruby-rdtool/Makefile b/textproc/ruby-rdtool/Makefile
index cde135906286..b405ca77923e 100644
--- a/textproc/ruby-rdtool/Makefile
+++ b/textproc/ruby-rdtool/Makefile
@@ -24,7 +24,7 @@ RUBY_MODNAME= rd
DOCS_EN= README.rd doc/rd-draft.rd
DOCS_JA= README.rd.ja doc/rd-draft.rd.ja
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS EXAMPLES
post-install:
${MKDIR} ${STAGEDIR}${RUBY_SITELIBDIR}/rd
diff --git a/textproc/tex2im/Makefile b/textproc/tex2im/Makefile
index 9df1be9be6c2..9815828cdac0 100644
--- a/textproc/tex2im/Makefile
+++ b/textproc/tex2im/Makefile
@@ -20,6 +20,8 @@ PORTEXAMPLES= example1.png example1.tex example2.png example2.tex \
example3.png example3.tex example4.png example4.tex \
fig_1.eps
+OPTIONS_DEFINE= EXAMPLES
+
post-patch:
@${REINPLACE_CMD} -e "s,^#!/bin/bash,#!${LOCALBASE}/bin/bash,g" ${WRKSRC}/tex2im
diff --git a/textproc/xerces-j/Makefile b/textproc/xerces-j/Makefile
index 4cce8e4bff5d..b9ea2465fb23 100644
--- a/textproc/xerces-j/Makefile
+++ b/textproc/xerces-j/Makefile
@@ -26,7 +26,7 @@ JARFILES= xercesImpl.jar xml-apis.jar
PLIST_FILES= ${JARFILES:S,^,%%JAVAJARDIR%%/,}
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS EXAMPLES
do-install:
@${ECHO_MSG} -n ">> Installing JAR files in ${JAVAJARDIR}..."
diff --git a/textproc/xom/Makefile b/textproc/xom/Makefile
index c8fe407a4499..8c2eb38088c5 100644
--- a/textproc/xom/Makefile
+++ b/textproc/xom/Makefile
@@ -18,7 +18,7 @@ JAVA_VERSION= 1.6+
NO_BUILD= yes
WRKSRC= ${WRKDIR}/XOM
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS EXAMPLES
PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
PORTDOCS= overview.html apidocs