aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-12-21 00:15:32 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-12-21 00:15:32 +0000
commit7604ffa39904e0618c9848be3f93fd765e9484d0 (patch)
tree1d0480e67954985668ec9efe730c7a0a2d0b624b /textproc
parent0c0376da37393c54b2cfeb061612a35b9d2ab075 (diff)
downloadports-7604ffa39904e0618c9848be3f93fd765e9484d0.tar.gz
ports-7604ffa39904e0618c9848be3f93fd765e9484d0.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/romdict/Makefile32
-rw-r--r--textproc/romdict/distinfo3
-rw-r--r--textproc/romdict/files/pkg-message.in8
-rw-r--r--textproc/romdict/pkg-descr4
-rw-r--r--textproc/romdict/pkg-plist3
6 files changed, 51 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 6fbeadd26060..1ee59e70eb14 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -634,6 +634,7 @@
SUBDIR += rman
SUBDIR += ro-aspell
SUBDIR += roap
+ SUBDIR += romdict
SUBDIR += rot
SUBDIR += rotix
SUBDIR += rtf2html
diff --git a/textproc/romdict/Makefile b/textproc/romdict/Makefile
new file mode 100644
index 000000000000..d7c2440840b2
--- /dev/null
+++ b/textproc/romdict/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: romdict
+# Date created: 2005-12-18
+# Whom: Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com>
+#
+# $FreeBSD$
+# $Tecnik: ports/textproc/romdict/Makefile,v 1.1 2005/12/18 23:40:33 itetcu Exp $
+
+PORTNAME= romdict
+PORTVERSION= 0.5
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTFILES= eng-rom-${PORTVERSION}
+
+MAINTAINER= itetcu@people.tecnik93.com
+COMMENT= Dictd database for Eng-Ro dictionary
+
+RUN_DEPENDS= ${LOCALBASE}/sbin/dictd:${PORTSDIR}/net/dictd
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+SUB_FILES= pkg-message
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/dictd
+ ${INSTALL_DATA} ${WRKSRC}/eng-rom.dict.dz ${PREFIX}/lib/dictd/
+ ${INSTALL_DATA} ${WRKSRC}/eng-rom.index ${PREFIX}/lib/dictd/
+
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/textproc/romdict/distinfo b/textproc/romdict/distinfo
new file mode 100644
index 000000000000..f75bc4b0105b
--- /dev/null
+++ b/textproc/romdict/distinfo
@@ -0,0 +1,3 @@
+MD5 (eng-rom-0.5) = f5c41c2bc664a07d42f6bfd378bcdd25
+SHA256 (eng-rom-0.5) = 980983717074cb9aea2ff190306f2c4aa7fc96d1afa6489c18dda746fc57fc65
+SIZE (eng-rom-0.5) = 21493
diff --git a/textproc/romdict/files/pkg-message.in b/textproc/romdict/files/pkg-message.in
new file mode 100644
index 000000000000..f62e3bbf72a3
--- /dev/null
+++ b/textproc/romdict/files/pkg-message.in
@@ -0,0 +1,8 @@
+===============================================================================
+To enable your new dictionary add to your
+%%LOCALBASE%%/etc/dictd/conf the lines
+database romdict { data "%%PREFIX%%/lib/dict/eng-rom.dict.dz"
+ index "%%PREFIX%%/lib/dict/eng-rom.index" }
+and run:
+%%LOCALBASE%%/etc/rc.d/dictd.sh restart
+===============================================================================
diff --git a/textproc/romdict/pkg-descr b/textproc/romdict/pkg-descr
new file mode 100644
index 000000000000..3df9bb7f05f7
--- /dev/null
+++ b/textproc/romdict/pkg-descr
@@ -0,0 +1,4 @@
+The RomDict project includes (for now) only an English -- Romanian dictionary.
+This port installs it in the data format for use with dictd server.
+
+WWW: http://romdict.sourceforge.net/
diff --git a/textproc/romdict/pkg-plist b/textproc/romdict/pkg-plist
new file mode 100644
index 000000000000..ac2ede2d8908
--- /dev/null
+++ b/textproc/romdict/pkg-plist
@@ -0,0 +1,3 @@
+lib/dictd/eng-rom.dict.dz
+lib/dictd/eng-rom.index
+@unexec rmdir %D/lib/dictd 2>/dev/null || true