aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2009-09-16 15:20:17 +0000
committerKoop Mast <kwm@FreeBSD.org>2009-09-16 15:20:17 +0000
commit869d16f3422df8a4123285f3d610f580efe9c2fa (patch)
tree48965d4c0420bd32efbddfe445347272cacec508 /textproc
parent16e66b73ba7423e836670e54e9e62188e355dda1 (diff)
downloadports-869d16f3422df8a4123285f3d610f580efe9c2fa.tar.gz
ports-869d16f3422df8a4123285f3d610f580efe9c2fa.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/libxml2/Makefile2
-rw-r--r--textproc/libxml2/files/patch-parser.c16
2 files changed, 17 insertions, 1 deletions
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index 100bff072348..5e24cda8b6b9 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -13,7 +13,7 @@
PORTNAME= libxml2
PORTVERSION= 2.7.4
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= textproc gnome
MASTER_SITES= ftp://fr.rpmfind.net/pub/libxml/ \
ftp://gd.tuwien.ac.at/pub/libxml/ \
diff --git a/textproc/libxml2/files/patch-parser.c b/textproc/libxml2/files/patch-parser.c
new file mode 100644
index 000000000000..5813507f7fe7
--- /dev/null
+++ b/textproc/libxml2/files/patch-parser.c
@@ -0,0 +1,16 @@
+--- parser.c.orig 2009-09-16 17:00:06.000000000 +0200
++++ parser.c 2009-09-16 17:01:07.000000000 +0200
+@@ -10130,8 +10130,12 @@ xmlParseDocument(xmlParserCtxtPtr ctxt)
+ /*
+ * Check for the XMLDecl in the Prolog.
+ * do not GROW here to avoid the detected encoder to decode more
+- * than just the first line
++ * than just the first line, unless the amount of data is really
++ * too small to hold "<?xml version="1.0" encoding="foo"
+ */
++ if ((ctxt->input->end - ctxt->input->cur) < 35) {
++ GROW;
++ }
+ if ((CMP5(CUR_PTR, '<', '?', 'x', 'm', 'l')) && (IS_BLANK_CH(NXT(5)))) {
+
+ /*