aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-07-14 18:42:04 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-07-14 18:42:04 +0000
commitffb7170399b77f34a48875ad6468eb796f00aed3 (patch)
tree3a1e4c5d813ec945366f43d48f94fa325ba0ead9 /textproc
parentc60af5b21ccf5bfc632b51afe126bbc7dac29ddd (diff)
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/apertium/Makefile8
-rw-r--r--textproc/exmpp/Makefile2
-rw-r--r--textproc/fcitx-m17n/Makefile4
-rw-r--r--textproc/groonga/Makefile8
-rw-r--r--textproc/hhm/Makefile2
-rw-r--r--textproc/lemmatizer2/Makefile2
-rw-r--r--textproc/libnxml/Makefile4
-rw-r--r--textproc/libxml++26/Makefile2
-rw-r--r--textproc/p5-HTML-CTPP2/Makefile2
-rw-r--r--textproc/p5-XML-CanonicalizeXML/Makefile2
-rw-r--r--textproc/pecl-ctemplate/Makefile2
-rw-r--r--textproc/pecl-enchant/Makefile2
-rw-r--r--textproc/pecl-wbxml/Makefile2
-rw-r--r--textproc/pecl-xdiff/Makefile2
-rw-r--r--textproc/pecl-yaml/Makefile2
-rw-r--r--textproc/py-libtre/Makefile2
-rw-r--r--textproc/py-pyctpp2/Makefile2
-rw-r--r--textproc/py-qt4-xml/Makefile2
-rw-r--r--textproc/py-qt4-xmlpatterns/Makefile2
-rw-r--r--textproc/rtfx/Makefile4
-rw-r--r--textproc/ruby-sary/Makefile2
-rw-r--r--textproc/ruby-xmlparser/Makefile2
-rw-r--r--textproc/rubygem-augeas/Makefile2
-rw-r--r--textproc/rubygem-zmq/Makefile2
-rw-r--r--textproc/scim-openvanilla/Makefile2
-rw-r--r--textproc/xalan-c/Makefile2
26 files changed, 35 insertions, 35 deletions
diff --git a/textproc/apertium/Makefile b/textproc/apertium/Makefile
index ec312c11b855..b667dd46d383 100644
--- a/textproc/apertium/Makefile
+++ b/textproc/apertium/Makefile
@@ -12,10 +12,10 @@ COMMENT= A toolbox to build shallow-transfer machine translation systems
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
-LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2 \
- xslt:${PORTSDIR}/textproc/libxslt \
- lttoolbox3:${PORTSDIR}/textproc/lttoolbox \
- pcre.3:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= libxml2.so:${PORTSDIR}/textproc/libxml2 \
+ libxslt.so:${PORTSDIR}/textproc/libxslt \
+ liblttoolbox3.so:${PORTSDIR}/textproc/lttoolbox \
+ libpcre.so:${PORTSDIR}/devel/pcre
APVER= 3.2
APREV= 0
diff --git a/textproc/exmpp/Makefile b/textproc/exmpp/Makefile
index 97f4e8e24007..89927f3fe76b 100644
--- a/textproc/exmpp/Makefile
+++ b/textproc/exmpp/Makefile
@@ -13,7 +13,7 @@ COMMENT= Fast and scalable library for XMPP written in Erlang/OTP
BUILD_DEPENDS= erlc:${PORTSDIR}/lang/erlang
RUN_DEPENDS= erl:${PORTSDIR}/lang/erlang
-LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2 \
+LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2 \
libxml2.so:${PORTSDIR}/textproc/libxml2
GNU_CONFIGURE= yes
diff --git a/textproc/fcitx-m17n/Makefile b/textproc/fcitx-m17n/Makefile
index c547e1b040e7..9b17da4f5d15 100644
--- a/textproc/fcitx-m17n/Makefile
+++ b/textproc/fcitx-m17n/Makefile
@@ -11,8 +11,8 @@ DIST_SUBDIR= fcitx
MAINTAINER= lichray@gmail.com
COMMENT= Multilingualization support for Fcitx
-LIB_DEPENDS= fcitx-config:${PORTSDIR}/chinese/fcitx \
- m17n:${PORTSDIR}/devel/m17n-lib
+LIB_DEPENDS= libfcitx-config.so:${PORTSDIR}/chinese/fcitx \
+ libm17n.so:${PORTSDIR}/devel/m17n-lib
USE_XZ= yes
USES= cmake gettext pkgconfig
diff --git a/textproc/groonga/Makefile b/textproc/groonga/Makefile
index f929c2192dd7..3a743b199e14 100644
--- a/textproc/groonga/Makefile
+++ b/textproc/groonga/Makefile
@@ -44,7 +44,7 @@ CONFIGURE_ARGS+= --disable-document
.if ${PORT_OPTIONS:MMECAB} || exists(${LOCALBASE}/lib/libmecab.so)
CONFIGURE_ARGS+= --with-mecab
-LIB_DEPENDS+= mecab:${PORTSDIR}/japanese/mecab
+LIB_DEPENDS+= libmecab.so:${PORTSDIR}/japanese/mecab
PLIST_SUB+= MECAB=""
.else
CONFIGURE_ARGS+= --without-mecab
@@ -55,9 +55,9 @@ PLIST_SUB+= MECAB="@comment "
CONFIGURE_ARGS+= --with-libevent=${LOCALBASE} \
--with-message-pack=${LOCALBASE} \
--enable-zeromq
-LIB_DEPENDS+= event-1.4:${PORTSDIR}/devel/libevent \
- msgpack:${PORTSDIR}/devel/msgpack \
- zmq:${PORTSDIR}/net/libzmq2
+LIB_DEPENDS+= libevent-1.4.so:${PORTSDIR}/devel/libevent \
+ libmsgpack.so:${PORTSDIR}/devel/msgpack \
+ libzmq.so:${PORTSDIR}/net/libzmq2
PLIST_SUB+= SUGGEST=""
.else
CONFIGURE_ARGS+= --without-libevent \
diff --git a/textproc/hhm/Makefile b/textproc/hhm/Makefile
index 35b19f9417d6..94559b8e13b5 100644
--- a/textproc/hhm/Makefile
+++ b/textproc/hhm/Makefile
@@ -10,7 +10,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= HTML Help Maker
-LIB_DEPENDS= lzxcomp.1:${PORTSDIR}/archivers/liblzxcomp
+LIB_DEPENDS= liblzxcomp.so:${PORTSDIR}/archivers/liblzxcomp
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/textproc/lemmatizer2/Makefile b/textproc/lemmatizer2/Makefile
index c44add51996f..030dae670620 100644
--- a/textproc/lemmatizer2/Makefile
+++ b/textproc/lemmatizer2/Makefile
@@ -15,7 +15,7 @@ DISTFILES= lemmatizer2-2.0.1.tar.gz \
MAINTAINER= ports@FreeBSD.org
COMMENT= Russian / German / English lemmatizer library
-LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
USES= cmake
diff --git a/textproc/libnxml/Makefile b/textproc/libnxml/Makefile
index 11a563890f6b..e9539c36574b 100644
--- a/textproc/libnxml/Makefile
+++ b/textproc/libnxml/Makefile
@@ -9,9 +9,9 @@ MASTER_SITES= http://www.autistici.org/bakunin/libnxml/ \
http://nivi.interfree.it/distfiles/${PORTNAME}/${PORTVERSION}/
MAINTAINER= nivit@FreeBSD.org
-COMMENT= A C library for writing XML 1.0/1.1 files or streams
+COMMENT= C library for writing XML 1.0/1.1 files or streams
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/textproc/libxml++26/Makefile b/textproc/libxml++26/Makefile
index 69ec14deeb53..f97354d137c4 100644
--- a/textproc/libxml++26/Makefile
+++ b/textproc/libxml++26/Makefile
@@ -19,7 +19,7 @@ PLIST_SUB= VERSION="2.6" API_VERSION="2.6"
LATEST_LINK= libxml++26
-LIB_DEPENDS= glibmm-2.4.1:${PORTSDIR}/devel/glibmm
+LIB_DEPENDS= libglibmm-2.4.so:${PORTSDIR}/devel/glibmm
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
USES= gmake pathfix pkgconfig
diff --git a/textproc/p5-HTML-CTPP2/Makefile b/textproc/p5-HTML-CTPP2/Makefile
index 05995bb520d6..ddc256a067c2 100644
--- a/textproc/p5-HTML-CTPP2/Makefile
+++ b/textproc/p5-HTML-CTPP2/Makefile
@@ -13,7 +13,7 @@ MAINTAINER= reki@reki.ru
COMMENT= Perl interface module to CTPP2 library
BUILD_DEPENDS= ctpp2>=2.5.1:${PORTSDIR}/textproc/ctpp2
-LIB_DEPENDS= ctpp2:${PORTSDIR}/textproc/ctpp2
+LIB_DEPENDS= libctpp2.so:${PORTSDIR}/textproc/ctpp2
USES= perl5
USE_PERL5= configure
diff --git a/textproc/p5-XML-CanonicalizeXML/Makefile b/textproc/p5-XML-CanonicalizeXML/Makefile
index 9bc0b20a14c4..78a0f7611a7e 100644
--- a/textproc/p5-XML-CanonicalizeXML/Makefile
+++ b/textproc/p5-XML-CanonicalizeXML/Makefile
@@ -12,7 +12,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Extension for inclusive/exclusive canonicalization of XML
-LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2
+LIB_DEPENDS= libxml2.so:${PORTSDIR}/textproc/libxml2
USES= perl5
USE_PERL5= configure
diff --git a/textproc/pecl-ctemplate/Makefile b/textproc/pecl-ctemplate/Makefile
index 63478b2eecef..eb808060eb4b 100644
--- a/textproc/pecl-ctemplate/Makefile
+++ b/textproc/pecl-ctemplate/Makefile
@@ -13,7 +13,7 @@ DIST_SUBDIR= PECL
MAINTAINER= vanilla@FreeBSD.org
COMMENT= A PECL extension for Google ctemplate library
-LIB_DEPENDS= ctemplate.2:${PORTSDIR}/textproc/google-ctemplate
+LIB_DEPENDS= libctemplate.so:${PORTSDIR}/textproc/google-ctemplate
USE_XZ= yes
USE_PHP= yes
diff --git a/textproc/pecl-enchant/Makefile b/textproc/pecl-enchant/Makefile
index a0fb2580ef94..81bc32dc82b2 100644
--- a/textproc/pecl-enchant/Makefile
+++ b/textproc/pecl-enchant/Makefile
@@ -12,7 +12,7 @@ DIST_SUBDIR= PECL
MAINTAINER= miwi@FreeBSD.org
COMMENT= Libenchant Binder that Support Near All Spelling Tools
-LIB_DEPENDS= enchant.1:${PORTSDIR}/textproc/enchant
+LIB_DEPENDS= libenchant.so:${PORTSDIR}/textproc/enchant
CONFIGURE_ARGS+=--with-enchant=${LOCALBASE}
diff --git a/textproc/pecl-wbxml/Makefile b/textproc/pecl-wbxml/Makefile
index e98b8e568f9a..3b909459fc70 100644
--- a/textproc/pecl-wbxml/Makefile
+++ b/textproc/pecl-wbxml/Makefile
@@ -12,7 +12,7 @@ DIST_SUBDIR= PECL
MAINTAINER= flo@FreeBSD.org
COMMENT= A PECL extension that provides WBXML conversion capabilities
-LIB_DEPENDS= wbxml2.0:${PORTSDIR}/textproc/wbxml2
+LIB_DEPENDS= libwbxml2.so:${PORTSDIR}/textproc/wbxml2
CONFIGURE_ARGS= --with-wbxml=${LOCALBASE} \
--with-libexpat-dir=${LOCALBASE}
diff --git a/textproc/pecl-xdiff/Makefile b/textproc/pecl-xdiff/Makefile
index 80f549a01803..f9ec52cd2aaf 100644
--- a/textproc/pecl-xdiff/Makefile
+++ b/textproc/pecl-xdiff/Makefile
@@ -14,7 +14,7 @@ COMMENT= A PECL extension to create/apply binary and text patches
LICENSE= PHP301
-LIB_DEPENDS= xdiff.0:${PORTSDIR}/textproc/libxdiff
+LIB_DEPENDS= libxdiff.so:${PORTSDIR}/textproc/libxdiff
USE_PHP= yes
USE_PHPEXT= yes
diff --git a/textproc/pecl-yaml/Makefile b/textproc/pecl-yaml/Makefile
index b8f4382c691a..7d23e8e65351 100644
--- a/textproc/pecl-yaml/Makefile
+++ b/textproc/pecl-yaml/Makefile
@@ -12,7 +12,7 @@ DIST_SUBDIR= PECL
MAINTAINER= miwi@FreeBSD.org
COMMENT= YAML-1.1 parser and emitter
-LIB_DEPENDS= yaml:${PORTSDIR}/textproc/libyaml
+LIB_DEPENDS= libyaml.so:${PORTSDIR}/textproc/libyaml
USE_PHP= yes
USE_PHP_BUILD= yes
diff --git a/textproc/py-libtre/Makefile b/textproc/py-libtre/Makefile
index 8861cc45672e..6f03780d5b0a 100644
--- a/textproc/py-libtre/Makefile
+++ b/textproc/py-libtre/Makefile
@@ -13,7 +13,7 @@ DISTNAME= tre-${PORTVERSION}
MAINTAINER= bf@FreeBSD.org
COMMENT= Python interface for the tre regular expressions library
-LIB_DEPENDS= tre.5:${PORTSDIR}/textproc/libtre
+LIB_DEPENDS= libtre.so:${PORTSDIR}/textproc/libtre
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/LICENSE
diff --git a/textproc/py-pyctpp2/Makefile b/textproc/py-pyctpp2/Makefile
index b55d5227cf4c..7671d6c94d8e 100644
--- a/textproc/py-pyctpp2/Makefile
+++ b/textproc/py-pyctpp2/Makefile
@@ -13,7 +13,7 @@ COMMENT= Python interface to CTPP2 library
LICENSE= MIT
-LIB_DEPENDS= ctpp2:${PORTSDIR}/textproc/ctpp2
+LIB_DEPENDS= libctpp2.so:${PORTSDIR}/textproc/ctpp2
# Python3 ready
USE_PYTHON= yes
diff --git a/textproc/py-qt4-xml/Makefile b/textproc/py-qt4-xml/Makefile
index 1f32522f9252..bd3dc554f24b 100644
--- a/textproc/py-qt4-xml/Makefile
+++ b/textproc/py-qt4-xml/Makefile
@@ -45,7 +45,7 @@ ARGS= -b ${PREFIX}/bin \
ARGS+= --no-qsci-api
PLIST_SUB+= API="@comment "
.else
-LIB_DEPENDS+= qscintilla2:${PORTSDIR}/devel/qscintilla2
+LIB_DEPENDS+= libqscintilla2.so:${PORTSDIR}/devel/qscintilla2
ARGS+= --qsci-api --qsci-api-destdir=${QSCIDIR}
PLIST_SUB+= API=""
.endif
diff --git a/textproc/py-qt4-xmlpatterns/Makefile b/textproc/py-qt4-xmlpatterns/Makefile
index 5c0fcf2f467a..d1e7a2d10c62 100644
--- a/textproc/py-qt4-xmlpatterns/Makefile
+++ b/textproc/py-qt4-xmlpatterns/Makefile
@@ -44,7 +44,7 @@ ARGS= -b ${PREFIX}/bin \
ARGS+= --no-qsci-api
PLIST_SUB+= API="@comment "
.else
-LIB_DEPENDS+= qscintilla2:${PORTSDIR}/devel/qscintilla2
+LIB_DEPENDS+= libqscintilla2.so:${PORTSDIR}/devel/qscintilla2
ARGS+= --qsci-api --qsci-api-destdir=${QSCIDIR}
PLIST_SUB+= API=""
.endif
diff --git a/textproc/rtfx/Makefile b/textproc/rtfx/Makefile
index 6967050edf29..50261f425c74 100644
--- a/textproc/rtfx/Makefile
+++ b/textproc/rtfx/Makefile
@@ -9,8 +9,8 @@ MASTER_SITES= http://memberwebs.com/stef/software/rtfx/
MAINTAINER= ports@FreeBSD.org
COMMENT= An RTF to XML converter
-LIB_DEPENDS= mba:${PORTSDIR}/devel/libmba \
- domc:${PORTSDIR}/textproc/domc
+LIB_DEPENDS= libmba.so:${PORTSDIR}/devel/libmba \
+ libdomc.so:${PORTSDIR}/textproc/domc
HAS_CONFIGURE= yes
CONFIGURE_ARGS+= --prefix=${PREFIX} --datarootdir=${PREFIX}
diff --git a/textproc/ruby-sary/Makefile b/textproc/ruby-sary/Makefile
index dcbb6bbc93f3..22e6a52f7e94 100644
--- a/textproc/ruby-sary/Makefile
+++ b/textproc/ruby-sary/Makefile
@@ -13,7 +13,7 @@ DIST_SUBDIR= ruby
MAINTAINER= clsung@FreeBSD.org
COMMENT= A Ruby interface to the Sary library
-LIB_DEPENDS= sary.10:${PORTSDIR}/textproc/sary
+LIB_DEPENDS= libsary.so:${PORTSDIR}/textproc/sary
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
diff --git a/textproc/ruby-xmlparser/Makefile b/textproc/ruby-xmlparser/Makefile
index ca86602d0036..14b051b9d698 100644
--- a/textproc/ruby-xmlparser/Makefile
+++ b/textproc/ruby-xmlparser/Makefile
@@ -12,7 +12,7 @@ MAINTAINER= ruby@FreeBSD.org
COMMENT= Ruby module to access James Clark XML Parser ToolKit ("expat")
BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
-LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/uconv.so:${PORTSDIR}/japanese/ruby-uconv \
p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
# to utilize encoding maps included in p5-XML-Parser
diff --git a/textproc/rubygem-augeas/Makefile b/textproc/rubygem-augeas/Makefile
index 13ec85cb86dd..e38662e64771 100644
--- a/textproc/rubygem-augeas/Makefile
+++ b/textproc/rubygem-augeas/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= http://download.augeas.net/ruby/
MAINTAINER= ruby@FreeBSD.org
COMMENT= Ruby bindings for Augeas
-LIB_DEPENDS= augeas:${PORTSDIR}/textproc/augeas
+LIB_DEPENDS= libaugeas.so:${PORTSDIR}/textproc/augeas
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/textproc/rubygem-zmq/Makefile b/textproc/rubygem-zmq/Makefile
index a1661f973944..ee568427bc3c 100644
--- a/textproc/rubygem-zmq/Makefile
+++ b/textproc/rubygem-zmq/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= Ruby ZeroMQ gem
-LIB_DEPENDS= zmq:${PORTSDIR}/net/libzmq2
+LIB_DEPENDS= libzmq.so:${PORTSDIR}/net/libzmq2
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/textproc/scim-openvanilla/Makefile b/textproc/scim-openvanilla/Makefile
index d0584e167c83..811d23acc8ca 100644
--- a/textproc/scim-openvanilla/Makefile
+++ b/textproc/scim-openvanilla/Makefile
@@ -15,7 +15,7 @@ COMMENT= SCIM OpenVanilla input method (IM)/output filter (OF) framework
BUILD_DEPENDS= scim:${PORTSDIR}/textproc/scim \
${LOCALBASE}/include/OpenVanilla/OpenVanilla.h:${PORTSDIR}/textproc/openvanilla-framework
RUN_DEPENDS= scim:${PORTSDIR}/textproc/scim
-LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
USE_AUTOTOOLS= libltdl
WRKSRC= ${WRKDIR}/${DISTNAME}/Loaders/SCIM
diff --git a/textproc/xalan-c/Makefile b/textproc/xalan-c/Makefile
index 3e4a6cef3124..4b7f01591572 100644
--- a/textproc/xalan-c/Makefile
+++ b/textproc/xalan-c/Makefile
@@ -31,7 +31,7 @@ DOCS_TARBALL= xalan_c-${PORTVERSION}-docs-html-nograf${EXTRACT_SUFX}
# we need the _extracted_ xerces-c3 port sources to build this one
# (installed version of port is enough)
XERCESC_LIB_VER?= 3
-LIB_DEPENDS+= xerces-c.${XERCESC_LIB_VER}:${PORTSDIR}/textproc/xerces-c3
+LIB_DEPENDS+= libxerces-c.${XERCESC_LIB_VER}.so:${PORTSDIR}/textproc/xerces-c3
XERCESCROOT?= ${LOCALBASE}
USE_LDCONFIG= yes