aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-11-26 13:10:21 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-11-26 13:10:21 +0000
commit3517637f90b967f990664ebe06d82916af0e44c6 (patch)
tree12bfba5e3927164ee5af0def878c9b8ad5b03e21 /textproc
parent70b1179c61675622ee3de992eacb5c99f9032045 (diff)
downloadports-3517637f90b967f990664ebe06d82916af0e44c6.tar.gz
ports-3517637f90b967f990664ebe06d82916af0e44c6.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/pcrs/Makefile38
-rw-r--r--textproc/pcrs/distinfo2
-rw-r--r--textproc/pcrs/files/patch-Makefile.in54
-rw-r--r--textproc/pcrs/files/patch-configure40
-rw-r--r--textproc/pcrs/pkg-descr5
6 files changed, 140 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index dcd67809abf4..52449522ad1a 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -550,6 +550,7 @@
SUBDIR += pa-aspell
SUBDIR += par
SUBDIR += pardiff
+ SUBDIR += pcrs
SUBDIR += pdftohtml
SUBDIR += pear-Numbers_Roman
SUBDIR += pear-Numbers_Words
diff --git a/textproc/pcrs/Makefile b/textproc/pcrs/Makefile
new file mode 100644
index 000000000000..ef7b2f2a337a
--- /dev/null
+++ b/textproc/pcrs/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: pcrs
+# Date created: 31 July 2005
+# Whom: Ken Wong <wongk@apt.homeunix.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pcrs
+PORTVERSION= 0.0.3
+CATEGORIES= textproc
+MASTER_SITES= http://www.oesterhelt.org/pcrs/\
+ http://distfiles.master.finkmirrors.net/\
+ http://download.mirror.ac.uk/mirror/master.us.finkmirrors.net/distfiles/\
+ http://mirror.phy.olemiss.edu/mirror/fink/distfiles/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= wongk@apt.homeunix.net
+COMMENT= Perl compatible regular expression based substitutions
+
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+INSTALLS_SHLIB= yes
+
+MAN3= pcrs.3
+PLIST_FILES= bin/pcrsed \
+ lib/libpcrs.a \
+ lib/libpcrs.so \
+ lib/libpcrs.so.0
+
+post-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pcrsed ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/textproc/pcrs/distinfo b/textproc/pcrs/distinfo
new file mode 100644
index 000000000000..dc2810e3fc9f
--- /dev/null
+++ b/textproc/pcrs/distinfo
@@ -0,0 +1,2 @@
+MD5 (pcrs-0.0.3-src.tar.gz) = a6070f22f7eee5637c14342b71b36ff5
+SIZE (pcrs-0.0.3-src.tar.gz) = 32296
diff --git a/textproc/pcrs/files/patch-Makefile.in b/textproc/pcrs/files/patch-Makefile.in
new file mode 100644
index 000000000000..d8a754e85e49
--- /dev/null
+++ b/textproc/pcrs/files/patch-Makefile.in
@@ -0,0 +1,54 @@
+--- Makefile.in.orig Mon Mar 11 08:56:16 2002
++++ Makefile.in Sun Nov 27 00:07:10 2005
+@@ -19,6 +19,7 @@
+
+ BINDIR = @bindir@
+ LIBDIR = @libdir@
++INCLUDEDIR = @includedir@
+ MANDIR = @mandir@/man3
+
+
+@@ -47,6 +48,7 @@
+ #############################################################################
+
+ CFLAGS = @CFLAGS@ -Wall -Wstrict-prototypes -Wshadow -Wconversion -pedantic \
++ -I$(INCLUDEDIR) -L$(LIBDIR) \
+ @PARANOID_FU@ -Wunreachable-code -Wmissing-prototypes \
+ -Waggregate-return -W -Wfloat-equal -Wsign-compare \
+ -Wwrite-strings
+@@ -66,29 +68,25 @@
+ $(CC) $(CFLAGS) pcrsed.c pcrs.@OBJEXT@ -o pcrsed@EXEEXT@ $(LIBS)
+
+ shared: pcrs.@OBJEXT@
+- $(CC) $(CLFLAGS) $(LDFLAGS) $(LIBFLAGS) -Wl,-soname,libpcrs.so.$(VERSION_MAJOR) -o libpcrs.so.$(VERSION) pcrs.@OBJEXT@ $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $(LIBFLAGS) -Wl,-soname,libpcrs.so.$(VERSION_MAJOR) -o libpcrs.so.$(VERSION_MAJOR) pcrs.@OBJEXT@ $(LIBS)
+
+ static:
+ $(AR) libpcrs.a pcrs.@OBJEXT@
+
+ install: all
+- $(INSTALL) -m 755 libpcrs.so.$(VERSION) $(LIBDIR)
+- $(LN_S) -f libpcrs.so.$(VERSION) $(LIBDIR)/libpcrs.so
+- $(INSTALL) -m 644 libpcrs.a $(LIBDIR)
++ $(INSTALL) -m 755 libpcrs.so.$(VERSION_MAJOR) $(prefix)/lib
++ $(LN_S) -f libpcrs.so.$(VERSION_MAJOR) $(prefix)/lib/libpcrs.so
++ $(INSTALL) -m 644 libpcrs.a $(prefix)/lib
+ $(INSTALL) -m 644 pcrs.3 $(MANDIR)
+
+- if test "$(HAVE_GZIP)" = "yes"; then \
+- gzip -f $(MANDIR)/pcrs.3; \
+- fi
+-
+ @echo -e " ***************************************************\n" \
+- "** Libraries have been installed in $(LIBDIR). \n" \
++ "** Libraries have been installed in $(prefix)/lib. \n" \
+ "** Don't forget to run ldconfig. \n" \
+ "***************************************************"
+
+ @if test -f pcrsed@EXEEXT@; then\
+ echo -e "\nRebuilding pcrsed to use the installed shared library"; \
+- $(CC) $(CFLAGS) -L$(LIBDIR) pcrsed.c -o pcrsed@EXEEXT@ $(LIBS) -lpcrs; \
++ $(CC) $(CFLAGS) -L$(prefix)/lib pcrsed.c -o pcrsed@EXEEXT@ $(LIBS) -lpcrs; \
+ fi
+
+ clean:
diff --git a/textproc/pcrs/files/patch-configure b/textproc/pcrs/files/patch-configure
new file mode 100644
index 000000000000..3a82a058d29e
--- /dev/null
+++ b/textproc/pcrs/files/patch-configure
@@ -0,0 +1,40 @@
+--- configure.orig Tue Dec 2 10:45:42 2003
++++ configure Sat Nov 26 02:57:22 2005
+@@ -19,12 +19,12 @@
+ # dashes changed to underlines.
+ build=NONE
+ cache_file=./config.cache
+-exec_prefix=NONE
++exec_prefix=/usr/local
+ host=NONE
+ no_create=
+ nonopt=NONE
+ no_recursion=
+-prefix=NONE
++prefix=/usr/local
+ program_prefix=NONE
+ program_suffix=NONE
+ program_transform_name=s,x,x,
+@@ -42,8 +42,8 @@
+ sysconfdir='${prefix}/etc'
+ sharedstatedir='${prefix}/com'
+ localstatedir='${prefix}/var'
+-libdir='${exec_prefix}/lib'
+-includedir='${prefix}/include'
++libdir="${exec_prefix}/lib"
++includedir="${prefix}/include"
+ oldincludedir='/usr/include'
+ infodir='${prefix}/info'
+ mandir='${prefix}/man'
+@@ -685,9 +685,9 @@
+ rm -fr conftest*
+ ac_ext=c
+ # CFLAGS is not in ac_cpp because -g, -O, etc. are not valid cpp options.
+-ac_cpp='$CPP $CPPFLAGS'
++ac_cpp='$CPP -I${includedir} -L${libdir} $CPPFLAGS'
+ ac_compile='${CC-cc} -c $CFLAGS $CPPFLAGS conftest.$ac_ext 1>&5'
+-ac_link='${CC-cc} -o conftest${ac_exeext} $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
++ac_link='${CC-cc} -I${includedir} -L${libdir} -o conftest${ac_exeext} $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
+ cross_compiling=$ac_cv_prog_cc_cross
+
+ echo "$ac_t""$ac_cv_prog_cc_works" 1>&6
diff --git a/textproc/pcrs/pkg-descr b/textproc/pcrs/pkg-descr
new file mode 100644
index 000000000000..b81b4b1de2f1
--- /dev/null
+++ b/textproc/pcrs/pkg-descr
@@ -0,0 +1,5 @@
+PCRS is a small library, written as a supplement to the PCRE library,
+that implements regex based substitution with the syntax and semantics
+of Perl's s/// operator.
+
+WWW: http://www.oesterhelt.org/pcrs/