aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2003-07-24 15:51:39 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2003-07-24 15:51:39 +0000
commit968a91ee79bf95e8cc0a43f89f5a2207982b105e (patch)
tree2f23b5e8d93869ffc584246cbb7b460043274633 /textproc
parent4e3da8e744b6b22a2e5ffeb0360e3023f9405f5d (diff)
downloadports-968a91ee79bf95e8cc0a43f89f5a2207982b105e.tar.gz
ports-968a91ee79bf95e8cc0a43f89f5a2207982b105e.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/xmlpp/Makefile9
-rw-r--r--textproc/xmlpp/files/patch-src::xmlcommon.h11
-rw-r--r--textproc/xmlpp/files/patch-src::xmlpp.cpp15
-rw-r--r--textproc/xmlpp/files/patch-src::xmltokenizer.cpp11
-rw-r--r--textproc/xmlpp/files/patch-test::nodetest.cpp10
5 files changed, 49 insertions, 7 deletions
diff --git a/textproc/xmlpp/Makefile b/textproc/xmlpp/Makefile
index 88749dfe382b..a3de73cdaa1b 100644
--- a/textproc/xmlpp/Makefile
+++ b/textproc/xmlpp/Makefile
@@ -19,14 +19,9 @@ FETCH_CMD= /usr/bin/fetch
USE_GMAKE= yes
USE_LIBTOOL= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
pre-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|/usr/local/share|$$(datadir)|g'
+ @${RM} ${WRKSRC}/config.cache
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/xmlpp/files/patch-src::xmlcommon.h b/textproc/xmlpp/files/patch-src::xmlcommon.h
new file mode 100644
index 000000000000..0a86e5acf3ff
--- /dev/null
+++ b/textproc/xmlpp/files/patch-src::xmlcommon.h
@@ -0,0 +1,11 @@
+--- src/xmlcommon.h.orig Wed Jul 23 04:10:04 2003
++++ src/xmlcommon.h Wed Jul 23 04:12:03 2003
+@@ -20,6 +20,8 @@
+
+ //! dummy define
+ #define XMLPP_API
++
++using std::string;
+
+ //! handle to a tagname string in a tagname map
+ typedef int xmltagnamehandle;
diff --git a/textproc/xmlpp/files/patch-src::xmlpp.cpp b/textproc/xmlpp/files/patch-src::xmlpp.cpp
new file mode 100644
index 000000000000..366a1d4cbbb8
--- /dev/null
+++ b/textproc/xmlpp/files/patch-src::xmlpp.cpp
@@ -0,0 +1,15 @@
+--- ./src/xmlpp.cpp.orig Wed Jul 23 04:12:52 2003
++++ ./src/xmlpp.cpp Wed Jul 23 04:13:52 2003
+@@ -21,6 +21,12 @@
+ //debug
+ #include <iostream>
+
++using std::cout;
++using std::cerr;
++using std::endl;
++using std::ifstream;
++using std::ofstream;
++
+ namespace xmlpp {
+
+ // internal use for saving
diff --git a/textproc/xmlpp/files/patch-src::xmltokenizer.cpp b/textproc/xmlpp/files/patch-src::xmltokenizer.cpp
new file mode 100644
index 000000000000..ced263bff89d
--- /dev/null
+++ b/textproc/xmlpp/files/patch-src::xmltokenizer.cpp
@@ -0,0 +1,11 @@
+--- src/xmltokenizer.cpp.orig Wed Jul 23 04:14:53 2003
++++ src/xmltokenizer.cpp Wed Jul 23 04:29:18 2003
+@@ -15,7 +15,7 @@
+ // needed includes
+ #include "xmlpp.h"
+ #include "xmltokenizer.h"
+-
++#include <iostream>
+
+ // namespace declaration
+ namespace xmlpp {
diff --git a/textproc/xmlpp/files/patch-test::nodetest.cpp b/textproc/xmlpp/files/patch-test::nodetest.cpp
new file mode 100644
index 000000000000..4d76d88a3f34
--- /dev/null
+++ b/textproc/xmlpp/files/patch-test::nodetest.cpp
@@ -0,0 +1,10 @@
+--- test/nodetest.cpp.orig Wed Jul 23 04:18:02 2003
++++ test/nodetest.cpp Wed Jul 23 04:19:01 2003
+@@ -5,6 +5,7 @@
+ */
+
+ #include <fstream>
++#include <iostream>
+ #include "xmlpp.h"
+
+ using namespace xmlpp;