aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2021-10-05 07:38:10 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2021-10-05 07:51:06 +0000
commit9b6b71faaa6942e54e77dec0d603807ef8964c1f (patch)
treee4cdf5f7318e78fb60607affb862f0e2fc4ad83e /textproc
parent1cc165530a199a5cffad3e004980c0712d8dc74b (diff)
downloadports-9b6b71faaa6942e54e77dec0d603807ef8964c1f.tar.gz
ports-9b6b71faaa6942e54e77dec0d603807ef8964c1f.zip
*/*: Make rails 6.1.3 available
The upgrade of rails to 6.1.4 broke www/gitlab-ce. PR: 258855 (cherry picked from commit f4511dc4a7c439b30c898b75246d314a574f01cb)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile3
-rw-r--r--textproc/rubygem-actiontext613/Makefile28
-rw-r--r--textproc/rubygem-actiontext613/distinfo3
-rw-r--r--textproc/rubygem-actiontext613/pkg-descr10
-rw-r--r--textproc/rubygem-sass-rails-rails613/Makefile22
-rw-r--r--textproc/rubygem-sass-rails-rails613/distinfo3
-rw-r--r--textproc/rubygem-sass-rails-rails613/pkg-descr3
-rw-r--r--textproc/rubygem-sassc-rails-rails613/Makefile26
-rw-r--r--textproc/rubygem-sassc-rails-rails613/distinfo3
-rw-r--r--textproc/rubygem-sassc-rails-rails613/pkg-descr5
10 files changed, 106 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index f4ee5b8f68ce..5d56263af114 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1568,6 +1568,7 @@
SUBDIR += rubygem-actionpack-xml_parser1-rails4
SUBDIR += rubygem-actiontext60
SUBDIR += rubygem-actiontext61
+ SUBDIR += rubygem-actiontext613
SUBDIR += rubygem-albino
SUBDIR += rubygem-amatch
SUBDIR += rubygem-asciidoctor
@@ -1747,6 +1748,7 @@
SUBDIR += rubygem-sass-rails-rails52
SUBDIR += rubygem-sass-rails-rails60
SUBDIR += rubygem-sass-rails-rails61
+ SUBDIR += rubygem-sass-rails-rails613
SUBDIR += rubygem-sass32
SUBDIR += rubygem-sass34
SUBDIR += rubygem-sassc
@@ -1756,6 +1758,7 @@
SUBDIR += rubygem-sassc-rails-rails52
SUBDIR += rubygem-sassc-rails-rails60
SUBDIR += rubygem-sassc-rails-rails61
+ SUBDIR += rubygem-sassc-rails-rails613
SUBDIR += rubygem-sassc22
SUBDIR += rubygem-sax-machine
SUBDIR += rubygem-scss_lint
diff --git a/textproc/rubygem-actiontext613/Makefile b/textproc/rubygem-actiontext613/Makefile
new file mode 100644
index 000000000000..aff2747bca9a
--- /dev/null
+++ b/textproc/rubygem-actiontext613/Makefile
@@ -0,0 +1,28 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= actiontext
+PORTVERSION= 6.1.3.2
+CATEGORIES= textproc rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 613
+
+MAINTAINER= mfechner@FreeBSD.org
+COMMENT= Edit and display rich text in Rails applications
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
+
+RUN_DEPENDS= rubygem-actionpack613>=${PORTVERSION}:www/rubygem-actionpack613 \
+ rubygem-activerecord613>=${PORTVERSION}:databases/rubygem-activerecord613 \
+ rubygem-activestorage613>=${PORTVERSION}:net/rubygem-activestorage613 \
+ rubygem-activesupport613>=${PORTVERSION}:devel/rubygem-activesupport613 \
+ rubygem-nokogiri>=1.8.5:textproc/rubygem-nokogiri
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+PORTSCOUT= limit:^6\.1\.
+
+.include <bsd.port.mk>
diff --git a/textproc/rubygem-actiontext613/distinfo b/textproc/rubygem-actiontext613/distinfo
new file mode 100644
index 000000000000..7dcda10bd3d6
--- /dev/null
+++ b/textproc/rubygem-actiontext613/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1633413329
+SHA256 (rubygem/actiontext-6.1.3.2.gem) = 0787918e22bb621b55a3d569258c22e0365450120e47b3486dc1f3742d9bd9fd
+SIZE (rubygem/actiontext-6.1.3.2.gem) = 18944
diff --git a/textproc/rubygem-actiontext613/pkg-descr b/textproc/rubygem-actiontext613/pkg-descr
new file mode 100644
index 000000000000..bac5cd69d009
--- /dev/null
+++ b/textproc/rubygem-actiontext613/pkg-descr
@@ -0,0 +1,10 @@
+Action Text brings rich text content and editing to Rails. It includes the Trix
+editor that handles everything from formatting to links to quotes to lists to
+embedded images and galleries. The rich text content generated by the Trix
+editor is saved in its own RichText model that's associated with any existing
+Active Record model in the application. Any embedded images (or other
+attachments) are automatically stored using Active Storage and associated with
+the included RichText model.
+
+WWW: https://rubyonrails.org/
+WWW: https://github.com/rails/rails/tree/master/actiontext
diff --git a/textproc/rubygem-sass-rails-rails613/Makefile b/textproc/rubygem-sass-rails-rails613/Makefile
new file mode 100644
index 000000000000..bba29220cedd
--- /dev/null
+++ b/textproc/rubygem-sass-rails-rails613/Makefile
@@ -0,0 +1,22 @@
+# Created by: Johannes Jost Meixner <xmj@FreeBSD.org>
+
+PORTNAME= sass-rails
+PORTVERSION= 6.0.0
+CATEGORIES= textproc rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= -rails613
+
+MAINTAINER= mfechner@FreeBSD.org
+COMMENT= Sass adapter for the Rails asset pipeline
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
+
+RUN_DEPENDS= rubygem-sassc-rails-rails613>=2.1.1<3:textproc/rubygem-sassc-rails-rails613
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/rubygem-sass-rails-rails613/distinfo b/textproc/rubygem-sass-rails-rails613/distinfo
new file mode 100644
index 000000000000..299386c07d4a
--- /dev/null
+++ b/textproc/rubygem-sass-rails-rails613/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1569832463
+SHA256 (rubygem/sass-rails-6.0.0.gem) = e0b6448ea1c7929fd5929fc7a8eb2d78045e44cc82fc0765a249d3fa1c5810d3
+SIZE (rubygem/sass-rails-6.0.0.gem) = 7168
diff --git a/textproc/rubygem-sass-rails-rails613/pkg-descr b/textproc/rubygem-sass-rails-rails613/pkg-descr
new file mode 100644
index 000000000000..e4a6b809b4d8
--- /dev/null
+++ b/textproc/rubygem-sass-rails-rails613/pkg-descr
@@ -0,0 +1,3 @@
+Sass adapter for the Rails asset pipeline.
+
+WWW: https://github.com/rails/sass-rails
diff --git a/textproc/rubygem-sassc-rails-rails613/Makefile b/textproc/rubygem-sassc-rails-rails613/Makefile
new file mode 100644
index 000000000000..f2479442c7e7
--- /dev/null
+++ b/textproc/rubygem-sassc-rails-rails613/Makefile
@@ -0,0 +1,26 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= sassc-rails
+PORTVERSION= 2.1.2
+CATEGORIES= textproc rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= -rails613
+
+MAINTAINER= mfechner@FreeBSD.org
+COMMENT= Integrate SassC-Ruby into Rails
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= rubygem-railties613>=4.0.0:www/rubygem-railties613 \
+ rubygem-sassc22>=2.0:textproc/rubygem-sassc22 \
+ rubygem-sprockets-rails-rails61>=0:devel/rubygem-sprockets-rails-rails61 \
+ rubygem-sprockets3>=3.0:devel/rubygem-sprockets3 \
+ rubygem-tilt>=0:devel/rubygem-tilt
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/rubygem-sassc-rails-rails613/distinfo b/textproc/rubygem-sassc-rails-rails613/distinfo
new file mode 100644
index 000000000000..7821c3227c9f
--- /dev/null
+++ b/textproc/rubygem-sassc-rails-rails613/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1561049536
+SHA256 (rubygem/sassc-rails-2.1.2.gem) = 5f4fdf3881fc9bdc8e856ffbd9850d70a2878866feae8114aa45996179952db5
+SIZE (rubygem/sassc-rails-2.1.2.gem) = 33280
diff --git a/textproc/rubygem-sassc-rails-rails613/pkg-descr b/textproc/rubygem-sassc-rails-rails613/pkg-descr
new file mode 100644
index 000000000000..8f0523959e59
--- /dev/null
+++ b/textproc/rubygem-sassc-rails-rails613/pkg-descr
@@ -0,0 +1,5 @@
+We all love working with Sass, but compilation can take quite a long time for
+larger codebases. This gem integrates the C implementation of Sass, LibSass,
+into the asset pipeline.
+
+WWW: https://github.com/sass/sassc-rails