aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2003-10-14 12:31:47 +0000
committerMathieu Arnold <mat@FreeBSD.org>2003-10-14 12:31:47 +0000
commita0fb8fb0086356b7ddf5bfdaa1b02e85e012f522 (patch)
tree85381ca50c3eb7109fd9ce56ff93219464efce14 /textproc
parentf5ff01800e464364a932e6f3462e08574aa36416 (diff)
downloadports-a0fb8fb0086356b7ddf5bfdaa1b02e85e012f522.tar.gz
ports-a0fb8fb0086356b7ddf5bfdaa1b02e85e012f522.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-XML-DTDParser/Makefile29
-rw-r--r--textproc/p5-XML-DTDParser/distinfo1
-rw-r--r--textproc/p5-XML-DTDParser/pkg-descr14
-rw-r--r--textproc/p5-XML-DTDParser/pkg-plist5
5 files changed, 50 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 956ccc6e4467..e8ce4f4e6bba 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -270,6 +270,7 @@
SUBDIR += p5-XML-DBMS
SUBDIR += p5-XML-DOM
SUBDIR += p5-XML-DT
+ SUBDIR += p5-XML-DTDParser
SUBDIR += p5-XML-Directory
SUBDIR += p5-XML-Dumper
SUBDIR += p5-XML-Encoding
diff --git a/textproc/p5-XML-DTDParser/Makefile b/textproc/p5-XML-DTDParser/Makefile
new file mode 100644
index 000000000000..dce5ff6ca3ef
--- /dev/null
+++ b/textproc/p5-XML-DTDParser/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: textproc/p5-XML-DTDParser
+# Date created: Oct 13th 2003
+# Whom: clsung@dragon2.net
+#
+# $FreeBSD$
+
+PORTNAME= XML-DTDParser
+PORTVERSION= 1.7
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= Perl module for parsing XML DTD strings
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::DTDParser.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+post-patch:
+ @${PERL} -pi -e 's/^our ([^\s;]+)/use vars qw($$1); $$1/;' \
+ ${WRKSRC}/DTDParser.pm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-XML-DTDParser/distinfo b/textproc/p5-XML-DTDParser/distinfo
new file mode 100644
index 000000000000..9d2a786e0684
--- /dev/null
+++ b/textproc/p5-XML-DTDParser/distinfo
@@ -0,0 +1 @@
+MD5 (XML-DTDParser-1.7.tar.gz) = 11929b44fe75012fd4f991c412855081
diff --git a/textproc/p5-XML-DTDParser/pkg-descr b/textproc/p5-XML-DTDParser/pkg-descr
new file mode 100644
index 000000000000..8d825dec65a2
--- /dev/null
+++ b/textproc/p5-XML-DTDParser/pkg-descr
@@ -0,0 +1,14 @@
+This module parses a DTD file and creates a data structure containing
+info about all tags, their allowed parameters, children, parents,
+optionality etc. etc. etc.
+
+Note: Parse a DTD you need and print the result to a file using
+Data::Dumper. The datastructure should be selfevident.
+
+Note: The module should be able to parse just about anything, but it intentional
+y looses some information.
+
+WWW: http://search.cpan.org/dist/XML-DTDParser/
+
+Jenda@Krynicky.cz
+http://Jenda.Krynicky.cz
diff --git a/textproc/p5-XML-DTDParser/pkg-plist b/textproc/p5-XML-DTDParser/pkg-plist
new file mode 100644
index 000000000000..9fe4a9825ea8
--- /dev/null
+++ b/textproc/p5-XML-DTDParser/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/XML/DTDParser.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/DTDParser/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/DTDParser
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/XML 2>/dev/null || true