aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2007-09-08 00:45:08 +0000
committerMark Linimon <linimon@FreeBSD.org>2007-09-08 00:45:08 +0000
commit41a56135d1e8a68844e4c575702cdbad451d7322 (patch)
tree009db3c80e9f224065cf6fcece6157eb9a5ad509 /textproc
parent8bf833f73199c3dc4303aad884f8483e5c33613a (diff)
downloadports-41a56135d1e8a68844e4c575702cdbad451d7322.tar.gz
ports-41a56135d1e8a68844e4c575702cdbad451d7322.zip
Notes
Diffstat (limited to 'textproc')
-rw-r--r--textproc/p5-Pod-Parser/Makefile13
-rw-r--r--textproc/p5-Pod-Parser/pkg-plist6
-rw-r--r--textproc/p5-XML-LibXSLT/Makefile8
-rw-r--r--textproc/p5-XML-LibXSLT/files/500503-patch-LibXSLT.xs26
-rw-r--r--textproc/p5-podlators/Makefile15
-rw-r--r--textproc/p5-podlators/pkg-plist2
6 files changed, 6 insertions, 64 deletions
diff --git a/textproc/p5-Pod-Parser/Makefile b/textproc/p5-Pod-Parser/Makefile
index 089ab91d387b..d6f3f1b55a81 100644
--- a/textproc/p5-Pod-Parser/Makefile
+++ b/textproc/p5-Pod-Parser/Makefile
@@ -25,19 +25,8 @@ MAN3= Pod::Checker.3 Pod::Find.3 Pod::InputObjects.3 \
Pod::ParseUtils.3 Pod::Parser.3 Pod::PlainText.3 Pod::Select.3 \
Pod::Usage.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-PLIST_SUB+= PL_FILES=""
-.else
-.undef MAN1
-PLIST_SUB+= PL_FILES="@comment "
-.endif
-
post-patch:
-.if ${PERL_LEVEL} >= 500600
@${REINPLACE_CMD} -e '/EXE_FILES/d' ${WRKSRC}/Makefile.PL
-.endif
@${FIND} ${WRKSRC} -name \*.orig -exec ${RM} {} \;
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/p5-Pod-Parser/pkg-plist b/textproc/p5-Pod-Parser/pkg-plist
index 1a7e7b17bbb5..807dc3aef443 100644
--- a/textproc/p5-Pod-Parser/pkg-plist
+++ b/textproc/p5-Pod-Parser/pkg-plist
@@ -1,6 +1,6 @@
-%%PL_FILES%%bin/pod2usage
-%%PL_FILES%%bin/podchecker
-%%PL_FILES%%bin/podselect
+bin/pod2usage
+bin/podchecker
+bin/podselect
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod/Parser/.packlist
%%SITE_PERL%%/Pod/Checker.pm
%%SITE_PERL%%/Pod/Find.pm
diff --git a/textproc/p5-XML-LibXSLT/Makefile b/textproc/p5-XML-LibXSLT/Makefile
index 39c8185ff48f..d2e44d990ae5 100644
--- a/textproc/p5-XML-LibXSLT/Makefile
+++ b/textproc/p5-XML-LibXSLT/Makefile
@@ -26,10 +26,4 @@ PERL_ABASE= ${SITE_PERL}/${PERL_ARCH}
MAN3= XML::LibXSLT.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-EXTRA_PATCHES= ${FILESDIR}/500503-*
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-LibXSLT/files/500503-patch-LibXSLT.xs b/textproc/p5-XML-LibXSLT/files/500503-patch-LibXSLT.xs
deleted file mode 100644
index 6ed285503380..000000000000
--- a/textproc/p5-XML-LibXSLT/files/500503-patch-LibXSLT.xs
+++ /dev/null
@@ -1,26 +0,0 @@
---- LibXSLT.xs.orig Mon Mar 1 21:42:43 2004
-+++ LibXSLT.xs Sun May 16 20:21:57 2004
-@@ -29,6 +29,23 @@
- }
- #endif
-
-+#ifndef dTHX
-+#define dTHX extern int errno
-+#endif
-+
-+#ifndef SvPV_nolen
-+#define SvPV_nolen(sv) \
-+ ((SvFLAGS(sv) & (SVf_POK)) == SVf_POK \
-+ ? SvPVX(sv) : sv_2pv_nolen(sv))
-+
-+static char *
-+sv_2pv_nolen(register SV *sv)
-+{
-+ STRLEN n_a;
-+ return sv_2pv(sv, &n_a);
-+}
-+#endif
-+
- #define SET_CB(cb, fld) \
- RETVAL = cb ? newSVsv(cb) : &PL_sv_undef;\
- if (SvOK(fld)) {\
diff --git a/textproc/p5-podlators/Makefile b/textproc/p5-podlators/Makefile
index 2aaf9adcdaf1..5eebdc7093a5 100644
--- a/textproc/p5-podlators/Makefile
+++ b/textproc/p5-podlators/Makefile
@@ -22,26 +22,13 @@ BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
-MAN1= pod2man.1 pod2text.1
MAN3= Pod::Man.3 Pod::ParseLink.3 Pod::Text.3 Pod::Text::Color.3 \
Pod::Text::Overstrike.3 Pod::Text::Termcap.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} >= 500600
-.undef MAN1
-PLIST_SUB= PL_FILES="@comment "
-.else
-RUN_DEPENDS+= ${SITE_PERL}/Term/ANSIColor.pm:${PORTSDIR}/devel/p5-Term-ANSIColor
-PLIST_SUB= PL_FILES=""
-.endif
-
post-patch:
-.if ${PERL_LEVEL} >= 500600
@${REINPLACE_CMD} -Ee '/(pod2man|pod2text)/d' ${WRKSRC}/Makefile.PL
-.endif
@${REINPLACE_CMD} -e 's/->\$$method;/->\$$method\(\);/g' ${WRKSRC}/lib/Pod/*.pm
@${REINPLACE_CMD} -e 's/\$${char}/(\$${char})/g' ${WRKSRC}/lib/Pod/Text/*.pm
@${FIND} ${WRKSRC} -name "*.bak" -delete
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/p5-podlators/pkg-plist b/textproc/p5-podlators/pkg-plist
index 7bfaf495571b..eb2a3d046815 100644
--- a/textproc/p5-podlators/pkg-plist
+++ b/textproc/p5-podlators/pkg-plist
@@ -1,5 +1,3 @@
-%%PL_FILES%%bin/pod2man
-%%PL_FILES%%bin/pod2text
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod/.packlist
%%SITE_PERL%%/Pod/Man.pm
%%SITE_PERL%%/Pod/ParseLink.pm