aboutsummaryrefslogtreecommitdiff
path: root/vietnamese/vn7to8
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1996-12-06 12:32:14 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>1996-12-06 12:32:14 +0000
commitc23ec56433519341184b454e5620bd24d652f94b (patch)
treea7e7efab13b1d187be5c5d62defba31d109dbf70 /vietnamese/vn7to8
parenta910b631177de63a70dd315833225db839a36baf (diff)
downloadports-c23ec56433519341184b454e5620bd24d652f94b.tar.gz
ports-c23ec56433519341184b454e5620bd24d652f94b.zip
Notes
Diffstat (limited to 'vietnamese/vn7to8')
-rw-r--r--vietnamese/vn7to8/Makefile28
-rw-r--r--vietnamese/vn7to8/distinfo1
-rw-r--r--vietnamese/vn7to8/files/patch-0111
-rw-r--r--vietnamese/vn7to8/files/patch-0211
-rw-r--r--vietnamese/vn7to8/files/vn7to8.174
-rw-r--r--vietnamese/vn7to8/files/vn80to81.161
-rw-r--r--vietnamese/vn7to8/files/vn8to7.172
-rw-r--r--vietnamese/vn7to8/pkg-comment1
-rw-r--r--vietnamese/vn7to8/pkg-descr13
-rw-r--r--vietnamese/vn7to8/pkg-plist6
10 files changed, 278 insertions, 0 deletions
diff --git a/vietnamese/vn7to8/Makefile b/vietnamese/vn7to8/Makefile
new file mode 100644
index 000000000000..d8c61220a0bb
--- /dev/null
+++ b/vietnamese/vn7to8/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# New ports collection makefile for: vn7to8
+# Version required: 1.1.1
+# Date created: Tue Dec 3, 1996
+# Whom: David O'Brien (obrien@cs.ucdavis.edu)
+#
+# $Id: Makefile,v 1.1.1.1 1996/08/09 04:17:16 asami Exp $
+#
+# version # is VISCII version supported + .<edit_revision>
+
+DISTNAME= vn7to8
+PKGNAME= vn-vn7to8-1.1.1
+CATEGORIES= vietnamese
+MASTER_SITES= ftp://ftp.media.mit.edu/pub/Vietnet/Viscii/Unix/ \
+ ftp://ftp.monash.edu.au/pub/vietnam/unix/
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= obrien@cs.ucdavis.edu
+
+CFLAGS+= -I../../include
+MAN1= vn7to8.1 vn8to7.1 vn80to81.1
+
+post-install:
+ @${INSTALL_MAN} ${FILESDIR}/vn7to8.1 ${PREFIX}/man/man1
+ @${INSTALL_MAN} ${FILESDIR}/vn80to81.1 ${PREFIX}/man/man1
+ @${INSTALL_MAN} ${FILESDIR}/vn8to7.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/vietnamese/vn7to8/distinfo b/vietnamese/vn7to8/distinfo
new file mode 100644
index 000000000000..d102925e8dd3
--- /dev/null
+++ b/vietnamese/vn7to8/distinfo
@@ -0,0 +1 @@
+MD5 (vn7to8.tar.Z) = 36b2f7e66cb5079e0716ad38cfeb4b4f
diff --git a/vietnamese/vn7to8/files/patch-01 b/vietnamese/vn7to8/files/patch-01
new file mode 100644
index 000000000000..365e7ec15776
--- /dev/null
+++ b/vietnamese/vn7to8/files/patch-01
@@ -0,0 +1,11 @@
+--- Makefile.orig Mon Sep 14 15:49:45 1992
++++ Makefile Wed Dec 4 02:54:53 1996
+@@ -6,7 +6,7 @@
+ CC = cc
+ VNLIBDIR= ../lib
+ VNINCDIR= ../include
+-BINDIR = /local/usr/bin
++BINDIR = ${PREFIX}/bin
+ LIBS = $(VNLIBDIR)/libviqr.a $(VNLIBDIR)/libvntype.a
+
+ INC = -I$(VNINCDIR)
diff --git a/vietnamese/vn7to8/files/patch-02 b/vietnamese/vn7to8/files/patch-02
new file mode 100644
index 000000000000..45efc5aaa195
--- /dev/null
+++ b/vietnamese/vn7to8/files/patch-02
@@ -0,0 +1,11 @@
+--- ../lib/vntype/Makefile.orig Tue Jan 5 22:18:07 1993
++++ ../lib/vntype/Makefile Wed Dec 4 03:02:33 1996
+@@ -15,7 +15,7 @@
+ #FLAGS = -DNOANSI_C
+ CFLAGS = $(FLAGS) $(INC)
+ CC = cc
+-CPP = /lib/cpp
++CPP = cpp
+
+ .c.o:
+ $(CC) $(CFLAGS) -c $*.c
diff --git a/vietnamese/vn7to8/files/vn7to8.1 b/vietnamese/vn7to8/files/vn7to8.1
new file mode 100644
index 000000000000..2ed36c9f5e73
--- /dev/null
+++ b/vietnamese/vn7to8/files/vn7to8.1
@@ -0,0 +1,74 @@
+.\"
+.\" Copyright (c) 1996 David E. O'Brien
+.\"
+.\" All rights reserved.
+.\"
+.\" Redistribution and use in source and binary forms, with or without
+.\" modification, are permitted provided that the following conditions
+.\" are met:
+.\" 1. Redistributions of source code must retain the above copyright
+.\" notice, this list of conditions and the following disclaimer.
+.\" 2. Redistributions in binary form must reproduce the above copyright
+.\" notice, this list of conditions and the following disclaimer in the
+.\" documentation and/or other materials provided with the distribution.
+.\"
+.\" THIS SOFTWARE IS PROVIDED BY THE DEVELOPERS ``AS IS'' AND ANY EXPRESS OR
+.\" IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
+.\" OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
+.\" IN NO EVENT SHALL THE DEVELOPERS BE LIABLE FOR ANY DIRECT, INDIRECT,
+.\" INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
+.\" NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+.\" DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+.\" THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+.\" (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
+.\" THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+.\"
+.\" $Id$
+.\"
+.Dd December 2, 1996
+.Os
+.Dt VN7TO8 1
+.Sh NAME
+.Nm vn7to8
+.Sh SYNOPSIS
+.Nm vn7to8
+.Op Fl com Ar composition character
+.Op Fl v | Fl m | Fl l
+.Op Ar file ...
+.Sh DESCRIPTION
+.Nm vn7to8
+converts files encoded in the Vietnamese 7-bit VIQR (VIetnamese Quoted
+Readable) format to the 8-bit VISCII (VIetnamese Standard Code for Information
+Interchange) data format. The converted output is written to standard out.
+.Pp
+The following options are available:
+.Bl -tag -width indent
+.It Fl com
+specifies the composition character, default is "\\"
+.It Fl v
+sets the initial state to Vietnamese (default)
+.It Fl m
+sets the initial state to English
+.It Fl l
+sets the initial state to Literal
+.El
+.Pp
+If the input file name isn't specified,
+.Nm vn7to8
+reads from standard input.
+.\" .Sh COMPATIBILITY
+.Sh SEE ALSO
+.Xr vn8to7 1 ,
+.Xr vn80to81 1 ,
+.Xr vnterm 1 ,
+.Xr vnelivs 1 ,
+.Xr vnless 1
+.Sh STANDARDS
+Viet-Std Standardization Specification (Viet-Std@Haydn.Stanford.EDU)
+.\" .Sh HISTORY
+.Sh AUTHORS
+Nguye^~n Cu+o+`ng (Cuong T. Nguyen <cuong@haydn.Stanford.EDU>) of the
+TriChlor group.
+.br
+This man page was written by David E. O'Brien.
+.\" .Sh BUGS
diff --git a/vietnamese/vn7to8/files/vn80to81.1 b/vietnamese/vn7to8/files/vn80to81.1
new file mode 100644
index 000000000000..082efab271c5
--- /dev/null
+++ b/vietnamese/vn7to8/files/vn80to81.1
@@ -0,0 +1,61 @@
+.\"
+.\" Copyright (c) 1996 David E. O'Brien
+.\"
+.\" All rights reserved.
+.\"
+.\" Redistribution and use in source and binary forms, with or without
+.\" modification, are permitted provided that the following conditions
+.\" are met:
+.\" 1. Redistributions of source code must retain the above copyright
+.\" notice, this list of conditions and the following disclaimer.
+.\" 2. Redistributions in binary form must reproduce the above copyright
+.\" notice, this list of conditions and the following disclaimer in the
+.\" documentation and/or other materials provided with the distribution.
+.\"
+.\" THIS SOFTWARE IS PROVIDED BY THE DEVELOPERS ``AS IS'' AND ANY EXPRESS OR
+.\" IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
+.\" OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
+.\" IN NO EVENT SHALL THE DEVELOPERS BE LIABLE FOR ANY DIRECT, INDIRECT,
+.\" INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
+.\" NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+.\" DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+.\" THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+.\" (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
+.\" THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+.\"
+.\" $Id$
+.\"
+.Dd December 2, 1996
+.Os
+.Dt VN80TO81 1
+.Sh NAME
+.Nm vn80to81
+.Sh SYNOPSIS
+.Nm vn80to81
+.Op Ar input file
+.Op Ar output file
+.Sh DESCRIPTION
+.Nm vn80to81
+converts Vietnamese language text files encoded in the old version 1.0 8-bit
+VISCII (VIetnamese Standard Code for Information Interchange) format to the
+updated version 1.1 VISCII format.
+.Pp
+If the file names aren't specified,
+.Nm vn80to81
+reads from standard input and writes to standard ouput.
+.\" .Sh COMPATIBILITY
+.Sh SEE ALSO
+.Xr vn7to8 1 ,
+.Xr vn8to7 1 ,
+.Xr vnterm 1 ,
+.Xr vnelivs 1 ,
+.Xr vnless 1
+.Sh STANDARDS
+Viet-Std Standardization Specification (Viet-Std@Haydn.Stanford.EDU)
+.\" .Sh HISTORY
+.Sh AUTHORS
+Nguye^~n Cu+o+`ng (Cuong T. Nguyen <cuong@haydn.Stanford.EDU>) of the
+TriChlor group.
+.br
+This man page was written by David E. O'Brien.
+.\" .Sh BUGS
diff --git a/vietnamese/vn7to8/files/vn8to7.1 b/vietnamese/vn7to8/files/vn8to7.1
new file mode 100644
index 000000000000..368c3c46f0c0
--- /dev/null
+++ b/vietnamese/vn7to8/files/vn8to7.1
@@ -0,0 +1,72 @@
+.\"
+.\" Copyright (c) 1996 David E. O'Brien
+.\"
+.\" All rights reserved.
+.\"
+.\" Redistribution and use in source and binary forms, with or without
+.\" modification, are permitted provided that the following conditions
+.\" are met:
+.\" 1. Redistributions of source code must retain the above copyright
+.\" notice, this list of conditions and the following disclaimer.
+.\" 2. Redistributions in binary form must reproduce the above copyright
+.\" notice, this list of conditions and the following disclaimer in the
+.\" documentation and/or other materials provided with the distribution.
+.\"
+.\" THIS SOFTWARE IS PROVIDED BY THE DEVELOPERS ``AS IS'' AND ANY EXPRESS OR
+.\" IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
+.\" OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
+.\" IN NO EVENT SHALL THE DEVELOPERS BE LIABLE FOR ANY DIRECT, INDIRECT,
+.\" INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
+.\" NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+.\" DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+.\" THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+.\" (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
+.\" THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+.\"
+.\" $Id$
+.\"
+.Dd December 2, 1996
+.Os
+.Dt VN8TO7 1
+.Sh NAME
+.Nm vn8to7
+.Sh SYNOPSIS
+.Nm vn8to7
+.Op Fl com Ar composition character
+.Op Fl v | Fl m
+.Op Ar file ...
+.Sh DESCRIPTION
+.Nm vn8to7
+converts files encoded in the Vietnamese 8-bit VISCII (VIetnamese Standard
+Code for Information Interchange) format to the 7-bit VIQR (VIetnamese Quoted
+Readable) data format. The converted output is written to standard out.
+.Pp
+The following options are available:
+.Bl -tag -width indent
+.It Fl com
+specifies the composition character, default is "\\"
+.It Fl v
+sets the initial state to Vietnamese (default)
+.It Fl m
+sets the initial state to English
+.El
+.Pp
+If the input file name isn't specified,
+.Nm vn8to7
+reads from standard input.
+.\" .Sh COMPATIBILITY
+.Sh SEE ALSO
+.Xr vn7to8 1 ,
+.Xr vn80to81 1 ,
+.Xr vnterm 1 ,
+.Xr vnelivs 1 ,
+.Xr vnless 1
+.Sh STANDARDS
+Viet-Std Standardization Specification (Viet-Std@Haydn.Stanford.EDU)
+.\" .Sh HISTORY
+.Sh AUTHORS
+Nguye^~n Cu+o+`ng (Cuong T. Nguyen <cuong@haydn.Stanford.EDU>) of the
+TriChlor group.
+.br
+This man page was written by David E. O'Brien.
+.\" .Sh BUGS
diff --git a/vietnamese/vn7to8/pkg-comment b/vietnamese/vn7to8/pkg-comment
new file mode 100644
index 000000000000..1d9f6e594b55
--- /dev/null
+++ b/vietnamese/vn7to8/pkg-comment
@@ -0,0 +1 @@
+converts between 7-bit Vietnamese VIQR and 8-bit VISCII formats
diff --git a/vietnamese/vn7to8/pkg-descr b/vietnamese/vn7to8/pkg-descr
new file mode 100644
index 000000000000..cd2477d8401f
--- /dev/null
+++ b/vietnamese/vn7to8/pkg-descr
@@ -0,0 +1,13 @@
+The two programs "vn7to8" and "vn8to7" convert between the 7-bit
+VIQR format for Vietnamese (Viet-Net like) and the 8-bit VISCII
+data format.
+
+The current supported version is VISCII 1.1.
+
+The program "vn80to81" converts files from VISCII 1.0 to VISCII 1.1.
+
+For complete details, please see the Viet-Std documents published elsewhere.
+Contact "viet-std@haydn.Stanford.EDU" if you would like a copy.
+
+David O'Brien
+obrien@cs.ucdavis.edu
diff --git a/vietnamese/vn7to8/pkg-plist b/vietnamese/vn7to8/pkg-plist
new file mode 100644
index 000000000000..1c54a29785b0
--- /dev/null
+++ b/vietnamese/vn7to8/pkg-plist
@@ -0,0 +1,6 @@
+bin/vn7to8
+bin/vn8to7
+bin/vn80to81
+man/man1/vn7to8.1.gz
+man/man1/vn8to7.1.gz
+man/man1/vn80to81.1.gz