aboutsummaryrefslogtreecommitdiff
path: root/vietnamese
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-08-25 14:22:46 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-08-25 14:22:46 +0000
commit46d328db5cafb6799badf0f7e6213da66abedb9c (patch)
treedcbb9e2253fd18b5a714893d775fe9cf43e5440c /vietnamese
parent336eab338eeea19c179db781f4c8321ada3324b2 (diff)
downloadports-46d328db5cafb6799badf0f7e6213da66abedb9c.tar.gz
ports-46d328db5cafb6799badf0f7e6213da66abedb9c.zip
vietnamese/x-unikey: Fix build with Clang 6
data.cpp:100:15: error: constant expression evaluates to -72 which cannot be narrowed to type 'unsigned char' [-Wc++11-narrowing] {{'A','a','<B8>','<B8>','<B5>','<B5>','<B6>','<B6>','<B7>','<B7>','<B9>','<B9>', // 0: a ^~~~~~ http://beefy11.nyi.freebsd.org/data/head-i386-default/p477696_s338122/logs/errors/vi-x-unikey-1.0.4.log - While here prevent build from asking an interactive question during the install phase
Notes
Notes: svn path=/head/; revision=478043
Diffstat (limited to 'vietnamese')
-rw-r--r--vietnamese/x-unikey/Makefile5
-rw-r--r--vietnamese/x-unikey/files/patch-src_xim_install.sh10
2 files changed, 14 insertions, 1 deletions
diff --git a/vietnamese/x-unikey/Makefile b/vietnamese/x-unikey/Makefile
index 1dbcca0d1acf..52edf4a775cc 100644
--- a/vietnamese/x-unikey/Makefile
+++ b/vietnamese/x-unikey/Makefile
@@ -9,10 +9,13 @@ MASTER_SITES= SF/unikey/${PORTNAME}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Vietnamese input method for X
-USES= tar:bzip2
+USES= compiler tar:bzip2
USE_XORG= x11
GNU_CONFIGURE= yes
+CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
+CXXFLAGS_clang= -Wno-c++11-narrowing
+
PLIST_FILES= bin/unikey bin/ukxim
.include <bsd.port.mk>
diff --git a/vietnamese/x-unikey/files/patch-src_xim_install.sh b/vietnamese/x-unikey/files/patch-src_xim_install.sh
new file mode 100644
index 000000000000..b8a635fcbefb
--- /dev/null
+++ b/vietnamese/x-unikey/files/patch-src_xim_install.sh
@@ -0,0 +1,10 @@
+Do not ask an interactive question during the install phase.
+
+--- src/xim/install.sh.orig 2018-08-25 14:18:57 UTC
++++ src/xim/install.sh
+@@ -1,4 +1,5 @@
+ #!/bin/sh
++exit 0
+ echo
+ echo "To use UniKey, certain environment variables must be set."
+ echo "Do you want to set these variables in /etc/profile? (y/N)"