aboutsummaryrefslogtreecommitdiff
path: root/www/WebMagick
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2010-09-15 05:26:17 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2010-09-15 05:26:17 +0000
commit63c612c10c148075e8e7c80811205858277e9873 (patch)
treed4c52064ad0603d78d7efdfa9656d3c0124f11ac /www/WebMagick
parent6755fc1e7ddb4b0da59c1a2f0a90c3ceca0549da (diff)
downloadports-63c612c10c148075e8e7c80811205858277e9873.tar.gz
ports-63c612c10c148075e8e7c80811205858277e9873.zip
Notes
Diffstat (limited to 'www/WebMagick')
-rw-r--r--www/WebMagick/Makefile2
-rw-r--r--www/WebMagick/files/patch-aa81
2 files changed, 41 insertions, 42 deletions
diff --git a/www/WebMagick/Makefile b/www/WebMagick/Makefile
index 14ebc4521035..e5a7c7a5c0e3 100644
--- a/www/WebMagick/Makefile
+++ b/www/WebMagick/Makefile
@@ -7,7 +7,7 @@
PORTNAME= WebMagick
PORTVERSION= 2.03p3
-PORTREVISION= 38
+PORTREVISION= 39
PORTEPOCH= 1
CATEGORIES= www graphics
MASTER_SITES= SF/${PORTNAME:L}/${PORTNAME:L}-beta/2.03pre3
diff --git a/www/WebMagick/files/patch-aa b/www/WebMagick/files/patch-aa
index 9c03e0dd1200..ee5a8a94b6c7 100644
--- a/www/WebMagick/files/patch-aa
+++ b/www/WebMagick/files/patch-aa
@@ -2,15 +2,15 @@ Index: webmagick.in
===================================================================
RCS file: /cvsroot/webmagick/WebMagick/webmagick.in,v
retrieving revision 1.117
-retrieving revision 1.159
-diff -u -r1.117 -r1.159
+retrieving revision 1.161
+diff -u -r1.117 -r1.161
--- webmagick.in 23 Oct 2002 16:14:47 -0000 1.117
-+++ webmagick.in 24 Jul 2010 14:12:39 -0000 1.159
++++ webmagick.in 15 Sep 2010 05:07:23 -0000 1.161
@@ -1,6 +1,6 @@
#! @PERL@
#
-# $Id: webmagick.in,v 1.117 2002/10/23 16:14:47 clindell Exp $
-+# $Id: webmagick.in,v 1.159 2010/07/24 14:12:39 ache Exp $
++# $Id: webmagick.in,v 1.161 2010/09/15 05:07:23 ache Exp $
#
# You are looking at the main PERL script for WebMagick, a package to
# intelligently create HTML and JavaScript index files and imagemaps
@@ -844,7 +844,7 @@ diff -u -r1.117 -r1.159
print( INDEX " <META NAME=\"Author\" CONTENT=\"${opt_metaauthor}\">\n" )
if( "$opt_metaauthor" ne '' );
print( INDEX " <META NAME=\"Description\" CONTENT=\"${opt_metadescription}\">\n" )
-@@ -2379,32 +2475,65 @@
+@@ -2379,32 +2475,63 @@
print( INDEX "</HEAD>\n" );
print( INDEX "<BODY\n" );
@@ -879,11 +879,8 @@ diff -u -r1.117 -r1.159
+ if( $imageCaptions{'pageTitle'} ne '') {
+ print( INDEX "<p><FONT SIZE=\"+3\">$imageCaptions{'pageTitle'}</FONT></p>\n");
+ print( STDERR "Using custom PageDescription\n") if $opt_debug;
-+ } else {
-+ print( INDEX "<P>\n" );
- }
- print( INDEX "$indexbar<BR>\n" );
-
++ }
++
+ if( $imageCaptions{'pageTitle'} eq '' &&
+ $opt_indexinfo && (!$opt_frames || $opt_framestyle == 1) ) {
+ my $desc1 = '';
@@ -902,11 +899,13 @@ diff -u -r1.117 -r1.159
+ } else {
+ $desc2=escapehtml($imageNames[$pageNumber - 1][$numimages-1]);
+ }
-+ print( INDEX "<FONT SIZE=\"-1\">${opt_msg_index_of_files}\"",
++ print( INDEX "<DIV class='wm_msgindex'>${opt_msg_index_of_files}\"",
+ $desc1, "\" ${opt_msg_index_through}", " \"", $desc2,
-+ "\"</FONT><BR>\n" );
-+ }
-+
++ "\"</DIV>\n" );
+ }
+- print( INDEX "$indexbar<BR>\n" );
++ print( INDEX "<DIV class='wm_indexbar'>$indexbar</DIV>\n" );
+
if ($opt_tables)
{
- print INDEX "<TABLE WIDTH=\"90%\">";
@@ -925,7 +924,7 @@ diff -u -r1.117 -r1.159
}
else
{
-@@ -2423,35 +2552,47 @@
+@@ -2423,35 +2550,47 @@
}
print( INDEX
"<IMG SRC=\"$montageImages[$pageNumber - 1]\" $montageImageSizes[$pageNumber - 1]",
@@ -979,7 +978,7 @@ diff -u -r1.117 -r1.159
print( PICHTML " <META NAME=\"Author\" CONTENT=\"${opt_metaauthor}\">\n" )
if( "$opt_metaauthor" ne '' );
print( PICHTML " <META NAME=\"Description\" CONTENT=\"${opt_metadescription}\">\n" )
-@@ -2469,32 +2610,19 @@
+@@ -2469,32 +2608,19 @@
print( PICHTML "</HEAD>\n" );
print( PICHTML "<BODY\n" );
@@ -1020,7 +1019,7 @@ diff -u -r1.117 -r1.159
# Must be visible at each page, if no frames
if (!$opt_frames) {
-@@ -2502,12 +2630,12 @@
+@@ -2502,12 +2628,12 @@
# --- readme link ---
if ( $haveReadme ) {
print (PICHTML "<A HREF=\"${opt_readme}\"><IMG\n",
@@ -1035,7 +1034,7 @@ diff -u -r1.117 -r1.159
if ($opt_frames) {
print ( PICHTML "<A HREF=\"${opt_pageindexname}${pageNumber}${opt_htmlext}\"");
print ( PICHTML " TARGET=\"$frameTargets{'thumbview'}\"")
-@@ -2515,51 +2643,100 @@
+@@ -2515,51 +2641,100 @@
print ( PICHTML "<A HREF=\"${pNumber}${opt_indexname}\"");
}
print ( PICHTML "><IMG SRC=\"$iconImageUrls{'up'}\"",
@@ -1153,7 +1152,7 @@ diff -u -r1.117 -r1.159
}
print( PICHTML "$opt_pichtmlbottom\n") if ("$opt_pichtmlbottom" ne '');
-@@ -2570,15 +2747,15 @@
+@@ -2570,15 +2745,15 @@
unless ($opt_tables)
{
@@ -1173,7 +1172,7 @@ diff -u -r1.117 -r1.159
}
}
-@@ -2590,7 +2767,7 @@
+@@ -2590,7 +2765,7 @@
print INDEX "<TR ALIGN=CENTER VALIGN=TOP>";
}
@@ -1182,7 +1181,7 @@ diff -u -r1.117 -r1.159
if ($opt_pichtml) {
print (INDEX "<A${target} HREF=\"", escapeurl($pichtml), "\">");
-@@ -2601,17 +2778,34 @@
+@@ -2601,17 +2776,34 @@
# TODO: make sure the thumbnails are created, and get some image sizes
# TODO: save the labels in a new array, maybe same with sizes
if ( $thumbImageSizes{$pic}) {
@@ -1222,7 +1221,7 @@ diff -u -r1.117 -r1.159
} # if ($opt_tables)
} # for each picture
-@@ -2622,6 +2816,13 @@
+@@ -2622,6 +2814,13 @@
{
print INDEX "</TR>";
}
@@ -1236,7 +1235,7 @@ diff -u -r1.117 -r1.159
print (INDEX "</TABLE>\n")
} else {print( INDEX "</MAP>\n" );}
}
-@@ -2630,6 +2831,9 @@
+@@ -2630,6 +2829,9 @@
# Print Copyright info on non-blank pages.
if( $numimages > 0 ) {
@@ -1246,7 +1245,7 @@ diff -u -r1.117 -r1.159
if( "${opt_address}" ne '' ) {
print( INDEX "<BR><ADDRESS>${opt_address}</ADDRESS>\n" );
}
-@@ -2642,13 +2846,17 @@
+@@ -2642,13 +2844,17 @@
# If anonymous, don't show copyright and address info
if( ! $opt_anonymous ) {
print( INDEX "<HR>\n${opt_msg_produced_by} " );
@@ -1266,7 +1265,7 @@ diff -u -r1.117 -r1.159
}
print( INDEX "</BODY>\n" );
-@@ -2674,13 +2882,12 @@
+@@ -2674,13 +2880,12 @@
open( JSINDEX, ">$fileNames{'jsPageIndex'}")
|| die("$0: Failed to open file $fileNames{'jsPageIndex'} for output\n$@\n");
@@ -1284,7 +1283,7 @@ diff -u -r1.117 -r1.159
print( JSINDEX " top.drawWindows();\n");
print( JSINDEX "</SCRIPT>\n");
print( JSINDEX "</BODY>\n");
-@@ -2714,6 +2921,8 @@
+@@ -2714,6 +2919,8 @@
# Image labels
print( JSVARS "\n// image titles\n", jsHash( 'imageLabels', \%imageLabels ) );
@@ -1293,7 +1292,7 @@ diff -u -r1.117 -r1.159
# Image labels
#print( JSVARS "\n// table image titles\n", jsHash( 'tableImageLabels', \%tableImageLabels ) );
-@@ -2803,6 +3012,8 @@
+@@ -2803,6 +3010,8 @@
# Image labels
print( PERLVARS "\n# image titles\n", plHash( 'imageLabels', \%imageLabels ) );
@@ -1302,7 +1301,7 @@ diff -u -r1.117 -r1.159
# Table image labels
print( PERLVARS "\n# table image titles\n", plHash( 'tableImageLabels', \%tableImageLabels ) );
-@@ -3062,7 +3273,7 @@
+@@ -3062,7 +3271,7 @@
# Copy image so we can play with it without effecting original
print( STDERR "Copying montage to scratch ...\n" )
if $opt_debug;
@@ -1311,7 +1310,7 @@ diff -u -r1.117 -r1.159
handleMagickError( __FILE__, __LINE__, "", $image) unless ref($image);
last MONTAGE unless ref($image);
-@@ -3465,6 +3676,10 @@
+@@ -3465,6 +3674,10 @@
sub sortDir {
if(defined($dirOrder{$a}) && defined($dirOrder{$b})) {
$dirOrder{$a} <=> $dirOrder{$b}
@@ -1322,7 +1321,7 @@ diff -u -r1.117 -r1.159
} else {
lc($a) cmp lc($b);
}
-@@ -3476,7 +3691,11 @@
+@@ -3476,7 +3689,11 @@
sub sortImages {
if(defined($imageOrder{$a}) && defined($imageOrder{$b})) {
$imageOrder{$a} <=> $imageOrder{$b}
@@ -1335,7 +1334,7 @@ diff -u -r1.117 -r1.159
lc($a) cmp lc($b);
}
}
-@@ -3533,6 +3752,9 @@
+@@ -3533,6 +3750,9 @@
sub compareHash {
my( $hash1, $hash2) = @_;
@@ -1345,7 +1344,7 @@ diff -u -r1.117 -r1.159
if(scalar(keys(%$hash1)) != scalar(keys(%$hash2))) {
return( 1 ); # different length
}
-@@ -3868,7 +4090,7 @@
+@@ -3868,7 +4088,7 @@
# Set image label
#
my $label = '';
@@ -1354,7 +1353,7 @@ diff -u -r1.117 -r1.159
if( defined( $imageLabels{$imagename} ) ) {
# Set image specific label
$label = $imageLabels{$imagename};
-@@ -3922,7 +4144,7 @@
+@@ -3922,7 +4142,7 @@
# put our label into the table image hash
@@ -1363,7 +1362,7 @@ diff -u -r1.117 -r1.159
$tableImageLabels{$imagename} =~ s/\n/<BR>/g;
print( STDERR "Applying image label: \"${label}\"\n" )
-@@ -4073,6 +4295,7 @@
+@@ -4073,6 +4293,7 @@
--[no]forcehtml Force HTML files to be generated (default off)
--[no]forcemontage Force montage (default off)
--[no]ignorefp Ignore directories with names like _vti (FrontPage directories) (default on)
@@ -1371,7 +1370,7 @@ diff -u -r1.117 -r1.159
--[no]help Display usage message (default off)
--[no]recurse Recurse directory tree (default off)
--srcdir Image directory to process
-@@ -4093,6 +4316,8 @@
+@@ -4093,6 +4314,8 @@
Filenames:
--dirindexname Directory-name to title cross-reference file name
--imgindexname Image-name to thumbnail label cross-reference file name
@@ -1380,7 +1379,7 @@ diff -u -r1.117 -r1.159
--indexname Name of master index files (default server index)
--pageindexname Base name of page-related index files
--readme Name of directory info file
-@@ -4138,6 +4363,7 @@
+@@ -4138,6 +4361,7 @@
HTML Colors & Appearance:
--address Optional user address info
@@ -1388,7 +1387,7 @@ diff -u -r1.117 -r1.159
--[no]anonymous Don't show WebMagick address and copyright info on pages (default off)
--coloralink Link (active) color
--colorback Background color (also applied to JPEG montage background)
-@@ -4150,31 +4376,45 @@
+@@ -4150,31 +4374,45 @@
--dircolorlink Link (unvisited) color (directory frame)
--dircolorvlink Link (visited) color (directory frame)
--dirhtmlext Extension for directory frame
@@ -1442,7 +1441,7 @@ diff -u -r1.117 -r1.159
--framestyle Frame style to use (out of those available)
--[no]allowconfig Allow user to configure framestyle, columns and rows (requires javascript and tables) (default off)
-@@ -4296,6 +4536,7 @@
+@@ -4296,6 +4534,7 @@
s/&/&amp;/g;
s/>/&gt;/g;
s/</&lt;/g;
@@ -1450,7 +1449,7 @@ diff -u -r1.117 -r1.159
return( $_ );
}
-@@ -4324,23 +4565,11 @@
+@@ -4324,23 +4563,11 @@
# Escape unsafe characters in URLs
#
sub escapeurl {
@@ -1478,7 +1477,7 @@ diff -u -r1.117 -r1.159
return( $_ );
}
-@@ -4387,7 +4616,6 @@
+@@ -4387,7 +4614,6 @@
my $rc;
foreach $rc (@_) {
next if ( ! -r $rc || ! -f $rc );
@@ -1486,7 +1485,7 @@ diff -u -r1.117 -r1.159
eval ( get_rc($rc) );
if( $@ ) {
print( STDERR "Bad Eval for file \"${rc}\"...\n$@\n" );
-@@ -4468,7 +4696,7 @@
+@@ -4468,7 +4694,7 @@
my $path=$top;
$direlem='';
do {