aboutsummaryrefslogtreecommitdiff
path: root/www/abcache
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2002-02-28 16:32:50 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2002-02-28 16:32:50 +0000
commitc34230526d53879966c6bf31f8c5edd9c62a1c74 (patch)
tree8a986f2ae11a4ac88e6e699c9b1746f78d1a6817 /www/abcache
parent7a948266fea202f17ce1663cb0fcf6a36fa8ff17 (diff)
downloadports-c34230526d53879966c6bf31f8c5edd9c62a1c74.tar.gz
ports-c34230526d53879966c6bf31f8c5edd9c62a1c74.zip
Notes
Diffstat (limited to 'www/abcache')
-rw-r--r--www/abcache/Makefile41
-rw-r--r--www/abcache/distinfo1
-rw-r--r--www/abcache/pkg-comment1
-rw-r--r--www/abcache/pkg-descr14
-rw-r--r--www/abcache/pkg-message14
-rw-r--r--www/abcache/pkg-plist1
6 files changed, 72 insertions, 0 deletions
diff --git a/www/abcache/Makefile b/www/abcache/Makefile
new file mode 100644
index 000000000000..58637d1d2cde
--- /dev/null
+++ b/www/abcache/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: abcache
+# Date created: Sat Feb 23 14:27:35 CET 2002
+# Whom: Alex Dupre <sysadmin@alexdupre.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= abcache
+PORTVERSION= 0.14
+CATEGORIES= www
+MASTER_SITES= http://afterburner.bware.it/download/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= sysadmin@alexdupre.com
+
+BUILD_DEPENDS= aclocal:${PORTSDIR}/devel/automake \
+ autoconf:${PORTSDIR}/devel/autoconf \
+ phpize:${PORTSDIR}/www/mod_php4
+RUN_DEPENDS= ${LOCALBASE}/sbin/httpd:${PORTSDIR}/www/apache13 \
+ ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
+
+USE_LIBTOOL= yes
+LIBTOOLFILES= aclocal.m4
+
+WRKSRC= ${WRKDIR}/bware_cache-${PORTVERSION}
+
+CONFIGURE_ARGS+=--enable-bware_cache=shared \
+ --with-php-config=${PREFIX}/bin/php-config
+
+post-extract:
+ @${ECHO_MSG} "===> PHPizing for ${DISTNAME}"
+ @cd ${WRKSRC} && ${LOCALBASE}/bin/phpize
+
+do-install:
+ @${INSTALL} ${WRKSRC}/modules/bware_cache.so \
+ ${LOCALBASE}/lib/php/20010901
+
+post-install:
+ @${SED} s!%%LOCALBASE%%!${LOCALBASE}!g ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/abcache/distinfo b/www/abcache/distinfo
new file mode 100644
index 000000000000..1df96804c82c
--- /dev/null
+++ b/www/abcache/distinfo
@@ -0,0 +1 @@
+MD5 (abcache-0.14.tgz) = 2fbdc342142066dcd02f7b55e8e1d505
diff --git a/www/abcache/pkg-comment b/www/abcache/pkg-comment
new file mode 100644
index 000000000000..921a8696f55b
--- /dev/null
+++ b/www/abcache/pkg-comment
@@ -0,0 +1 @@
+A tool to cache applications written in PHP
diff --git a/www/abcache/pkg-descr b/www/abcache/pkg-descr
new file mode 100644
index 000000000000..3a4d48d3a95d
--- /dev/null
+++ b/www/abcache/pkg-descr
@@ -0,0 +1,14 @@
+afterBURNER*Cache is a tool to speed up web applications written
+in PHP.
+It works by caching inside the web server compiled PHP code (the
+first time it's executed) so that the next time the same script
+is called it is simply restored, already compiled, from the cache
+with big savings in terms of execution time.
+Caching and saving scripts at compile time can be a big performance
+win, especially if your PHP script is complex and makes heavy use
+of libraries.
+
+WWW: http://afterburner.bware.it/
+
+- Alex Dupre
+sysadmin@alexdupre.com
diff --git a/www/abcache/pkg-message b/www/abcache/pkg-message
new file mode 100644
index 000000000000..e60c43635c7f
--- /dev/null
+++ b/www/abcache/pkg-message
@@ -0,0 +1,14 @@
+*****************************************************************************
+
+You have installed the abcache package.
+
+Edit %%LOCALBASE%%/etc/php.ini and add:
+
+[abcache]
+zend_extension="%%LOCALBASE%%/lib/php/20010901/bware_cache.so"
+bware_cache_enable="1"
+bware_cache_check_stamp="1"
+bware_cache_log_level="1"
+bware_cache_only=*.php"
+
+*****************************************************************************
diff --git a/www/abcache/pkg-plist b/www/abcache/pkg-plist
new file mode 100644
index 000000000000..880462ad9765
--- /dev/null
+++ b/www/abcache/pkg-plist
@@ -0,0 +1 @@
+lib/php/20010901/bware_cache.so