aboutsummaryrefslogtreecommitdiff
path: root/www/abyssws/Makefile
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2014-08-22 09:16:44 +0000
committerRene Ladan <rene@FreeBSD.org>2014-08-22 09:16:44 +0000
commitc8d71ace8551a8e04d523d034aabb457bd80e67c (patch)
tree3b7e04588986f7ef8465da72e414abc21dcfd4eb /www/abyssws/Makefile
parente9d3c6233cde12feee735b103206cb20bdff8639 (diff)
downloadports-c8d71ace8551a8e04d523d034aabb457bd80e67c.tar.gz
ports-c8d71ace8551a8e04d523d034aabb457bd80e67c.zip
Notes
Diffstat (limited to 'www/abyssws/Makefile')
-rw-r--r--www/abyssws/Makefile54
1 files changed, 0 insertions, 54 deletions
diff --git a/www/abyssws/Makefile b/www/abyssws/Makefile
deleted file mode 100644
index cb57dc3fec5e..000000000000
--- a/www/abyssws/Makefile
+++ /dev/null
@@ -1,54 +0,0 @@
-# Created by: Daniel Voisine <voisined@wit.edu>
-# $FreeBSD$
-
-PORTNAME= abyssws
-PORTVERSION= 2.6
-PORTREVISION= 1
-CATEGORIES= www
-MASTER_SITES= http://www.aprelium.com/data/
-DISTNAME= abwsx1-freebsd
-EXTRACT_SUFX= .tgz
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Abyss Web Server is a compact and easy to use web server
-
-BROKEN= Fails to install
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2014-08-22
-
-WRKSRC= ${WRKDIR}/abyssws
-ONLY_FOR_ARCHS= i386
-NO_BUILD= yes
-
-USE_RC_SUBR= abyssws
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700043
-LIB_DEPENDS+= libc.so.6:${PORTSDIR}/misc/compat6x
-.endif
-
-pre-install:
- @${SETENV} PKG_PREFIX=${PREFIX} \
- ${SH} ${PKGINSTALL} ${PORTNAME} PRE-INSTALL
- @if [ -f ${WRKSRC}/htdocs/index.html ]; then \
- ${MV} -f ${WRKSRC}/htdocs/index.html \
- ${WRKSRC}/htdocs/index.html-dist ; \
- fi
-
-do-install:
- @${INSTALL} -d ${PREFIX}/lib/abyssws
- ${TAR} -C ${WRKSRC} -cf - . | ${TAR} -C ${PREFIX}/lib/abyssws -xf -
- @ ${CHOWN} -R abyssws:abyssws ${PREFIX}/lib/abyssws/
- @${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}' >> ${TMPPLIST}
-
-post-install:
- @if [ ! -f ${PREFIX}/lib/abyssws/htdocs/index.html ]; then \
- ${CP} -p ${PREFIX}/lib/abyssws/htdocs/index.html-dist \
- ${PREFIX}/lib/abyssws/htdocs/index.html ; \
- fi
- @${SETENV} PKG_PREFIX=${PREFIX} \
- ${SH} ${PKGINSTALL} ${PORTNAME} POST-INSTALL
-
-.include <bsd.port.post.mk>