aboutsummaryrefslogtreecommitdiff
path: root/www/ajaxplorer/Makefile
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2013-07-07 15:48:16 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2013-07-07 15:48:16 +0000
commit692e9ad38862eb6ffe84333523b58b2a1bdc1b79 (patch)
treea23381c089b8a2b5b515b9da5ac87d570608f237 /www/ajaxplorer/Makefile
parentb2fb659e12e4d2d00a3cf79f2efb5bdb9c25e8ee (diff)
Notes
Diffstat (limited to 'www/ajaxplorer/Makefile')
-rw-r--r--www/ajaxplorer/Makefile22
1 files changed, 20 insertions, 2 deletions
diff --git a/www/ajaxplorer/Makefile b/www/ajaxplorer/Makefile
index 7957293827f7..718a89e3c209 100644
--- a/www/ajaxplorer/Makefile
+++ b/www/ajaxplorer/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= ajaxplorer
-PORTVERSION= 4.2.3
+PORTVERSION= 5.0.1
CATEGORIES= www
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/stable-channel/${PORTVERSION}
DISTNAME= ${PORTNAME}-core-${PORTVERSION}
@@ -16,15 +16,33 @@ USE_PHP= dom mcrypt gd
USE_DOS2UNIX= yes
DOS2UNIX_REGEX= .*\.php
WANT_PHP_WEB= yes
-SUB_FILES= pkg-deinstall pkg-message
+SUB_FILES= pkg-deinstall pkg-install pkg-message
+
+post-patch:
+ @${RM} -f ${WRKSRC}/plugins/gui.ajax/res/themes/vision/images/mimes/16/._users-folder.png
+ @${MV} ${WRKSRC}/conf/bootstrap_conf.php ${WRKDIR}/bootstrap_conf.php.sample
+ @${MV} ${WRKSRC}/conf/bootstrap_context.php ${WRKDIR}/bootstrap_context.php.sample
+ @${MV} ${WRKSRC}/conf/bootstrap_repositories.php ${WRKDIR}/bootstrap_repositories.php.sample
do-install:
${MKDIR} ${WWWDIR}
(cd ${WRKSRC} && ${COPYTREE_SHARE} "* .htaccess" ${WWWDIR})
+ ${INSTALL_DATA} ${WRKDIR}/bootstrap_*.php.sample ${WWWDIR}/conf
+ ${INSTALL_DATA} ${FILESDIR}/4.2.3-5.0.0-db-upgrade.sql ${WWWDIR}/conf
${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
post-install:
+ @if [ ! -f ${WWWDIR}/conf/bootstrap_conf.php ]; then \
+ ${CP} -p ${WWWDIR}/conf/bootstrap_conf.php.sample ${WWWDIR}/conf/bootstrap_conf.php ; \
+ fi
+ @if [ ! -f ${WWWDIR}/conf/bootstrap_context.php ]; then \
+ ${CP} -p ${WWWDIR}/conf/bootstrap_context.php.sample ${WWWDIR}/conf/bootstrap_context.php ; \
+ fi
+ @if [ ! -f ${WWWDIR}/conf/bootstrap_repositories.php ]; then \
+ ${CP} -p ${WWWDIR}/conf/bootstrap_repositories.php.sample ${WWWDIR}/conf/bootstrap_repositories.php ; \
+ fi
@${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}' >> ${TMPPLIST}
+ @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>