aboutsummaryrefslogtreecommitdiff
path: root/www/amaya/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2001-12-02 18:20:59 +0000
committerSteve Price <steve@FreeBSD.org>2001-12-02 18:20:59 +0000
commitfb822abab8db4736dab872235be2222626899704 (patch)
treecfed6e29644acc784f5cf1187d39642107280bd3 /www/amaya/Makefile
parent607c86dd5d0fecac63c8f8b8086bfceac456f4a7 (diff)
Notes
Diffstat (limited to 'www/amaya/Makefile')
-rw-r--r--www/amaya/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/www/amaya/Makefile b/www/amaya/Makefile
index 5d15f7c4f321..07b2a9411852 100644
--- a/www/amaya/Makefile
+++ b/www/amaya/Makefile
@@ -6,19 +6,19 @@
#
PORTNAME= amaya
-PORTVERSION= 5.1
+PORTVERSION= 5.2
CATEGORIES= www
MASTER_SITES= http://www.w3.org/Amaya/Distribution/ \
ftp://ftp.w3.org/pub/amaya/
DISTNAME= ${PORTNAME}-src-${PORTVERSION}
DISTFILES= ${DISTNAME}.tgz
+DIST_SUBDIR= amaya
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png
-DIST_SUBDIR= amaya
WRKSRC= ${WRKDIR}/Amaya/obj
USE_MOTIF= yes
@@ -45,7 +45,7 @@ DISTFILES+= ${DICT:S/$/.tgz/g}
.endif
.endif
-pre-fetch:
+pre-everything::
.if ${DICT} == "none"
@${ECHO_MSG} Several spellchecking dictionaries are available. To use
@${ECHO_MSG} one of them, define DICT to be the appropriate language.
@@ -54,6 +54,9 @@ pre-fetch:
post-extract:
${MKDIR} ${WRKSRC}
+post-patch:
+ ${PERL} -pi.dist -e 's|\"1.0\\.|\"1\\.|g' ${WRKSRC}/../configure
+
post-configure:
${CP} ${WRKSRC}/Options.orig ${WRKSRC}/Options