aboutsummaryrefslogtreecommitdiff
path: root/www/analog
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2006-01-04 23:32:10 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2006-01-04 23:32:10 +0000
commit526cba4b55f9fd5afd12640bcdac4468b41f6236 (patch)
treec65ad1d3e5c07fbebfb75b2b2061fde64a486f75 /www/analog
parent04e6ceb56366b097653eeed6c208fa51bcb4438a (diff)
downloadports-526cba4b55f9fd5afd12640bcdac4468b41f6236.tar.gz
ports-526cba4b55f9fd5afd12640bcdac4468b41f6236.zip
Notes
Diffstat (limited to 'www/analog')
-rw-r--r--www/analog/Makefile9
-rw-r--r--www/analog/files/pkg-message.in7
-rw-r--r--www/analog/pkg-plist2
3 files changed, 17 insertions, 1 deletions
diff --git a/www/analog/Makefile b/www/analog/Makefile
index 8574450bb815..daeb87e24bb3 100644
--- a/www/analog/Makefile
+++ b/www/analog/Makefile
@@ -7,7 +7,7 @@
PORTNAME= analog
PORTVERSION= 6.0
-PORTREVISION= 0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= http://www.analog.cx/ \
@@ -35,6 +35,8 @@ PLIST_SUB= IMGDIR=${LIMGDIR}
MAN1= analog.1
ALL_TARGET= analog
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKSRC}/pkg-message
.include <bsd.port.pre.mk>
@@ -53,6 +55,8 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/docs/* ${DOCSDIR}
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/*.cfg ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/anlgform.html ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/anlgform.pl ${EXAMPLESDIR}
${MKDIR} ${EXAMPLESDIR}/css
${INSTALL_DATA} ${WRKSRC}/examples/css/Readme.txt ${EXAMPLESDIR}/css
${INSTALL_DATA} ${WRKSRC}/examples/css/default.css ${EXAMPLESDIR}/css
@@ -61,4 +65,7 @@ do-install:
.endif
${INSTALL_MAN} ${WRKSRC}/analog.man ${PREFIX}/man/man1/analog.1
+post-install:
+ ${CAT} ${PKGMESSAGE}
+
.include <bsd.port.post.mk>
diff --git a/www/analog/files/pkg-message.in b/www/analog/files/pkg-message.in
new file mode 100644
index 000000000000..81eb8dac1380
--- /dev/null
+++ b/www/analog/files/pkg-message.in
@@ -0,0 +1,7 @@
+Note: Analog includes an optional form and perl script to request
+analyses via a web interface. The form and script both require
+customization before use. If you would like to use them, first copy
+%%EXAMPLESDIR%%/etc/anlgform.pl to $$CGI-BIN, and then edit
+$$HTDOCS/anlgform.html and $$CGI-BIN/anlgform.pl for your local
+configuration. Both files are extensively commented with instructions
+for customization.
diff --git a/www/analog/pkg-plist b/www/analog/pkg-plist
index 40d0f550b204..b76e2a8fbd0a 100644
--- a/www/analog/pkg-plist
+++ b/www/analog/pkg-plist
@@ -234,6 +234,8 @@ share/analog/lang/yudom.tab
%%PORTDOCS%%%%DOCSDIR%%/wasnew5.html
%%PORTDOCS%%%%DOCSDIR%%/webworks.html
%%PORTDOCS%%%%DOCSDIR%%/whatsnew.html
+%%PORTDOCS%%%%EXAMPLESDIR%%/anlgform.html
+%%PORTDOCS%%%%EXAMPLESDIR%%/anlgform.pl
%%PORTDOCS%%%%EXAMPLESDIR%%/big.cfg
%%PORTDOCS%%%%EXAMPLESDIR%%/bigbyrep.cfg
%%PORTDOCS%%%%EXAMPLESDIR%%/css/Readme.txt