aboutsummaryrefslogtreecommitdiff
path: root/www/anyremote2html/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-01-01 00:18:11 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-01-01 00:18:11 +0000
commitc5e7914fb4c76f5e033df34e96d7003a428b663f (patch)
tree44036f7c6c59e4fef7a53833a3d382ee8051c734 /www/anyremote2html/Makefile
parentded8f1f589b2f250627a4f1fbf890fa7225f4204 (diff)
downloadports-c5e7914fb4c76f5e033df34e96d7003a428b663f.tar.gz
ports-c5e7914fb4c76f5e033df34e96d7003a428b663f.zip
Notes
Diffstat (limited to 'www/anyremote2html/Makefile')
-rw-r--r--www/anyremote2html/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/www/anyremote2html/Makefile b/www/anyremote2html/Makefile
new file mode 100644
index 000000000000..1b47c76b2480
--- /dev/null
+++ b/www/anyremote2html/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: anyremote2html
+# Date created: 26 December 2008
+# Whom: Alexander Logvinov <ports@logvinov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= anyremote2html
+PORTVERSION= 0.6
+CATEGORIES= www deskutils
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= anyremote
+
+MAINTAINER= ports@logvinov.com
+COMMENT= A web interface for anyRemote
+
+RUN_DEPENDS= anyremote:${PORTSDIR}/comms/anyremote
+
+GNU_CONFIGURE= yes
+USE_PYTHON_RUN= yes
+
+PORTDOCS= NEWS README COPYING VERSION AUTHORS
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|g' ${WRKSRC}/${PORTNAME}
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '/doc\/${PORTNAME}/d' ${WRKSRC}/Makefile.in
+.endif
+
+post-install:
+.for dir in 16 32 64
+ @${CHMOD} 644 ${PREFIX}/share/pixmaps/${PORTNAME}/${dir}/*
+.endfor
+
+.include <bsd.port.mk>