aboutsummaryrefslogtreecommitdiff
path: root/www/anyterm
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-04-15 08:20:27 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2015-04-15 08:20:27 +0000
commit074ea5282a00d556c73d86231bec5444990597dc (patch)
treeeec3d608e84e79f0187985e5a1e29cd4f04f13eb /www/anyterm
parent522c152d1c7b0c92982e310110fa6d59f915ffeb (diff)
downloadports-074ea5282a00d556c73d86231bec5444990597dc.tar.gz
ports-074ea5282a00d556c73d86231bec5444990597dc.zip
Notes
Diffstat (limited to 'www/anyterm')
-rw-r--r--www/anyterm/Makefile16
-rw-r--r--www/anyterm/files/patch-libpbe-include-Iconver.hh11
2 files changed, 24 insertions, 3 deletions
diff --git a/www/anyterm/Makefile b/www/anyterm/Makefile
index feec025e7f49..8166412213a4 100644
--- a/www/anyterm/Makefile
+++ b/www/anyterm/Makefile
@@ -3,6 +3,7 @@
PORTNAME= anyterm
PORTVERSION= 1.1.29
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://anyterm.org/download/ \
http://apt.douglasthrift.net/files/${PORTNAME}/ \
@@ -23,12 +24,21 @@ ALL_TARGET= default_target
PLIST_FILES= man/man1/anytermd.1.gz \
sbin/anytermd
+CPPFLAGS+= -I${LOCALBASE}/include
+
post-patch:
@${REINPLACE_CMD} -e 's|/private/etc/apache2|${FILESDIR}|' \
${WRKSRC}/scripts/mimetype.sh
- @${REINPLACE_CMD} -e 's|^CPP_FLAGS=|&-I${LOCALBASE}/include |' \
- -e 's|^LINK_FLAGS=|&-L${ICONV_PREFIX}/lib ${ICONV_LIB} |' ${WRKSRC}/common.mk
- @${REINPLACE_CMD} -e 's|^COMPILE_FLAGS=|&-I${LOCALBASE}/include |' \
+ @${REINPLACE_CMD} \
+ -e 's|$$(CPP_FLAGS)|& ${CPPFLAGS} |' \
+ -e '/^COMPILE_FLAGS=/s|$$| ${CXXFLAGS}|' \
+ -e 's|$${OPTIMISE_FLAGS}||' \
+ -e 's|$$(LINK_FLAGS)|& -L${ICONV_PREFIX}/lib ${ICONV_LIB} |' \
+ ${WRKSRC}/common.mk
+ @${REINPLACE_CMD} \
+ -e '/^COMPILE_FLAGS=/s|$$| ${CXXFLAGS}|' \
+ -e 's|$$(INC_FLAGS)|& ${CPPFLAGS} |' \
+ -e 's|$$(CXXFLAGS)||' -e 's|$$(OPTIMISE_FLAGS)||' \
${WRKSRC}/libpbe/common.mk
do-install:
diff --git a/www/anyterm/files/patch-libpbe-include-Iconver.hh b/www/anyterm/files/patch-libpbe-include-Iconver.hh
new file mode 100644
index 000000000000..432458b874b7
--- /dev/null
+++ b/www/anyterm/files/patch-libpbe-include-Iconver.hh
@@ -0,0 +1,11 @@
+--- libpbe/include/Iconver.hh.orig 2008-10-25 12:17:29 UTC
++++ libpbe/include/Iconver.hh
+@@ -36,7 +36,7 @@
+ #include "Exception.hh"
+
+
+-#if defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__sun__)
++#if defined(__OpenBSD__) || defined(__sun__)
+ // Previously __APPLE__ was included in this list; presumably they have
+ // changed their headers. If you have an older system you may need to put
+ // it back.