aboutsummaryrefslogtreecommitdiff
path: root/www/aolserver
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2007-04-05 12:37:59 +0000
committerMartin Matuska <mm@FreeBSD.org>2007-04-05 12:37:59 +0000
commit8926ff3d5007512d298d5a1de618309b67deec9f (patch)
tree783457f0433c535c30cdfcb69da340f119a92ec1 /www/aolserver
parent98d5084a24ce8464ecac4df6bcea9b9dec8a9309 (diff)
downloadports-8926ff3d5007512d298d5a1de618309b67deec9f.tar.gz
ports-8926ff3d5007512d298d5a1de618309b67deec9f.zip
Notes
Diffstat (limited to 'www/aolserver')
-rw-r--r--www/aolserver/Makefile16
1 files changed, 6 insertions, 10 deletions
diff --git a/www/aolserver/Makefile b/www/aolserver/Makefile
index 4248c6d66ca0..c6a7b3f9202a 100644
--- a/www/aolserver/Makefile
+++ b/www/aolserver/Makefile
@@ -14,7 +14,7 @@ MASTER_SITE_SUBDIR= aolserver
DIST_SUBDIR= aolserver
DISTVERSIONSUFFIX= -src
-MAINTAINER= martin@matuska.org
+MAINTAINER= mm@FreeBSD.org
COMMENT= A multithreaded web server with embedded TCL interpreter
WRKSRC= ${WRKDIR}/${DISTNAME:S/-src//}
@@ -37,14 +37,10 @@ SUB_VARS= AOLSERVERUSER=${AOLSERVERUSER} \
SUB_LIST+= ${SUB_VARS} AOLSERVERBASE=${AOLSERVERBASE}
PLIST_SUB+= ${SUB_VARS} AOLSERVERBASE=${AOLSERVERBASE:S/${TARGETDIR}\///}
-USE_TCL_VER?= 84
-ONLY_FOR_ARCHS= i386 amd64
-
-.if ${USE_TCL_VER} != 84 && ${USE_TCL_VER} != 85
-IGNORE= supported values for USE_TCL_VER are only 84 and 85
-.endif
+USE_TCL= 84+
+USE_TCL_THREADS= yes
-LIB_DEPENDS+= tcl${USE_TCL_VER}-threads:${PORTSDIR}/lang/tcl${USE_TCL_VER}-thread
+ONLY_FOR_ARCHS= i386 amd64
OPTIONS= HTMLDOCS "Install HTML documentation" off \
TESTS "Install tests in examples directory" off
@@ -55,9 +51,9 @@ OPTIONS= HTMLDOCS "Install HTML documentation" off \
BROKEN= does not compile on ia64
.endif
-CONFIGURE_ENV+= TCLSH=${LOCALBASE}/bin/tclsh${USE_TCL_VER:S/8/8./}-threads
+CONFIGURE_ENV+= TCLSH=${TCLSH}
CONFIGURE_ARGS+= --prefix=${AOLSERVERBASE} \
- --with-tcl=${LOCALBASE}/lib/tcl${USE_TCL_VER:S/8/8./}-threads
+ --with-tcl=${TCL_LIBDIR}
.if !defined(NO_INSTALL_MANPAGES)
INSTALL_TARGET= install install-man