aboutsummaryrefslogtreecommitdiff
path: root/www/apache-forrest
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2014-07-11 23:16:20 +0000
committerNicola Vitale <nivit@FreeBSD.org>2014-07-11 23:16:20 +0000
commit8f63476fffd1599693aa6f45d2e107740ff86b72 (patch)
treeac9108b3b40eef9c3b1c752be3c31a43b4ba80f5 /www/apache-forrest
parenteb9674d053f64887a0c5e9dfc0334fc4644870e2 (diff)
downloadports-8f63476fffd1599693aa6f45d2e107740ff86b72.tar.gz
ports-8f63476fffd1599693aa6f45d2e107740ff86b72.zip
Notes
Diffstat (limited to 'www/apache-forrest')
-rw-r--r--www/apache-forrest/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/www/apache-forrest/Makefile b/www/apache-forrest/Makefile
index 9768614dbf1c..6ee1fc6b6bb8 100644
--- a/www/apache-forrest/Makefile
+++ b/www/apache-forrest/Makefile
@@ -16,9 +16,12 @@ COMMENT= Tool for rapid development of small sites
ANT= ${STAGEDIR}${DATADIR}/tools/ant/bin/ant
ANT_TARGET= local-deploy
-IGNORE_FILES= KEYS README.txt .gitignore *.bak *.bat \
- *.orig forrest ant index.html
-IGNORE_FILES:= ${IGNORE_FILES:@f@-and ! -name ${f}@}
+IGNORE_FILES= ! -name *\.bak -and ! -name *\.bat \
+ -and ! -name *\.orig -and ! -name .gitignore \
+ -and ! -name KEYS -and ! -name README.txt \
+ -and ! -name ant -and ! -name forrest \
+ -and ! -name index.html
+
INSTALL_WRKSRC= ${WRKSRC}/build
JAVA_VERSION= 1.6+
@@ -42,7 +45,7 @@ post-patch:
do-install:
@cd ${WRKSRC}; \
- ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR} '${IGNORE_FILES:[2..-1]}'
+ ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR} '${IGNORE_FILES}'
@${INSTALL_SCRIPT} ${WRKSRC}/bin/forrest ${STAGEDIR}${DATADIR}/bin/forrest
@${INSTALL_SCRIPT} ${WRKSRC}/tools/ant/bin/ant ${STAGEDIR}${DATADIR}/tools/ant/bin/ant
@${LN} -sf ../${DATADIR_REL}/bin/forrest ${STAGEDIR}${PREFIX}/bin/forrest