aboutsummaryrefslogtreecommitdiff
path: root/www/apache13+ipv6
diff options
context:
space:
mode:
authorMunechika SUMIKAWA <sumikawa@FreeBSD.org>2008-09-30 03:13:43 +0000
committerMunechika SUMIKAWA <sumikawa@FreeBSD.org>2008-09-30 03:13:43 +0000
commit250abc5bd1e8b320cc5d8ec4d71700a4a2350357 (patch)
tree52ec583e4860682ead6d5395af778f981f0ca73c /www/apache13+ipv6
parent4e967735b2f411174fbcaf250dc5f8718d55fb92 (diff)
downloadports-250abc5bd1e8b320cc5d8ec4d71700a4a2350357.tar.gz
ports-250abc5bd1e8b320cc5d8ec4d71700a4a2350357.zip
Notes
Diffstat (limited to 'www/apache13+ipv6')
-rw-r--r--www/apache13+ipv6/Makefile13
-rw-r--r--www/apache13+ipv6/files/patch-ag36
2 files changed, 26 insertions, 23 deletions
diff --git a/www/apache13+ipv6/Makefile b/www/apache13+ipv6/Makefile
index aa86787859aa..cd6ca9b467c6 100644
--- a/www/apache13+ipv6/Makefile
+++ b/www/apache13+ipv6/Makefile
@@ -45,16 +45,16 @@ CGIBIN_ROOT=${DATADIR}/cgi-bin
.endif
DEFAULT_PATH=/bin:/usr/bin:${PREFIX}/bin
-.if defined(WITHOUT_APACHE_EXPAT) && ${WITHOUT_APACHE_EXPAT} == yes
+.if defined(WITHOUT_APACHE_EXPAT)
EXPAT_CONF+= --disable-rule=EXPAT
.else
-.if !defined(WITH_APACHE_INTERNAL_EXPAT) || ${WITH_APACHE_INTERNAL_EXPAT} != yes
+.if !defined(WITH_APACHE_INTERNAL_EXPAT)
LIB_DEPENDS+= expat.6:${PORTSDIR}/textproc/expat2
.endif
EXPAT_CONF+= --enable-rule=EXPAT
.endif
-.if defined(WITH_APACHE_SUEXEC) && ${WITH_APACHE_SUEXEC} == yes
+.if defined(WITH_APACHE_SUEXEC)
APACHE_SUEXEC_DOCROOT?=${DOCUMENT_ROOT}
APACHE_SUEXEC_LOG?=/var/log/httpd-suexec.log
@@ -129,9 +129,9 @@ CFLAGS+=-DHARD_SERVER_LIMIT=512
.endif
#
-# Set WITH_APACHE_PERF_TUNING env. variable to yes to get maximum performance
+# Set WITH_APACHE_PERF_TUNING env. variable to get maximum performance
#
-.if defined(WITH_APACHE_PERF_TUNING) && ${WITH_APACHE_PERF_TUNING} == yes
+.if defined(WITH_APACHE_PERF_TUNING)
CFLAGS+=-DBUFFERED_LOGS
# Don't use OPTIM below, it is inserted _before_ CFLAGS
CFLAGS+=-O3
@@ -139,8 +139,7 @@ CFLAGS+=-O3
CONFIGURE_ENV= OPTIM='${OPTIM}' LD_SHLIB='${CC}' LIBS='${LIBS}'
-.if (!defined(WITHOUT_APACHE_EXPAT) || ${WITHOUT_APACHE_EXPAT} != yes) && \
- (!defined(WITH_APACHE_INTERNAL_EXPAT) || ${WITH_APACHE_INTERNAL_EXPAT} != yes)
+.if !defined(WITHOUT_APACHE_EXPAT) && !defined(WITH_APACHE_INTERNAL_EXPAT)
CONFIGURE_ENV+= \
INCLUDES=-I${LOCALBASE}/include \
LDFLAGS=-L${LOCALBASE}/lib
diff --git a/www/apache13+ipv6/files/patch-ag b/www/apache13+ipv6/files/patch-ag
index 58c60812aa88..58ef46c45c2f 100644
--- a/www/apache13+ipv6/files/patch-ag
+++ b/www/apache13+ipv6/files/patch-ag
@@ -1,24 +1,24 @@
---- conf/httpd.conf-dist.orig Wed Jan 9 19:05:31 2002
-+++ conf/httpd.conf-dist Fri Jan 25 07:59:12 2002
+--- conf/httpd.conf-dist.old 2004-11-24 22:10:19.000000000 +0300
++++ conf/httpd.conf-dist 2008-07-19 18:42:27.000000000 +0400
@@ -356,7 +356,22 @@
# directory index. Separate multiple entries with spaces.
#
<IfModule mod_dir.c>
- DirectoryIndex index.html
+ <IfModule mod_php3.c>
-+ <IfModule mod_php4.c>
-+ DirectoryIndex index.php index.php3 index.html
-+ </IfModule>
-+ <IfModule !mod_php4.c>
-+ DirectoryIndex index.php3 index.html
-+ </IfModule>
++ DirectoryIndex index.php3 index.html
+ </IfModule>
+ <IfModule !mod_php3.c>
+ <IfModule mod_php4.c>
+ DirectoryIndex index.php index.html
+ </IfModule>
+ <IfModule !mod_php4.c>
-+ DirectoryIndex index.html
++ <IfModule mod_php5.c>
++ DirectoryIndex index.php index.html
++ </IfModule>
++ <IfModule !mod_php5.c>
++ DirectoryIndex index.html
++ </IfModule>
+ </IfModule>
+ </IfModule>
</IfModule>
@@ -42,12 +42,10 @@
#
# Optionally add a line containing the server version and virtual host
-@@ -759,6 +774,15 @@
- #
- <IfModule mod_negotiation.c>
+@@ -746,6 +761,19 @@
LanguagePriority en da nl et fr de el it ja kr no pl pt pt-br ru ltz ca es sv tw
-+ </IfModule>
-+
+ </IfModule>
+
+ <IfModule mod_php3.c>
+ AddType application/x-httpd-php3 .php3
+ AddType application/x-httpd-php3-source .php3s
@@ -55,6 +53,12 @@
+ <IfModule mod_php4.c>
+ AddType application/x-httpd-php .php
+ AddType application/x-httpd-php-source .phps
- </IfModule>
-
++ </IfModule>
++ <IfModule mod_php5.c>
++ AddType application/x-httpd-php .php
++ AddType application/x-httpd-php-source .phps
++ </IfModule>
++
#
+ # AddType allows you to tweak mime.types without actually editing it, or to
+ # make certain files to be certain types.