aboutsummaryrefslogtreecommitdiff
path: root/www/apache13-ssl/Makefile
diff options
context:
space:
mode:
authorMark Murray <markm@FreeBSD.org>1998-02-17 12:53:47 +0000
committerMark Murray <markm@FreeBSD.org>1998-02-17 12:53:47 +0000
commit26d85038780cfbd22140e99ed9acf742eb881b2c (patch)
tree48885c914ba1aba57c72f3f47323b905285c2114 /www/apache13-ssl/Makefile
parent493b8c21ad2f091bb76d597b77844231fb2d5f51 (diff)
downloadports-26d85038780cfbd22140e99ed9acf742eb881b2c.tar.gz
ports-26d85038780cfbd22140e99ed9acf742eb881b2c.zip
Notes
Diffstat (limited to 'www/apache13-ssl/Makefile')
-rw-r--r--www/apache13-ssl/Makefile74
1 files changed, 52 insertions, 22 deletions
diff --git a/www/apache13-ssl/Makefile b/www/apache13-ssl/Makefile
index 88becd81c9aa..d211cf1cbb28 100644
--- a/www/apache13-ssl/Makefile
+++ b/www/apache13-ssl/Makefile
@@ -1,54 +1,84 @@
# New ports collection makefile for: apache HTTPSD
-# Version required: 1.2.4
+# Version required: 1.2.5
# Date created: 15th August 1997
-# Whom: Richard Seaman <dick@tar.com>
+# Whom: Mark Murray <mark@grondar.za>
#
-# $Id: Makefile,v 1.40 1997/09/22 19:44:48 markm Exp $
+# $Id: Makefile,v 1.41 1997/10/13 15:03:39 markm Exp $
-DISTNAME= apache_1.2.4
-PKGNAME= apacheSSL-1.2.4
-CATEGORIES= www
+DISTNAME= apache_1.2.5
+PKGNAME= apacheSSL-1.2.5
+CATEGORIES= www security
MASTER_SITES= ftp://www.apache.org/apache/dist/ \
ftp://ftp.ox.ac.uk/pub/crypto/SSL/
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} apache_1.2.4+ssl_1.11.tar.gz
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} apache_1.2.5+ssl_1.13.tar.gz
-MAINTAINER= markm@freebsd.org
-
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+MAINTAINER= markm@freebsd.org
BUILD_DEPENDS= ssleay:${PORTSDIR}/security/SSLeay
+RUN_DEPENDS= ssleay:${PORTSDIR}/security/SSLeay
+
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
RESTRICTED= "Contains cryptography"
post-extract:
- @cd ${WRKSRC} && tar xzf ${DISTDIR}/apache_1.2.4+ssl_1.11.tar.gz
+ @cd ${WRKSRC} && tar xzf ${DISTDIR}/apache_1.2.5+ssl_1.13.tar.gz
pre-patch:
@cd ${WRKSRC} && ${PATCH} ${PATCH_DIST_ARGS} < SSLpatch
+MAN1= htpasswd.1
+MAN8= httpd.8
+DOCDIR= ${PREFIX}/share/doc/apache
+
+# Set it for local-supplied patch, f.e.
+# VERS_ID = mods-1.0/me
+
+.if defined(VERS_ID)
+post-patch:
+ @cd ${WRKSRC}/src && \
+ ${MV} Configuration Configuration.old && \
+ ${SED} 's;^#*OPTIM=.*;OPTIM= -DSERVER_SUBVERSION=\\"${VERS_ID}\\";' \
+ < Configuration.old > Configuration
+.endif
+
post-install:
- @if [ ! -f ${PREFIX}/etc/rc.d/apache_ssl.sh ]; then \
- ${ECHO} "Installing ${PREFIX}/etc/rc.d/apache_ssl.sh startup file."; \
- ${ECHO} "#!/bin/sh" > ${PREFIX}/etc/rc.d/apache_ssl.sh; \
- ${ECHO} "[ -x ${PREFIX}/sbin/httpsd ] && ${PREFIX}/sbin/httpsd && ${ECHO} -n ' httpsd'" >> ${PREFIX}/etc/rc.d/apache_ssl.sh; \
- chmod 751 ${PREFIX}/etc/rc.d/apache_ssl.sh; \
+ @if [ ! -f ${PREFIX}/etc/rc.d/apacheSSL.sh ]; then \
+ ${ECHO} "Installing ${PREFIX}/etc/rc.d/apacheSSL.sh startup file."; \
+ ${ECHO} "#!/bin/sh" > ${PREFIX}/etc/rc.d/apacheSSL.sh; \
+ ${ECHO} "[ -x ${PREFIX}/sbin/httpsd ] && ${PREFIX}/sbin/httpsd && ${ECHO} -n ' httpsd'" >> ${PREFIX}/etc/rc.d/apacheSSL.sh; \
+ chmod 751 ${PREFIX}/etc/rc.d/apacheSSL.sh; \
fi
- @${ECHO} "Please note: in order to install a certificate you have to"
- @${ECHO} "type:"
- @${ECHO} " make certificate"
+.for i in ${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/support/$i ${PREFIX}/man/man1
+.endfor
+.for i in ${MAN8}
+ ${INSTALL_MAN} ${WRKSRC}/support/$i ${PREFIX}/man/man8
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCDIR}
+.for i in README LICENSE ABOUT_APACHE
+ ${INSTALL_DATA} ${WRKSRC}/$i ${DOCDIR}
+.endfor
+ @cd ${WRKSRC}/htdocs; tar cf - . | (cd ${DOCDIR}; tar xf -)
+.endif
.if !defined(USA_RESIDENT) || ${USA_RESIDENT} != YES && ${USA_RESIDENT} != NO
pre-fetch:
@${ECHO}
- @${ECHO} You must set variable USA_RESIDENT to YES, if you are USA
- @${ECHO} resident or to NO, if you aren\'t USA resident to build
+ @${ECHO} You must set variable USA_RESIDENT to YES if you are USA
+ @${ECHO} resident or to NO if you aren\'t USA resident to build
@${ECHO} this package.
- @${ECHO} You must also have installed RSAREF if you are USA resident.
@false
.elif defined(USA_RESIDENT)
.if ${USA_RESIDENT} == YES
pre-build:
+ @${ECHO} If you are USA resident, then this port is broken for you.
+ @${ECHO} I am unable to get some of the necessary goodies, so
+ @${ECHO} please assist by fixing this and sending me the patches.
+ @${ECHO} Thanks\!
${PATCH} <${FILESDIR}/Makefile.rsa.patch
+BROKEN= "RSAref code doesn't apply cleanly"
.endif
.endif