aboutsummaryrefslogtreecommitdiff
path: root/www/apache13-ssl
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2003-01-27 17:05:36 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2003-01-27 17:05:36 +0000
commitb6f8a043820536087c2d4c1e42cff348a5c498a1 (patch)
treeff0cb856e3ab07d2bd9c4cdcf3ddcc6977fb6850 /www/apache13-ssl
parent9222584b287afb448dbd5c5759b6928862155886 (diff)
downloadports-b6f8a043820536087c2d4c1e42cff348a5c498a1.tar.gz
ports-b6f8a043820536087c2d4c1e42cff348a5c498a1.zip
Notes
Diffstat (limited to 'www/apache13-ssl')
-rw-r--r--www/apache13-ssl/Makefile9
-rw-r--r--www/apache13-ssl/files/patch-as10
-rw-r--r--www/apache13-ssl/files/patch-httpd.conf-dist32
-rw-r--r--www/apache13-ssl/pkg-plist3
4 files changed, 40 insertions, 14 deletions
diff --git a/www/apache13-ssl/Makefile b/www/apache13-ssl/Makefile
index caa1625d84cd..944df3a83193 100644
--- a/www/apache13-ssl/Makefile
+++ b/www/apache13-ssl/Makefile
@@ -9,7 +9,7 @@
PORTNAME= apache+ssl
PORTVERSION= ${APACHE_VERSION}.${APACHE_SSL_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www security
MASTER_SITES= http://www.apache.org/dist/httpd/ \
ftp://src.doc.ic.ac.uk/packages/apache/dist/ \
@@ -58,7 +58,8 @@ CFLAGS+= -I${OPENSSLINC}/openssl
HAS_CONFIGURE= yes
CONFIGURE_ARGS= \
--prefix=${PREFIX} \
- --server-gid=nogroup \
+ --server-uid=www \
+ --server-gid=www \
--with-perl=${PERL} \
--with-layout=GNU \
--suexec-docroot=${PREFIX}/www/data \
@@ -96,9 +97,11 @@ post-patch:
@cd ${WRKSRC} && ${SETENV} PREFIX=${PREFIX} ./FixPatch ${OPENSSLBASE}
certificate:
+ -${MKDIR} ${PREFIX}/etc/apache/certs
@if [ -f ${OPENSSLDIR}/openssl.cnf ]; then \
cd ${WRKSRC}/src; ${MAKE} ${MAKE_ENV} $@; \
- ${CP} ${WRKSRC}/SSLconf/conf/httpsd.pem ${PREFIX}/certs/cert.pem; \
+ ${CP} ${WRKSRC}/SSLconf/conf/httpsd.pem \
+ ${PREFIX}/etc/apache/certs/cert.pem; \
else \
${ECHO} "You must create the file ${OPENSSLDIR}/openssl.cnf first."; \
fi
diff --git a/www/apache13-ssl/files/patch-as b/www/apache13-ssl/files/patch-as
deleted file mode 100644
index f4f61f16ac8a..000000000000
--- a/www/apache13-ssl/files/patch-as
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.org Sun Feb 13 11:11:46 2000
-+++ configure Sun Feb 13 11:12:16 2000
-@@ -366,8 +366,8 @@
- ##
- ## Initialize server user ID and group ID variables
- ##
--conf_user=""
--conf_group=""
-+conf_user="nobody"
-+conf_group="nogroup"
diff --git a/www/apache13-ssl/files/patch-httpd.conf-dist b/www/apache13-ssl/files/patch-httpd.conf-dist
new file mode 100644
index 000000000000..90ac6002e0c5
--- /dev/null
+++ b/www/apache13-ssl/files/patch-httpd.conf-dist
@@ -0,0 +1,32 @@
+--- conf/httpd.conf-dist.orig Wed Sep 4 06:39:41 2002
++++ conf/httpd.conf-dist Mon Jan 27 17:29:26 2003
+@@ -943,6 +943,29 @@
+ #</IfModule>
+ # End of proxy directives.
+
++# Note that all SSL options can apply to virtual hosts.
++# Disable SSL. Useful in combination with virtual hosts. Note that SSLEnable is
++# now also supported.
++#SSLDisable
++SSLEnable
++
++# Set the path for the global cache server executable.
++# If this facility gives you trouble, you can disable it by setting
++# CACHE_SESSIONS to FALSE in apache_ssl.c
++SSLCacheServerPath @@ServerRoot@@/sbin/gcache
++
++# Set the global cache server port number, or path. If it is a path, a Unix
++# domain socket is used. If a number, a TCP socket.
++SSLCacheServerPort logs/gcache_port
++#SSLCacheServerPort 1234
++
++# Directory for the cache server to run in (in case of crashes). Optional.
++SSLCacheServerRunDir /usr/tmp
++
++# Set the session cache timeout, in seconds (set to 15 for testing, use a
++# higher value in real life)
++SSLSessionCacheTimeout 15
++
+ ### Section 3: Virtual Hosts
+ #
+ # VirtualHost: If you want to maintain multiple domains/hostnames on your
diff --git a/www/apache13-ssl/pkg-plist b/www/apache13-ssl/pkg-plist
index ed5c375f5509..a28ac90d6d2e 100644
--- a/www/apache13-ssl/pkg-plist
+++ b/www/apache13-ssl/pkg-plist
@@ -1,10 +1,11 @@
+bin/checkgid
bin/dbmmanage
bin/htdigest
bin/htpasswd
@unexec if cmp -s %D/etc/apache/access.conf %D/etc/apache/access.conf.default; then rm -f %D/etc/apache/access.conf; fi
etc/apache/access.conf.default
@exec [ -f %B/access.conf ] || cp %B/%f %B/access.conf
-@unexec if cmp -s %D/etc/apache/httpsd.conf %D/etc/apache/httpsd.conf.default; then rm -f %D/etc/apache/httpd.conf; fi
+@unexec if cmp -s %D/etc/apache/httpsd.conf %D/etc/apache/httpsd.conf.default; then rm -f %D/etc/apache/httpsd.conf; fi
etc/apache/httpsd.conf.default
@exec [ -f %B/httpsd.conf ] || cp %B/%f %B/httpsd.conf
@unexec if cmp -s %D/etc/apache/magic %D/etc/apache/magic.default; then rm -f %D/etc/apache/magic; fi