aboutsummaryrefslogtreecommitdiff
path: root/www/apache13-ssl
diff options
context:
space:
mode:
authorMark Murray <markm@FreeBSD.org>1998-02-17 12:53:47 +0000
committerMark Murray <markm@FreeBSD.org>1998-02-17 12:53:47 +0000
commit26d85038780cfbd22140e99ed9acf742eb881b2c (patch)
tree48885c914ba1aba57c72f3f47323b905285c2114 /www/apache13-ssl
parent493b8c21ad2f091bb76d597b77844231fb2d5f51 (diff)
downloadports-26d85038780cfbd22140e99ed9acf742eb881b2c.tar.gz
ports-26d85038780cfbd22140e99ed9acf742eb881b2c.zip
Notes
Diffstat (limited to 'www/apache13-ssl')
-rw-r--r--www/apache13-ssl/Makefile74
-rw-r--r--www/apache13-ssl/distinfo4
-rw-r--r--www/apache13-ssl/pkg-plist111
3 files changed, 162 insertions, 27 deletions
diff --git a/www/apache13-ssl/Makefile b/www/apache13-ssl/Makefile
index 88becd81c9aa..d211cf1cbb28 100644
--- a/www/apache13-ssl/Makefile
+++ b/www/apache13-ssl/Makefile
@@ -1,54 +1,84 @@
# New ports collection makefile for: apache HTTPSD
-# Version required: 1.2.4
+# Version required: 1.2.5
# Date created: 15th August 1997
-# Whom: Richard Seaman <dick@tar.com>
+# Whom: Mark Murray <mark@grondar.za>
#
-# $Id: Makefile,v 1.40 1997/09/22 19:44:48 markm Exp $
+# $Id: Makefile,v 1.41 1997/10/13 15:03:39 markm Exp $
-DISTNAME= apache_1.2.4
-PKGNAME= apacheSSL-1.2.4
-CATEGORIES= www
+DISTNAME= apache_1.2.5
+PKGNAME= apacheSSL-1.2.5
+CATEGORIES= www security
MASTER_SITES= ftp://www.apache.org/apache/dist/ \
ftp://ftp.ox.ac.uk/pub/crypto/SSL/
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} apache_1.2.4+ssl_1.11.tar.gz
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} apache_1.2.5+ssl_1.13.tar.gz
-MAINTAINER= markm@freebsd.org
-
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+MAINTAINER= markm@freebsd.org
BUILD_DEPENDS= ssleay:${PORTSDIR}/security/SSLeay
+RUN_DEPENDS= ssleay:${PORTSDIR}/security/SSLeay
+
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
RESTRICTED= "Contains cryptography"
post-extract:
- @cd ${WRKSRC} && tar xzf ${DISTDIR}/apache_1.2.4+ssl_1.11.tar.gz
+ @cd ${WRKSRC} && tar xzf ${DISTDIR}/apache_1.2.5+ssl_1.13.tar.gz
pre-patch:
@cd ${WRKSRC} && ${PATCH} ${PATCH_DIST_ARGS} < SSLpatch
+MAN1= htpasswd.1
+MAN8= httpd.8
+DOCDIR= ${PREFIX}/share/doc/apache
+
+# Set it for local-supplied patch, f.e.
+# VERS_ID = mods-1.0/me
+
+.if defined(VERS_ID)
+post-patch:
+ @cd ${WRKSRC}/src && \
+ ${MV} Configuration Configuration.old && \
+ ${SED} 's;^#*OPTIM=.*;OPTIM= -DSERVER_SUBVERSION=\\"${VERS_ID}\\";' \
+ < Configuration.old > Configuration
+.endif
+
post-install:
- @if [ ! -f ${PREFIX}/etc/rc.d/apache_ssl.sh ]; then \
- ${ECHO} "Installing ${PREFIX}/etc/rc.d/apache_ssl.sh startup file."; \
- ${ECHO} "#!/bin/sh" > ${PREFIX}/etc/rc.d/apache_ssl.sh; \
- ${ECHO} "[ -x ${PREFIX}/sbin/httpsd ] && ${PREFIX}/sbin/httpsd && ${ECHO} -n ' httpsd'" >> ${PREFIX}/etc/rc.d/apache_ssl.sh; \
- chmod 751 ${PREFIX}/etc/rc.d/apache_ssl.sh; \
+ @if [ ! -f ${PREFIX}/etc/rc.d/apacheSSL.sh ]; then \
+ ${ECHO} "Installing ${PREFIX}/etc/rc.d/apacheSSL.sh startup file."; \
+ ${ECHO} "#!/bin/sh" > ${PREFIX}/etc/rc.d/apacheSSL.sh; \
+ ${ECHO} "[ -x ${PREFIX}/sbin/httpsd ] && ${PREFIX}/sbin/httpsd && ${ECHO} -n ' httpsd'" >> ${PREFIX}/etc/rc.d/apacheSSL.sh; \
+ chmod 751 ${PREFIX}/etc/rc.d/apacheSSL.sh; \
fi
- @${ECHO} "Please note: in order to install a certificate you have to"
- @${ECHO} "type:"
- @${ECHO} " make certificate"
+.for i in ${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/support/$i ${PREFIX}/man/man1
+.endfor
+.for i in ${MAN8}
+ ${INSTALL_MAN} ${WRKSRC}/support/$i ${PREFIX}/man/man8
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCDIR}
+.for i in README LICENSE ABOUT_APACHE
+ ${INSTALL_DATA} ${WRKSRC}/$i ${DOCDIR}
+.endfor
+ @cd ${WRKSRC}/htdocs; tar cf - . | (cd ${DOCDIR}; tar xf -)
+.endif
.if !defined(USA_RESIDENT) || ${USA_RESIDENT} != YES && ${USA_RESIDENT} != NO
pre-fetch:
@${ECHO}
- @${ECHO} You must set variable USA_RESIDENT to YES, if you are USA
- @${ECHO} resident or to NO, if you aren\'t USA resident to build
+ @${ECHO} You must set variable USA_RESIDENT to YES if you are USA
+ @${ECHO} resident or to NO if you aren\'t USA resident to build
@${ECHO} this package.
- @${ECHO} You must also have installed RSAREF if you are USA resident.
@false
.elif defined(USA_RESIDENT)
.if ${USA_RESIDENT} == YES
pre-build:
+ @${ECHO} If you are USA resident, then this port is broken for you.
+ @${ECHO} I am unable to get some of the necessary goodies, so
+ @${ECHO} please assist by fixing this and sending me the patches.
+ @${ECHO} Thanks\!
${PATCH} <${FILESDIR}/Makefile.rsa.patch
+BROKEN= "RSAref code doesn't apply cleanly"
.endif
.endif
diff --git a/www/apache13-ssl/distinfo b/www/apache13-ssl/distinfo
index 358e61bbc169..0179202cd276 100644
--- a/www/apache13-ssl/distinfo
+++ b/www/apache13-ssl/distinfo
@@ -1,2 +1,2 @@
-MD5 (apache_1.2.4.tar.gz) = d97b54896454d85d39d9aa60df0eeab1
-MD5 (apache_1.2.4+ssl_1.11.tar.gz) = dc09229f633caae519af3cb56d84ad9e
+MD5 (apache_1.2.5.tar.gz) = a87b3bd7e4b9246d849844a5b370bdb0
+MD5 (apache_1.2.5+ssl_1.13.tar.gz) = b4bff73dd8118d777752b80f590a7457
diff --git a/www/apache13-ssl/pkg-plist b/www/apache13-ssl/pkg-plist
index 9e7dd9d80078..a04c2e7cbb0b 100644
--- a/www/apache13-ssl/pkg-plist
+++ b/www/apache13-ssl/pkg-plist
@@ -1,12 +1,113 @@
-etc/rc.d/apache_ssl.sh
+etc/rc.d/apacheSSL.sh
@exec mkdir -p %D/www/cgi-bin %D/www/data
-etc/apache-SSL/access.conf
etc/apache-SSL/httpd.conf
+etc/apache-SSL/srm.conf
+etc/apache-SSL/access.conf
etc/apache-SSL/httpd.conf-SSL
etc/apache-SSL/mime.types
etc/apache-SSL/mime.types-SSL
-etc/apache-SSL/srm.conf
+man/man1/htpasswd.1.gz
+man/man8/httpd.8.gz
sbin/httpsd
+share/doc/apache/ABOUT_APACHE
+share/doc/apache/LICENSE
+share/doc/apache/README
+share/doc/apache/apache_pb.gif
+share/doc/apache/index.html
+share/doc/apache/manual/LICENSE
+share/doc/apache/manual/TODO
+share/doc/apache/manual/bind.html
+share/doc/apache/manual/cgi_path.html
+share/doc/apache/manual/content-negotiation.html
+share/doc/apache/manual/custom-error.html
+share/doc/apache/manual/dns-caveats.html
+share/doc/apache/manual/env.html
+share/doc/apache/manual/footer.html
+share/doc/apache/manual/handler.html
+share/doc/apache/manual/header.html
+share/doc/apache/manual/host.html
+share/doc/apache/manual/images/home.gif
+share/doc/apache/manual/images/index.gif
+share/doc/apache/manual/images/sub.gif
+share/doc/apache/manual/index.html
+share/doc/apache/manual/install.html
+share/doc/apache/manual/install_1_1.html
+share/doc/apache/manual/invoking.html
+share/doc/apache/manual/keepalive.html
+share/doc/apache/manual/location.html
+share/doc/apache/manual/man-template.html
+share/doc/apache/manual/misc/API.html
+share/doc/apache/manual/misc/FAQ.html
+share/doc/apache/manual/misc/client_block_api.html
+share/doc/apache/manual/misc/compat_notes.html
+share/doc/apache/manual/misc/descriptors.html
+share/doc/apache/manual/misc/fin_wait_2.html
+share/doc/apache/manual/misc/footer.html
+share/doc/apache/manual/misc/header.html
+share/doc/apache/manual/misc/howto.html
+share/doc/apache/manual/misc/index.html
+share/doc/apache/manual/misc/known_bugs.html
+share/doc/apache/manual/misc/nopgp.html
+share/doc/apache/manual/misc/perf-bsd44.html
+share/doc/apache/manual/misc/perf-dec.html
+share/doc/apache/manual/misc/perf.html
+share/doc/apache/manual/misc/security_tips.html
+share/doc/apache/manual/misc/vif-info.html
+share/doc/apache/manual/misc/windoz_keepalive.html
+share/doc/apache/manual/mod/core.html
+share/doc/apache/manual/mod/directives.html
+share/doc/apache/manual/mod/footer.html
+share/doc/apache/manual/mod/header.html
+share/doc/apache/manual/mod/index.html
+share/doc/apache/manual/mod/mod_access.html
+share/doc/apache/manual/mod/mod_actions.html
+share/doc/apache/manual/mod/mod_alias.html
+share/doc/apache/manual/mod/mod_asis.html
+share/doc/apache/manual/mod/mod_auth.html
+share/doc/apache/manual/mod/mod_auth_anon.html
+share/doc/apache/manual/mod/mod_auth_db.html
+share/doc/apache/manual/mod/mod_auth_dbm.html
+share/doc/apache/manual/mod/mod_auth_msql.html
+share/doc/apache/manual/mod/mod_browser.html
+share/doc/apache/manual/mod/mod_cern_meta.html
+share/doc/apache/manual/mod/mod_cgi.html
+share/doc/apache/manual/mod/mod_cookies.html
+share/doc/apache/manual/mod/mod_digest.html
+share/doc/apache/manual/mod/mod_dir.html
+share/doc/apache/manual/mod/mod_dld.html
+share/doc/apache/manual/mod/mod_env.html
+share/doc/apache/manual/mod/mod_example.html
+share/doc/apache/manual/mod/mod_expires.html
+share/doc/apache/manual/mod/mod_headers.html
+share/doc/apache/manual/mod/mod_imap.html
+share/doc/apache/manual/mod/mod_include.html
+share/doc/apache/manual/mod/mod_info.html
+share/doc/apache/manual/mod/mod_log_agent.html
+share/doc/apache/manual/mod/mod_log_common.html
+share/doc/apache/manual/mod/mod_log_config.html
+share/doc/apache/manual/mod/mod_log_referer.html
+share/doc/apache/manual/mod/mod_mime.html
+share/doc/apache/manual/mod/mod_negotiation.html
+share/doc/apache/manual/mod/mod_proxy.html
+share/doc/apache/manual/mod/mod_rewrite.html
+share/doc/apache/manual/mod/mod_status.html
+share/doc/apache/manual/mod/mod_userdir.html
+share/doc/apache/manual/mod/mod_usertrack.html
+share/doc/apache/manual/multilogs.html
+share/doc/apache/manual/new_features_1_0.html
+share/doc/apache/manual/new_features_1_1.html
+share/doc/apache/manual/new_features_1_2.html
+share/doc/apache/manual/process-model.html
+share/doc/apache/manual/stopping.html
+share/doc/apache/manual/suexec.html
+share/doc/apache/manual/unixware.html
+share/doc/apache/manual/vhosts-in-depth.html
+share/doc/apache/manual/virtual-host.html
+@dirrm share/doc/apache/manual/images
+@dirrm share/doc/apache/manual/misc
+@dirrm share/doc/apache/manual/mod
+@dirrm share/doc/apache/manual
+@dirrm share/doc/apache
www/icons/README
www/icons/a.gif
www/icons/alert.black.gif
@@ -83,3 +184,7 @@ www/icons/uu.gif
www/icons/uuencoded.gif
www/icons/world1.gif
www/icons/world2.gif
+@dirrm www/cgi-bin
+@dirrm www/data
+@dirrm www/icons
+@dirrm www