aboutsummaryrefslogtreecommitdiff
path: root/www/apache13
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2004-05-19 02:11:05 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2004-05-19 02:11:05 +0000
commit2627b64644d29950bae417335800fdf4542d6b58 (patch)
treecc49cffb35baa56f915a8edf463751aee1ef51ed /www/apache13
parentbe69c806b8b5142725bf358c5827dddce08036a2 (diff)
downloadports-2627b64644d29950bae417335800fdf4542d6b58.tar.gz
ports-2627b64644d29950bae417335800fdf4542d6b58.zip
Notes
Diffstat (limited to 'www/apache13')
-rw-r--r--www/apache13/Makefile5
-rw-r--r--www/apache13/distinfo3
-rw-r--r--www/apache13/files/patch-mod_access.c118
-rw-r--r--www/apache13/pkg-plist15
4 files changed, 15 insertions, 126 deletions
diff --git a/www/apache13/Makefile b/www/apache13/Makefile
index b16b3dddee2f..3e42fa5e824e 100644
--- a/www/apache13/Makefile
+++ b/www/apache13/Makefile
@@ -6,14 +6,13 @@
#
PORTNAME= apache
-PORTVERSION= 1.3.29
-PORTREVISION= 6
+PORTVERSION= 1.3.31
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
DISTNAME= apache_${PORTVERSION}
#PATCH_SITES= ${MASTER_SITE_APACHE_HTTPD}
-#PATCH_SITE_SUBDIR= patches/apply_to_1.3.29/
+#PATCH_SITE_SUBDIR= patches/apply_to_1.3.31/
#PATCHFILES=
#PATCH_DIST_ARGS= -d ${WRKSRC}/src --forward --quiet -E ${PATCH_DIST_STRIP}
diff --git a/www/apache13/distinfo b/www/apache13/distinfo
index 921b1ffe15c5..404b8d34cd78 100644
--- a/www/apache13/distinfo
+++ b/www/apache13/distinfo
@@ -1 +1,2 @@
-MD5 (apache_1.3.29.tar.gz) = e97fe9bf51dc2c9c233d53f63b1347e3
+MD5 (apache_1.3.31.tar.gz) = bd548a06ac48dda496b4e613572bb020
+SIZE (apache_1.3.31.tar.gz) = 2467371
diff --git a/www/apache13/files/patch-mod_access.c b/www/apache13/files/patch-mod_access.c
deleted file mode 100644
index b42c1f213c05..000000000000
--- a/www/apache13/files/patch-mod_access.c
+++ /dev/null
@@ -1,118 +0,0 @@
-===================================================================
-RCS file: /home/cvspublic/apache-1.3/src/modules/standard/mod_access.c,v
-retrieving revision 1.46
-retrieving revision 1.47
-diff -u -r1.46 -r1.47
---- src/modules/standard/mod_access.c 2004/02/20 20:37:40 1.46
-+++ src/modules/standard/mod_access.c 2004/03/07 21:47:14 1.47
-@@ -39,8 +39,8 @@
- union {
- char *from;
- struct {
-- unsigned long net;
-- unsigned long mask;
-+ struct in_addr net;
-+ struct in_addr mask;
- } ip;
- } x;
- enum allowdeny_type type;
-@@ -124,14 +124,14 @@
-
- }
- else if ((s = strchr(where, '/'))) {
-- unsigned long mask;
-+ struct in_addr mask;
-
- a->type = T_IP;
- /* trample on where, we won't be using it any more */
- *s++ = '\0';
-
- if (!is_ip(where)
-- || (a->x.ip.net = ap_inet_addr(where)) == INADDR_NONE) {
-+ || (a->x.ip.net.s_addr = ap_inet_addr(where)) == INADDR_NONE) {
- a->type = T_FAIL;
- return "syntax error in network portion of network/netmask";
- }
-@@ -143,24 +143,26 @@
- }
- /* is it in /a.b.c.d form? */
- if (strchr(s, '.')) {
-- mask = ap_inet_addr(s);
-- if (mask == INADDR_NONE) {
-+ mask.s_addr = ap_inet_addr(s);
-+ if (mask.s_addr == INADDR_NONE) {
- a->type = T_FAIL;
- return "syntax error in mask portion of network/netmask";
- }
- }
- else {
-+ int i;
-+
- /* assume it's in /nnn form */
-- mask = atoi(s);
-- if (mask > 32 || mask <= 0) {
-+ i = atoi(s);
-+ if (i > 32 || i <= 0) {
- a->type = T_FAIL;
- return "invalid mask in network/netmask";
- }
-- mask = 0xFFFFFFFFUL << (32 - mask);
-- mask = htonl(mask);
-+ mask.s_addr = 0xFFFFFFFFUL << (32 - i);
-+ mask.s_addr = htonl(mask.s_addr);
- }
- a->x.ip.mask = mask;
-- a->x.ip.net = (a->x.ip.net & mask); /* pjr - This fixes PR 4770 */
-+ a->x.ip.net.s_addr = (a->x.ip.net.s_addr & mask.s_addr); /* pjr - This fixes PR 4770 */
- }
- else if (ap_isdigit(*where) && is_ip(where)) {
- /* legacy syntax for ip addrs: a.b.c. ==> a.b.c.0/24 for example */
-@@ -171,8 +173,8 @@
- a->type = T_IP;
- /* parse components */
- s = where;
-- a->x.ip.net = 0;
-- a->x.ip.mask = 0;
-+ a->x.ip.net.s_addr = 0;
-+ a->x.ip.mask.s_addr = 0;
- shift = 24;
- while (*s) {
- t = s;
-@@ -191,6 +193,7 @@
- return "invalid ip address";
- }
- if (shift < 0) {
-+ a->type = T_FAIL;
- return "invalid ip address, only 4 octets allowed";
- }
- octet = atoi(s);
-@@ -198,13 +201,13 @@
- a->type = T_FAIL;
- return "each octet must be between 0 and 255 inclusive";
- }
-- a->x.ip.net |= octet << shift;
-- a->x.ip.mask |= 0xFFUL << shift;
-+ a->x.ip.net.s_addr |= (unsigned int)octet << shift;
-+ a->x.ip.mask.s_addr |= 0xFFUL << shift;
- s = t;
- shift -= 8;
- }
-- a->x.ip.net = ntohl(a->x.ip.net);
-- a->x.ip.mask = ntohl(a->x.ip.mask);
-+ a->x.ip.net.s_addr = ntohl(a->x.ip.net.s_addr);
-+ a->x.ip.mask.s_addr = ntohl(a->x.ip.mask.s_addr);
- }
- else {
- a->type = T_HOST;
-@@ -272,9 +275,9 @@
- return 1;
-
- case T_IP:
-- if (ap[i].x.ip.net != INADDR_NONE
-+ if (ap[i].x.ip.net.s_addr != INADDR_NONE
- && (r->connection->remote_addr.sin_addr.s_addr
-- & ap[i].x.ip.mask) == ap[i].x.ip.net) {
-+ & ap[i].x.ip.mask.s_addr) == ap[i].x.ip.net.s_addr) {
- return 1;
- }
- break;
diff --git a/www/apache13/pkg-plist b/www/apache13/pkg-plist
index 60c73d8da083..1be0a2b0ef5f 100644
--- a/www/apache13/pkg-plist
+++ b/www/apache13/pkg-plist
@@ -85,6 +85,7 @@ libexec/apache/mod_imap.so
libexec/apache/mod_include.so
libexec/apache/mod_info.so
libexec/apache/mod_log_config.so
+libexec/apache/mod_log_forensic.so
libexec/apache/mod_mime.so
libexec/apache/mod_mime_magic.so
libexec/apache/mod_mmap_static.so
@@ -117,6 +118,7 @@ www/data-dist/index.html.en
www/data-dist/index.html.es
www/data-dist/index.html.fr
www/data-dist/index.html.he.iso8859-8
+www/data-dist/index.html.hu
www/data-dist/index.html.it
www/data-dist/index.html.ja.jis
www/data-dist/index.html.kr.iso-kr
@@ -136,7 +138,6 @@ www/data-dist/index.html.ru.ucs4
www/data-dist/index.html.ru.utf8
www/data-dist/index.html.se
www/data-dist/index.html.zh-tw.big5
-share/doc/apache/FAQ.html
share/doc/apache/LICENSE
share/doc/apache/bind.html.en
share/doc/apache/bind.html.fr
@@ -207,7 +208,9 @@ share/doc/apache/invoking.html.html
share/doc/apache/keepalive.html.en
share/doc/apache/keepalive.html.html
share/doc/apache/keepalive.html.ja.jis
-share/doc/apache/location.html
+share/doc/apache/location.html.en
+share/doc/apache/location.html.html
+share/doc/apache/location.html.ja.jis
share/doc/apache/logs.html
share/doc/apache/man-template.html
share/doc/apache/misc/API.html
@@ -276,7 +279,9 @@ share/doc/apache/mod/mod_auth_anon.html
share/doc/apache/mod/mod_auth_db.html
share/doc/apache/mod/mod_auth_dbm.html
share/doc/apache/mod/mod_auth_digest.html
-share/doc/apache/mod/mod_autoindex.html
+share/doc/apache/mod/mod_autoindex.html.en
+share/doc/apache/mod/mod_autoindex.html.html
+share/doc/apache/mod/mod_autoindex.html.ja.jis
share/doc/apache/mod/mod_browser.html
share/doc/apache/mod/mod_cern_meta.html
share/doc/apache/mod/mod_cgi.html.en
@@ -305,6 +310,8 @@ share/doc/apache/mod/mod_log_common.html
share/doc/apache/mod/mod_log_config.html.en
share/doc/apache/mod/mod_log_config.html.html
share/doc/apache/mod/mod_log_config.html.ja.jis
+share/doc/apache/mod/mod_log_forensic.html.en
+share/doc/apache/mod/mod_log_forensic.html.html
share/doc/apache/mod/mod_log_referer.html
share/doc/apache/mod/mod_mime.html.en
share/doc/apache/mod/mod_mime.html.html
@@ -377,7 +384,6 @@ share/doc/apache/programs/suexec.html.en
share/doc/apache/programs/suexec.html.html
share/doc/apache/programs/suexec.html.ja.jis
share/doc/apache/readme-tpf.html
-share/doc/apache/search/manual-index.cgi
share/doc/apache/sections.html.en
share/doc/apache/sections.html.html
share/doc/apache/sections.html.ja.jis
@@ -423,6 +429,7 @@ share/doc/apache/win_service.html.en
share/doc/apache/win_service.html.html
share/doc/apache/win_service.html.ja.jis
share/doc/apache/windows.html.en
+share/doc/apache/windows.html.html
share/doc/apache/windows.html.ja.jis
www/cgi-bin-dist/EXAMPLE_DIRECTORY-DONT_ADD_OR_TOUCH_ANYTHING
@exec [ -d %D/www/cgi-bin/ ] || ln -fs %B %D/www/cgi-bin