aboutsummaryrefslogtreecommitdiff
path: root/www/apache2/files
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-06-18 23:02:05 +0000
committerPatrick Li <pat@FreeBSD.org>2002-06-18 23:02:05 +0000
commitea103f8b132b726b150911f85de9ea0c2050e8a3 (patch)
tree88e1d86a855be5a407f3ecee139d0373e9a0fc37 /www/apache2/files
parentae4d5efa509e7411f5d3a99a46fb13205482463b (diff)
downloadports-ea103f8b132b726b150911f85de9ea0c2050e8a3.tar.gz
ports-ea103f8b132b726b150911f85de9ea0c2050e8a3.zip
Notes
Diffstat (limited to 'www/apache2/files')
-rw-r--r--www/apache2/files/apache.sh2
-rw-r--r--www/apache2/files/config.layout2
-rw-r--r--www/apache2/files/patch-Makefile.in77
-rw-r--r--www/apache2/files/patch-docs:conf:ssl-std.conf47
-rw-r--r--www/apache2/files/patch-support:apxs.in49
-rw-r--r--www/apache2/files/patch-support:log_server_status.in12
6 files changed, 52 insertions, 137 deletions
diff --git a/www/apache2/files/apache.sh b/www/apache2/files/apache.sh
index 82405c6e8e2c..ab1a71895d0c 100644
--- a/www/apache2/files/apache.sh
+++ b/www/apache2/files/apache.sh
@@ -7,7 +7,7 @@ start)
[ -x ${PREFIX}/sbin/apachectl ] && ${PREFIX}/sbin/apachectl start${SSL} > /dev/null && echo -n ' apache2'
;;
stop)
- [ -r @@DESTDIR@@/var/run/httpd.pid ] && ${PREFIX}/sbin/apachectl stop > /dev/null && echo -n ' apache2'
+ [ -r /var/run/httpd.pid ] && ${PREFIX}/sbin/apachectl stop > /dev/null && echo -n ' apache2'
;;
*)
echo "Usage: `basename $0` {start|stop}" >&2
diff --git a/www/apache2/files/config.layout b/www/apache2/files/config.layout
index 9344b823d0a2..e4f8ca8e22a4 100644
--- a/www/apache2/files/config.layout
+++ b/www/apache2/files/config.layout
@@ -14,7 +14,7 @@
manualdir: ${prefix}/share/doc/apache2
cgidir: ${datadir}/cgi-bin
includedir: ${prefix}/include/apache2
- localstatedir: @@DESTDIR@@/var
+ localstatedir: /var
runtimedir: ${localstatedir}/run
logfiledir: ${localstatedir}/log
proxycachedir: ${datadir}/proxy
diff --git a/www/apache2/files/patch-Makefile.in b/www/apache2/files/patch-Makefile.in
index 5d49a5d426a9..1ce27f5cdf55 100644
--- a/www/apache2/files/patch-Makefile.in
+++ b/www/apache2/files/patch-Makefile.in
@@ -1,13 +1,13 @@
---- Makefile.in.orig Sun Apr 28 16:41:25 2002
-+++ Makefile.in Tue May 7 19:05:12 2002
-@@ -33,23 +33,27 @@
- @test -d $(sysconfdir) || $(MKINSTALLDIRS) $(sysconfdir)
+--- Makefile.in.orig Sat Jun 15 18:41:03 2002
++++ Makefile.in Tue Jun 18 22:37:19 2002
+@@ -31,12 +31,14 @@
+ @test -d $(DESTDIR)$(sysconfdir) || $(MKINSTALLDIRS) $(DESTDIR)$(sysconfdir)
@cd $(top_srcdir)/docs/conf; \
for i in mime.types magic; do \
-- $(INSTALL_DATA) $$i $(sysconfdir); \
-+ test -f $(sysconfdir)/$$i || $(INSTALL_DATA) $$i $(sysconfdir); \
+- $(INSTALL_DATA) $$i $(DESTDIR)$(sysconfdir); \
++ test -f $(DESTDIR)$(sysconfdir)/$$i || $(INSTALL_DATA) $$i $(DESTDIR)$(sysconfdir); \
+ cp -f $$i $$i.default; \
-+ $(INSTALL_DATA) $$i.default $(sysconfdir); \
++ $(INSTALL_DATA) $$i.default $(DESTDIR)$(sysconfdir); \
done; \
for j in $(top_srcdir)/docs/conf $(top_builddir)/docs/conf ; do \
cd $$j ; \
@@ -17,58 +17,35 @@
( \
n_lm=`awk 'BEGIN {n=0} /@@LoadModule@@/ {n+=1} END {print n}' < $$i`; \
if test $$n_lm -eq 0 -o "x$(DSO_MODULES)" = "x"; then \
- sed -e 's#@@ServerRoot@@#$(prefix)#g' \
- -e 's#@@Port@@#$(PORT)#g' \
-+ -e 's#@@DESTDIR@@#$(DESTDIR)#g' \
- -e '/@@LoadModule@@/d' \
- < $$i; \
- else \
- sed -n -e '/@@LoadModule@@/q' \
- -e 's#@@ServerRoot@@#$(prefix)#g' \
- -e 's#@@Port@@#$(PORT)#g' \
-+ -e 's#@@DESTDIR@@#$(DESTDIR)#g' \
- -e 'p' \
- < $$i; \
- for j in $(DSO_MODULES) "^EOL^"; do \
-@@ -57,7 +61,7 @@
- echo "<IfDefine SSL>"; \
- fi; \
- if test $$j != "^EOL^"; then \
-- echo "LoadModule $${j}_module modules/mod_$${j}.so"; \
-+ echo "LoadModule $${j}_module ${libexecdir:S|^${prefix}/||}/mod_$${j}.so"; \
- fi; \
- if test "x$$j" = "xssl"; then \
- echo "</IfDefine>"; \
-@@ -106,12 +110,14 @@
+@@ -104,11 +106,14 @@
install-htdocs:
@echo Installing HTML documents
-- @test -d $(htdocsdir) || $(MKINSTALLDIRS) $(htdocsdir)
-- @test -d $(htdocs-srcdir) && (cd $(htdocs-srcdir) && cp -rp * $(htdocsdir))
-+ @test -d $(htdocsdir).default || $(MKINSTALLDIRS) $(htdocsdir).default
-+ @test -d $(htdocs-srcdir) && (cd $(htdocs-srcdir) && cp -rp * $(htdocsdir).default)
-+ @test -e $(htdocsdir) || ln -sf $(htdocsdir).default $(htdocsdir)
+- @test -d $(DESTDIR)$(htdocsdir) || $(MKINSTALLDIRS) $(DESTDIR)$(htdocsdir)
+- @test -d $(htdocs-srcdir) && (cd $(htdocs-srcdir) && cp -rp * $(DESTDIR)$(htdocsdir))
++ @test -d $(DESTDIR)$(htdocsdir).default || $(MKINSTALLDIRS) $(DESTDIR)$(htdocsdir).default
++ @test -d $(htdocs-srcdir) && (cd $(htdocs-srcdir) && cp -rp * $(DESTDIR)$(htdocsdir).default)
++ @test -e $(DESTDIR)$(htdocsdir) || ln -sf $(DESTDIR)$(htdocsdir).default $(DESTDIR)$(htdocsdir)
+.if !defined(NOPORTDOCS)
- @test -d $(manualdir) || $(MKINSTALLDIRS) $(manualdir)
- @test -d $(top_srcdir)/docs/manual && (cd $(top_srcdir)/docs/manual && cp -rp * $(manualdir))
-- @test "x$(htdocsdir)" != "x" && cd $(htdocsdir) && find . -name "CVS" -print | xargs rm -rf {} \;
--
+ @test -d $(DESTDIR)$(manualdir) || $(MKINSTALLDIRS) $(DESTDIR)$(manualdir)
+ @test -d $(top_srcdir)/docs/manual && (cd $(top_srcdir)/docs/manual && cp -rp * $(DESTDIR)$(manualdir))
+- -@test "x$(htdocsdir)" != "x" && cd $(DESTDIR)$(htdocsdir) && find . -name "CVS" -print | xargs rm -rf
+.endif
-+ @test "x$(htdocsdir)" != "x" && cd $(htdocsdir).default && find . -name "CVS" -print | xargs rm -rf {} \;
++ -@test "x$(htdocsdir)" != "x" && cd $(DESTDIR)$(htdocsdir).default && find . -name "CVS" -print | xargs rm -rf
+
install-error:
@echo Installing error documents
- @test -d $(errordir) || $(MKINSTALLDIRS) $(errordir)
-@@ -126,9 +132,10 @@
+@@ -124,9 +129,10 @@
install-cgi:
@echo Installing CGIs
-- @test -d $(cgidir) || $(MKINSTALLDIRS) $(cgidir)
-- @cd $(top_srcdir)/docs/cgi-examples && cp -rp * $(cgidir)
-- @test "x$(cgidir)" != "x" && cd $(cgidir) && find . -name "CVS" -print | xargs rm -rf {} \;
-+ @test -d $(cgidir).default || $(MKINSTALLDIRS) $(cgidir).default
-+ @(cd $(top_srcdir)/docs/cgi-examples && cp -rp * $(cgidir).default)
-+ @test -e $(cgidir) || ln -sf $(cgidir).default $(cgidir)
-+ @test "x$(cgidir)" != "x" && cd $(cgidir).default && find . -name "CVS" -print | xargs rm -rf {} \;
+- @test -d $(DESTDIR)$(cgidir) || $(MKINSTALLDIRS) $(DESTDIR)$(cgidir)
+- @cd $(top_srcdir)/docs/cgi-examples && cp -rp * $(DESTDIR)$(cgidir)
+- -@test "x$(cgidir)" != "x" && cd $(DESTDIR)$(cgidir) && find . -name "CVS" -print | xargs rm -rf
++ @test -d $(DESTDIR)$(cgidir).default || $(MKINSTALLDIRS) $(DESTDIR)$(cgidir).default
++ @cd $(top_srcdir)/docs/cgi-examples && cp -rp * $(DESTDIR)$(cgidir).default
++ @test -e $(DESTDIR)$(cgidir) || ln -sf $(DESTDIR)$(cgidir).default $(DESTDIR)$(cgidir)
++ -@test "x$(cgidir)" != "x" && cd $(DESTDIR)$(cgidir).default && find . -name "CVS" -print | xargs rm -rf
install-other:
- @test -d $(logfiledir) || $(MKINSTALLDIRS) $(logfiledir)
+ @test -d $(DESTDIR)$(logfiledir) || $(MKINSTALLDIRS) $(DESTDIR)$(logfiledir)
diff --git a/www/apache2/files/patch-docs:conf:ssl-std.conf b/www/apache2/files/patch-docs:conf:ssl-std.conf
index 267aaae4d9e4..39ea9c6e7483 100644
--- a/www/apache2/files/patch-docs:conf:ssl-std.conf
+++ b/www/apache2/files/patch-docs:conf:ssl-std.conf
@@ -1,5 +1,5 @@
---- docs/conf/ssl-std.conf.orig Thu Nov 8 07:16:09 2001
-+++ docs/conf/ssl-std.conf Sun Apr 7 09:26:02 2002
+--- docs/conf/ssl-std.conf.orig Fri May 17 04:05:24 2002
++++ docs/conf/ssl-std.conf Tue Jun 18 23:15:32 2002
@@ -55,15 +55,15 @@
# Configure the SSL Session Cache: First the mechanism
# to use and second the expiring timeout (in seconds).
@@ -7,29 +7,20 @@
-#SSLSessionCache shmht:logs/ssl_scache(512000)
-#SSLSessionCache shmcb:logs/ssl_scache(512000)
-SSLSessionCache dbm:logs/ssl_scache
-+#SSLSessionCache shmht:@@DESTDIR@@/var/log/httpd-ssl_scache(512000)
-+#SSLSessionCache shmcb:@@DESTDIR@@/var/log/httpd-ssl_scache(512000)
-+SSLSessionCache dbm:@@DESTDIR@@/var/log/httpd-ssl_scache
++#SSLSessionCache shmht:/var/log/httpd-ssl_scache(512000)
++#SSLSessionCache shmcb:/var/log/httpd-ssl_scache(512000)
++SSLSessionCache dbm:/var/log/httpd-ssl_scache
SSLSessionCacheTimeout 300
# Semaphore:
# Configure the path to the mutual exclusion semaphore the
# SSL engine uses internally for inter-process synchronization.
-SSLMutex file:logs/ssl_mutex
-+SSLMutex file:@@DESTDIR@@/var/log/httpd-ssl_mutex
++SSLMutex file:/var/log/httpd-ssl_mutex
# Pseudo Random Number Generator (PRNG):
# Configure one or more sources to seed the PRNG of the
-@@ -89,7 +89,7 @@
- # a real server (i.e. somewhere where only root can write).
- # Log levels are (ascending order: higher ones include lower ones):
- # none, error, warn, info, trace, debug.
--SSLLog logs/ssl_engine_log
-+SSLLog @@DESTDIR@@/var/log/httpd-ssl_engine_log
- SSLLogLevel info
-
- ##
-@@ -99,11 +99,11 @@
+@@ -89,11 +89,11 @@
<VirtualHost _default_:443>
# General setup for the virtual host
@@ -39,15 +30,15 @@
ServerAdmin you@your.address
-ErrorLog logs/error_log
-TransferLog logs/access_log
-+ErrorLog @@DESTDIR@@/var/log/httpd-error.log
-+TransferLog @@DESTDIR@@/var/log/httpd-access.log
++ErrorLog /var/log/httpd-error.log
++TransferLog /var/log/httpd-access.log
# SSL Engine Switch:
# Enable/Disable SSL for this virtual host.
-@@ -122,16 +122,16 @@
- # built time. Keep in mind that if you've both a RSA and a DSA
- # certificate you can configure both in parallel (to also allow
- # the use of DSA ciphers, etc.)
+@@ -111,16 +111,16 @@
+ # in mind that if you have both an RSA and a DSA certificate you
+ # can configure both in parallel (to also allow the use of DSA
+ # ciphers, etc.)
-SSLCertificateFile @@ServerRoot@@/conf/ssl.crt/server.crt
-#SSLCertificateFile @@ServerRoot@@/conf/ssl.crt/server-dsa.crt
+SSLCertificateFile @@ServerRoot@@/etc/apache2/ssl.crt/server.crt
@@ -65,7 +56,7 @@
# Server Certificate Chain:
# Point SSLCertificateChainFile at a file containing the
-@@ -140,7 +140,7 @@
+@@ -129,7 +129,7 @@
# the referenced file can be the same as SSLCertificateFile
# when the CA certificates are directly appended to the server
# certificate for convinience.
@@ -74,7 +65,7 @@
# Certificate Authority (CA):
# Set the CA certificate verification path where to find CA
-@@ -149,8 +149,8 @@
+@@ -138,8 +138,8 @@
# Note: Inside SSLCACertificatePath you need hash symlinks
# to point to the certificate files. Use the provided
# Makefile to update the hash symlinks after changes.
@@ -85,7 +76,7 @@
# Certificate Revocation Lists (CRL):
# Set the CA revocation path where to find CA CRLs for client
-@@ -159,8 +159,8 @@
+@@ -148,8 +148,8 @@
# Note: Inside SSLCARevocationPath you need hash symlinks
# to point to the certificate files. Use the provided
# Makefile to update the hash symlinks after changes.
@@ -96,7 +87,7 @@
# Client Authentication (Type):
# Client certificate verification type and depth. Types are
-@@ -220,7 +220,7 @@
+@@ -209,7 +209,7 @@
<Files ~ "\.(cgi|shtml|phtml|php3?)$">
SSLOptions +StdEnvVars
</Files>
@@ -105,12 +96,12 @@
SSLOptions +StdEnvVars
</Directory>
-@@ -255,7 +255,7 @@
+@@ -244,7 +244,7 @@
# Per-Server Logging:
# The home of a custom SSL log file. Use this when you want a
# compact non-error SSL logfile on a virtual host basis.
-CustomLog logs/ssl_request_log \
-+CustomLog @@DESTDIR@@/var/log/httpd-ssl_request.log \
++CustomLog /var/log/httpd-ssl_request.log \
"%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"
</VirtualHost>
diff --git a/www/apache2/files/patch-support:apxs.in b/www/apache2/files/patch-support:apxs.in
deleted file mode 100644
index ffa21a1ff918..000000000000
--- a/www/apache2/files/patch-support:apxs.in
+++ /dev/null
@@ -1,49 +0,0 @@
---- support/apxs.in.orig Tue Apr 30 03:09:02 2002
-+++ support/apxs.in Wed May 8 19:41:06 2002
-@@ -66,7 +66,7 @@
-
- # read the configuration variables once
- my %config_vars = ();
--get_config_vars("$prefix/build/config_vars.mk",\%config_vars);
-+get_config_vars("$prefix/share/apache2/config_vars.mk",\%config_vars);
-
- my $exec_prefix = get_vars("exec_prefix");
- my $CFG_TARGET = get_vars("progname");
-@@ -223,7 +223,7 @@
- my $httpd = get_vars("sbindir") . "/" . get_vars("progname");
- $httpd = eval qq("$httpd");
- $httpd = eval qq("$httpd");
--my $envvars = get_vars("bindir") . "/envvars";
-+my $envvars = get_vars("sbindir") . "/envvars";
- $envvars = eval qq("$envvars");
- $envvars = eval qq("$envvars");
-
-@@ -418,7 +418,7 @@
- $la =~ s|\.c$|.la|;
- my $o = $s;
- $o =~ s|\.c$|.o|;
-- push(@cmds, "$prefix/build/libtool $ltflags --mode=compile $CFG_CC $cflags -I$CFG_INCLUDEDIR $opt -c -o $lo $s && touch $slo");
-+ push(@cmds, "$prefix/share/apache2/libtool $ltflags --mode=compile $CFG_CC $cflags -I$CFG_INCLUDEDIR $opt -c -o $lo $s && touch $slo");
- unshift(@objs, $lo);
- }
-
-@@ -443,7 +443,7 @@
- $opt .= " -l$opt_l";
- }
-
-- push(@cmds, "$prefix/build/libtool $ltflags --mode=link $CFG_CC -o $dso_file -rpath $CFG_LIBEXECDIR -module -avoid-version $opt $lo");
-+ push(@cmds, "$prefix/share/apache2/libtool $ltflags --mode=link $CFG_CC -o $dso_file -rpath $CFG_LIBEXECDIR -module -avoid-version $opt $lo");
-
- # execute the commands
- &execute_cmds(@cmds);
-@@ -474,8 +474,8 @@
- $t =~ s|^.+/([^/]+)$|$1|;
- $t =~ s|\.la$|\.so|;
- if ($opt_i) {
-- push(@cmds, "$prefix/build/instdso.sh SH_LIBTOOL='" .
-- "$prefix/build/libtool' $f $CFG_LIBEXECDIR");
-+ push(@cmds, "$prefix/share/apache2/instdso.sh SH_LIBTOOL='" .
-+ "$prefix/share/apache2/libtool' $f $CFG_LIBEXECDIR");
- push(@cmds, "chmod 755 $CFG_LIBEXECDIR/$t");
- }
-
diff --git a/www/apache2/files/patch-support:log_server_status.in b/www/apache2/files/patch-support:log_server_status.in
index 652edf444a4c..136bafb9ff1a 100644
--- a/www/apache2/files/patch-support:log_server_status.in
+++ b/www/apache2/files/patch-support:log_server_status.in
@@ -1,6 +1,6 @@
---- support/log_server_status.in.orig Thu Mar 14 05:48:06 2002
-+++ support/log_server_status.in Sun Apr 7 08:47:53 2002
-@@ -63,10 +63,10 @@
+--- support/log_server_status.in.orig Tue Jun 18 23:21:53 2002
++++ support/log_server_status.in Tue Jun 18 23:23:08 2002
+@@ -63,7 +63,7 @@
#
require 'sys/socket.ph';
@@ -8,11 +8,7 @@
+$wherelog = "@logfiledir@/httpd-status-"; # Logs will be like "/var/log/httpd-status-19960312.log"
$server = "localhost"; # Name of server, could be "www.foo.com"
$port = "80"; # Port on server
--$request = "/status/?auto"; # Request to send
-+$request = "/status-status/?auto"; # Request to send
-
- sub tcp_connect
- {
+ $request = "/status/?auto"; # Request to send
@@ -96,7 +96,7 @@
chomp($date);
($day,$time)=split(/:/,$date);