aboutsummaryrefslogtreecommitdiff
path: root/www/apache20/Makefile
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2001-11-19 22:47:47 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2001-11-19 22:47:47 +0000
commit6d2b11cde952cdb029859d536224d6342de683d5 (patch)
treeae7567b417e2e5d69b20cb127ad27a269d2731ae /www/apache20/Makefile
parent0b0af46d5b72b3a7dc72e6234b505a960388598b (diff)
downloadports-6d2b11cde952cdb029859d536224d6342de683d5.tar.gz
ports-6d2b11cde952cdb029859d536224d6342de683d5.zip
Notes
Diffstat (limited to 'www/apache20/Makefile')
-rw-r--r--www/apache20/Makefile86
1 files changed, 48 insertions, 38 deletions
diff --git a/www/apache20/Makefile b/www/apache20/Makefile
index ea501e6245d5..48f99ccca4a3 100644
--- a/www/apache20/Makefile
+++ b/www/apache20/Makefile
@@ -6,19 +6,14 @@
#
PORTNAME= apache
-PORTVERSION= 2.0.16
-PORTREVISION= 3
+PORTVERSION= 2.0.28
CATEGORIES= www ipv6
-MASTER_SITES= http://httpd.apache.org/dist/httpd/ \
- http://www.cybernic.com/mirror/dist/httpd/ \
- http://mirrors.partnersforever.net/apache/dist/httpd/ \
- http://www.technotopia.com/vroom/apache/dist/httpd/ \
- http://www.tux.org/pub/net/apache/dist/httpd/ \
- ftp://ftp.raver.net/pub/ftp.apache.org/httpd/ \
- ftp://ftp.epix.net/pub/apache/dist/httpd/ \
- ftp://ftp.connectnet.com/pub/www/apache/httpd/ \
+MASTER_SITES= http://www.apache.org/dist/httpd/ \
+ http://apache.mirrorcentral.com/dist/httpd/ \
+ http://apache.missouri.edu/dist/httpd/ \
+ http://ftp.epix.net/apache/dist/httpd/ \
ftp://ftp.digex.net/pub/packages/network/apache/httpd/ \
- ftp://ftp.cuckoo.com/pub/mirrors/apache/httpd/
+ ftp://ftp.cuckoo.com/pub/mirrors/apache/dist/httpd/
DISTNAME= httpd-${PORTVERSION:S/./_/g}-beta
MAINTAINER?= perky@fallin.lv
@@ -26,46 +21,61 @@ MAINTAINER?= perky@fallin.lv
LATEST_LINK= apache2
WRKSRC= ${WRKDIR}/httpd-${PORTVERSION:S/./_/g}
-FIND?= find
-XARGS?= xargs
-
-# apache2 doesn't process '--enable-share=max' option yet.
-# and some modules are very unstable at DSO mode.
-SHARED_MODS?= unique_id mime_magic rewrite speling auth_db \
- auth_anon digest headers cern_meta expires include \
- cgid status info usertrack dav dav_fs imap proxy \
- auth_digest file_cache echo optional_fn_import \
- optional_fn_export
-STATIC_MODS?= so env setenvif dir autoindex access auth negotiation \
- userdir alias asis cgi mime log_config vhost_alias actions
+FIND= find
+
+WITH_MPM?= prefork # or perchild, threaded
+HTTP_PORT?= 80
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= \
- --prefix=${PREFIX} \
+CONFIGURE_ARGS= --prefix=${PREFIX} \
--enable-layout=FreeBSD \
--with-perl=${PERL} \
+ --enable-so \
--with-suexec-docroot=${PREFIX}/www/data \
- --enable-shared \
- --disable-threads \
- --with-mpm=prefork # Apache's thread doesn't work well in FreeBSD
+ --with-mpm=${WITH_MPM} \
+ --with-port=${HTTP_PORT} \
+ --includedir=${PREFIX}/include/apache # for apr, apr-util
+CONFIGURE_ENV= CC="${CC}" CPPFLAGS="${CPPFLAGS}" CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+SHARED_MODULES= all cgid
+
+.if defined(NOPORTDOCS)
+MAKE_ENV+= NOPORTDOCS=YES
+.endif
+
+.if !defined(WITHOUT_SSL) && exists(/usr/lib/libcrypto.so)
+SHARED_MODULES+= ssl
+PLIST_SUB+= SSLOPT=""
+.else
+PLIST_SUB+= SSLOPT="@comment "
+.endif
+
+.if !defined(WITHOUT_PROXY)
+SHARED_MODULES+= proxy proxy-connect proxy-ftp proxy-http
+PLIST_SUB+= PROXYOPT=""
+.else
+PLIST_SUB+= PROXYOPT="@comment "
+.endif
-OPTIM+= -DHARD_SERVER_LIMIT=512 \
- -DDEFAULT_PATH=\\"/bin:/usr/bin:${PREFIX}/bin\\"
+.if !defined(WITHOUT_CACHE)
+SHARED_MODULES+= cache mem-cache file-cache #disk-cache
+PLIST_SUB+= CACHEOPT=""
+.else
+PLIST_SUB+= CACHEOPT="@comment "
+.endif
-CONFIGURE_ENV= OPTIM='${OPTIM}'
+CONFIGURE_ARGS+= --enable-mods-shared="${SHARED_MODULES}"
MAN1= dbmmanage.1 htdigest.1 htpasswd.1
MAN8= ab.8 apachectl.8 apxs.8 httpd.8 logresolve.8 rotatelogs.8 suexec.8
-.for mod in ${SHARED_MODS}
-CONFIGURE_ARGS+= --enable-${mod}=shared
-.endfor
-.for mod in ${STATIC_MODS}
-CONFIGURE_ARGS+= --enable-${mod}=yes
-.endfor
+pre-extract:
+.if !defined(WITHOUT_SSL)
+ @${ECHO_MSG} "You can disable support for SSL by defining WITHOUT_SSL."
+.endif
post-patch:
- @${FIND} ${WRKSRC} -name "*.orig"|${XARGS} ${RM} -f
+ @${FIND} ${WRKSRC} -name "*.orig" -exec rm -f {} \;
pre-install:
PKG_PREFIX=${PREFIX} ${SH} pkg-install ${PKGNAME} PRE-INSTALL