aboutsummaryrefslogtreecommitdiff
path: root/www/apache20
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-05-07 21:48:58 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-05-07 21:48:58 +0000
commit48888ab32afa9d133885901f2a22982a884f2b36 (patch)
tree8f78c2442a8d40b4b81f3d434db38124ddb1a1d0 /www/apache20
parent3f811ff3087e01031787baf535840a74190f798d (diff)
downloadports-48888ab32afa9d133885901f2a22982a884f2b36.tar.gz
ports-48888ab32afa9d133885901f2a22982a884f2b36.zip
Notes
Diffstat (limited to 'www/apache20')
-rw-r--r--www/apache20/Makefile2
-rw-r--r--www/apache20/files/patch-support__apxs.in23
-rw-r--r--www/apache20/pkg-plist2
3 files changed, 24 insertions, 3 deletions
diff --git a/www/apache20/Makefile b/www/apache20/Makefile
index 98815f463cdf..9cb6c518c158 100644
--- a/www/apache20/Makefile
+++ b/www/apache20/Makefile
@@ -9,7 +9,7 @@
PORTNAME= apache
PORTVERSION= 2.0.63
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD} \
${MASTER_SITE_LOCAL:S/$/:powerlogo/}
diff --git a/www/apache20/files/patch-support__apxs.in b/www/apache20/files/patch-support__apxs.in
index dc9cffb31f00..547b85e9a768 100644
--- a/www/apache20/files/patch-support__apxs.in
+++ b/www/apache20/files/patch-support__apxs.in
@@ -1,6 +1,27 @@
--- ./support/apxs.in.orig 2006-07-12 03:40:55.000000000 -0400
+++ ./support/apxs.in 2010-05-06 16:06:03.795832133 -0400
-@@ -628,8 +628,7 @@
+@@ -548,7 +548,10 @@
+ $c = '#' if ($opt_A);
+ foreach $lmd (@lmd) {
+ my $what = $opt_A ? "preparing" : "activating";
+- if ($content !~ m|\n#?\s*$lmd|) {
++ my $lmd_re = $lmd;
++ $lmd_re =~ s/\s+/\\s+/g;
++
++ if ($content !~ m|\n#?\s*$lmd_re|) {
+ # check for open <containers>, so that the new LoadModule
+ # directive always appears *outside* of an <container>.
+
+@@ -611,7 +614,7 @@
+ }
+ } else {
+ # replace already existing LoadModule line
+- $content =~ s|^(.*\n)#?\s*$lmd[^\n]*\n|$1$c$lmd\n|s;
++ $content =~ s|^(.*\n)#?\s*$lmd_re[^\n]*\n|$1|s;
+ }
+ $lmd =~ m|LoadModule\s+(.+?)_module.*|;
+ notice("[$what module `$1' in $CFG_SYSCONFDIR/$CFG_TARGET.conf]");
+@@ -628,8 +631,7 @@
if (open(FP, ">$CFG_SYSCONFDIR/$CFG_TARGET.conf.new")) {
print FP $content;
close(FP);
diff --git a/www/apache20/pkg-plist b/www/apache20/pkg-plist
index 21fcb622ac1a..dd84f89e7fd2 100644
--- a/www/apache20/pkg-plist
+++ b/www/apache20/pkg-plist
@@ -1,6 +1,6 @@
@comment $FreeBSD$
@exec mkdir -p %D/etc/apache2 2> /dev/null
-@unexec if cmp -s %D/etc/apache2/httpd.conf %D/%%EXAMPLESDIR%%/httpd-std.conf; then rm -f %D/etc/apache2/httpd.conf; fi
+@unexec if cmp %D/etc/apache2/httpd.conf %D/%%EXAMPLESDIR%%/httpd-std.conf; then rm -f %D/etc/apache2/httpd.conf; fi
%%EXAMPLESDIR%%/httpd-std.conf
@exec [ -f %D/etc/apache2/httpd.conf ] || cp %D/%%EXAMPLESDIR%%/httpd-std.conf %D/etc/apache2/httpd.conf
@unexec if cmp -s %D/etc/apache2/magic %D/%%EXAMPLESDIR%%/magic-dist; then rm -f %D/etc/apache2/magic; fi