aboutsummaryrefslogtreecommitdiff
path: root/www/apache21
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2001-12-07 23:12:32 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2001-12-07 23:12:32 +0000
commit61a5d4412139660bc7c0de63eeb1051f50720c13 (patch)
tree76eea29ddd9ae1e8cac32bf4dc35fdad46008c50 /www/apache21
parent5b36ff26b0a61aa2f0640000f469a95038206c87 (diff)
Suggest a command to delete user instead of actually deleting it
PR: 32536
Notes
Notes: svn path=/head/; revision=51196
Diffstat (limited to 'www/apache21')
-rw-r--r--www/apache21/Makefile2
-rw-r--r--www/apache21/pkg-deinstall11
2 files changed, 4 insertions, 9 deletions
diff --git a/www/apache21/Makefile b/www/apache21/Makefile
index 907bf66bdf01..f9eab5fbd9cc 100644
--- a/www/apache21/Makefile
+++ b/www/apache21/Makefile
@@ -7,7 +7,7 @@
PORTNAME= apache
PORTVERSION= 2.0.28
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www ipv6
MASTER_SITES= http://www.apache.org/dist/httpd/ \
http://apache.mirrorcentral.com/dist/httpd/ \
diff --git a/www/apache21/pkg-deinstall b/www/apache21/pkg-deinstall
index c45782a9c38c..d1162ea1a922 100644
--- a/www/apache21/pkg-deinstall
+++ b/www/apache21/pkg-deinstall
@@ -1,20 +1,15 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/www/apache21/Attic/pkg-deinstall,v 1.3 2001-10-29 20:05:37 ache Exp $
+# $FreeBSD: /tmp/pcvs/ports/www/apache21/Attic/pkg-deinstall,v 1.4 2001-12-07 23:12:32 ache Exp $
#
if [ "$2" != "POST-DEINSTALL" ]; then
- exit 0
+ exit 0
fi
USER=www
if pw usershow "${USER}" 2>/dev/null 1>&2; then
- if pw userdel ${USER}; then
- echo "Delete user/group \"${USER}\"."
- else
- echo "Deleting user/group \"${USER}\" failed..."
- exit 1
- fi
+ echo "To delete Apache user permanently, use 'pw userdel ${USER}'"
fi
exit 0