aboutsummaryrefslogtreecommitdiff
path: root/www/apache22/Makefile.modules
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2007-09-10 19:15:48 +0000
committerClement Laforet <clement@FreeBSD.org>2007-09-10 19:15:48 +0000
commit002890da3339ea1dc4d0e78bed5542d912234b5c (patch)
tree0df908805b7a6b46f6f34d15341410e38c9a4958 /www/apache22/Makefile.modules
parentf451894da91996b1e3b28d3a77142dc3fd923750 (diff)
downloadports-002890da3339ea1dc4d0e78bed5542d912234b5c.tar.gz
ports-002890da3339ea1dc4d0e78bed5542d912234b5c.zip
Notes
Diffstat (limited to 'www/apache22/Makefile.modules')
-rw-r--r--www/apache22/Makefile.modules12
1 files changed, 4 insertions, 8 deletions
diff --git a/www/apache22/Makefile.modules b/www/apache22/Makefile.modules
index fb8f1965ed89..8258b5ec3436 100644
--- a/www/apache22/Makefile.modules
+++ b/www/apache22/Makefile.modules
@@ -26,15 +26,11 @@ WITH_THREADS_MODULES= yes
WITHOUT_MODULES+= cgi
. endif
. if ${WITH_MPM:L} == "worker"
-PLIST_SUB+= PREFORK="@comment " WORKER="" THREADPOOL="@comment " EVENT="@comment "
-. elif ${WITH_MPM:L} == "perchild"
-PLIST_SUB+= PREFORK="@comment " WORKER="@comment " THREADPOOL="@comment " EVENT="@comment "
-. elif ${WITH_MPM:L} == "threadpool"
-PLIST_SUB+= PREFORK="@comment " WORKER="@comment " THREADPOOL="" EVENT="@comment "
+PLIST_SUB+= PREFORK="@comment " WORKER="" EVENT="@comment "
. elif ${WITH_MPM:L} == "event"
-PLIST_SUB+= PREFORK="@comment " WORKER="@comment " THREADPOOL="@comment " EVENT=""
+PLIST_SUB+= PREFORK="@comment " WORKER="@comment " EVENT=""
. elif ${WITH_MPM:L} == "itk"
-PLIST_SUB+= PREFORK="@comment " WORKER="@comment " THREADPOOL="@comment " EVENT="@comment "
+PLIST_SUB+= PREFORK="@comment " WORKER="@comment " EVENT="@comment "
. else
IGNORE= "Unknown MPM: ${WITH_MPM}"
. endif
@@ -42,7 +38,7 @@ IGNORE= "Unknown MPM: ${WITH_MPM}"
PLIST_SUB+= PREFORK="@comment " WORKER="@comment " THREADPOOL="@comment " EVENT="@comment "
. endif
.else
-PLIST_SUB+= PREFORK="@comment " WORKER="@comment " THREADPOOL="@comment " EVENT="@comment "
+PLIST_SUB+= PREFORK="@comment " WORKER="@comment " EVENT="@comment "
.endif
# xDBM section