aboutsummaryrefslogtreecommitdiff
path: root/www/apache22/Makefile.modules
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-12-13 18:48:03 +0000
committerClement Laforet <clement@FreeBSD.org>2004-12-13 18:48:03 +0000
commit97d30de79542a04133ef86c200c27c6c80bbdb10 (patch)
tree660fbd5dcefb62b7c08332710e4453d37637eae5 /www/apache22/Makefile.modules
parent30ef2fb9017bc9b82ffed58126296a403022e336 (diff)
downloadports-97d30de79542a04133ef86c200c27c6c80bbdb10.tar.gz
ports-97d30de79542a04133ef86c200c27c6c80bbdb10.zip
Notes
Diffstat (limited to 'www/apache22/Makefile.modules')
-rw-r--r--www/apache22/Makefile.modules13
1 files changed, 8 insertions, 5 deletions
diff --git a/www/apache22/Makefile.modules b/www/apache22/Makefile.modules
index 71663322e595..1f2404e60556 100644
--- a/www/apache22/Makefile.modules
+++ b/www/apache22/Makefile.modules
@@ -24,19 +24,22 @@ WITH_THREADS= yes
WITH_THREADS_MODULES= yes
WITHOUT_MODULES+= cgi
. if ${WITH_MPM:L} == "worker"
-PLIST_SUB+= PREFORK="@comment " WORKER="" THREADPOOL="@comment "
+PLIST_SUB+= PREFORK="@comment " WORKER="" THREADPOOL="@comment " EVENT="@comment "
. elif ${WITH_MPM:L} == "perchild"
-PLIST_SUB+= PREFORK="@comment " WORKER="@comment " THREADPOOL="@comment "
+PLIST_SUB+= PREFORK="@comment " WORKER="@comment " THREADPOOL="@comment " EVENT="@comment "
. elif ${WITH_MPM:L} == "threadpool"
-PLIST_SUB+= PREFORK="@comment " WORKER="@comment " THREADPOOL=""
+PLIST_SUB+= PREFORK="@comment " WORKER="@comment " THREADPOOL="" EVENT="@comment "
+. elif ${WITH_MPM:L} == "event"
+PLIST_SUB+= PREFORK="@comment " WORKER="@comment " THREADPOOL="@comment " EVENT=""
+EXTRA_PATCHES+= ${FILESDIR}/exp-event-mpm-apr-backport.patch
. else
IGNORE= "Unknown MPM: ${WITH_MPM}"
. endif
. else
-PLIST_SUB+= PREFORK="@comment " WORKER="@comment " THREADPOOL="@comment "
+PLIST_SUB+= PREFORK="@comment " WORKER="@comment " THREADPOOL="@comment " EVENT="@comment "
. endif
.else
-PLIST_SUB+= PREFORK="@comment " WORKER="@comment " THREADPOOL="@comment "
+PLIST_SUB+= PREFORK="@comment " WORKER="@comment " THREADPOOL="@comment " EVENT="@comment "
.endif
# xDBM section