aboutsummaryrefslogtreecommitdiff
path: root/www/apache22/Makefile
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-05-18 04:55:15 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-05-18 04:55:15 +0000
commit61a0dda84ee85db82a9eb52788135d2fc8554c51 (patch)
tree5e454b9e16bb26b6f8e3b4fdc8c49cf0b1c2ac23 /www/apache22/Makefile
parent9d17de211215161596702f1b94f3a9e5013076ee (diff)
- remove apr/apr-util vestiges
- fullbuild not needed anymore - buildconf not needed anymore - scripts_env not needed anymore With Hat: apache@
Notes
Notes: svn path=/head/; revision=254536
Diffstat (limited to 'www/apache22/Makefile')
-rw-r--r--www/apache22/Makefile18
1 files changed, 2 insertions, 16 deletions
diff --git a/www/apache22/Makefile b/www/apache22/Makefile
index a0053db03ae4..71e30f36b6bb 100644
--- a/www/apache22/Makefile
+++ b/www/apache22/Makefile
@@ -19,7 +19,7 @@ MAINTAINER?= apache@FreeBSD.org
COMMENT?= Version 2.2.x of Apache web server with ${WITH_MPM:L} MPM.
LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2 \
- apr-1:${PORTSDIR}/devel/apr \
+ apr-1:${PORTSDIR}/devel/apr1 \
pcre.0:${PORTSDIR}/devel/pcre
MAKE_JOBS_SAFE= yes
@@ -34,18 +34,13 @@ CONFLICTS= apache+mod_ssl-1.* apache+mod_ssl+ipv6-1.* apache+mod_ssl+modsnmp-1.*
ru-apache+mod_ssl-1.* ru-apache-1.* \
apache-2.0.* apache-*-2.0.*
-SCRIPTS_ENV+= LIBTOOL=${LIBTOOL} LIBTOOLIZE=${LIBTOOLIZE} \
- LIBTOOL_VERSION=${LIBTOOL_VERSION} AUTOCONF=${AUTOCONF} \
- LIBTOOL_M4=${LIBTOOL_M4} \
- AUTOHEADER=${AUTOHEADER}
-
USE_APACHE= common22
USE_BZIP2= yes
USE_ICONV= yes
USE_AUTOTOOLS= autoconf:262 libtool:22
USE_PERL5= yes
USE_RC_SUBR= apache22 htcacheclean
-LIBTOOLFILES= configure
+LIBTOOLFILES= configure
MPM_ITK_VERSION?= 20090414-00
@@ -136,12 +131,6 @@ LDFLAGS+= -L${OPENSSLLIB}
.endif
-# When using apr_mysql_db we _must_ rebuild makefiles
-.if defined(WITH_FULLBUILD)
-BUILD_DEPENDS= python:${PORTSDIR}/lang/python
-SCRIPTS_ENV+= FULLBUILD=on
-.endif
-
.if defined (WITH_LDAP) || defined (WITH_LDAP_MODULES)
USE_OPENLDAP= yes
CONFIGURE_ARGS+= --enable-ldap=shared --with-ldap --enable-authnz-ldap \
@@ -200,9 +189,6 @@ post-patch:
@${REINPLACE_CMD} -e "s,%%OSVERSION%%,${OSVERSION}," ${WRKSRC}/srclib/apr/build/apr_hints.m4
@${INSTALL_DATA} ${WRKSRC}/NOTICE ${WRKSRC}/docs/manual
-pre-configure:
- @cd ${WRKSRC}; ${SETENV} ${SCRIPTS_ENV} ./buildconf
-
post-configure:
@FTPUSERS=`${EGREP} -v '^#' /etc/ftpusers| ${TR} -s "\n" " "` ;\
${REINPLACE_CMD} -e "s,%%FTPUSERS%%,$${FTPUSERS}," ${WRKSRC}/docs/conf/extra/httpd-userdir.conf