aboutsummaryrefslogtreecommitdiff
path: root/www/apache22/files
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-03-23 08:31:55 +0000
committerPatrick Li <pat@FreeBSD.org>2002-03-23 08:31:55 +0000
commit499e0c4b797840a592cd16bc2215e1e403a97e86 (patch)
tree7fda7761690ce3b29b218053228dc7d7145dfb33 /www/apache22/files
parent023cea8ca14cf72fbadefe6b083f0bb690cd92c9 (diff)
downloadports-499e0c4b797840a592cd16bc2215e1e403a97e86.tar.gz
ports-499e0c4b797840a592cd16bc2215e1e403a97e86.zip
Notes
Diffstat (limited to 'www/apache22/files')
-rw-r--r--www/apache22/files/patch-Makefile.in30
-rw-r--r--www/apache22/files/patch-config.layout17
-rw-r--r--www/apache22/files/patch-configure28
-rw-r--r--www/apache22/files/patch-docs:conf:httpd-std.conf63
-rw-r--r--www/apache22/files/patch-docs:conf:ssl-std.conf48
-rw-r--r--www/apache22/files/patch-srclib:apr-util:configure11
-rw-r--r--www/apache22/files/patch-support:apachectl.in14
-rw-r--r--www/apache22/files/patch-support:apxs.in37
-rw-r--r--www/apache22/files/patch-support:log_server_status.in4
9 files changed, 133 insertions, 119 deletions
diff --git a/www/apache22/files/patch-Makefile.in b/www/apache22/files/patch-Makefile.in
index a9d597aaa827..dc71e6df0a20 100644
--- a/www/apache22/files/patch-Makefile.in
+++ b/www/apache22/files/patch-Makefile.in
@@ -1,44 +1,44 @@
---- Makefile.in.orig Mon Oct 22 21:46:29 2001
-+++ Makefile.in Tue Jan 22 19:02:30 2002
-@@ -32,7 +32,7 @@
+--- Makefile.in.orig Wed Jan 23 16:10:16 2002
++++ Makefile.in Fri Feb 22 03:32:58 2002
+@@ -32,7 +32,9 @@
@test -d $(sysconfdir) || $(MKINSTALLDIRS) $(sysconfdir)
@cd $(top_srcdir)/docs/conf; \
for i in mime.types magic; do \
- $(INSTALL_DATA) $$i $(sysconfdir); \
+ test -f $(sysconfdir)/$$i || $(INSTALL_DATA) $$i $(sysconfdir); \
++ cp -f $$i $$i.default; \
++ $(INSTALL_DATA) $$i.default $(sysconfdir); \
done; \
for i in *-std* ssl.conf; do \
[ -f $$i ] || continue; \
-@@ -51,7 +51,7 @@
- < $$i; \
- for j in $(DSO_MODULES) "^EOL^"; do \
+@@ -54,7 +56,7 @@
+ echo "<IfDefine SSL>"; \
+ fi; \
if test $$j != "^EOL^"; then \
- echo "LoadModule $${j}_module modules/mod_$${j}.so"; \
+ echo "LoadModule $${j}_module ${libexecdir:S|^${prefix}/||}/mod_$${j}.so"; \
fi; \
- done; \
- sed -e '1,/@@LoadModule@@/d' \
-@@ -93,11 +93,14 @@
+ if test "x$$j" = "xssl"; then \
+ echo "</IfDefine>"; \
+@@ -106,11 +108,14 @@
install-htdocs:
@echo Installing HTML documents
- @test -d $(htdocsdir) || $(MKINSTALLDIRS) $(htdocsdir)
- @test -d $(htdocs-srcdir) && (cd $(htdocs-srcdir) && cp -rp * $(htdocsdir))
-- @test -d $(prefix)/manual || $(MKINSTALLDIRS) $(prefix)/manual
-- @test -d $(top_srcdir)/docs/manual && (cd $(top_srcdir)/docs/manual && cp -rp * $(prefix)/manual)
-- @(cd $(htdocsdir) && find . -name "CVS" -print | xargs rm -rf {} \;)
+ @test -d $(htdocsdir).default || $(MKINSTALLDIRS) $(htdocsdir).default
+ @test -d $(htdocs-srcdir) && (cd $(htdocs-srcdir) && cp -rp * $(htdocsdir).default)
+ @test -e $(htdocsdir) || ln -sf $(htdocsdir).default $(htdocsdir)
+.if !defined(NOPORTDOCS)
-+ @test -d $(manualdir) || $(MKINSTALLDIRS) $(manualdir)
-+ @test -d $(top_srcdir)/docs/manual && (cd $(top_srcdir)/docs/manual && cp -rp * $(manualdir))
+ @test -d $(manualdir) || $(MKINSTALLDIRS) $(manualdir)
+ @test -d $(top_srcdir)/docs/manual && (cd $(top_srcdir)/docs/manual && cp -rp * $(manualdir))
+- @(cd $(htdocsdir) && find . -name "CVS" -print | xargs rm -rf {} \;)
+.endif
+ @(cd $(htdocsdir).default && find . -name "CVS" -print | xargs rm -rf {} \;)
install-error:
@echo Installing error documents
-@@ -113,9 +116,10 @@
+@@ -126,9 +131,10 @@
install-cgi:
@echo Installing CGIs
diff --git a/www/apache22/files/patch-config.layout b/www/apache22/files/patch-config.layout
index 0bb23d72594f..8fae2764a544 100644
--- a/www/apache22/files/patch-config.layout
+++ b/www/apache22/files/patch-config.layout
@@ -1,8 +1,8 @@
---- config.layout.orig Fri Oct 26 11:59:26 2001
-+++ config.layout Fri Nov 16 18:36:14 2001
-@@ -285,3 +285,25 @@
- logfiledir: $prefix/logs
- proxycachedir: $prefix/proxy
+--- config.layout.orig Thu Feb 21 03:02:06 2002
++++ config.layout Thu Feb 21 03:04:56 2002
+@@ -307,3 +307,26 @@
+ infodir: $exec_prefix/share/info
+ installbuilddir: $prefix/etc/apache2/build
</Layout>
+
+<Layout FreeBSD>
@@ -12,17 +12,18 @@
+ sbindir: $exec_prefix/sbin
+ libexecdir: $exec_prefix/libexec/apache
+ mandir: $prefix/man
-+ sysconfdir: $prefix/etc/apache
++ sysconfdir: $prefix/etc/apache2
+ datadir: $prefix/www
-+ installbuilddir: $prefix/share/mk/apache
++ installbuilddir: $prefix/share/apache
+ errordir: $datadir/error
+ iconsdir: $datadir/icons
+ htdocsdir: $datadir/data
-+ manualdir: ${prefix}/share/doc/apache
++ manualdir: $prefix/share/doc/apache
+ cgidir: $datadir/cgi-bin
+ includedir: $prefix/include/apache
+ localstatedir: /var
+ runtimedir: $localstatedir/run
+ logfiledir: $localstatedir/log
+ proxycachedir: $datadir/proxy
++ infodir: $exec_prefix/share/info
+</Layout>
diff --git a/www/apache22/files/patch-configure b/www/apache22/files/patch-configure
index 007d46173167..7ceda58436da 100644
--- a/www/apache22/files/patch-configure
+++ b/www/apache22/files/patch-configure
@@ -1,31 +1,13 @@
---- configure.orig Tue Nov 13 04:07:39 2001
-+++ configure Fri Nov 16 23:32:52 2001
-@@ -1084,7 +1084,7 @@
- esac
-
- # The eval makes quoting arguments work.
-- if eval $ac_abs_srcdir/configure $ac_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_abs_srcdir "$apache_apr_flags --prefix=$prefix $disable_shared"
-+ if eval $ac_abs_srcdir/configure $ac_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_abs_srcdir --includedir=$includedir "$apache_apr_flags --prefix=$prefix $disable_shared"
- then :
- echo "srclib/apr configured properly"
- else
-@@ -1175,7 +1175,7 @@
- esac
-
- # The eval makes quoting arguments work.
-- if eval $ac_abs_srcdir/configure $ac_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_abs_srcdir "--with-apr=../apr --prefix=$prefix $disable_shared"
-+ if eval $ac_abs_srcdir/configure $ac_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_abs_srcdir --includedir=$includedir "--with-apr=../apr --prefix=$prefix $disable_shared"
- then :
- echo "srclib/apr-util configured properly"
- else
-@@ -10508,7 +10508,10 @@
+--- configure.orig Fri Feb 22 03:43:38 2002
++++ configure Fri Feb 22 03:44:56 2002
+@@ -11095,7 +11095,10 @@
EOF
cat >> confdefs.h <<EOF
-#define SERVER_CONFIG_FILE "conf/$progname.conf"
-+#define SERVER_CONFIG_FILE "etc/apache/$progname.conf"
++#define SERVER_CONFIG_FILE "etc/apache2/$progname.conf"
+#define DEFAULT_ERRORLOG "/var/log/httpd-error.log"
-+#define AP_TYPES_CONFIG_FILE "etc/apache/mime.types"
++#define AP_TYPES_CONFIG_FILE "etc/apache2/mime.types"
+#define DOCUMENT_LOCATION HTTPD_ROOT "/www/data"
EOF
diff --git a/www/apache22/files/patch-docs:conf:httpd-std.conf b/www/apache22/files/patch-docs:conf:httpd-std.conf
index eb63c30ac79a..8b0665b95c63 100644
--- a/www/apache22/files/patch-docs:conf:httpd-std.conf
+++ b/www/apache22/files/patch-docs:conf:httpd-std.conf
@@ -1,24 +1,24 @@
---- docs/conf/httpd-std.conf.orig Fri Nov 9 07:31:28 2001
-+++ docs/conf/httpd-std.conf Sat Nov 17 01:49:29 2001
-@@ -64,7 +64,7 @@
+--- docs/conf/httpd-std.conf.orig Fri Jan 25 09:24:47 2002
++++ docs/conf/httpd-std.conf Fri Feb 22 02:32:28 2002
+@@ -66,7 +66,7 @@
#
- <IfModule !mpm_winnt.c>
+ <IfModule !mpm_netware.c>
<IfModule !perchild.c>
-ScoreBoardFile logs/apache_runtime_status
+ScoreBoardFile /var/run/apache_runtime_status
</IfModule>
</IfModule>
-@@ -73,7 +73,7 @@
- # PidFile: The file in which the server should record its process
+@@ -76,7 +76,7 @@
# identification number when it starts.
#
+ <IfModule !mpm_netware.c>
-PidFile logs/httpd.pid
+PidFile /var/run/httpd.pid
+ </IfModule>
#
- # Timeout: The number of seconds before receives and sends time out.
-@@ -229,8 +229,8 @@
+@@ -248,8 +248,8 @@
# when the value of (unsigned)Group is above 60000;
# don't use Group #-1 on these systems!
#
@@ -27,9 +27,9 @@
+User www
+Group www
</IfModule>
+ </IfModule>
- #
-@@ -259,7 +259,7 @@
+@@ -279,7 +279,7 @@
# documents. By default, all requests are taken from this directory, but
# symbolic links and aliases may be used to point to other locations.
#
@@ -37,8 +37,8 @@
+DocumentRoot "@@ServerRoot@@/www/data"
#
- # Each directory to which Apache has access, can be configured with respect
-@@ -284,7 +284,7 @@
+ # Each directory to which Apache has access can be configured with respect
+@@ -304,7 +304,7 @@
#
# This should be changed to whatever you set DocumentRoot to.
#
@@ -46,26 +46,26 @@
+<Directory "@@ServerRoot@@/www/data">
#
- # This may also be "None", "All", or any combination of "Indexes",
-@@ -377,7 +377,7 @@
+ # Possible values for the Options directive are "None", "All",
+@@ -397,7 +397,7 @@
# TypesConfig describes where the mime.types file (or equivalent) is
# to be found.
#
-TypesConfig conf/mime.types
-+TypesConfig etc/apache/mime.types
++TypesConfig etc/apache2/mime.types
#
# DefaultType is the default MIME type the server will use for a document
-@@ -396,7 +396,7 @@
+@@ -416,7 +416,7 @@
# directive tells the module where the hint definitions are located.
#
<IfModule mod_mime_magic.c>
- MIMEMagicFile conf/magic
-+ MIMEMagicFile etc/apache/magic
++ MIMEMagicFile etc/apache2/magic
</IfModule>
#
-@@ -416,7 +416,7 @@
+@@ -436,7 +436,7 @@
# logged here. If you *do* define an error logfile for a <VirtualHost>
# container, that host's errors will be logged there and not here.
#
@@ -74,16 +74,23 @@
#
# LogLevel: Control the number of messages logged to the error_log.
-@@ -441,7 +441,7 @@
+@@ -461,20 +461,20 @@
# define per-<VirtualHost> access logfiles, transactions will be
# logged therein and *not* in this file.
#
-CustomLog logs/access_log common
-+#CustomLog logs/access_log common
++#CustomLog /var/log/httpd-access_log common
#
# If you would like to have agent and referer logfiles, uncomment the
-@@ -454,7 +454,7 @@
+ # following directives.
+ #
+-#CustomLog logs/referer_log referer
+-#CustomLog logs/agent_log agent
++#CustomLog /var/log/httpd-referer_log referer
++#CustomLog /var/log/httpd-agent_log agent
+
+ #
# If you prefer a single logfile with access, agent, and referer information
# (Combined Logfile Format) you can use the following directive.
#
@@ -92,7 +99,7 @@
#
# Optionally add a line containing the server version and virtual host
-@@ -478,9 +478,9 @@
+@@ -498,9 +498,9 @@
# We include the /icons/ alias for FancyIndexed directory listings. If you
# do not use FancyIndexing, you may comment this out.
#
@@ -104,7 +111,7 @@
Options Indexes MultiViews
AllowOverride None
Order allow,deny
-@@ -492,9 +492,9 @@
+@@ -512,9 +512,9 @@
# the manual, even if you choose to move your DocumentRoot. You may comment
# this out if you do not care for the documentation.
#
@@ -116,7 +123,7 @@
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
-@@ -509,21 +509,21 @@
+@@ -529,21 +529,21 @@
# The same rules about trailing "/" apply to ScriptAlias directives as to
# Alias.
#
@@ -141,9 +148,9 @@
AllowOverride None
Options None
Order allow,deny
-@@ -851,9 +851,9 @@
- #
+@@ -859,9 +859,9 @@
+ <IfModule mod_negotiation.c>
<IfModule mod_include.c>
- Alias /error/ "@@ServerRoot@@/error/"
+ Alias /error/ "@@ServerRoot@@/www/error/"
@@ -153,12 +160,12 @@
AllowOverride None
Options IncludesNoExec
AddOutputFilter Includes html
-@@ -964,7 +964,7 @@
+@@ -974,7 +974,7 @@
# Bring in additional module-specific configurations
#
<IfModule mod_ssl.c>
- Include conf/ssl.conf
-+ Include etc/apache/ssl.conf
++ Include etc/apache2/ssl.conf
</IfModule>
diff --git a/www/apache22/files/patch-docs:conf:ssl-std.conf b/www/apache22/files/patch-docs:conf:ssl-std.conf
index f647b91fac48..9dcf0d50384a 100644
--- a/www/apache22/files/patch-docs:conf:ssl-std.conf
+++ b/www/apache22/files/patch-docs:conf:ssl-std.conf
@@ -1,14 +1,34 @@
---- docs/conf/ssl-std.conf.orig Fri Nov 16 21:56:55 2001
-+++ docs/conf/ssl-std.conf Fri Nov 16 22:00:27 2001
-@@ -57,7 +57,7 @@
+--- docs/conf/ssl-std.conf.orig Thu Nov 8 07:16:09 2001
++++ docs/conf/ssl-std.conf Fri Feb 22 02:37:27 2002
+@@ -55,15 +55,15 @@
+ # Configure the SSL Session Cache: First the mechanism
+ # to use and second the expiring timeout (in seconds).
#SSLSessionCache none
- #SSLSessionCache shmht:logs/ssl_scache(512000)
- #SSLSessionCache shmcb:logs/ssl_scache(512000)
+-#SSLSessionCache shmht:logs/ssl_scache(512000)
+-#SSLSessionCache shmcb:logs/ssl_scache(512000)
-SSLSessionCache dbm:logs/ssl_scache
++#SSLSessionCache shmht:/var/log/httpd-ssl_scache(512000)
++#SSLSessionCache shmcb:/var/log/httpd-ssl_scache(512000)
+SSLSessionCache dbm:/var/log/httpd-ssl_scache
SSLSessionCacheTimeout 300
# Semaphore:
+ # Configure the path to the mutual exclusion semaphore the
+ # SSL engine uses internally for inter-process synchronization.
+-SSLMutex file:logs/ssl_mutex
++SSLMutex file:/var/log/httpd-ssl_mutex
+
+ # Pseudo Random Number Generator (PRNG):
+ # Configure one or more sources to seed the PRNG of the
+@@ -89,7 +89,7 @@
+ # a real server (i.e. somewhere where only root can write).
+ # Log levels are (ascending order: higher ones include lower ones):
+ # none, error, warn, info, trace, debug.
+-SSLLog logs/ssl_engine_log
++SSLLog /var/log/httpd-ssl_engine_log
+ SSLLogLevel info
+
+ ##
@@ -99,11 +99,11 @@
<VirtualHost _default_:443>
@@ -30,8 +50,8 @@
# the use of DSA ciphers, etc.)
-SSLCertificateFile @@ServerRoot@@/conf/ssl.crt/server.crt
-#SSLCertificateFile @@ServerRoot@@/conf/ssl.crt/server-dsa.crt
-+SSLCertificateFile @@ServerRoot@@/etc/apache/ssl.crt/server.crt
-+#SSLCertificateFile @@ServerRoot@@/etc/apache/ssl.crt/server-dsa.crt
++SSLCertificateFile @@ServerRoot@@/etc/apache2/ssl.crt/server.crt
++#SSLCertificateFile @@ServerRoot@@/etc/apache2/ssl.crt/server-dsa.crt
# Server Private Key:
# If the key is not combined with the certificate, use this
@@ -40,8 +60,8 @@
# both in parallel (to also allow the use of DSA ciphers, etc.)
-SSLCertificateKeyFile @@ServerRoot@@/conf/ssl.key/server.key
-#SSLCertificateKeyFile @@ServerRoot@@/conf/ssl.key/server-dsa.key
-+SSLCertificateKeyFile @@ServerRoot@@/etc/apache/ssl.key/server.key
-+#SSLCertificateKeyFile @@ServerRoot@@/etc/apache/ssl.key/server-dsa.key
++SSLCertificateKeyFile @@ServerRoot@@/etc/apache2/ssl.key/server.key
++#SSLCertificateKeyFile @@ServerRoot@@/etc/apache2/ssl.key/server-dsa.key
# Server Certificate Chain:
# Point SSLCertificateChainFile at a file containing the
@@ -50,7 +70,7 @@
# when the CA certificates are directly appended to the server
# certificate for convinience.
-#SSLCertificateChainFile @@ServerRoot@@/conf/ssl.crt/ca.crt
-+#SSLCertificateChainFile @@ServerRoot@@/etc/apache/ssl.crt/ca.crt
++#SSLCertificateChainFile @@ServerRoot@@/etc/apache2/ssl.crt/ca.crt
# Certificate Authority (CA):
# Set the CA certificate verification path where to find CA
@@ -60,8 +80,8 @@
# Makefile to update the hash symlinks after changes.
-#SSLCACertificatePath @@ServerRoot@@/conf/ssl.crt
-#SSLCACertificateFile @@ServerRoot@@/conf/ssl.crt/ca-bundle.crt
-+#SSLCACertificatePath @@ServerRoot@@/etc/apache/ssl.crt
-+#SSLCACertificateFile @@ServerRoot@@/etc/apache/ssl.crt/ca-bundle.crt
++#SSLCACertificatePath @@ServerRoot@@/etc/apache2/ssl.crt
++#SSLCACertificateFile @@ServerRoot@@/etc/apache2/ssl.crt/ca-bundle.crt
# Certificate Revocation Lists (CRL):
# Set the CA revocation path where to find CA CRLs for client
@@ -71,8 +91,8 @@
# Makefile to update the hash symlinks after changes.
-#SSLCARevocationPath @@ServerRoot@@/conf/ssl.crl
-#SSLCARevocationFile @@ServerRoot@@/conf/ssl.crl/ca-bundle.crl
-+#SSLCARevocationPath @@ServerRoot@@/etc/apache/ssl.crl
-+#SSLCARevocationFile @@ServerRoot@@/etc/apache/ssl.crl/ca-bundle.crl
++#SSLCARevocationPath @@ServerRoot@@/etc/apache2/ssl.crl
++#SSLCARevocationFile @@ServerRoot@@/etc/apache2/ssl.crl/ca-bundle.crl
# Client Authentication (Type):
# Client certificate verification type and depth. Types are
diff --git a/www/apache22/files/patch-srclib:apr-util:configure b/www/apache22/files/patch-srclib:apr-util:configure
new file mode 100644
index 000000000000..bd10fd35df68
--- /dev/null
+++ b/www/apache22/files/patch-srclib:apr-util:configure
@@ -0,0 +1,11 @@
+--- srclib/apr-util/configure.orig Fri Feb 22 02:55:35 2002
++++ srclib/apr-util/configure Fri Feb 22 02:56:03 2002
+@@ -5770,7 +5770,7 @@
+
+
+ if test -z "$expat_include_dir"; then
+- for d in /usr /usr/local xml/expat-cvs xml/expat $srcdir/xml/expat ; do
++ for d in xml/expat-cvs xml/expat $srcdir/xml/expat ; do
+
+ echo $ac_n "checking for Expat in $d""... $ac_c" 1>&6
+ echo "configure:5777: checking for Expat in $d" >&5
diff --git a/www/apache22/files/patch-support:apachectl.in b/www/apache22/files/patch-support:apachectl.in
index f5b347b4633d..2e4ba03f6166 100644
--- a/www/apache22/files/patch-support:apachectl.in
+++ b/www/apache22/files/patch-support:apachectl.in
@@ -1,6 +1,6 @@
---- support/apachectl.in.orig Fri Nov 16 21:22:36 2001
-+++ support/apachectl.in Fri Nov 16 22:07:31 2001
-@@ -25,10 +25,10 @@
+--- support/apachectl.in.orig Sat Dec 15 22:56:36 2001
++++ support/apachectl.in Fri Feb 22 02:40:03 2002
+@@ -26,10 +26,10 @@
# -------------------- --------------------
#
# the path to your PID file
@@ -11,13 +11,13 @@
-HTTPD='@prefix@/bin/@progname@'
+HTTPD='@prefix@/sbin/@progname@'
#
- # a command that outputs a formatted text version of the HTML at the
- # url given on the command line. Designed for lynx, however other
-@@ -41,6 +41,7 @@
+ # pick up any necessary environment variables
+ if test -f @prefix@/bin/envvars; then
+@@ -47,6 +47,7 @@
#
# -------------------- --------------------
# |||||||||||||||||||| END CONFIGURATION SECTION ||||||||||||||||||||
+eval `limits -e -C daemon` >/dev/null 2>&1
ERROR=0
- ARGV="$@"
+ if [ "x$ARGV" = "x" ] ; then
diff --git a/www/apache22/files/patch-support:apxs.in b/www/apache22/files/patch-support:apxs.in
index 4106153d5e90..6ea17a914bdc 100644
--- a/www/apache22/files/patch-support:apxs.in
+++ b/www/apache22/files/patch-support:apxs.in
@@ -1,47 +1,40 @@
---- support/apxs.in.orig Sat Nov 3 05:09:20 2001
-+++ support/apxs.in Sun Dec 9 14:47:57 2001
+--- support/apxs.in.orig Sat Feb 2 04:25:14 2002
++++ support/apxs.in Fri Feb 22 02:49:11 2002
@@ -66,7 +66,7 @@
# read the configuration variables once
my %config_vars = ();
-get_config_vars("$prefix/build/config_vars.mk",\%config_vars);
-+get_config_vars("$prefix/share/mk/apache/config_vars.mk",\%config_vars);
++get_config_vars("$prefix/share/apache/config_vars.mk",\%config_vars);
my $exec_prefix = get_vars("exec_prefix");
my $CFG_TARGET = get_vars("progname");
-@@ -218,7 +218,7 @@
- ##
- ## Initial shared object support check
- ##
--my $httpd = get_vars("bindir") . "/" . get_vars("progname");
-+my $httpd = get_vars("sbindir") . "/" . get_vars("progname");
- $httpd = eval qq("$httpd");
- $httpd = eval qq("$httpd");
-
-@@ -412,7 +412,7 @@
+@@ -414,7 +414,7 @@
$la =~ s|\.c$|.la|;
my $o = $s;
$o =~ s|\.c$|.o|;
-- push(@cmds, "$prefix/build/libtool --silent --mode=compile $CFG_CC $cflags -I$CFG_INCLUDEDIR $opt -c -o $lo $s && touch $slo");
-+ push(@cmds, "$prefix/share/mk/apache/libtool --silent --mode=compile $CFG_CC $cflags -I$CFG_INCLUDEDIR $opt -c -o $lo $s && touch $slo");
+- push(@cmds, "$prefix/build/libtool $ltflags --mode=compile $CFG_CC $cflags -I$CFG_INCLUDEDIR $opt -c -o $lo $s && touch $slo");
++ push(@cmds, "$prefix/share/apache/libtool $ltflags --mode=compile $CFG_CC $cflags -I$CFG_INCLUDEDIR $opt -c -o $lo $s && touch $slo");
unshift(@objs, $lo);
}
-@@ -437,7 +437,7 @@
+@@ -439,7 +439,7 @@
$opt .= " -l$opt_l";
}
-- push(@cmds, "$prefix/build/libtool --silent --mode=link $CFG_CC -o $dso_file -rpath $CFG_LIBEXECDIR -module -avoid-version $opt $lo");
-+ push(@cmds, "$prefix/share/mk/apache/libtool --silent --mode=link $CFG_CC -o $dso_file -rpath $CFG_LIBEXECDIR -module -avoid-version $opt $lo");
+- push(@cmds, "$prefix/build/libtool $ltflags --mode=link $CFG_CC -o $dso_file -rpath $CFG_LIBEXECDIR -module -avoid-version $opt $lo");
++ push(@cmds, "$prefix/share/apache/libtool $ltflags --mode=link $CFG_CC -o $dso_file -rpath $CFG_LIBEXECDIR -module -avoid-version $opt $lo");
# execute the commands
&execute_cmds(@cmds);
-@@ -467,7 +467,7 @@
- my $t = $f;
+@@ -470,8 +470,8 @@
$t =~ s|^.+/([^/]+)$|$1|;
+ $t =~ s|\.la$|\.so|;
if ($opt_i) {
-- push(@cmds, "$prefix/build/libtool --mode=install cp $f $CFG_LIBEXECDIR/$t");
-+ push(@cmds, "$prefix/share/mk/apache/libtool --mode=install cp $f $CFG_LIBEXECDIR/$t");
+- push(@cmds, "$prefix/build/instdso.sh SH_LIBTOOL='" .
+- "$prefix/build/libtool' $f $CFG_LIBEXECDIR");
++ push(@cmds, "$prefix/share/apache/instdso.sh SH_LIBTOOL='" .
++ "$prefix/share/apache/libtool' $f $CFG_LIBEXECDIR");
push(@cmds, "chmod 755 $CFG_LIBEXECDIR/$t");
}
diff --git a/www/apache22/files/patch-support:log_server_status.in b/www/apache22/files/patch-support:log_server_status.in
index d8a970ebe8cd..20e899a9272c 100644
--- a/www/apache22/files/patch-support:log_server_status.in
+++ b/www/apache22/files/patch-support:log_server_status.in
@@ -1,5 +1,5 @@
---- support/log_server_status.in.orig Fri Nov 16 22:11:16 2001
-+++ support/log_server_status.in Fri Nov 16 22:13:50 2001
+--- support/log_server_status.in.orig Mon Mar 12 08:40:47 2001
++++ support/log_server_status.in Fri Feb 22 02:50:20 2002
@@ -63,10 +63,10 @@
#
require 'sys/socket.ph';