aboutsummaryrefslogtreecommitdiff
path: root/www/apache22
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2013-10-27 17:40:21 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2013-10-27 17:40:21 +0000
commiteaabba7357b16b613e96d40e34c847db0ab8536d (patch)
tree41e8a54708d9ac459582cbae41e8509885da709b /www/apache22
parent166d24f12c74b34fc896d2b16bb1f35b2d0b3a10 (diff)
downloadports-eaabba7357b16b613e96d40e34c847db0ab8536d.tar.gz
ports-eaabba7357b16b613e96d40e34c847db0ab8536d.zip
Notes
Diffstat (limited to 'www/apache22')
-rw-r--r--www/apache22/Makefile93
-rw-r--r--www/apache22/Makefile.doc12
-rw-r--r--www/apache22/Makefile.modules22
-rw-r--r--www/apache22/files/patch-Makefile.in76
-rw-r--r--www/apache22/files/patch-support__Makefile.in8
-rw-r--r--www/apache22/pkg-message2
-rw-r--r--www/apache22/pkg-plist107
7 files changed, 156 insertions, 164 deletions
diff --git a/www/apache22/Makefile b/www/apache22/Makefile
index 81339202cdd1..e19ffb892f9e 100644
--- a/www/apache22/Makefile
+++ b/www/apache22/Makefile
@@ -11,12 +11,9 @@ DIST_SUBDIR= apache22
MAINTAINER?= apache@FreeBSD.org
COMMENT?= Version 2.2.x of Apache web server with ${WITH_MPM} MPM.
-LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2 \
- apr-1:${PORTSDIR}/devel/apr1 \
- pcre:${PORTSDIR}/devel/pcre
-
-
-LATEST_LINK?= apache22
+LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libapr-1.so:${PORTSDIR}/devel/apr1 \
+ libpcre.so:${PORTSDIR}/devel/pcre
CONFLICTS_INSTALL= caudium14-1.* \
apache-*-2.2.* apache22-*-2.2.* \
@@ -25,10 +22,13 @@ CONFLICTS_INSTALL= caudium14-1.* \
USE_APACHE= common22
USE_BZIP2= yes
USES= iconv perl5
+USE_PERL5= run
USE_AUTOTOOLS= autoconf libtool
USE_RC_SUBR= apache22 htcacheclean
LIBTOOLFILES= configure.in
+PORTDOCS= *
+
USERS= www
GROUPS= www
@@ -41,11 +41,32 @@ APACHEDIR= ${MASTERDIR}
WITH_MPM?= prefork # or worker, event, itk, peruser
WITH_HTTP_PORT?= 80
+WITH_SSL_PORT?= 443
-NO_STAGE= yes
.include "${APACHEDIR}/Makefile.options"
+
+AUTHNZ_LDAP_CONFIGURE_ON= --enable-authnz-ldap
+
+# http://httpd.apache.org/docs/2.2/bind.html
+IPV4_MAPPED_CONFIGURE_OFF= --disable-v4-mapped
+IPV4_MAPPED_CONFIGURE_ON= --enable-v4-mapped
+
+LDAP_CONFIGURE_ON= --enable-ldap=shared
+SSL_CFLAGS= -I${OPENSSLINC}
+SSL_CONFIGURE_ON= --with-ssl=${OPENSSLBASE}
+SSL_LDFLAGS= -L${OPENSSLLIB}
+SSL_USE= OPENSSL=yes
+
+SUEXEC_RSRCLIMIT_EXTRA_PATCHES= ${FILESDIR}/extra-patch-suexec_rsrclimit
+SUEXEC_USERDIR_EXTRA_PATCHES= ${FILESDIR}/extra-patch-suexec_userdir
+
.include <bsd.port.options.mk>
-.include "${APACHEDIR}/Makefile.doc"
+
+ETC_SUBDIRS= Includes envvars.d extra
+
+.if ! ${PORT_OPTIONS:MDOCS}
+MAKE_ENV+= NOPORTDOCS=yes
+.endif
APR_CONFIG?= ${LOCALBASE}/bin/apr-1-config
APU_CONFIG?= ${LOCALBASE}/bin/apu-1-config
@@ -57,13 +78,13 @@ APU_DBD_SQLITE3?= ${LOCALBASE}/lib/apr-util-1/apr_dbd_sqlite3.so
# APU module used by AUTHNZ_LDAP LDAP
APU_LDAP?= ${LOCALBASE}/lib/apr-util-1/apr_ldap.so
# APU module used by SESSION_CRYPTO
-APU_CRYPTO_SSL?= ${LOCALBASE}/lib/apr-util-1/apr_crypto_openssl.so
+APU_CRYPTO_OPENSSL?= ${LOCALBASE}/lib/apr-util-1/apr_crypto_openssl.so
APU_CRYPTO_NSS?= ${LOCALBASE}/lib/apr-util-1/apr_crypto_nss.so
-CONFIGURE_ARGS= --prefix=${PREFIX_RELDEST} \
+CONFIGURE_ARGS+=--prefix=${PREFIX} \
--enable-layout=FreeBSD \
- --with-perl=${PERL5} \
--with-port=${WITH_HTTP_PORT} \
+ --with-sslport=${WITH_SSL_PORT} \
--with-expat=${LOCALBASE} \
--with-iconv=${ICONV_PREFIX} \
--enable-http \
@@ -75,33 +96,22 @@ CONFIGURE_ENV= \
CONFIG_SHELL="${SH}" \
LOCALBASE="${LOCALBASE}"
-PREFIX_RELDEST= ${PREFIX:S,^${DESTDIR},,}
-
MAKE_ENV+= EXPR_COMPAT=yes \
- INSTALL_MAN="${INSTALL_MAN}"
+ INSTALL_MAN="${INSTALL_MAN}" \
+ EXAMPLESDIR=${EXAMPLESDIR}
#=====================================================
# CONFIGURE_ARGS will be handled in Makefile.modules,
# here we do only OPTIONS fixups
-.if ${PORT_OPTIONS:MSSL}
-USE_OPENSSL= yes
-.endif
-
-.if ${PORT_OPTIONS:MSUEXEC_RSRCLIMIT}
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-suexec_rsrclimit
-. if empty(PORT_OPTIONS:MSUEXEC)
+.if ${PORT_OPTIONS:MSUEXEC_RSRCLIMIT} && !${PORT_OPTIONS:MSUEXEC}
IGNORE= suEXEC resource limit patch requires mod_suexec.\
Please (re)run 'make config' and choose SUEXEC option also
-. endif
.endif
-.if ${PORT_OPTIONS:MSUEXEC_USERDIR}
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-suexec_userdir
-. if empty(PORT_OPTIONS:MSUEXEC)
+.if ${PORT_OPTIONS:MSUEXEC_USERDIR} && !${PORT_OPTIONS:MSUEXEC}
IGNORE= suEXEC UserDir patch requires mod_suexec.\
Please (re)run 'make config' and choose SUEXEC option also
-. endif
.endif
.include <bsd.port.pre.mk>
@@ -115,12 +125,23 @@ pre-configure::
show-options:
@${SED} -ne 's/^##//p' ${APACHEDIR}/Makefile.doc
+post-extract:
+# remove possible leftover .svn directories in the sources
+ @${FIND} ${WRKSRC} -type d -name .svn -print | ${XARGS} ${RM} -rf
+# limit grep results ...
+ @${FIND} ${WRKSRC} -type f \( -name 'NWGNU*' -o -name '*.ds?' -o -name '*.dep' -o -name '*.mak' -o -name '*.win' \) -delete
+
post-patch:
+ @${REINPLACE_CMD} -e 's," PLATFORM ",FreeBSD,' ${WRKSRC}/server/core.c
+# IPv4_mapping fix: https://issues.apache.org/bugzilla/show_bug.cgi?id=53824
@${REINPLACE_CMD} -e 's|freebsd5|freebsd|' \
+ -e 's|^perlbin=.*|perlbin=${PERL}|' \
${WRKSRC}/configure.in ${WRKSRC}/configure
@${RM} -f ${WRKSRC}/docs/docroot/*.bak
- @${REINPLACE_CMD} -e 's," PLATFORM ",FreeBSD,' ${WRKSRC}/server/core.c
@${INSTALL_DATA} ${WRKSRC}/NOTICE ${WRKSRC}/docs/manual
+# we use devel/apr and devel/pcre
+ @${RM} -rf ${WRKSRC}/srclib
+ @${REINPLACE_CMD} -e 's/srclib//' ${WRKSRC}/Makefile.in
post-configure:
@FTPUSERS=`${EGREP} -v '^#' /etc/ftpusers| ${TR} -s "\n" " "` ;\
@@ -129,20 +150,12 @@ post-configure:
@${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX}," ${WRKSRC}/support/envvars-std
post-install:
- @${MKDIR} ${ETCDIR}/envvars.d
- @${MKDIR} ${ETCDIR}/Includes
- @${INSTALL_DATA} ${FILESDIR}/no-accf.conf ${ETCDIR}/Includes/
+ @${MKDIR} ${ETC_SUBDIRS:S|^|${STAGEDIR}${ETCDIR}/|}
+ @${INSTALL_DATA} ${FILESDIR}/no-accf.conf ${STAGEDIR}${ETCDIR}/Includes/
.if ${PORT_OPTIONS:MLOG_FORENSIC}
- @${INSTALL_SCRIPT} ${WRKSRC}/support/check_forensic ${PREFIX}/sbin
-.endif
-
-.if ${PORT_OPTIONS:MDOCS}
-. for dir in style/lang style/xsl/util style/xsl
- @[ -d ${DOCSDIR}/${dir}/ ] && ${TOUCH} ${DOCSDIR}/${dir}/.keepme
-. endfor
+ @${INSTALL_SCRIPT} ${WRKSRC}/support/check_forensic ${STAGEDIR}${PREFIX}/sbin
.endif
- @${CAT} ${PKGMESSAGE}
# maintainer only, check for new modules
modlist: extract
@@ -150,7 +163,7 @@ modlist: extract
{printf "%%%%%s%%%%libexec/apache22/%s.so\n", \
toupper($$8), $$8}' ${WRKSRC}/configure \
| ${TR} -d '"' \
- | ${GREP} -E -v 'MOD_(ECHO|EXAMPLE|HTTP|IDENT|ISAPI|SO)' \
- | ${SORT} -u
+ | ${SORT} -u \
+ | ${GREP} -E -v '^%%MOD_(ECHO|EXAMPLE|HTTP|IDENT|ISAPI|SO)%%'
.include <bsd.port.post.mk>
diff --git a/www/apache22/Makefile.doc b/www/apache22/Makefile.doc
index 6c308457181a..7b13ab0f5b6a 100644
--- a/www/apache22/Makefile.doc
+++ b/www/apache22/Makefile.doc
@@ -64,14 +64,4 @@
## on the Apache website: http://httpd.apache.org/docs/2.2/bind.html
## To find out which binding was used to build httpd use the command
## $> httpd -V
-
-MAKE_ENV+= EXAMPLESDIR=${EXAMPLESDIR}
-
-.if empty(PORT_OPTIONS:MDOCS)
-MAKE_ENV+= NOPORTDOCS=yes
-.endif
-
-MAN1= dbmmanage.1 htdbm.1 htdigest.1 htpasswd.1 httxt2dbm.1
-MAN8= ab.8 apxs.8 apachectl.8 htcacheclean.8 httpd.8 logresolve.8 rotatelogs.8 suexec.8
-
-PORTDOCS= * #don't blame me ;-)
+##
diff --git a/www/apache22/Makefile.modules b/www/apache22/Makefile.modules
index 227cc482327a..e1a1fb2267ce 100644
--- a/www/apache22/Makefile.modules
+++ b/www/apache22/Makefile.modules
@@ -66,7 +66,6 @@ IGNORE= Unknown MPM: ${WITH_MPM}
.if ${WITH_MPM} != "prefork"
PKGNAMESUFFIX= -${WITH_MPM}-mpm
-LATEST_LINK= apache22-${WITH_MPM}-mpm
.endif
.if ${WITH_MPM} == "worker" || ${WITH_MPM} == "event"
@@ -100,20 +99,6 @@ WITH_EXCEPTION_HOOK= yes
CONFIGURE_ARGS+= --enable-exception-hook
.endif
-.if ${PORT_OPTIONS:MSSL}
-CFLAGS+= -I${OPENSSLINC}
-LDFLAGS+= -L${OPENSSLLIB}
-CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE}
-.endif
-
-.if ${PORT_OPTIONS:MAUTHNZ_LDAP}
-CONFIGURE_ARGS+= --enable-authnz-ldap
-.endif
-
-.if ${PORT_OPTIONS:MLDAP}
-CONFIGURE_ARGS+= --enable-ldap=shared
-.endif
-
.if ${PORT_OPTIONS:MAUTH_BASIC} || ${PORT_OPTIONS:MAUTH_DIGEST}
. if !${APACHE_MODULES:MAUTHN*}
IGNORE= AUTH_BASIC and AUTH_DIGEST need at last one AUTHN provider
@@ -134,13 +119,6 @@ IGNORE= MEM_CACHE requires APR threads. Please rebuild APR with THREAD support
. endif
.endif
-# http://httpd.apache.org/docs/2.2/bind.html
-.if ${PORT_OPTIONS:MIPV4_MAPPED}
-CONFIGURE_ARGS+= --enable-v4-mapped
-.else
-CONFIGURE_ARGS+= --disable-v4-mapped
-.endif
-
CONFIGURE_ARGS+= --with-mpm=${WITH_MPM}
.endif # _PREMKINCLUDED
diff --git a/www/apache22/files/patch-Makefile.in b/www/apache22/files/patch-Makefile.in
index e77f63d68718..55413e755cff 100644
--- a/www/apache22/files/patch-Makefile.in
+++ b/www/apache22/files/patch-Makefile.in
@@ -1,19 +1,21 @@
---- ./Makefile.in.orig 2008-11-25 15:24:49.000000000 -0500
-+++ ./Makefile.in 2010-05-06 19:37:54.211730130 -0400
-@@ -31,9 +31,11 @@
+--- ./Makefile.in.orig 2008-11-25 21:24:49.000000000 +0100
++++ ./Makefile.in 2013-10-27 15:13:17.000000000 +0100
+@@ -31,12 +31,10 @@
install-conf:
@echo Installing configuration files
@$(MKINSTALLDIRS) $(DESTDIR)$(sysconfdir) $(DESTDIR)$(sysconfdir)/extra
- @$(MKINSTALLDIRS) $(DESTDIR)$(sysconfdir)/original/extra
+ @$(MKINSTALLDIRS) $(DESTDIR)$(EXAMPLESDIR) $(DESTDIR)$(EXAMPLESDIR)/extra
-+
@cd $(top_srcdir)/docs/conf; \
for i in mime.types magic; do \
+- if test ! -f $(DESTDIR)$(sysconfdir)/$$i; then \
+- $(INSTALL_DATA) $$i $(DESTDIR)$(sysconfdir); \
+- fi; \
+ $(INSTALL_DATA) $$i $(DESTDIR)$(EXAMPLESDIR); \
- if test ! -f $(DESTDIR)$(sysconfdir)/$$i; then \
- $(INSTALL_DATA) $$i $(DESTDIR)$(sysconfdir); \
- fi; \
-@@ -69,14 +71,14 @@
+ done; \
+ for j in $(top_srcdir)/docs/conf $(top_builddir)/docs/conf ; do \
+ cd $$j ; \
+@@ -69,15 +67,12 @@
-e 's#@@SSLPort@@#$(SSLPORT)#g' \
< $$i; \
fi \
@@ -25,13 +27,13 @@
if [ "$$i" = "httpd.conf" ]; then \
file=`echo $$i|sed s/.*.conf/$(PROGRAM_NAME).conf/`; \
fi; \
- if test ! -f $(DESTDIR)$(sysconfdir)/$$file; then \
+- if test ! -f $(DESTDIR)$(sysconfdir)/$$file; then \
- $(INSTALL_DATA) $(DESTDIR)$(sysconfdir)/original/$$i $(DESTDIR)$(sysconfdir)/$$file; \
-+ $(INSTALL_DATA) $(DESTDIR)$(EXAMPLESDIR)/$$i $(DESTDIR)$(sysconfdir)/$$file; \
- fi; \
+- fi; \
fi; \
done ; \
-@@ -120,48 +122,29 @@
+ done ; \
+@@ -120,48 +115,25 @@
doxygen $(top_srcdir)/docs/doxygen.conf
install-htdocs:
@@ -49,8 +51,7 @@
- fi; \
- fi
+ $(MKINSTALLDIRS) $(DESTDIR)$(EXAMPLESDIR) ; \
-+ test -d $(htdocs-srcdir) && (cd $(htdocs-srcdir) && cp -rp index.html $(DESTDIR)$(EXAMPLESDIR)) && \
-+ ( [ ! -f $(DESTDIR)$(htdocsdir)/index.html ] && cp -p $(DESTDIR)$(EXAMPLESDIR)/index.html $(DESTDIR)$(htdocsdir)/index.html) || true
++ test -d $(htdocs-srcdir) && (cd $(htdocs-srcdir) && cp -rp index.html $(DESTDIR)$(EXAMPLESDIR)) || true
install-error:
- -@if [ -d $(DESTDIR)$(errordir) ]; then \
@@ -59,10 +60,10 @@
- echo Installing error documents ; \
+ @echo Installing error documents ; \
$(MKINSTALLDIRS) $(DESTDIR)$(errordir) ; \
- cd $(top_srcdir)/docs/error && cp -rp * $(DESTDIR)$(errordir) ; \
+- cd $(top_srcdir)/docs/error && cp -rp * $(DESTDIR)$(errordir) ; \
- test "x$(errordir)" != "x" && cd $(DESTDIR)$(errordir) && find . -name ".svn" -type d -print | xargs rm -rf 2>/dev/null || true; \
- fi
-+ test "x$(errordir)" != "x" && cd $(DESTDIR)$(errordir) && find . -name ".svn" -type d -print | xargs rm -rf 2>/dev/null || true;
++ cd $(top_srcdir)/docs/error && cp -rp * $(DESTDIR)$(errordir) ;
install-icons:
- -@if [ -d $(DESTDIR)$(iconsdir) ]; then \
@@ -71,10 +72,10 @@
- echo Installing icons ; \
+ @echo Installing icons ; \
$(MKINSTALLDIRS) $(DESTDIR)$(iconsdir) ; \
- cd $(top_srcdir)/docs/icons && cp -rp * $(DESTDIR)$(iconsdir) ; \
+- cd $(top_srcdir)/docs/icons && cp -rp * $(DESTDIR)$(iconsdir) ; \
- test "x$(iconsdir)" != "x" && cd $(DESTDIR)$(iconsdir) && find . -name ".svn" -type d -print | xargs rm -rf 2>/dev/null || true; \
- fi
-+ test "x$(iconsdir)" != "x" && cd $(DESTDIR)$(iconsdir) && find . -name ".svn" -type d -print | xargs rm -rf 2>/dev/null || true;
++ cd $(top_srcdir)/docs/icons && cp -rp * $(DESTDIR)$(iconsdir) ;
install-cgi:
- -@if [ -d $(DESTDIR)$(cgidir) ];then \
@@ -83,32 +84,35 @@
- echo Installing CGIs ; \
+ @echo Installing CGIs ; \
$(MKINSTALLDIRS) $(DESTDIR)$(cgidir) ; \
- cd $(top_srcdir)/docs/cgi-examples && cp -rp * $(DESTDIR)$(cgidir) ; \
+- cd $(top_srcdir)/docs/cgi-examples && cp -rp * $(DESTDIR)$(cgidir) ; \
- test "x$(cgidir)" != "x" && cd $(DESTDIR)$(cgidir) && find . -name ".svn" -type d -print | xargs rm -rf 2>/dev/null || true; \
- fi
-+ test "x$(cgidir)" != "x" && cd $(DESTDIR)$(cgidir) && find . -name ".svn" -type d -print | xargs rm -rf 2>/dev/null || true;
++ cd $(top_srcdir)/docs/cgi-examples && cp -rp * $(DESTDIR)$(cgidir) ;
install-other:
@test -d $(DESTDIR)$(logfiledir) || $(MKINSTALLDIRS) $(DESTDIR)$(logfiledir)
-@@ -208,14 +191,20 @@
+@@ -203,19 +175,17 @@
+ done
+
+ install-man:
+- @echo Installing man pages and online manual
++ @echo Installing man pages
+ @test -d $(DESTDIR)$(mandir) || $(MKINSTALLDIRS) $(DESTDIR)$(mandir)
@test -d $(DESTDIR)$(mandir)/man1 || $(MKINSTALLDIRS) $(DESTDIR)$(mandir)/man1
@test -d $(DESTDIR)$(mandir)/man8 || $(MKINSTALLDIRS) $(DESTDIR)$(mandir)/man8
- @test -d $(DESTDIR)$(manualdir) || $(MKINSTALLDIRS) $(DESTDIR)$(manualdir)
-- @cp -p $(top_srcdir)/docs/man/*.1 $(DESTDIR)$(mandir)/man1
-- @cp -p $(top_srcdir)/docs/man/*.8 $(DESTDIR)$(mandir)/man8
-+ for i in dbmmanage htdbm htdigest htpasswd httxt2dbm ; do \
-+ ${INSTALL_MAN} $(top_srcdir)/docs/man/$$i.1 $(DESTDIR)$(mandir)/man1; \
-+ done
-+ for i in ab apachectl apxs htcacheclean httpd logresolve rotatelogs suexec; do \
-+ ${INSTALL_MAN} $(top_srcdir)/docs/man/$$i.8 $(DESTDIR)$(mandir)/man8; \
-+ done
+- @test -d $(DESTDIR)$(manualdir) || $(MKINSTALLDIRS) $(DESTDIR)$(manualdir)
+ @cp -p $(top_srcdir)/docs/man/*.1 $(DESTDIR)$(mandir)/man1
+ @cp -p $(top_srcdir)/docs/man/*.8 $(DESTDIR)$(mandir)/man8
+- @if test "x$(RSYNC)" != "x" && test -x $(RSYNC) ; then \
+- $(RSYNC) --exclude .svn -rlpt --numeric-ids $(top_srcdir)/docs/manual/ $(DESTDIR)$(manualdir)/; \
+- else \
+- cd $(top_srcdir)/docs/manual && cp -rp * $(DESTDIR)$(manualdir); \
+- cd $(DESTDIR)$(manualdir) && find . -name ".svn" -type d -print | xargs rm -rf 2>/dev/null || true; \
+- fi
+.if !defined(NOPORTDOCS)
- @if test "x$(RSYNC)" != "x" && test -x $(RSYNC) ; then \
- $(RSYNC) --exclude .svn -rlpt --numeric-ids $(top_srcdir)/docs/manual/ $(DESTDIR)$(manualdir)/; \
- else \
- cd $(top_srcdir)/docs/manual && cp -rp * $(DESTDIR)$(manualdir); \
- cd $(DESTDIR)$(manualdir) && find . -name ".svn" -type d -print | xargs rm -rf 2>/dev/null || true; \
- fi
++ @echo Installing online manual
++ @test -d $(DESTDIR)$(manualdir) || $(MKINSTALLDIRS) $(DESTDIR)$(manualdir)
++ cd $(top_srcdir)/docs/manual && cp -rp * $(DESTDIR)$(manualdir);
+.endif
install-suexec:
diff --git a/www/apache22/files/patch-support__Makefile.in b/www/apache22/files/patch-support__Makefile.in
index c67427dc271b..867af7b73246 100644
--- a/www/apache22/files/patch-support__Makefile.in
+++ b/www/apache22/files/patch-support__Makefile.in
@@ -1,16 +1,14 @@
---- ./support/Makefile.in.orig 2005-07-06 19:15:34.000000000 -0400
-+++ ./support/Makefile.in 2010-05-06 19:37:54.258730387 -0400
-@@ -16,17 +16,16 @@
+--- ./support/Makefile.in.orig 2011-04-16 21:09:47.000000000 +0200
++++ ./support/Makefile.in 2013-09-25 21:02:44.000000000 +0200
+@@ -16,17 +16,14 @@
@test -d $(DESTDIR)$(sbindir) || $(MKINSTALLDIRS) $(DESTDIR)$(sbindir)
@test -d $(DESTDIR)$(libexecdir) || $(MKINSTALLDIRS) $(DESTDIR)$(libexecdir)
@cp -p $(top_builddir)/server/httpd.exp $(DESTDIR)$(libexecdir)
- @for i in apxs apachectl dbmmanage; do \
-+ @chown root:wheel $(DESTDIR)$(libexecdir)/httpd.exp
+ @for i in apxs apachectl dbmmanage split-logfile; do \
if test -f "$(builddir)/$$i"; then \
cp -p $$i $(DESTDIR)$(sbindir); \
chmod 755 $(DESTDIR)$(sbindir)/$$i; \
-+ chown root:wheel $(DESTDIR)$(sbindir)/$$i; \
fi ; \
done
@if test -f "$(builddir)/envvars-std"; then \
diff --git a/www/apache22/pkg-message b/www/apache22/pkg-message
index 510793ed1406..92f31cbc1d4c 100644
--- a/www/apache22/pkg-message
+++ b/www/apache22/pkg-message
@@ -2,5 +2,5 @@ To run apache www server from startup, add apache22_enable="YES"
in your /etc/rc.conf. Extra options can be found in startup script.
Your hostname must be resolvable using at least 1 mechanism in
-/etc/nsswitch typically DNS or /etc/hosts or apache might
+/etc/nsswitch.conf typically DNS or /etc/hosts or apache might
have issues starting depending on the modules you are using.
diff --git a/www/apache22/pkg-plist b/www/apache22/pkg-plist
index 98a0378a2b6f..feb52f2a9358 100644
--- a/www/apache22/pkg-plist
+++ b/www/apache22/pkg-plist
@@ -1,49 +1,4 @@
@comment $FreeBSD$
-@exec mkdir -p %D/%%ETCDIR%%/extra 2> /dev/null
-@exec mkdir -p %D/%%ETCDIR%%/Includes 2> /dev/null || true
-@exec mkdir -p %D/%%ETCDIR%%/envvars.d 2> /dev/null || true
-@unexec if cmp %D/%%ETCDIR%%/httpd.conf %D/%%EXAMPLESDIR%%/httpd.conf; then rm -f %D/%%ETCDIR%%/httpd.conf; fi
-%%EXAMPLESDIR%%/httpd.conf
-@exec [ -f %D/%%ETCDIR%%/httpd.conf ] || cp %D/%%EXAMPLESDIR%%/httpd.conf %D/%%ETCDIR%%/httpd.conf
-@unexec if cmp -s %D/%%ETCDIR%%/magic %D/%%EXAMPLESDIR%%/magic; then rm -f %D/%%ETCDIR%%/magic; fi
-%%EXAMPLESDIR%%/magic
-@exec [ -f %D/%%ETCDIR%%/magic ] || cp %D/%%EXAMPLESDIR%%/magic %D/%%ETCDIR%%/magic
-@unexec if cmp -s %D/%%ETCDIR%%/mime.types %D/%%EXAMPLESDIR%%/mime.types; then rm -f %D/%%ETCDIR%%/mime.types; fi
-%%EXAMPLESDIR%%/mime.types
-@exec [ -f %D/%%ETCDIR%%/mime.types ] || cp %D/%%EXAMPLESDIR%%/mime.types %D/%%ETCDIR%%/mime.types
-@unexec if cmp -s %D/%%ETCDIR%%/extra/httpd-autoindex.conf %D/%%EXAMPLESDIR%%/extra/httpd-autoindex.conf; then rm -f %D/%%ETCDIR%%/extra/httpd-autoindex.conf; fi
-%%EXAMPLESDIR%%/extra/httpd-autoindex.conf
-@exec [ -f %D/%%ETCDIR%%/extra/httpd-autoindex.conf ] || cp %D/%%EXAMPLESDIR%%/extra/httpd-autoindex.conf %D/%%ETCDIR%%/extra/httpd-autoindex.conf
-@unexec if cmp -s %D/%%ETCDIR%%/extra/httpd-dav.conf %D/%%EXAMPLESDIR%%/extra/httpd-dav.conf; then rm -f %D/%%ETCDIR%%/extra/httpd-dav.conf; fi
-%%EXAMPLESDIR%%/extra/httpd-dav.conf
-@exec [ -f %D/%%ETCDIR%%/extra/httpd-dav.conf ] || cp %D/%%EXAMPLESDIR%%/extra/httpd-dav.conf %D/%%ETCDIR%%/extra/httpd-dav.conf
-@unexec if cmp -s %D/%%ETCDIR%%/extra/httpd-default.conf %D/%%EXAMPLESDIR%%/extra/httpd-default.conf; then rm -f %D/%%ETCDIR%%/extra/httpd-default.conf; fi
-%%EXAMPLESDIR%%/extra/httpd-default.conf
-@exec [ -f %D/%%ETCDIR%%/extra/httpd-default.conf ] || cp %D/%%EXAMPLESDIR%%/extra/httpd-default.conf %D/%%ETCDIR%%/extra/httpd-default.conf
-@unexec if cmp -s %D/%%ETCDIR%%/extra/httpd-info.conf %D/%%EXAMPLESDIR%%/extra/httpd-info.conf; then rm -f %D/%%ETCDIR%%/extra/httpd-info.conf; fi
-%%EXAMPLESDIR%%/extra/httpd-info.conf
-@exec [ -f %D/%%ETCDIR%%/extra/httpd-info.conf ] || cp %D/%%EXAMPLESDIR%%/extra/httpd-info.conf %D/%%ETCDIR%%/extra/httpd-info.conf
-@unexec if cmp -s %D/%%ETCDIR%%/extra/httpd-languages.conf %D/%%EXAMPLESDIR%%/extra/httpd-languages.conf; then rm -f %D/%%ETCDIR%%/extra/httpd-languages.conf; fi
-%%EXAMPLESDIR%%/extra/httpd-languages.conf
-@exec [ -f %D/%%ETCDIR%%/extra/httpd-languages.conf ] || cp %D/%%EXAMPLESDIR%%/extra/httpd-languages.conf %D/%%ETCDIR%%/extra/httpd-languages.conf
-@unexec if cmp -s %D/%%ETCDIR%%/extra/httpd-manual.conf %D/%%EXAMPLESDIR%%/extra/httpd-manual.conf; then rm -f %D/%%ETCDIR%%/extra/httpd-manual.conf; fi
-%%EXAMPLESDIR%%/extra/httpd-manual.conf
-@exec [ -f %D/%%ETCDIR%%/extra/httpd-manual.conf ] || cp %D/%%EXAMPLESDIR%%/extra/httpd-manual.conf %D/%%ETCDIR%%/extra/httpd-manual.conf
-@unexec if cmp -s %D/%%ETCDIR%%/extra/httpd-mpm.conf %D/%%EXAMPLESDIR%%/extra/httpd-mpm.conf; then rm -f %D/%%ETCDIR%%/extra/httpd-mpm.conf; fi
-%%EXAMPLESDIR%%/extra/httpd-mpm.conf
-@exec [ -f %D/%%ETCDIR%%/extra/httpd-mpm.conf ] || cp %D/%%EXAMPLESDIR%%/extra/httpd-mpm.conf %D/%%ETCDIR%%/extra/httpd-mpm.conf
-@unexec if cmp -s %D/%%ETCDIR%%/extra/httpd-multilang-errordoc.conf %D/%%EXAMPLESDIR%%/extra/httpd-multilang-errordoc.conf; then rm -f %D/%%ETCDIR%%/extra/httpd-multilang-errordoc.conf; fi
-%%EXAMPLESDIR%%/extra/httpd-multilang-errordoc.conf
-@exec [ -f %D/%%ETCDIR%%/extra/httpd-multilang-errordoc.conf ] || cp %D/%%EXAMPLESDIR%%/extra/httpd-multilang-errordoc.conf %D/%%ETCDIR%%/extra/httpd-multilang-errordoc.conf
-@unexec if cmp -s %D/%%ETCDIR%%/extra/httpd-ssl.conf %D/%%EXAMPLESDIR%%/extra/httpd-ssl.conf; then rm -f %D/%%ETCDIR%%/extra/httpd-ssl.conf; fi
-%%EXAMPLESDIR%%/extra/httpd-ssl.conf
-@exec [ -f %D/%%ETCDIR%%/extra/httpd-ssl.conf ] || cp %D/%%EXAMPLESDIR%%/extra/httpd-ssl.conf %D/%%ETCDIR%%/extra/httpd-ssl.conf
-@unexec if cmp -s %D/%%ETCDIR%%/extra/httpd-userdir.conf %D/%%EXAMPLESDIR%%/extra/httpd-userdir.conf; then rm -f %D/%%ETCDIR%%/extra/httpd-userdir.conf; fi
-%%EXAMPLESDIR%%/extra/httpd-userdir.conf
-@exec [ -f %D/%%ETCDIR%%/extra/httpd-userdir.conf ] || cp %D/%%EXAMPLESDIR%%/extra/httpd-userdir.conf %D/%%ETCDIR%%/extra/httpd-userdir.conf
-@unexec if cmp -s %D/%%ETCDIR%%/extra/httpd-vhosts.conf %D/%%EXAMPLESDIR%%/extra/httpd-vhosts.conf; then rm -f %D/%%ETCDIR%%/extra/httpd-vhosts.conf; fi
-%%EXAMPLESDIR%%/extra/httpd-vhosts.conf
-@exec [ -f %D/%%ETCDIR%%/extra/httpd-vhosts.conf ] || cp %D/%%EXAMPLESDIR%%/extra/httpd-vhosts.conf %D/%%ETCDIR%%/extra/httpd-vhosts.conf
%%ETCDIR%%/Includes/no-accf.conf
include/apache22/ap_compat.h
include/apache22/ap_config.h
@@ -172,11 +127,24 @@ libexec/apache22/httpd.exp
%%MOD_USERTRACK%%libexec/apache22/mod_usertrack.so
%%MOD_VERSION%%libexec/apache22/mod_version.so
%%MOD_VHOST_ALIAS%%libexec/apache22/mod_vhost_alias.so
+man/man1/dbmmanage.1.gz
+man/man1/htdbm.1.gz
+man/man1/htdigest.1.gz
+man/man1/htpasswd.1.gz
+man/man1/httxt2dbm.1.gz
+man/man8/ab.8.gz
+man/man8/apachectl.8.gz
+man/man8/apxs.8.gz
+man/man8/htcacheclean.8.gz
+man/man8/httpd.8.gz
+man/man8/logresolve.8.gz
+man/man8/rotatelogs.8.gz
+man/man8/suexec.8.gz
sbin/ab
sbin/apachectl
sbin/apxs
-sbin/checkgid
%%FORENSIC%%sbin/check_forensic
+sbin/checkgid
sbin/dbmmanage
sbin/envvars
sbin/htcacheclean
@@ -198,12 +166,54 @@ sbin/split-logfile
%%DATADIR%%/build/program.mk
%%DATADIR%%/build/rules.mk
%%DATADIR%%/build/special.mk
-%%WWWDIR%%/cgi-bin/printenv
-%%WWWDIR%%/cgi-bin/test-cgi
+@unexec if cmp -s %D/%%ETCDIR%%/extra/httpd-autoindex.conf %D/%%EXAMPLESDIR%%/extra/httpd-autoindex.conf; then rm -f %D/%%ETCDIR%%/extra/httpd-autoindex.conf; fi
+%%EXAMPLESDIR%%/extra/httpd-autoindex.conf
+@exec [ -f %D/%%ETCDIR%%/extra/httpd-autoindex.conf ] || cp %D/%%EXAMPLESDIR%%/extra/httpd-autoindex.conf %D/%%ETCDIR%%/extra/httpd-autoindex.conf
+@unexec if cmp -s %D/%%ETCDIR%%/extra/httpd-dav.conf %D/%%EXAMPLESDIR%%/extra/httpd-dav.conf; then rm -f %D/%%ETCDIR%%/extra/httpd-dav.conf; fi
+%%EXAMPLESDIR%%/extra/httpd-dav.conf
+@exec [ -f %D/%%ETCDIR%%/extra/httpd-dav.conf ] || cp %D/%%EXAMPLESDIR%%/extra/httpd-dav.conf %D/%%ETCDIR%%/extra/httpd-dav.conf
+@unexec if cmp -s %D/%%ETCDIR%%/extra/httpd-default.conf %D/%%EXAMPLESDIR%%/extra/httpd-default.conf; then rm -f %D/%%ETCDIR%%/extra/httpd-default.conf; fi
+%%EXAMPLESDIR%%/extra/httpd-default.conf
+@exec [ -f %D/%%ETCDIR%%/extra/httpd-default.conf ] || cp %D/%%EXAMPLESDIR%%/extra/httpd-default.conf %D/%%ETCDIR%%/extra/httpd-default.conf
+@unexec if cmp -s %D/%%ETCDIR%%/extra/httpd-info.conf %D/%%EXAMPLESDIR%%/extra/httpd-info.conf; then rm -f %D/%%ETCDIR%%/extra/httpd-info.conf; fi
+%%EXAMPLESDIR%%/extra/httpd-info.conf
+@exec [ -f %D/%%ETCDIR%%/extra/httpd-info.conf ] || cp %D/%%EXAMPLESDIR%%/extra/httpd-info.conf %D/%%ETCDIR%%/extra/httpd-info.conf
+@unexec if cmp -s %D/%%ETCDIR%%/extra/httpd-languages.conf %D/%%EXAMPLESDIR%%/extra/httpd-languages.conf; then rm -f %D/%%ETCDIR%%/extra/httpd-languages.conf; fi
+%%EXAMPLESDIR%%/extra/httpd-languages.conf
+@exec [ -f %D/%%ETCDIR%%/extra/httpd-languages.conf ] || cp %D/%%EXAMPLESDIR%%/extra/httpd-languages.conf %D/%%ETCDIR%%/extra/httpd-languages.conf
+@unexec if cmp -s %D/%%ETCDIR%%/extra/httpd-manual.conf %D/%%EXAMPLESDIR%%/extra/httpd-manual.conf; then rm -f %D/%%ETCDIR%%/extra/httpd-manual.conf; fi
+%%EXAMPLESDIR%%/extra/httpd-manual.conf
+@exec [ -f %D/%%ETCDIR%%/extra/httpd-manual.conf ] || cp %D/%%EXAMPLESDIR%%/extra/httpd-manual.conf %D/%%ETCDIR%%/extra/httpd-manual.conf
+@unexec if cmp -s %D/%%ETCDIR%%/extra/httpd-mpm.conf %D/%%EXAMPLESDIR%%/extra/httpd-mpm.conf; then rm -f %D/%%ETCDIR%%/extra/httpd-mpm.conf; fi
+%%EXAMPLESDIR%%/extra/httpd-mpm.conf
+@exec [ -f %D/%%ETCDIR%%/extra/httpd-mpm.conf ] || cp %D/%%EXAMPLESDIR%%/extra/httpd-mpm.conf %D/%%ETCDIR%%/extra/httpd-mpm.conf
+@unexec if cmp -s %D/%%ETCDIR%%/extra/httpd-multilang-errordoc.conf %D/%%EXAMPLESDIR%%/extra/httpd-multilang-errordoc.conf; then rm -f %D/%%ETCDIR%%/extra/httpd-multilang-errordoc.conf; fi
+%%EXAMPLESDIR%%/extra/httpd-multilang-errordoc.conf
+@exec [ -f %D/%%ETCDIR%%/extra/httpd-multilang-errordoc.conf ] || cp %D/%%EXAMPLESDIR%%/extra/httpd-multilang-errordoc.conf %D/%%ETCDIR%%/extra/httpd-multilang-errordoc.conf
+@unexec if cmp -s %D/%%ETCDIR%%/extra/httpd-ssl.conf %D/%%EXAMPLESDIR%%/extra/httpd-ssl.conf; then rm -f %D/%%ETCDIR%%/extra/httpd-ssl.conf; fi
+%%EXAMPLESDIR%%/extra/httpd-ssl.conf
+@exec [ -f %D/%%ETCDIR%%/extra/httpd-ssl.conf ] || cp %D/%%EXAMPLESDIR%%/extra/httpd-ssl.conf %D/%%ETCDIR%%/extra/httpd-ssl.conf
+@unexec if cmp -s %D/%%ETCDIR%%/extra/httpd-userdir.conf %D/%%EXAMPLESDIR%%/extra/httpd-userdir.conf; then rm -f %D/%%ETCDIR%%/extra/httpd-userdir.conf; fi
+%%EXAMPLESDIR%%/extra/httpd-userdir.conf
+@exec [ -f %D/%%ETCDIR%%/extra/httpd-userdir.conf ] || cp %D/%%EXAMPLESDIR%%/extra/httpd-userdir.conf %D/%%ETCDIR%%/extra/httpd-userdir.conf
+@unexec if cmp -s %D/%%ETCDIR%%/extra/httpd-vhosts.conf %D/%%EXAMPLESDIR%%/extra/httpd-vhosts.conf; then rm -f %D/%%ETCDIR%%/extra/httpd-vhosts.conf; fi
+%%EXAMPLESDIR%%/extra/httpd-vhosts.conf
+@exec [ -f %D/%%ETCDIR%%/extra/httpd-vhosts.conf ] || cp %D/%%EXAMPLESDIR%%/extra/httpd-vhosts.conf %D/%%ETCDIR%%/extra/httpd-vhosts.conf
+@unexec if cmp %D/%%ETCDIR%%/httpd.conf %D/%%EXAMPLESDIR%%/httpd.conf; then rm -vf %D/%%ETCDIR%%/httpd.conf; fi
+%%EXAMPLESDIR%%/httpd.conf
+@exec [ -f %D/%%ETCDIR%%/httpd.conf ] || cp -v %D/%%EXAMPLESDIR%%/httpd.conf %D/%%ETCDIR%%/httpd.conf
@unexec if cmp -s %D/%%WWWDIR%%/data/index.html %D/%%EXAMPLESDIR%%/index.html; then rm -f %D/%%WWWDIR%%/data/index.html; fi
%%EXAMPLESDIR%%/index.html
@exec [ -d %D/%%WWWDIR%%/data ] || mkdir -p %D/%%WWWDIR%%/data
@exec [ -f %D/%%WWWDIR%%/data/index.html ] || cp %D/%%EXAMPLESDIR%%/index.html %D/%%WWWDIR%%/data/index.html
+@unexec if cmp -s %D/%%ETCDIR%%/magic %D/%%EXAMPLESDIR%%/magic; then rm -f %D/%%ETCDIR%%/magic; fi
+%%EXAMPLESDIR%%/magic
+@exec [ -f %D/%%ETCDIR%%/magic ] || cp %D/%%EXAMPLESDIR%%/magic %D/%%ETCDIR%%/magic
+@unexec if cmp -s %D/%%ETCDIR%%/mime.types %D/%%EXAMPLESDIR%%/mime.types; then rm -f %D/%%ETCDIR%%/mime.types; fi
+%%EXAMPLESDIR%%/mime.types
+@exec [ -f %D/%%ETCDIR%%/mime.types ] || cp %D/%%EXAMPLESDIR%%/mime.types %D/%%ETCDIR%%/mime.types
+%%WWWDIR%%/cgi-bin/printenv
+%%WWWDIR%%/cgi-bin/test-cgi
%%WWWDIR%%/error/HTTP_BAD_GATEWAY.html.var
%%WWWDIR%%/error/HTTP_BAD_REQUEST.html.var
%%WWWDIR%%/error/HTTP_FORBIDDEN.html.var
@@ -456,7 +466,6 @@ sbin/split-logfile
@dirrmtry %%WWWDIR%%
@dirrm %%EXAMPLESDIR%%/extra
@dirrm %%EXAMPLESDIR%%
-@dirrmtry %%DOCSDIR%%
@dirrm %%DATADIR%%/build
@dirrm %%DATADIR%%
@dirrmtry libexec/apache22