aboutsummaryrefslogtreecommitdiff
path: root/www/apache22
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2012-07-22 21:13:34 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2012-07-22 21:13:34 +0000
commit2a3105aff06d8d77e77f07c3fadca7ec4701031a (patch)
treedaa5674f64c64c27cb7cf505e6cc5d4520361f4d /www/apache22
parent29dc3566b88afd0aad0bbb4c04b5ac9a651bfb1a (diff)
downloadports-2a3105aff06d8d77e77f07c3fadca7ec4701031a.tar.gz
ports-2a3105aff06d8d77e77f07c3fadca7ec4701031a.zip
Notes
Diffstat (limited to 'www/apache22')
-rw-r--r--www/apache22/Makefile7
-rw-r--r--www/apache22/Makefile.modules75
-rw-r--r--www/apache22/Makefile.options162
3 files changed, 126 insertions, 118 deletions
diff --git a/www/apache22/Makefile b/www/apache22/Makefile
index 947dbec7a436..666aef50172a 100644
--- a/www/apache22/Makefile
+++ b/www/apache22/Makefile
@@ -51,13 +51,6 @@ APACHEDIR= ${MASTERDIR}
.endif
.if !defined(WITHOUT_APACHE_OPTIONS)
-OPTIONS= \
- THREADS "Enable threads support in APR" Off \
- MYSQL "Enable MySQL support for apr-dbd" Off \
- PGSQL "Enable PostgreSQL support for apr-dbd" Off \
- SQLITE "Enable SQLite support for apr-dbd" Off \
- IPV6 "Enable IPv6 support" On \
- BDB "Enable BerkeleyDB dbm" Off
.include "${APACHEDIR}/Makefile.options"
.endif
diff --git a/www/apache22/Makefile.modules b/www/apache22/Makefile.modules
index 57c6fffdea13..183cca09a320 100644
--- a/www/apache22/Makefile.modules
+++ b/www/apache22/Makefile.modules
@@ -44,45 +44,49 @@ ALL_MODULES_CATEGORIES= AUTH AUTHN AUTHZ CACHE DAV EXPERIMENTAL LDAP \
.endif
+# =============================================
.if defined(_PREMKINCLUDED)
-# MPM section:
-# << TO BE WRITTEN >>
-.if defined (SLAVE_PORT_MPM)
-PLIST_SUB+= PREFORK="@comment " WORKER="@comment " EVENT="@comment "
-PKGNAMESUFFIX= -${SLAVE_PORT_MPM}
+# MPM's: prefork worker event itk peruser
+
+.if ${WITH_MPM:L} == "prefork"
+PLIST_SUB+= WORKER="@comment " EVENT="@comment "
+
+.elif ${WITH_MPM:L} == "worker"
+PLIST_SUB+= WORKER="" EVENT="@comment "
+
+.elif ${WITH_MPM:L} == "event"
+PLIST_SUB+= WORKER="@comment " EVENT=""
+
+.elif ${WITH_MPM:L} == "peruser"
+PLIST_SUB+= WORKER="@comment " EVENT="@comment "
+
+.elif ${WITH_MPM:L} == "itk"
+PLIST_SUB+= WORKER="@comment " EVENT="@comment "
+EXTRA_PATCHES+= ${PATCHDIR}/mpm-itk-${MPM_ITK_VERSION}
+. if defined (WITH_ITK_PERDIR_REGEX)
+EXTRA_PATCHES+= ${PATCHDIR}/mpm-itk-perdir-regex
+. endif
+
.else
-. if ${WITH_MPM} != "prefork"
+IGNORE= "Unknown MPM: ${WITH_MPM}"
+.endif # MPM prefork
+
+.if ${WITH_MPM:L} != "prefork"
PKGNAMESUFFIX= -${WITH_MPM:L}
-. if ${WITH_MPM} != "itk"
+LATEST_LINK= apache22-${WITH_MPM:L}-mpm
+.endif
+
+.if ${WITH_MPM:L} == "worker" || ${WITH_MPM:L} == "event"
WITH_THREADS= yes
WITH_THREADS_MODULES= yes
WITHOUT_MODULES+= cgi
-. endif
-. if ${WITH_MPM:L} == "worker"
-PLIST_SUB+= PREFORK="@comment " WORKER="" EVENT="@comment "
-. elif ${WITH_MPM:L} == "event"
-PLIST_SUB+= PREFORK="@comment " WORKER="@comment " EVENT=""
-. elif ${WITH_MPM:L} == "itk"
-PLIST_SUB+= PREFORK="@comment " WORKER="@comment " EVENT="@comment "
-EXTRA_PATCHES+= ${PATCHDIR}/mpm-itk-${MPM_ITK_VERSION}
-. if defined (WITH_ITK_PERDIR_REGEX)
-EXTRA_PATCHES+= ${PATCHDIR}/mpm-itk-perdir-regex
-. endif
-. else
-IGNORE= "Unknown MPM: ${WITH_MPM}"
-. endif
-. else
-PLIST_SUB+= PREFORK="@comment " WORKER="@comment " THREADPOOL="@comment " EVENT="@comment "
-. endif
-.else
-PLIST_SUB+= PREFORK="@comment " WORKER="@comment " EVENT="@comment "
.endif
# xDBM section
#
.if !defined(WITH_DBM)
. if defined(WITH_BDB) || defined(WITH_BDB_BASE) || defined(WITH_BERKELEYDB)
-WITH_DBM=bdb
+WITH_DBM= bdb
PLIST_SUB+= BDB=""
. else
PLIST_SUB+= BDB="@comment "
@@ -91,9 +95,9 @@ PLIST_SUB+= BDB="@comment "
.if defined(WITH_BERKELEYDB) && !defined(WITH_BDB_VER)
. if ${WITH_BERKELEYDB} == "FreeBSD"
- WITH_BDB_BASE=YES
+WITH_BDB_BASE=YES
. else
- WITH_BDB_VER=${WITH_BERKELEYDB:S/db//}
+WITH_BDB_VER=${WITH_BERKELEYDB:S/db//}
. endif
.endif
@@ -111,7 +115,7 @@ CONFIGURE_ARGS+= --with-dbm=db185 \
USE_BDB= yes
CONFIGURE_ARGS+= --with-dbm=db${BDB_VER:S/40/4/} \
--with-berkeley-db=${LOCALBASE}
-. endif
+. endif
. else
IGNORE= "Unknown DBM"
. endif
@@ -139,9 +143,9 @@ CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE}
.if !defined(WITH_THREADS)
WITHOUT_MODULES+= mem_cache
-.if !defined(WITHOUT_APACHE_OPTIONS) && defined(WITH_MEM_CACHE)
+. if !defined(WITHOUT_APACHE_OPTIONS) && defined(WITH_MEM_CACHE)
IGNORE+= mod_mem_cache requires WITH_THREADS
-.endif
+. endif
.else
CFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= ${PTHREAD_LIBS}
@@ -149,8 +153,9 @@ LDFLAGS+= ${PTHREAD_LIBS}
.if !defined(WITH_MYSQL) && !defined(WITH_PGSQL) && !defined(WITH_SQLITE)
WITHOUT_MODULES+= authn_dbd dbd
-.if !defined(WITHOUT_APACHE_OPTIONS) && (defined(WITH_DBD) || defined(WITH_AUTHN_DBD))
+. if !defined(WITHOUT_APACHE_OPTIONS) && (defined(WITH_DBD) || defined(WITH_AUTHN_DBD))
IGNORE+= You need to enable at least one DBD backend
+. endif
.endif
-.endif
-.endif
+
+.endif # _PREMKINCLUDED
diff --git a/www/apache22/Makefile.options b/www/apache22/Makefile.options
index 28c60da470dd..a4a7b804e2e9 100644
--- a/www/apache22/Makefile.options
+++ b/www/apache22/Makefile.options
@@ -1,78 +1,88 @@
+# $FreeBSD$
+
+OPTIONS= \
+ THREADS "Threads support in APR" off \
+ MYSQL "MySQL support for apr-dbd" off \
+ PGSQL "PostgreSQL support for apr-dbd" off \
+ SQLITE "SQLite support for apr-dbd" off \
+ IPV6 "IPv6 support" on \
+ BDB "BerkeleyDB dbm" off
+
OPTIONS+= \
- AUTH_BASIC "Enable mod_auth_basic" ON \
- AUTH_DIGEST "Enable mod_auth_digest" ON \
- AUTHN_FILE "Enable mod_authn_file" ON \
- AUTHN_DBD "Enable mod_authn_dbd" OFF \
- AUTHN_DBM "Enable mod_authn_dbm" ON \
- AUTHN_ANON "Enable mod_authn_anon" ON \
- AUTHN_DEFAULT "Enable mod_authn_default" ON \
- AUTHN_ALIAS "Enable mod_authn_alias" ON \
- AUTHZ_HOST "Enable mod_authz_host" ON \
- AUTHZ_GROUPFILE "Enable mod_authz_groupfile" ON \
- AUTHZ_USER "Enable mod_authz_user" ON \
- AUTHZ_DBM "Enable mod_authz_dbm" ON \
- AUTHZ_OWNER "Enable mod_authz_owner" ON \
- AUTHZ_DEFAULT "Enable mod_authz_default" ON \
- CACHE "Enable mod_cache" ON \
- DISK_CACHE "Enable mod_disk_cache" ON \
- FILE_CACHE "Enable mod_file_cache" ON \
- MEM_CACHE "Enable mod_mem_cache" OFF \
- DAV "Enable mod_dav" ON \
- DAV_FS "Enable mod_dav_fs" ON \
- BUCKETEER "Enable mod_bucketeer" OFF \
- CASE_FILTER "Enable mod_case_filter" OFF \
- CASE_FILTER_IN "Enable mod_case_filter_in" OFF \
- EXT_FILTER "Enable mod_ext_filter" OFF \
- LOG_FORENSIC "Enable mod_log_forensic" OFF \
- OPTIONAL_HOOK_EXPORT "Enable mod_optional_hook_export" OFF \
- OPTIONAL_HOOK_IMPORT "Enable mod_optional_hook_import" OFF \
- OPTIONAL_FN_IMPORT "Enable mod_optional_fn_import" OFF \
- OPTIONAL_FN_EXPORT "Enable mod_optional_fn_export" OFF \
- LDAP "Enable mod_ldap" OFF \
- AUTHNZ_LDAP "Enable mod_authnz_ldap" OFF \
- ACTIONS "Enable mod_actions" ON \
- ALIAS "Enable mod_alias" ON \
- ASIS "Enable mod_asis" ON \
- AUTOINDEX "Enable mod_autoindex" ON \
- CERN_META "Enable mod_cern_meta" ON \
- CGI "Enable mod_cgi" ON \
- CHARSET_LITE "Enable mod_charset_lite" ON \
- DBD "Enable mod_dbd" OFF \
- DEFLATE "Enable mod_deflate" ON \
- DIR "Enable mod_dir" ON \
- DUMPIO "Enable mod_dumpio" ON \
- ENV "Enable mod_env" ON \
- EXPIRES "Enable mod_expires" ON \
- HEADERS "Enable mod_headers" ON \
- IMAGEMAP "Enable mod_imagemap" ON \
- INCLUDE "Enable mod_include" ON \
- INFO "Enable mod_info" ON \
- LOG_CONFIG "Enable mod_log_config" ON \
- LOGIO "Enable mod_logio" ON \
- MIME "Enable mod_mime" ON \
- MIME_MAGIC "Enable mod_mime_magic" ON \
- NEGOTIATION "Enable mod_negotiation" ON \
- REWRITE "Enable mod_rewrite" ON \
- SETENVIF "Enable mod_setenvif" ON \
- SPELING "Enable mod_speling" ON \
- STATUS "Enable mod_status" ON \
- UNIQUE_ID "Enable mod_unique_id" ON \
- USERDIR "Enable mod_userdir" ON \
- USERTRACK "Enable mod_usertrack" ON \
- VHOST_ALIAS "Enable mod_vhost_alias" ON \
- FILTER "Enable mod_filter" ON \
- SUBSTITUTE "Enable mod_substitute" OFF \
- VERSION "Enable mod_version" ON \
- PROXY "Enable mod_proxy" OFF \
- PROXY_CONNECT "Enable mod_proxy_connect" OFF \
- PROXY_FTP "Enable mod_proxy_ftp" OFF \
- PROXY_HTTP "Enable mod_proxy_http" OFF \
- PROXY_AJP "Enable mod_proxy_ajp" OFF \
- PROXY_BALANCER "Enable mod_proxy_balancer" OFF \
- PROXY_SCGI "Enable mod_proxy_scgi" OFF \
- SSL "Enable mod_ssl" ON \
- SUEXEC "Enable mod_suexec" OFF \
- SUEXEC_RSRCLIMIT "SuEXEC rlimits based on login class" OFF \
- REQTIMEOUT "Enable mod_reqtimeout" ON \
- CGID "Enable mod_cgid" OFF \
+ AUTH_BASIC "mod_auth_basic" on \
+ AUTH_DIGEST "mod_auth_digest" on \
+ AUTHN_FILE "mod_authn_file" on \
+ AUTHN_DBD "mod_authn_dbd" off \
+ AUTHN_DBM "mod_authn_dbm" on \
+ AUTHN_ANON "mod_authn_anon" on \
+ AUTHN_DEFAULT "mod_authn_default" on \
+ AUTHN_ALIAS "mod_authn_alias" on \
+ AUTHZ_HOST "mod_authz_host" on \
+ AUTHZ_GROUPFILE "mod_authz_groupfile" on \
+ AUTHZ_USER "mod_authz_user" on \
+ AUTHZ_DBM "mod_authz_dbm" on \
+ AUTHZ_OWNER "mod_authz_owner" on \
+ AUTHZ_DEFAULT "mod_authz_default" on \
+ CACHE "mod_cache" on \
+ DISK_CACHE "mod_disk_cache" on \
+ FILE_CACHE "mod_file_cache" on \
+ MEM_CACHE "mod_mem_cache" off \
+ DAV "mod_dav" on \
+ DAV_FS "mod_dav_fs" on \
+ BUCKETEER "mod_bucketeer" off \
+ CASE_FILTER "mod_case_filter" off \
+ CASE_FILTER_IN "mod_case_filter_in" off \
+ EXT_FILTER "mod_ext_filter" off \
+ LOG_FORENSIC "mod_log_forensic" off \
+ OPTIONAL_HOOK_EXPORT "mod_optional_hook_export" off \
+ OPTIONAL_HOOK_IMPORT "mod_optional_hook_import" off \
+ OPTIONAL_FN_IMPORT "mod_optional_fn_import" off \
+ OPTIONAL_FN_EXPORT "mod_optional_fn_export" off \
+ LDAP "mod_ldap" off \
+ AUTHNZ_LDAP "mod_authnz_ldap" off \
+ ACTIONS "mod_actions" on \
+ ALIAS "mod_alias" on \
+ ASIS "mod_asis" on \
+ AUTOINDEX "mod_autoindex" on \
+ CERN_META "mod_cern_meta" on \
+ CGI "mod_cgi" on \
+ CHARSET_LITE "mod_charset_lite" on \
+ DBD "mod_dbd" off \
+ DEFLATE "mod_deflate" on \
+ DIR "mod_dir" on \
+ DUMPIO "mod_dumpio" on \
+ ENV "mod_env" on \
+ EXPIRES "mod_expires" on \
+ HEADERS "mod_headers" on \
+ IMAGEMAP "mod_imagemap" on \
+ INCLUDE "mod_include" on \
+ INFO "mod_info" on \
+ LOG_CONFIG "mod_log_config" on \
+ LOGIO "mod_logio" on \
+ MIME "mod_mime" on \
+ MIME_MAGIC "mod_mime_magic" on \
+ NEGOTIATION "mod_negotiation" on \
+ REWRITE "mod_rewrite" on \
+ SETENVIF "mod_setenvif" on \
+ SPELING "mod_speling" on \
+ STATUS "mod_status" on \
+ UNIQUE_ID "mod_unique_id" on \
+ USERDIR "mod_userdir" on \
+ USERTRACK "mod_usertrack" on \
+ VHOST_ALIAS "mod_vhost_alias" on \
+ FILTER "mod_filter" on \
+ SUBSTITUTE "mod_substitute" off \
+ VERSION "mod_version" on \
+ PROXY "mod_proxy" off \
+ PROXY_CONNECT "mod_proxy_connect" off \
+ PROXY_FTP "mod_proxy_ftp" off \
+ PROXY_HTTP "mod_proxy_http" off \
+ PROXY_AJP "mod_proxy_ajp" off \
+ PROXY_BALANCER "mod_proxy_balancer" off \
+ PROXY_SCGI "mod_proxy_scgi" off \
+ SSL "mod_ssl" on \
+ SUEXEC "mod_suexec" off \
+ SUEXEC_RSRCLIMIT "SuEXEC rlimits based on login class" off \
+ REQTIMEOUT "mod_reqtimeout" on \
+ CGID "mod_cgid" off