aboutsummaryrefslogtreecommitdiff
path: root/www/apache2
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-07-11 09:43:17 +0000
committerClement Laforet <clement@FreeBSD.org>2004-07-11 09:43:17 +0000
commitc36c607e27a4de025f61c1b99b594cbae1cab37e (patch)
treecfb186612b74f1d5923f412d2ee2864dc69124a0 /www/apache2
parent5238e910855e517ff0fbb05181e2f5aca61d84bc (diff)
Notes
Diffstat (limited to 'www/apache2')
-rw-r--r--www/apache2/Makefile.modules.3rd13
1 files changed, 12 insertions, 1 deletions
diff --git a/www/apache2/Makefile.modules.3rd b/www/apache2/Makefile.modules.3rd
index 9e3a5700c2e5..b73c7018e9b3 100644
--- a/www/apache2/Makefile.modules.3rd
+++ b/www/apache2/Makefile.modules.3rd
@@ -79,17 +79,28 @@ AP_EXTRAS+= -I ${AP_INC}
AP_EXTRAS+= -L ${AP_LIB}
.endif
+.if exists(${APXS})
+APXS_PREFIX!= ${APXS} -q prefix
+.else
+APXS_PREFIX= ${APXS:S/\/sbin\/apxs//}
+.endif
+
.if defined(AP_FAST_BUILD)
ap-gen-plist:
.if defined(AP_GENPLIST)
+. if !exists(${PLIST})
@${ECHO} "===> Generating apache plist"
- @${ECHO} "@unexec %D/sbin/apxs -e -A -n %%AP_NAME%% %D/%%APACHEMODDIR%%/%%AP_MODULE%%" > ${PLIST}
+ @${ECHO} "@cwd ${APXS_PREFIX}" > ${PLIST}
+ @${ECHO} "@unexec %D/sbin/apxs -e -A -n %%AP_NAME%% %D/%%APACHEMODDIR%%/%%AP_MODULE%%" >> ${PLIST}
@${ECHO} "%%APACHEMODDIR%%/%%AP_MODULE%%" >> ${PLIST}
@${ECHO} "@exec %D/sbin/apxs -e -A -n %%AP_NAME%% %D/%F" >> ${PLIST}
+ @${ECHO} "@cwd ${PREFIX}" >> ${PLIST}
+. endif
.else
@${DO_NADA}
.endif
+
do-build: ap-gen-plist
@cd ${WRKSRC} && ${APXS} -c ${AP_EXTRAS} -o ${MODULENAME}.${AP_BUILDEXT} ${SRC_FILE}