aboutsummaryrefslogtreecommitdiff
path: root/www/apache2
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-08-18 19:40:07 +0000
committerClement Laforet <clement@FreeBSD.org>2004-08-18 19:40:07 +0000
commita4dd64d0322ac83e1d8fe63be5a73bf164c15821 (patch)
tree09b46670c28dfb154937e7d9a678b27270895c49 /www/apache2
parent581544e9fcfdec2dd0eecfbbe7906dc1e71bb790 (diff)
downloadports-a4dd64d0322ac83e1d8fe63be5a73bf164c15821.tar.gz
ports-a4dd64d0322ac83e1d8fe63be5a73bf164c15821.zip
Notes
Diffstat (limited to 'www/apache2')
-rw-r--r--www/apache2/Makefile2
-rw-r--r--www/apache2/files/patch-secfix-modules:ssl:ssl_engine_io.c34
2 files changed, 35 insertions, 1 deletions
diff --git a/www/apache2/Makefile b/www/apache2/Makefile
index 156efc00b756..e8f6087e5573 100644
--- a/www/apache2/Makefile
+++ b/www/apache2/Makefile
@@ -9,7 +9,7 @@
PORTNAME= apache
PORTVERSION= 2.0.50
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD} \
http://sheepkiller.nerim.net/ports/${PORTNAME}/:powerlogo
diff --git a/www/apache2/files/patch-secfix-modules:ssl:ssl_engine_io.c b/www/apache2/files/patch-secfix-modules:ssl:ssl_engine_io.c
new file mode 100644
index 000000000000..f29cfd5aed4d
--- /dev/null
+++ b/www/apache2/files/patch-secfix-modules:ssl:ssl_engine_io.c
@@ -0,0 +1,34 @@
+===================================================================
+RCS file: /home/cvspublic/httpd-2.0/modules/ssl/ssl_engine_io.c,v
+retrieving revision 1.124
+retrieving revision 1.126
+diff -u -r1.124 -r1.126
+--- modules/ssl/ssl_engine_io.c 2004/07/13 18:11:22 1.124
++++ modules/ssl/ssl_engine_io.c 2004/08/17 16:31:23 1.126
+@@ -564,8 +564,12 @@
+ *len = bytes;
+ if (inctx->mode == AP_MODE_SPECULATIVE) {
+ /* We want to rollback this read. */
+- inctx->cbuf.value -= bytes;
+- inctx->cbuf.length += bytes;
++ if (inctx->cbuf.length > 0) {
++ inctx->cbuf.value -= bytes;
++ inctx->cbuf.length += bytes;
++ } else {
++ char_buffer_write(&inctx->cbuf, buf, (int)bytes);
++ }
+ return APR_SUCCESS;
+ }
+ /* This could probably be *len == wanted, but be safe from stray
+@@ -589,6 +593,10 @@
+ while (1) {
+
+ if (!inctx->filter_ctx->pssl) {
++ /* Ensure a non-zero error code is returned */
++ if (inctx->rc == APR_SUCCESS) {
++ inctx->rc = APR_EGENERAL;
++ }
+ break;
+ }
+
+