aboutsummaryrefslogtreecommitdiff
path: root/www/asp2php/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-06-29 20:05:45 +0000
committerWill Andrews <will@FreeBSD.org>2000-06-29 20:05:45 +0000
commitc4fdd6d90cee0c58cdfc6eb2e7f707f01721e324 (patch)
tree614196cccc4b3043a914cd489d163eabf9754f5c /www/asp2php/Makefile
parentf707fab18cccf71cf5a64db27dd8aa28d15b2a60 (diff)
downloadports-c4fdd6d90cee0c58cdfc6eb2e7f707f01721e324.tar.gz
ports-c4fdd6d90cee0c58cdfc6eb2e7f707f01721e324.zip
Notes
Diffstat (limited to 'www/asp2php/Makefile')
-rw-r--r--www/asp2php/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/www/asp2php/Makefile b/www/asp2php/Makefile
new file mode 100644
index 000000000000..f3c4aa7e5ed9
--- /dev/null
+++ b/www/asp2php/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: asp2php
+# Date created: Thu 29 Jun 2000
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= asp2php
+PORTVERSION= 0.75.1
+CATEGORIES= www
+MASTER_SITES= http://home.i1.net/~naken/asp2php/
+DISTNAME= ${PORTNAME}${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+.if defined(WANT_GTK)
+LIB_DEPENDS+= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
+.endif
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+WRKSRC= ${WRKDIR}/${PORTNAME}
+MAKE_ENV+= GTK_CONFIG="${GTK_CONFIG}"
+ALL_TARGET= all
+INSTALL_TARGET= install
+
+.if defined(WANT_GTK)
+ALL_TARGET+= gtkasp2php
+INSTALL_TARGET+=install-gtk
+PLIST_SUB+= WANT_GTK=""
+.else
+PLIST_SUB+= WANT_GTK="@comment "
+.endif
+
+pre-fetch:
+ @${ECHO}
+.if !defined(WANT_GTK)
+ @${ECHO} "If you want the GTK frontend, define the WANT_GTK variable"
+ @${ECHO} "in your make args. For example:"
+ @${ECHO}
+ @${ECHO} " make -DWANT_GTK"
+.else
+ @${ECHO} "Building with GTK frontend."
+.endif
+ @${ECHO}
+
+.include <bsd.port.mk>