aboutsummaryrefslogtreecommitdiff
path: root/www/asp2php
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-03-25 12:31:06 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-03-25 12:31:06 +0000
commita2bf583ff7859123c7d3d2e95fe0de32578cbc57 (patch)
tree9cc751022f7c614249f27abd0f5be9333d1828c7 /www/asp2php
parent12a5805c9cce75ee874b93dda6c61b51add59dfe (diff)
downloadports-a2bf583ff7859123c7d3d2e95fe0de32578cbc57.tar.gz
ports-a2bf583ff7859123c7d3d2e95fe0de32578cbc57.zip
Notes
Diffstat (limited to 'www/asp2php')
-rw-r--r--www/asp2php/Makefile21
-rw-r--r--www/asp2php/distinfo2
-rw-r--r--www/asp2php/files/patch-aa68
3 files changed, 13 insertions, 78 deletions
diff --git a/www/asp2php/Makefile b/www/asp2php/Makefile
index 6d6f94476801..b8fb4866451a 100644
--- a/www/asp2php/Makefile
+++ b/www/asp2php/Makefile
@@ -6,33 +6,36 @@
#
PORTNAME= asp2php
-PORTVERSION= 0.75.12
+PORTVERSION= 0.76.3
CATEGORIES= www
MASTER_SITES= http://home.i1.net/~naken/asp2php/
-DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-WRKSRC= ${WRKDIR}/${DISTNAME}
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
WANT_GTK= yes
+MAKE_ENV= FLAGS="${CFLAGS}"
.include <bsd.port.pre.mk>
.if defined(HAVE_GTK)
USE_GTK= yes
-ALL_TARGET= all gtkasp2php
-INSTALL_TARGET= install install-gtk
+ALL_TARGET= default gui
PLIST_SUB+= WANT_GTK=""
.else
+ALL_TARGET= default
PLIST_SUB+= WANT_GTK="@comment "
.endif
post-patch:
- @${PERL} -pi -e 's,strcasestr,strcasestr_,' ${WRKSRC}/functions.h \
- ${WRKSRC}/general.c
+ @${PERL} -pi -e 's|^CC=|#CC=|g ; \
+ s|`gtk-config|`\$$\{GTK_CONFIG\}|g' ${WRKSRC}/Makefile
-pre-build:
- ${PERL} -pi -e "s:gtk-config:${GTK_CONFIG}:g" ${WRKSRC}/Makefile
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/asp2php ${PREFIX}/bin
+.if defined(HAVE_GTK)
+ ${INSTALL_PROGRAM} ${WRKSRC}/gtkasp2php ${PREFIX}/bin
+.endif
.include <bsd.port.post.mk>
diff --git a/www/asp2php/distinfo b/www/asp2php/distinfo
index 269bb5f764eb..d8099d66bd01 100644
--- a/www/asp2php/distinfo
+++ b/www/asp2php/distinfo
@@ -1 +1 @@
-MD5 (asp2php-0.75.12.tar.gz) = dd2375e825ec98062ea257c8fde576c0
+MD5 (asp2php-0.76.3.tar.gz) = 3d3da1daf4536a998d044cfa73f227c6
diff --git a/www/asp2php/files/patch-aa b/www/asp2php/files/patch-aa
deleted file mode 100644
index c76a60e01965..000000000000
--- a/www/asp2php/files/patch-aa
+++ /dev/null
@@ -1,68 +0,0 @@
---- Makefile.orig Tue Feb 27 17:50:21 2001
-+++ Makefile Sun Mar 11 04:43:49 2001
-@@ -1,51 +1,21 @@
-+PROG= asp2php
-+NOMAN= true
-+CC?= cc
-+CFLAGS?=-O -pipe
-+CFLAGS+=-Wall
-+SRCS= conditionals.c database.c evalelement.c expression.c general.c \
-+ gettoken.c html.c loops.c mysql.c odbc.c oracle.c postgres.c \
-+ response.c request.c session.c sybase.c asp2php.c
-
--CC=gcc
--
--default:
-- $(CC) -c conditionals.c -Wall
-- $(CC) -c database.c -Wall
-- $(CC) -c evalelement.c -Wall
-- $(CC) -c expression.c -Wall
-- $(CC) -c general.c -Wall
-- $(CC) -c gettoken.c -Wall
-- $(CC) -c html.c -Wall
-- $(CC) -c loops.c -Wall
-- $(CC) -c mysql.c -Wall
-- $(CC) -c odbc.c -Wall
-- $(CC) -c oracle.c -Wall
-- $(CC) -c postgres.c -Wall
-- $(CC) -c response.c -Wall
-- $(CC) -c request.c -Wall
-- $(CC) -c session.c -Wall
-- $(CC) -c sybase.c -Wall
-- $(CC) -o asp2php asp2php.c conditionals.o database.o \
-- evalelement.o expression.o general.o gettoken.o \
-- html.o loops.o mysql.o \
-- odbc.o oracle.o postgres.o response.o \
-- request.o session.o sybase.o -Wall
-- @echo ""
--# @echo "Done! You may type: make gtkasp2php for the optional GUI now"
--
--clean:
-- @if [ -e database.o ]; then rm *.o; fi;
-- @if [ -e asp2php ]; then rm asp2php; fi;
-- @if [ -e gtkasp2php ]; then rm gtkasp2php; fi;
-- @if [ -e unipiss ]; then rm unipiss; fi;
-- @echo "Clean!"
-+CLEANFILES+= gtkasp2php.o gtkasp2php
-
- gtkasp2php: gtkasp2php.c
-- $(CC) -o gtkasp2php gtkasp2php.c `gtk-config --cflags` `gtk-config --libs`
--
--unipiss:
-- $(CC) -o unipiss unipiss.c html.o general.o -Wall
-+ $(CC) -o gtkasp2php gtkasp2php.c `$(GTK_CONFIG) --cflags` `$(GTK_CONFIG) --libs`
-
- install:
-- @if [ -e asp2php ]; then cp asp2php /usr/local/bin; fi;
-- @if [ -e unipiss ]; then cp unipiss /usr/local/bin; fi;
-- @if [ -e gtkasp2php ]; then cp gtkasp2php /usr/local/bin; fi;
-- @echo "Compiled programs have been installed in /usr/local/bin"
-- @echo ""
--
--all: default
-+ $(BSD_INSTALL_PROGRAM) asp2php $(PREFIX)/bin
-
-+install-gtk:
-+ $(BSD_INSTALL_PROGRAM) gtkasp2php $(PREFIX)/bin
-
-+.include <bsd.prog.mk>