aboutsummaryrefslogtreecommitdiff
path: root/www/auth_ldap
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2006-03-19 16:26:25 +0000
committerClement Laforet <clement@FreeBSD.org>2006-03-19 16:26:25 +0000
commit1963cea5fb20aed0600bd9f2a7979374d2fbfbc2 (patch)
treeedb7f6ffb834ef172c8bdf370f9d43642f220c55 /www/auth_ldap
parentb1494a2ec3485a1740c56c1bcf5df58c06159a14 (diff)
downloadports-1963cea5fb20aed0600bd9f2a7979374d2fbfbc2.tar.gz
ports-1963cea5fb20aed0600bd9f2a7979374d2fbfbc2.zip
Notes
Diffstat (limited to 'www/auth_ldap')
-rw-r--r--www/auth_ldap/Makefile11
-rw-r--r--www/auth_ldap/distinfo6
-rw-r--r--www/auth_ldap/files/patch-auth_ldap.c14
3 files changed, 20 insertions, 11 deletions
diff --git a/www/auth_ldap/Makefile b/www/auth_ldap/Makefile
index ef5169084390..e04c4ddee6d1 100644
--- a/www/auth_ldap/Makefile
+++ b/www/auth_ldap/Makefile
@@ -6,20 +6,15 @@
#
PORTNAME= auth_ldap
-PORTVERSION= 1.6.0
-PORTREVISION= 4
+PORTVERSION= 1.6.1
CATEGORIES= www
MASTER_SITES= http://www.rudedog.org/auth_ldap/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= apache@FreeBSD.org
COMMENT= Apache module to authenticate against an LDAP directory
-FORBIDDEN= Contains multiple format strings vulnerabilities
-DEPRECATED= ${FORBIDDEN}
-EXPIRATION_DATE=2006-04-08
-
USE_OPENLDAP= yes
-USE_APACHE= yes
+USE_APACHE= 13
GNU_CONFIGURE= yes
CONFIGURE_ENV+= LIBS="-llber"
CONFIGURE_ARGS= --with-sdk-headers=${LOCALBASE}/include \
diff --git a/www/auth_ldap/distinfo b/www/auth_ldap/distinfo
index 0c46bc3ce1f2..d3853dcd10f4 100644
--- a/www/auth_ldap/distinfo
+++ b/www/auth_ldap/distinfo
@@ -1,3 +1,3 @@
-MD5 (auth_ldap-1.6.0.tar.gz) = ff7de9027fe8852facd27be93462c5cc
-SHA256 (auth_ldap-1.6.0.tar.gz) = bc909954b1edfc9638d9c09a6aa0dbcb72d2bd97f182acaeab03f4df26aedae8
-SIZE (auth_ldap-1.6.0.tar.gz) = 79296
+MD5 (auth_ldap-1.6.1.tar.gz) = a78d8c5fc77086562ca056c226c97992
+SHA256 (auth_ldap-1.6.1.tar.gz) = bc68e105fe452cad3fac717ba04abd7c1450dadeea5b653ad2655dfdbc82849b
+SIZE (auth_ldap-1.6.1.tar.gz) = 82718
diff --git a/www/auth_ldap/files/patch-auth_ldap.c b/www/auth_ldap/files/patch-auth_ldap.c
new file mode 100644
index 000000000000..86593a955355
--- /dev/null
+++ b/www/auth_ldap/files/patch-auth_ldap.c
@@ -0,0 +1,14 @@
+--- auth_ldap.c.orig Mon Jan 9 20:08:56 2006
++++ auth_ldap.c Tue Mar 14 19:12:02 2006
+@@ -168,11 +168,7 @@
+ ap_log_rerror(APLOG_MARK, APLOG_DEBUG|APLOG_NOERRNO, r,
+ "{%d} LDAP OP: init", (int)getpid());
+
+-#if defined(WITH_OPENLDAP) && LDAP_VENDOR_VERSION >= 20000
+- if ((ldap_initialize(&(sec->ldc->ldap), (sec->url))) != LDAP_SUCCESS) {
+-#else
+ if ((sec->ldc->ldap = ldap_init(sec->host, sec->port)) == NULL) {
+-#endif
+ extern int errno;
+ auth_ldap_log_reason(r, "Could not connect to LDAP server: %s", strerror(errno));
+ return 0;