aboutsummaryrefslogtreecommitdiff
path: root/www/bacon/Makefile
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>1999-09-09 14:55:08 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>1999-09-09 14:55:08 +0000
commite8c2e7809184165f10be443f9612cec01e07b6a3 (patch)
treef51c173f779d21ca48f7d1d9dbbbccbaf4e80a35 /www/bacon/Makefile
parentef97c18cd32d42b147a8a1be04973211cabbb582 (diff)
downloadports-e8c2e7809184165f10be443f9612cec01e07b6a3.tar.gz
ports-e8c2e7809184165f10be443f9612cec01e07b6a3.zip
Notes
Diffstat (limited to 'www/bacon/Makefile')
-rw-r--r--www/bacon/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/www/bacon/Makefile b/www/bacon/Makefile
new file mode 100644
index 000000000000..3285562968d1
--- /dev/null
+++ b/www/bacon/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: bacon
+# Version required: 1.1b
+# Date created: 9 September 1999
+# Whom: Justin Robinson <jmrobins@samurai.ruin.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= bacon-1.071999
+CATEGORIES= www
+MASTER_SITES= ftp://samurai.ruin.org/pub/All/
+
+MAINTAINER= jmrobins@samurai.ruin.org
+
+USE_PERL5= YES
+
+DIST= bacon.pl
+
+do-build:
+ @cd ${WRKSRC}; ${MV} ${DIST} ${DIST}.orig; \
+ ${SED} -e 's;^#! */usr/local/bin/perl *;#!${PERL5};' \
+ ${DIST}.orig > ${DIST}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/bacon.pl ${PREFIX}/www/cgi-bin/bacon.pl
+
+post-install:
+ ${MKDIR} ${PREFIX}/share/doc/bacon/
+ ${INSTALL_DATA} ${WRKSRC}/INSTALL ${PREFIX}/share/doc/bacon/INSTALL
+ @${CAT} ${PKGDIR}/MESSAGE
+
+.include <bsd.port.mk>