aboutsummaryrefslogtreecommitdiff
path: root/www/bins
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-03-19 12:33:01 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-03-19 12:33:01 +0000
commit3f837e4172d20d91763e6d77aed1dc64653875fd (patch)
tree39c37938b5d0aa65a6d26a5b05e68c94dc61c305 /www/bins
parent6031f8342c6edb9dd0afa438e1fa682f4fa13391 (diff)
downloadports-3f837e4172d20d91763e6d77aed1dc64653875fd.tar.gz
ports-3f837e4172d20d91763e6d77aed1dc64653875fd.zip
Notes
Diffstat (limited to 'www/bins')
-rw-r--r--www/bins/Makefile34
-rw-r--r--www/bins/distinfo6
-rw-r--r--www/bins/files/extra-patch-install.sh26
-rw-r--r--www/bins/pkg-descr2
-rw-r--r--www/bins/pkg-plist543
5 files changed, 454 insertions, 157 deletions
diff --git a/www/bins/Makefile b/www/bins/Makefile
index 79c18fd848b1..ee1c99059273 100644
--- a/www/bins/Makefile
+++ b/www/bins/Makefile
@@ -6,18 +6,19 @@
#
PORTNAME= bins
-PORTVERSION= 1.1.20
-PORTREVISION= 2
+PORTVERSION= 1.1.29
CATEGORIES= www
-MASTER_SITES= http://jsautret.free.fr/BINS/
+MASTER_SITES= http://download.gna.org/bins/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= araujo@bsdmail.org
COMMENT= Tool to generate HTML photo albums with XML support
RUN_DEPENDS= \
${PBASE}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
${PBASE}/${PERL_ARCH}/Image/Magick.pm:${PORTSDIR}/graphics/ImageMagick \
${PBASE}/${PERL_ARCH}/Text/Iconv.pm:${PORTSDIR}/converters/p5-Text-Iconv \
+ ${PBASE}/${PERL_ARCH}/Text/Unaccent.pm:${PORTSDIR}/textproc/p5-Text-Unaccent \
+ ${PBASE}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate \
${PBASE}/Getopt/Long.pm:${PORTSDIR}/devel/p5-Getopt-Long \
${PBASE}/HTML/Clean.pm:${PORTSDIR}/www/p5-HTML-Clean \
${PBASE}/HTML/Template.pm:${PORTSDIR}/www/p5-HTML-Template \
@@ -29,7 +30,6 @@ RUN_DEPENDS= \
${PBASE}/XML/Handler/YAWriter.pm:${PORTSDIR}/textproc/p5-XML-Handler-YAWriter \
${PBASE}/XML/Parser/PerlSAX.pm:${PORTSDIR}/textproc/p5-libxml
-IS_INTERACTIVE= yes
USE_BZIP2= yes
USE_PERL5_RUN= yes
NO_BUILD= yes
@@ -38,13 +38,13 @@ NO_BUILD= yes
PBASE= ${SITE_PERL}
# additional scripts
-BINS_SCRIPTS= bins_txt2xml
+BINS_SCRIPTS= tools/bins_txt2xml
# doc file extension
DOC_EXTS= html sgml xml
MAN1= bins-edit-gui.1 bins.1 bins_edit.1
-post-patch:
+post-patch::
# perl PREFIX safeness
@${FIND} ${WRKSRC} -type f | \
${XARGS} -n 10 -x ${REINPLACE_CMD} -E \
@@ -52,7 +52,7 @@ post-patch:
# prefix safeness
@${REINPLACE_CMD} -E \
-e 's|(bins_edit=)".+"(.*)$$|\1"${PREFIX}/bin/bins_edit"\2|' \
- ${WRKSRC}/bins_txt2xml
+ ${WRKSRC}/tools/bins_txt2xml
do-install:
@${SETENV} PREFIX=${PREFIX} RC=${PREFIX}/share/bins ${WRKSRC}/install.sh
@@ -71,29 +71,25 @@ post-install:
.include <bsd.port.pre.mk>
##
-## this port requires PERL 5.6.x or later
+## default for either pointyhat or unattended builds
##
-.if !(exists(${LOCALBASE}/bin/perl5.6.0) || exists(${LOCALBASE}/bin/perl5.6.1))
-IGNORE= requires perl 5.6.x or later. Install lang/perl5 then try again
-.endif
+.if defined(PACKAGE_BUILDING) || defined(BATCH)
+WITH_I18N= yes
-##
-## default for either bento or unattended builds
-##
-.ifdef(BATCH)
-WITH_I18N=yes
+post-patch::
+ @${REINPLACE_CMD} -e 's,read dummy,,' ${WRKSRC}/install.sh
.endif
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-install.sh
# localization support
-.ifdef(WITH_I18N)
+.if defined(WITH_I18N)
RUN_DEPENDS+= \
${PBASE}/${PERL_ARCH}/Locale/gettext.pm:${PORTSDIR}/devel/p5-Locale-gettext
.endif
pre-everything::
-.ifndef(WITH_I18N)
+.if !defined(WITH_I18N)
@${ECHO_MSG} '===>'
@${ECHO_MSG} '===> Define WITH_I18N to enable localization support.'
@${ECHO_MSG} '===> Support for languages other than english.'
diff --git a/www/bins/distinfo b/www/bins/distinfo
index 2b6d2df7a7ea..7a6fe0dc337b 100644
--- a/www/bins/distinfo
+++ b/www/bins/distinfo
@@ -1,3 +1,3 @@
-MD5 (bins-1.1.20.tar.bz2) = c0933c1952077fd2c6f8c7062c63b4b4
-SHA256 (bins-1.1.20.tar.bz2) = 25b01b9ba2a3b7077bd399268be118faaac2c069b545f1b2fb6b84cac7507a40
-SIZE (bins-1.1.20.tar.bz2) = 147155
+MD5 (bins-1.1.29.tar.bz2) = 3398d0ea3a97e49f5aaabb3b79da334a
+SHA256 (bins-1.1.29.tar.bz2) = efdf1932ec260d80f1fda6054baf9b3c9a47ce263a1db9e10ad5d4df5871d626
+SIZE (bins-1.1.29.tar.bz2) = 259270
diff --git a/www/bins/files/extra-patch-install.sh b/www/bins/files/extra-patch-install.sh
index 110917bffb6a..08fe44255c90 100644
--- a/www/bins/files/extra-patch-install.sh
+++ b/www/bins/files/extra-patch-install.sh
@@ -1,23 +1,21 @@
---- install.sh.orig Sat Nov 23 09:40:01 2002
-+++ install.sh Sat Nov 23 09:40:58 2002
-@@ -60,12 +60,11 @@
- mkdir -p $BIN 2>/dev/null || true
+--- install.sh.orig Thu Aug 25 06:07:05 2005
++++ install.sh Mon Mar 19 02:47:24 2007
+@@ -67,11 +67,10 @@
if [ -w $BIN ] ; then
echo "Installing program files in $BIN"
+ # bins_cleanupgallery anti_bins
- cp bins bins_edit bins-edit-gui $BIN
+ cp bins bins_edit $BIN
chmod a+rx $BIN/bins
chmod a+rx $BIN/bins_edit
+ chmod a+rx $BIN/bins_cleanupgallery
- chmod a+rx $BIN/bins-edit-gui
- perl -pi -e "s{/usr/local/share}{$SHARE}g" \
-- $BIN/bins $BIN/bins_edit $BIN/bins-edit-gui
-+ $BIN/bins $BIN/bins_edit
- return 0
- else
- echo "Cannot write to $BIN directory."
-@@ -124,13 +123,6 @@
- fi
+ chmod a+rx $BIN/anti_bins
+ # perl -pi -e "s{/usr/local/share}{$SHARE}g" \
+ # $BIN/bins $BIN/bins_edit $BIN/bins-edit-gui
+@@ -169,13 +168,6 @@
fi
+ set -o errexit
-# additionnal files
-mkdir -p $GLADE 2>/dev/null || true
@@ -29,7 +27,7 @@
# man pages
mkdir -p $MAN 2>/dev/null || true
if [ -w $MAN ] ; then
-@@ -146,9 +138,6 @@
+@@ -203,9 +195,6 @@
do
mkdir -p $LOCALE/$L/LC_MESSAGES 2>/dev/null || true
cp intl/$L.mo $LOCALE/$L/LC_MESSAGES/bins.mo
@@ -38,4 +36,4 @@
- fi
done
else
- cat <<!EoF
+ cat <<!EoF
diff --git a/www/bins/pkg-descr b/www/bins/pkg-descr
index b6bd5fbefaed..9d6959ff8149 100644
--- a/www/bins/pkg-descr
+++ b/www/bins/pkg-descr
@@ -14,4 +14,4 @@ Some of the functionalities of BINS are:
produced by digital cameras) to fill automatically some fields
(date and time for example).
-WWW: http://bins.sautret.org/
+WWW: https://gna.org/projects/bins/
diff --git a/www/bins/pkg-plist b/www/bins/pkg-plist
index 159c9fbf6a66..ee718a6b596f 100644
--- a/www/bins/pkg-plist
+++ b/www/bins/pkg-plist
@@ -1,131 +1,434 @@
bin/bins
bin/bins_edit
bin/bins_txt2xml
-share/bins/binsrc
-share/bins/templates.default/details.html
-share/bins/templates.default/footer.html
-share/bins/templates.default/image.html
-share/bins/templates.default/imagelist.html
-share/bins/templates.default/navbar.html
-share/bins/templates.default/path.html
-share/bins/templates.default/subalbum.html
-share/bins/templates.default/thumbnail.html
-share/bins/templates.default/tree.html
-share/bins/templates.joi/details.html
-share/bins/templates.joi/footer.html
-share/bins/templates.joi/image.html
-share/bins/templates.joi/imagelist.html
-share/bins/templates.joi/navbar.html
-share/bins/templates.joi/path.html
-share/bins/templates.joi/static/actthumb.png
-share/bins/templates.joi/static/actthumb.png.bak
-share/bins/templates.joi/static/albumtree.png
-share/bins/templates.joi/static/albumtree.png.bak
-share/bins/templates.joi/static/back.png
-share/bins/templates.joi/static/back.png.bak
-share/bins/templates.joi/static/contact.png
-share/bins/templates.joi/static/contact.png.bak
-share/bins/templates.joi/static/exit.png
-share/bins/templates.joi/static/exit.png.bak
-share/bins/templates.joi/static/home.png
-share/bins/templates.joi/static/home.png.bak
-share/bins/templates.joi/static/imagelist.png
-share/bins/templates.joi/static/imagelist.png.bak
-share/bins/templates.joi/static/info.png
-share/bins/templates.joi/static/info.png.bak
-share/bins/templates.joi/static/large.png
-share/bins/templates.joi/static/large.png.bak
-share/bins/templates.joi/static/largeActive.png
-share/bins/templates.joi/static/largeActive.png.bak
-share/bins/templates.joi/static/medium.png
-share/bins/templates.joi/static/medium.png.bak
-share/bins/templates.joi/static/mediumActive.png
-share/bins/templates.joi/static/mediumActive.png.bak
-share/bins/templates.joi/static/meshman.css
-share/bins/templates.joi/static/meshman.css.bak
-share/bins/templates.joi/static/next.png
-share/bins/templates.joi/static/next.png.bak
-share/bins/templates.joi/static/nextInactive.png
-share/bins/templates.joi/static/nextInactive.png.bak
-share/bins/templates.joi/static/prev.png
-share/bins/templates.joi/static/prev.png.bak
-share/bins/templates.joi/static/prevInactive.png
-share/bins/templates.joi/static/prevInactive.png.bak
-share/bins/templates.joi/static/preview.js
-share/bins/templates.joi/static/preview.js.bak
-share/bins/templates.joi/static/small.png
-share/bins/templates.joi/static/small.png.bak
-share/bins/templates.joi/static/smallActive.png
-share/bins/templates.joi/static/smallActive.png.bak
-share/bins/templates.joi/static/subalbum.png
-share/bins/templates.joi/static/subalbum.png.bak
-share/bins/templates.joi/static/thumbnails.png
-share/bins/templates.joi/static/thumbnails.png.bak
-share/bins/templates.joi/static/up.png
-share/bins/templates.joi/static/up.png.bak
-share/bins/templates.joi/subalbum.html
-share/bins/templates.joi/subjectpath.html
-share/bins/templates.joi/thumbnail.html
-share/bins/templates.joi/thumbnav.html
-share/bins/templates.joi/thumbnavrow.html
-share/bins/templates.joi/tree.html
-%%PORTDOCS%%share/doc/bins/album.xml
-%%PORTDOCS%%share/doc/bins/autolayout.xml
-%%PORTDOCS%%share/doc/bins/bins-edit-gui.sgml
-%%PORTDOCS%%share/doc/bins/bins-edit-gui_man.html
-%%PORTDOCS%%share/doc/bins/bins.sgml
-%%PORTDOCS%%share/doc/bins/bins_edit.sgml
-%%PORTDOCS%%share/doc/bins/bins_edit_man.html
-%%PORTDOCS%%share/doc/bins/bins_man.html
-%%PORTDOCS%%share/doc/bins/download.html
-%%PORTDOCS%%share/doc/bins/download.xml
-%%PORTDOCS%%share/doc/bins/examples.html
-%%PORTDOCS%%share/doc/bins/examples.xml
-%%PORTDOCS%%share/doc/bins/index.html
-%%PORTDOCS%%share/doc/bins/index.xml
-%%PORTDOCS%%share/doc/bins/index_fr.html
-%%PORTDOCS%%share/doc/bins/install.html
-%%PORTDOCS%%share/doc/bins/install.xml
-%%PORTDOCS%%share/doc/bins/install_automatic.html
-%%PORTDOCS%%share/doc/bins/install_automatic.xml
-%%PORTDOCS%%share/doc/bins/install_manual.html
-%%PORTDOCS%%share/doc/bins/install_manual.xml
-%%PORTDOCS%%share/doc/bins/install_prerequisites.html
-%%PORTDOCS%%share/doc/bins/install_prerequisites.xml
-%%PORTDOCS%%share/doc/bins/intro.html
-%%PORTDOCS%%share/doc/bins/intro.xml
-%%PORTDOCS%%share/doc/bins/layout.xml
-%%PORTDOCS%%share/doc/bins/license.html
-%%PORTDOCS%%share/doc/bins/license.xml
-%%PORTDOCS%%share/doc/bins/usage.html
-%%PORTDOCS%%share/doc/bins/usage.xml
-%%PORTDOCS%%share/doc/bins/usage_album.html
-%%PORTDOCS%%share/doc/bins/usage_album.xml
-%%PORTDOCS%%share/doc/bins/usage_custom.html
-%%PORTDOCS%%share/doc/bins/usage_custom.xml
-%%PORTDOCS%%share/doc/bins/usage_desc.html
-%%PORTDOCS%%share/doc/bins/usage_desc.xml
-%%PORTDOCS%%share/doc/bins/usage_desc_cli.html
-%%PORTDOCS%%share/doc/bins/usage_desc_cli.xml
-%%PORTDOCS%%share/doc/bins/usage_desc_gui.html
-%%PORTDOCS%%share/doc/bins/usage_desc_gui.xml
-%%PORTDOCS%%share/doc/bins/usage_desc_gui_gqview.html
-%%PORTDOCS%%share/doc/bins/usage_desc_gui_gqview.xml
-%%PORTDOCS%%share/doc/bins/usage_desc_gui_nautilus.html
-%%PORTDOCS%%share/doc/bins/usage_desc_gui_nautilus.xml
-%%PORTDOCS%%share/doc/bins/usage_desc_xml.html
-%%PORTDOCS%%share/doc/bins/usage_desc_xml.xml
+%%DATADIR%%/binsrc
+%%DATADIR%%/templates.joi/details.html
+%%DATADIR%%/templates.joi/footer.html
+%%DATADIR%%/templates.joi/image.html
+%%DATADIR%%/templates.joi/imagelist.html
+%%DATADIR%%/templates.joi/imagenavbar.html
+%%DATADIR%%/templates.joi/navbar.html
+%%DATADIR%%/templates.joi/path.html
+%%DATADIR%%/templates.joi/static
+%%DATADIR%%/templates.joi/static/actthumb.png
+%%DATADIR%%/templates.joi/static/actthumb.png.bak
+%%DATADIR%%/templates.joi/static/albumtree.png
+%%DATADIR%%/templates.joi/static/albumtree.png.bak
+%%DATADIR%%/templates.joi/static/back.png
+%%DATADIR%%/templates.joi/static/back.png.bak
+%%DATADIR%%/templates.joi/static/contact.png
+%%DATADIR%%/templates.joi/static/contact.png.bak
+%%DATADIR%%/templates.joi/static/exit.png
+%%DATADIR%%/templates.joi/static/exit.png.bak
+%%DATADIR%%/templates.joi/static/home.png
+%%DATADIR%%/templates.joi/static/home.png.bak
+%%DATADIR%%/templates.joi/static/huge.png
+%%DATADIR%%/templates.joi/static/huge.png.bak
+%%DATADIR%%/templates.joi/static/hugeActive.png
+%%DATADIR%%/templates.joi/static/hugeActive.png.bak
+%%DATADIR%%/templates.joi/static/imagelist.png
+%%DATADIR%%/templates.joi/static/imagelist.png.bak
+%%DATADIR%%/templates.joi/static/info.png
+%%DATADIR%%/templates.joi/static/info.png.bak
+%%DATADIR%%/templates.joi/static/joi.css
+%%DATADIR%%/templates.joi/static/joi.css.bak
+%%DATADIR%%/templates.joi/static/joi.js
+%%DATADIR%%/templates.joi/static/joi.js.bak
+%%DATADIR%%/templates.joi/static/large.png
+%%DATADIR%%/templates.joi/static/large.png.bak
+%%DATADIR%%/templates.joi/static/largeActive.png
+%%DATADIR%%/templates.joi/static/largeActive.png.bak
+%%DATADIR%%/templates.joi/static/media.png
+%%DATADIR%%/templates.joi/static/media.png.bak
+%%DATADIR%%/templates.joi/static/medium.png
+%%DATADIR%%/templates.joi/static/medium.png.bak
+%%DATADIR%%/templates.joi/static/mediumActive.png
+%%DATADIR%%/templates.joi/static/mediumActive.png.bak
+%%DATADIR%%/templates.joi/static/meshman.css
+%%DATADIR%%/templates.joi/static/meshman.css.bak
+%%DATADIR%%/templates.joi/static/next.png
+%%DATADIR%%/templates.joi/static/next.png.bak
+%%DATADIR%%/templates.joi/static/nextInactive.png
+%%DATADIR%%/templates.joi/static/nextInactive.png.bak
+%%DATADIR%%/templates.joi/static/pink.css
+%%DATADIR%%/templates.joi/static/pink.css.bak
+%%DATADIR%%/templates.joi/static/pink2.css
+%%DATADIR%%/templates.joi/static/pink2.css.bak
+%%DATADIR%%/templates.joi/static/prev.png
+%%DATADIR%%/templates.joi/static/prev.png.bak
+%%DATADIR%%/templates.joi/static/prevInactive.png
+%%DATADIR%%/templates.joi/static/prevInactive.png.bak
+%%DATADIR%%/templates.joi/static/preview.js
+%%DATADIR%%/templates.joi/static/preview.js.bak
+%%DATADIR%%/templates.joi/static/related.png
+%%DATADIR%%/templates.joi/static/related.png.bak
+%%DATADIR%%/templates.joi/static/small.png
+%%DATADIR%%/templates.joi/static/small.png.bak
+%%DATADIR%%/templates.joi/static/smallActive.png
+%%DATADIR%%/templates.joi/static/smallActive.png.bak
+%%DATADIR%%/templates.joi/static/subalbum.png
+%%DATADIR%%/templates.joi/static/subalbum.png.bak
+%%DATADIR%%/templates.joi/static/thumbnails.png
+%%DATADIR%%/templates.joi/static/thumbnails.png.bak
+%%DATADIR%%/templates.joi/static/up.png
+%%DATADIR%%/templates.joi/static/up.png.bak
+%%DATADIR%%/templates.joi/subalbum.html
+%%DATADIR%%/templates.joi/subjectpath.html
+%%DATADIR%%/templates.joi/thumbnail.html
+%%DATADIR%%/templates.joi/thumbnav.html
+%%DATADIR%%/templates.joi/thumbnavrow.html
+%%DATADIR%%/templates.joi/tree.html
+%%DATADIR%%/templates.joi/xlink.html
+%%DATADIR%%/templates.marc/details.html
+%%DATADIR%%/templates.marc/footer.html
+%%DATADIR%%/templates.marc/image.html
+%%DATADIR%%/templates.marc/imagelist.html
+%%DATADIR%%/templates.marc/imagenavbar.html
+%%DATADIR%%/templates.marc/navbar.html
+%%DATADIR%%/templates.marc/path.html
+%%DATADIR%%/templates.marc/static/actthumb.png
+%%DATADIR%%/templates.marc/static/actthumb.png.bak
+%%DATADIR%%/templates.marc/static/albumtree.png
+%%DATADIR%%/templates.marc/static/albumtree.png.bak
+%%DATADIR%%/templates.marc/static/back.png
+%%DATADIR%%/templates.marc/static/back.png.bak
+%%DATADIR%%/templates.marc/static/contact.png
+%%DATADIR%%/templates.marc/static/contact.png.bak
+%%DATADIR%%/templates.marc/static/exit.png
+%%DATADIR%%/templates.marc/static/exit.png.bak
+%%DATADIR%%/templates.marc/static/home.png
+%%DATADIR%%/templates.marc/static/home.png.bak
+%%DATADIR%%/templates.marc/static/imagelist.png
+%%DATADIR%%/templates.marc/static/imagelist.png.bak
+%%DATADIR%%/templates.marc/static/info.png
+%%DATADIR%%/templates.marc/static/info.png.bak
+%%DATADIR%%/templates.marc/static/joi.css
+%%DATADIR%%/templates.marc/static/joi.css.bak
+%%DATADIR%%/templates.marc/static/joi.js
+%%DATADIR%%/templates.marc/static/joi.js.bak
+%%DATADIR%%/templates.marc/static/large.png
+%%DATADIR%%/templates.marc/static/large.png.bak
+%%DATADIR%%/templates.marc/static/largeActive.png
+%%DATADIR%%/templates.marc/static/largeActive.png.bak
+%%DATADIR%%/templates.marc/static/media.png
+%%DATADIR%%/templates.marc/static/media.png.bak
+%%DATADIR%%/templates.marc/static/medium.png
+%%DATADIR%%/templates.marc/static/medium.png.bak
+%%DATADIR%%/templates.marc/static/mediumActive.png
+%%DATADIR%%/templates.marc/static/mediumActive.png.bak
+%%DATADIR%%/templates.marc/static/meshman.css
+%%DATADIR%%/templates.marc/static/meshman.css.bak
+%%DATADIR%%/templates.marc/static/next.png
+%%DATADIR%%/templates.marc/static/next.png.bak
+%%DATADIR%%/templates.marc/static/nextInactive.png
+%%DATADIR%%/templates.marc/static/nextInactive.png.bak
+%%DATADIR%%/templates.marc/static/prev.png
+%%DATADIR%%/templates.marc/static/prev.png.bak
+%%DATADIR%%/templates.marc/static/prevInactive.png
+%%DATADIR%%/templates.marc/static/prevInactive.png.bak
+%%DATADIR%%/templates.marc/static/preview.js
+%%DATADIR%%/templates.marc/static/preview.js.bak
+%%DATADIR%%/templates.marc/static/related.png
+%%DATADIR%%/templates.marc/static/related.png.bak
+%%DATADIR%%/templates.marc/static/small.png
+%%DATADIR%%/templates.marc/static/small.png.bak
+%%DATADIR%%/templates.marc/static/smallActive.png
+%%DATADIR%%/templates.marc/static/smallActive.png.bak
+%%DATADIR%%/templates.marc/static/subalbum.png
+%%DATADIR%%/templates.marc/static/subalbum.png.bak
+%%DATADIR%%/templates.marc/static/thumbnails.png
+%%DATADIR%%/templates.marc/static/thumbnails.png.bak
+%%DATADIR%%/templates.marc/static/up.png
+%%DATADIR%%/templates.marc/static/up.png.bak
+%%DATADIR%%/templates.marc/subalbum.html
+%%DATADIR%%/templates.marc/subjectpath.html
+%%DATADIR%%/templates.marc/thumbnail.html
+%%DATADIR%%/templates.marc/thumbnav.html
+%%DATADIR%%/templates.marc/thumbnavrow.html
+%%DATADIR%%/templates.marc/tree.html
+%%DATADIR%%/templates.marc/xlink.html
+%%DATADIR%%/templates.martin/details.html
+%%DATADIR%%/templates.martin/footer.html
+%%DATADIR%%/templates.martin/image.html
+%%DATADIR%%/templates.martin/imagelist.html
+%%DATADIR%%/templates.martin/imagenavbar.html
+%%DATADIR%%/templates.martin/navbar.html
+%%DATADIR%%/templates.martin/path.html
+%%DATADIR%%/templates.martin/static
+%%DATADIR%%/templates.martin/static/actthumb.png
+%%DATADIR%%/templates.martin/static/actthumb.png.bak
+%%DATADIR%%/templates.martin/static/albumtree.png
+%%DATADIR%%/templates.martin/static/albumtree.png.bak
+%%DATADIR%%/templates.martin/static/back.png
+%%DATADIR%%/templates.martin/static/back.png.bak
+%%DATADIR%%/templates.martin/static/contact.png
+%%DATADIR%%/templates.martin/static/contact.png.bak
+%%DATADIR%%/templates.martin/static/exit.png
+%%DATADIR%%/templates.martin/static/exit.png.bak
+%%DATADIR%%/templates.martin/static/first.png
+%%DATADIR%%/templates.martin/static/first.png.bak
+%%DATADIR%%/templates.martin/static/firstInactive.png
+%%DATADIR%%/templates.martin/static/firstInactive.png.bak
+%%DATADIR%%/templates.martin/static/home.png
+%%DATADIR%%/templates.martin/static/home.png.bak
+%%DATADIR%%/templates.martin/static/huge.png
+%%DATADIR%%/templates.martin/static/huge.png.bak
+%%DATADIR%%/templates.martin/static/hugeActive.png
+%%DATADIR%%/templates.martin/static/hugeActive.png.bak
+%%DATADIR%%/templates.martin/static/imagelist.png
+%%DATADIR%%/templates.martin/static/imagelist.png.bak
+%%DATADIR%%/templates.martin/static/info.png
+%%DATADIR%%/templates.martin/static/info.png.bak
+%%DATADIR%%/templates.martin/static/large.png
+%%DATADIR%%/templates.martin/static/large.png.bak
+%%DATADIR%%/templates.martin/static/largeActive.png
+%%DATADIR%%/templates.martin/static/largeActive.png.bak
+%%DATADIR%%/templates.martin/static/last.png
+%%DATADIR%%/templates.martin/static/last.png.bak
+%%DATADIR%%/templates.martin/static/lastInactive.png
+%%DATADIR%%/templates.martin/static/lastInactive.png.bak
+%%DATADIR%%/templates.martin/static/martin.css
+%%DATADIR%%/templates.martin/static/martin.css.bak
+%%DATADIR%%/templates.martin/static/media.png
+%%DATADIR%%/templates.martin/static/media.png.bak
+%%DATADIR%%/templates.martin/static/medium.png
+%%DATADIR%%/templates.martin/static/medium.png.bak
+%%DATADIR%%/templates.martin/static/mediumActive.png
+%%DATADIR%%/templates.martin/static/mediumActive.png.bak
+%%DATADIR%%/templates.martin/static/metal_slide_light.gif
+%%DATADIR%%/templates.martin/static/metal_slide_light.gif.bak
+%%DATADIR%%/templates.martin/static/metal_slide_light.png
+%%DATADIR%%/templates.martin/static/metal_slide_light.png.bak
+%%DATADIR%%/templates.martin/static/next.png
+%%DATADIR%%/templates.martin/static/next.png.bak
+%%DATADIR%%/templates.martin/static/nextInactive.png
+%%DATADIR%%/templates.martin/static/nextInactive.png.bak
+%%DATADIR%%/templates.martin/static/prev.png
+%%DATADIR%%/templates.martin/static/prev.png.bak
+%%DATADIR%%/templates.martin/static/prevInactive.png
+%%DATADIR%%/templates.martin/static/prevInactive.png.bak
+%%DATADIR%%/templates.martin/static/related.png
+%%DATADIR%%/templates.martin/static/related.png.bak
+%%DATADIR%%/templates.martin/static/slides.css
+%%DATADIR%%/templates.martin/static/slides.css.bak
+%%DATADIR%%/templates.martin/static/small.png
+%%DATADIR%%/templates.martin/static/small.png.bak
+%%DATADIR%%/templates.martin/static/smallActive.png
+%%DATADIR%%/templates.martin/static/smallActive.png.bak
+%%DATADIR%%/templates.martin/static/subalbum.png
+%%DATADIR%%/templates.martin/static/subalbum.png.bak
+%%DATADIR%%/templates.martin/static/thumbnails.png
+%%DATADIR%%/templates.martin/static/thumbnails.png.bak
+%%DATADIR%%/templates.martin/static/up.png
+%%DATADIR%%/templates.martin/static/up.png.bak
+%%DATADIR%%/templates.martin/subalbum.html
+%%DATADIR%%/templates.martin/subjectpath.html
+%%DATADIR%%/templates.martin/thumbnail.html
+%%DATADIR%%/templates.martin/thumbnavrow.html
+%%DATADIR%%/templates.martin/tree.html
+%%DATADIR%%/templates.martin/xlink.html
+%%DATADIR%%/templates.mwolson/bodyheader.html
+%%DATADIR%%/templates.mwolson/details.html
+%%DATADIR%%/templates.mwolson/footer.html
+%%DATADIR%%/templates.mwolson/header.html
+%%DATADIR%%/templates.mwolson/image.html
+%%DATADIR%%/templates.mwolson/imagelist.html
+%%DATADIR%%/templates.mwolson/navbar.html
+%%DATADIR%%/templates.mwolson/path.html
+%%DATADIR%%/templates.mwolson/static
+%%DATADIR%%/templates.mwolson/static/style.css
+%%DATADIR%%/templates.mwolson/static/style.css.bak
+%%DATADIR%%/templates.mwolson/subalbum.html
+%%DATADIR%%/templates.mwolson/thheader.html
+%%DATADIR%%/templates.mwolson/thumbnail.html
+%%DATADIR%%/templates.mwolson/tree.html
+%%DATADIR%%/templates.petrus/details.html
+%%DATADIR%%/templates.petrus/footer.html
+%%DATADIR%%/templates.petrus/image.html
+%%DATADIR%%/templates.petrus/imagelist.html
+%%DATADIR%%/templates.petrus/imagenavbar.html
+%%DATADIR%%/templates.petrus/moreinfos.html
+%%DATADIR%%/templates.petrus/navbar.html
+%%DATADIR%%/templates.petrus/path.html
+%%DATADIR%%/templates.petrus/static
+%%DATADIR%%/templates.petrus/static/actthumb.png
+%%DATADIR%%/templates.petrus/static/actthumb.png.bak
+%%DATADIR%%/templates.petrus/static/albumtree.png
+%%DATADIR%%/templates.petrus/static/albumtree.png.bak
+%%DATADIR%%/templates.petrus/static/back.png
+%%DATADIR%%/templates.petrus/static/back.png.bak
+%%DATADIR%%/templates.petrus/static/contact.png
+%%DATADIR%%/templates.petrus/static/contact.png.bak
+%%DATADIR%%/templates.petrus/static/exit.png
+%%DATADIR%%/templates.petrus/static/exit.png.bak
+%%DATADIR%%/templates.petrus/static/home.png
+%%DATADIR%%/templates.petrus/static/home.png.bak
+%%DATADIR%%/templates.petrus/static/huge.png
+%%DATADIR%%/templates.petrus/static/huge.png.bak
+%%DATADIR%%/templates.petrus/static/hugeActive.png
+%%DATADIR%%/templates.petrus/static/hugeActive.png.bak
+%%DATADIR%%/templates.petrus/static/imagelist.png
+%%DATADIR%%/templates.petrus/static/imagelist.png.bak
+%%DATADIR%%/templates.petrus/static/info.png
+%%DATADIR%%/templates.petrus/static/info.png.bak
+%%DATADIR%%/templates.petrus/static/joi.css
+%%DATADIR%%/templates.petrus/static/joi.css.bak
+%%DATADIR%%/templates.petrus/static/joi.js
+%%DATADIR%%/templates.petrus/static/joi.js.bak
+%%DATADIR%%/templates.petrus/static/large.png
+%%DATADIR%%/templates.petrus/static/large.png.bak
+%%DATADIR%%/templates.petrus/static/largeActive.png
+%%DATADIR%%/templates.petrus/static/largeActive.png.bak
+%%DATADIR%%/templates.petrus/static/media.png
+%%DATADIR%%/templates.petrus/static/media.png.bak
+%%DATADIR%%/templates.petrus/static/medium.png
+%%DATADIR%%/templates.petrus/static/medium.png.bak
+%%DATADIR%%/templates.petrus/static/mediumActive.png
+%%DATADIR%%/templates.petrus/static/mediumActive.png.bak
+%%DATADIR%%/templates.petrus/static/next.png
+%%DATADIR%%/templates.petrus/static/next.png.bak
+%%DATADIR%%/templates.petrus/static/nextInactive.png
+%%DATADIR%%/templates.petrus/static/nextInactive.png.bak
+%%DATADIR%%/templates.petrus/static/petrus.css
+%%DATADIR%%/templates.petrus/static/petrus.css.bak
+%%DATADIR%%/templates.petrus/static/prev.png
+%%DATADIR%%/templates.petrus/static/prev.png.bak
+%%DATADIR%%/templates.petrus/static/prevInactive.png
+%%DATADIR%%/templates.petrus/static/prevInactive.png.bak
+%%DATADIR%%/templates.petrus/static/preview.js
+%%DATADIR%%/templates.petrus/static/preview.js.bak
+%%DATADIR%%/templates.petrus/static/related.png
+%%DATADIR%%/templates.petrus/static/related.png.bak
+%%DATADIR%%/templates.petrus/static/small.png
+%%DATADIR%%/templates.petrus/static/small.png.bak
+%%DATADIR%%/templates.petrus/static/smallActive.png
+%%DATADIR%%/templates.petrus/static/smallActive.png.bak
+%%DATADIR%%/templates.petrus/static/subalbum.png
+%%DATADIR%%/templates.petrus/static/subalbum.png.bak
+%%DATADIR%%/templates.petrus/static/thumbnails.png
+%%DATADIR%%/templates.petrus/static/thumbnails.png.bak
+%%DATADIR%%/templates.petrus/static/up.png
+%%DATADIR%%/templates.petrus/static/up.png.bak
+%%DATADIR%%/templates.petrus/subalbum.html
+%%DATADIR%%/templates.petrus/subjectpath.html
+%%DATADIR%%/templates.petrus/thumbnail.html
+%%DATADIR%%/templates.petrus/thumbnav.html
+%%DATADIR%%/templates.petrus/thumbnavrow.html
+%%DATADIR%%/templates.petrus/title1.html
+%%DATADIR%%/templates.petrus/tree.html
+%%DATADIR%%/templates.petrus/xlink.html
+%%DATADIR%%/templates.satyap/bodyheader.html
+%%DATADIR%%/templates.satyap/details.html
+%%DATADIR%%/templates.satyap/footer.html
+%%DATADIR%%/templates.satyap/header.html
+%%DATADIR%%/templates.satyap/image.html
+%%DATADIR%%/templates.satyap/imagelist.html
+%%DATADIR%%/templates.satyap/navbar.html
+%%DATADIR%%/templates.satyap/path.html
+%%DATADIR%%/templates.satyap/static
+%%DATADIR%%/templates.satyap/static/style.css
+%%DATADIR%%/templates.satyap/static/style.css.bak
+%%DATADIR%%/templates.satyap/subalbum.html
+%%DATADIR%%/templates.satyap/thheader.html
+%%DATADIR%%/templates.satyap/thumbnail.html
+%%DATADIR%%/templates.satyap/tree.html
+%%DATADIR%%/templates.swigs/details.html
+%%DATADIR%%/templates.swigs/footer.html
+%%DATADIR%%/templates.swigs/image.html
+%%DATADIR%%/templates.swigs/imagelist.html
+%%DATADIR%%/templates.swigs/navbar.html
+%%DATADIR%%/templates.swigs/path.html
+%%DATADIR%%/templates.swigs/search.html
+%%DATADIR%%/templates.swigs/search.js
+%%DATADIR%%/templates.swigs/search_data.js
+%%DATADIR%%/templates.swigs/search_result.html
+%%DATADIR%%/templates.swigs/subalbum.html
+%%DATADIR%%/templates.swigs/thumbnail.html
+%%DATADIR%%/templates.swigs/tree.html
+%%PORTDOCS%%%%DOCSDIR%%/album.xml
+%%PORTDOCS%%%%DOCSDIR%%/autolayout.xml
+%%PORTDOCS%%%%DOCSDIR%%/bins-edit-gui.sgml
+%%PORTDOCS%%%%DOCSDIR%%/bins-edit-gui_man.html
+%%PORTDOCS%%%%DOCSDIR%%/bins.sgml
+%%PORTDOCS%%%%DOCSDIR%%/bins_edit.sgml
+%%PORTDOCS%%%%DOCSDIR%%/bins_edit_man.html
+%%PORTDOCS%%%%DOCSDIR%%/bins_man.html
+%%PORTDOCS%%%%DOCSDIR%%/contact.html
+%%PORTDOCS%%%%DOCSDIR%%/contact.xml
+%%PORTDOCS%%%%DOCSDIR%%/download.html
+%%PORTDOCS%%%%DOCSDIR%%/download.xml
+%%PORTDOCS%%%%DOCSDIR%%/examples.html
+%%PORTDOCS%%%%DOCSDIR%%/examples.xml
+%%PORTDOCS%%%%DOCSDIR%%/faq.html
+%%PORTDOCS%%%%DOCSDIR%%/faq.xml
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/index.xml
+%%PORTDOCS%%%%DOCSDIR%%/index_fr.html
+%%PORTDOCS%%%%DOCSDIR%%/install.html
+%%PORTDOCS%%%%DOCSDIR%%/install.xml
+%%PORTDOCS%%%%DOCSDIR%%/install_automatic.html
+%%PORTDOCS%%%%DOCSDIR%%/install_automatic.xml
+%%PORTDOCS%%%%DOCSDIR%%/install_manual.html
+%%PORTDOCS%%%%DOCSDIR%%/install_manual.xml
+%%PORTDOCS%%%%DOCSDIR%%/install_prerequisites.html
+%%PORTDOCS%%%%DOCSDIR%%/install_prerequisites.xml
+%%PORTDOCS%%%%DOCSDIR%%/intro.html
+%%PORTDOCS%%%%DOCSDIR%%/intro.xml
+%%PORTDOCS%%%%DOCSDIR%%/layout.xml
+%%PORTDOCS%%%%DOCSDIR%%/license.html
+%%PORTDOCS%%%%DOCSDIR%%/license.xml
+%%PORTDOCS%%%%DOCSDIR%%/usage.html
+%%PORTDOCS%%%%DOCSDIR%%/usage.xml
+%%PORTDOCS%%%%DOCSDIR%%/usage_album.html
+%%PORTDOCS%%%%DOCSDIR%%/usage_album.xml
+%%PORTDOCS%%%%DOCSDIR%%/usage_custom.html
+%%PORTDOCS%%%%DOCSDIR%%/usage_custom.xml
+%%PORTDOCS%%%%DOCSDIR%%/usage_desc.html
+%%PORTDOCS%%%%DOCSDIR%%/usage_desc.xml
+%%PORTDOCS%%%%DOCSDIR%%/usage_desc_cli.html
+%%PORTDOCS%%%%DOCSDIR%%/usage_desc_cli.xml
+%%PORTDOCS%%%%DOCSDIR%%/usage_desc_gui.html
+%%PORTDOCS%%%%DOCSDIR%%/usage_desc_gui.xml
+%%PORTDOCS%%%%DOCSDIR%%/usage_desc_gui_feh.html
+%%PORTDOCS%%%%DOCSDIR%%/usage_desc_gui_feh.xml
+%%PORTDOCS%%%%DOCSDIR%%/usage_desc_gui_gqview.html
+%%PORTDOCS%%%%DOCSDIR%%/usage_desc_gui_gqview.xml
+%%PORTDOCS%%%%DOCSDIR%%/usage_desc_gui_nautilus.html
+%%PORTDOCS%%%%DOCSDIR%%/usage_desc_gui_nautilus.xml
+%%PORTDOCS%%%%DOCSDIR%%/usage_desc_xml.html
+%%PORTDOCS%%%%DOCSDIR%%/usage_desc_xml.xml
+%%PORTDOCS%%%%DOCSDIR%%/usage_httpd.html
+%%PORTDOCS%%%%DOCSDIR%%/usage_httpd.xml
+%%PORTDOCS%%%%DOCSDIR%%/usage_tools.html
+%%PORTDOCS%%%%DOCSDIR%%/usage_tools.xml
+share/locale/ca/LC_MESSAGES/bins.mo
share/locale/de/LC_MESSAGES/bins.mo
+share/locale/eo/LC_MESSAGES/bins.mo
share/locale/es/LC_MESSAGES/bins.mo
+share/locale/fi/LC_MESSAGES/bins.mo
share/locale/fr/LC_MESSAGES/bins.mo
+share/locale/hu/LC_MESSAGES/bins.mo
share/locale/it/LC_MESSAGES/bins.mo
+share/locale/ja/LC_MESSAGES/bins.mo
+share/locale/nl/LC_MESSAGES/bins.mo
share/locale/pl/LC_MESSAGES/bins.mo
share/locale/ru/LC_MESSAGES/bins.mo
-share/locale/zh/LC_MESSAGES/bins.mo
+share/locale/zh_TW/LC_MESSAGES/bins.mo
@dirrmtry share/locale/pl/LC_MESSAGES
@dirrmtry share/locale/pl
-%%PORTDOCS%%@dirrm share/doc/bins
-@dirrm share/bins/templates.joi/static
-@dirrm share/bins/templates.joi
-@dirrm share/bins/templates.default
-@dirrm share/bins
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%/templates.swigs
+@dirrm %%DATADIR%%/templates.satyap/static
+@dirrm %%DATADIR%%/templates.satyap
+@dirrm %%DATADIR%%/templates.petrus/static
+@dirrm %%DATADIR%%/templates.petrus
+@dirrm %%DATADIR%%/templates.mwolson/static
+@dirrm %%DATADIR%%/templates.mwolson
+@dirrm %%DATADIR%%/templates.martin/static
+@dirrm %%DATADIR%%/templates.martin
+@dirrm %%DATADIR%%/templates.marc/static
+@dirrm %%DATADIR%%/templates.marc
+@dirrm %%DATADIR%%/templates.joi/static
+@dirrm %%DATADIR%%/templates.joi
+@dirrm %%DATADIR%%/templates.default
+@dirrm %%DATADIR%%