aboutsummaryrefslogtreecommitdiff
path: root/www/blogsum
diff options
context:
space:
mode:
authorYi-Jheng Lin <yzlin@FreeBSD.org>2009-12-04 15:48:10 +0000
committerYi-Jheng Lin <yzlin@FreeBSD.org>2009-12-04 15:48:10 +0000
commit98babe36dbc6f3f39d34b34b32a7d0fff9ce8e28 (patch)
tree6d5cd11f15e3f14a2412389a631a2aad54c367d5 /www/blogsum
parentd3790a5ced2bb6e32b3b677338eeb0fc7ba8e641 (diff)
downloadports-98babe36dbc6f3f39d34b34b32a7d0fff9ce8e28.tar.gz
ports-98babe36dbc6f3f39d34b34b32a7d0fff9ce8e28.zip
Notes
Diffstat (limited to 'www/blogsum')
-rw-r--r--www/blogsum/Makefile15
-rw-r--r--www/blogsum/distinfo6
-rw-r--r--www/blogsum/files/pkg-message.in24
-rw-r--r--www/blogsum/pkg-plist65
4 files changed, 58 insertions, 52 deletions
diff --git a/www/blogsum/Makefile b/www/blogsum/Makefile
index 43e293902d7a..fd2c5645df14 100644
--- a/www/blogsum/Makefile
+++ b/www/blogsum/Makefile
@@ -6,15 +6,13 @@
#
PORTNAME= blogsum
-PORTVERSION= 0.9
+PORTVERSION= 1.1
CATEGORIES= www
MASTER_SITES= http://www.dixongroup.net/
MAINTAINER= jhuldtgren@gmail.com
COMMENT= Simple weblog
-WWWROOT?= ${PREFIX}/www/
-
PERL_MODULES= ${APXS}:${PORTSDIR}/${APACHE_PORT} \
${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
${SITE_PERL}/${PERL_ARCH}/DBD/SQLite.pm:${PORTSDIR}/databases/p5-DBD-SQLite \
@@ -43,10 +41,9 @@ PERL_MODULES+= ${LOCALBASE}/libexec/apache/libperl.so:${PORTSDIR}/www/mod_perl \
.endif
RUN_DEPENDS+= ${PERL_MODULES}
-PLIST_SUB= WWWROOT=${WWWROOT:S,${PREFIX}/,,}
SUB_FILES= pkg-message
-SUB_LIST= WWWROOT=${WWWROOT} APACHEETCDIR=${APACHEETCDIR} APACHEMODDIR=${APACHEMODDIR}
+SUB_LIST+= APACHEETCDIR=${APACHEETCDIR} APACHEMODDIR=${APACHEMODDIR} WWWOWN=${WWWOWN}
.include <bsd.port.pre.mk>
@@ -54,13 +51,13 @@ pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "You may set following options:"
@${ECHO_MSG} ""
- @${ECHO_MSG} "WITH_APACHE2=1 Use apache2+ instead of apache 1.3"
- @${ECHO_MSG} "WWWROOT=${PREFIX}/www/ Where do you put httpd's document root?"
+ @${ECHO_MSG} "WITH_APACHE2=yes Use apache2+ instead of apache 1.3"
+ @${ECHO_MSG} "WWWDIR=${WWWDIR} Where do you put httpd's document root?"
@${ECHO_MSG} ""
do-install:
- ${MKDIR} ${WWWROOT}/blogsum
- @ cd ${WRKSRC} && ${COPYTREE_SHARE} . ${WWWROOT}/blogsum
+ @${MKDIR} ${WWWDIR}
+ @ cd ${WRKSRC} && ${COPYTREE_SHARE} . ${WWWDIR}
post-install:
@${ECHO_MSG} ""
diff --git a/www/blogsum/distinfo b/www/blogsum/distinfo
index 4eba20281d92..b5229b3a2425 100644
--- a/www/blogsum/distinfo
+++ b/www/blogsum/distinfo
@@ -1,3 +1,3 @@
-MD5 (blogsum-0.9.tar.gz) = 0eaf8b13cd3a2720ee7a93e3e2c4bcd9
-SHA256 (blogsum-0.9.tar.gz) = 2d5b5cdf7f9013df179b5df781a097c3d258d2794aa388ad69b1a0df1fcdda42
-SIZE (blogsum-0.9.tar.gz) = 19444
+MD5 (blogsum-1.1.tar.gz) = ce6399d80e0308b43223049c2b3442d2
+SHA256 (blogsum-1.1.tar.gz) = 99bf35af599215ef22a85dc2d1903309953c9d6b58d000a75949bc1258991494
+SIZE (blogsum-1.1.tar.gz) = 21722
diff --git a/www/blogsum/files/pkg-message.in b/www/blogsum/files/pkg-message.in
index 9dc75ce006b3..2f892321bd2b 100644
--- a/www/blogsum/files/pkg-message.in
+++ b/www/blogsum/files/pkg-message.in
@@ -2,24 +2,33 @@
1) Setup the SQLite database:
- $ sudo -u www sqlite3 %%WWWROOT%%/blogsum/data/site.db < \
- %%WWWROOT%%/blogsum/examples/create_sqlite.sql
+ $ su -m %%WWWOWN%% -c 'sqlite3 %%WWWDIR%%/data/site.db < \
+ %%WWWDIR%%/examples/create_sqlite.sql'
2) Create your local configuration and modify as necessary:
- $ sudo cp %%WWWROOT%%/blogsum/Blogsum/Config.pm.dist \
- %%WWWROOT%%/blogsum/Blogsum/Config.pm
+ $ cp %%WWWDIR%%/Blogsum/Config.pm.dist \
+ %%WWWDIR%%/Blogsum/Config.pm
+
+################################################################
+NOTE: If you are updating from blogsum 0.9 you should merge the
+relevant changes from %%WWWDIR%%/Blogsum/Config.pm.dist
+into your current %%WWWDIR%%/Blogsum/Config.pm
+###############################################################
3) If comments will be enabled, visit the CAPTCHA (http://www.captcha.net/)
project and register your account. Add your keys to Config.pm.
-4) Edit the example httpd-blogsum.conf and enable it for your site:
+4) Edit the example httpd-blogsum.conf (httpd2-blogsum.conf if you are using
+ apache2+) and enable it for your site:
- $ sudo cp %%WWWROOT%%/blogsum/examples/httpd-blogsum.conf %%PREFIX%%/%%APACHEETCDIR%%/conf
+ $ cp %%WWWDIR%%/examples/httpd-blogsum.conf %%PREFIX%%/%%APACHEETCDIR%%/conf
+ or
+ $ cp %%WWWDIR%%/examples/httpd2-blogsum.conf %%PREFIX%%/%%APACHEETCDIR%%/conf
5) Create your AuthUserFile file as defined in httpd-blogsum.conf:
- $ sudo htpasswd -c %%APACHEETCDIR%%/conf/blogsum.htpasswd
+ $ sudo htpasswd -c %%PREFIX%%/%%APACHEETCDIR%%/conf/blogsum.htpasswd
6) Enable the following modules in %%APACHEETCDIR%%/httpd.conf:
@@ -29,7 +38,6 @@
7) Stop and start your Apache service.
-
The installation should now be complete. Your blogsum installation can be
viewed at http://localhost/blogsum/index.cgi. Posts can be created and
edited at http://localhost/blogsum/admin.cgi.
diff --git a/www/blogsum/pkg-plist b/www/blogsum/pkg-plist
index f18861f65be9..535c4df3f4b7 100644
--- a/www/blogsum/pkg-plist
+++ b/www/blogsum/pkg-plist
@@ -1,32 +1,33 @@
-%%WWWROOT%%/blogsum/Blogsum/Config.pm.dist
-%%WWWROOT%%/blogsum/admin.cgi
-%%WWWROOT%%/blogsum/docs/LICENSE
-%%WWWROOT%%/blogsum/docs/LICENSE.images
-%%WWWROOT%%/blogsum/docs/README
-%%WWWROOT%%/blogsum/examples/create_sqlite.sql
-%%WWWROOT%%/blogsum/examples/httpd-blogsum.conf
-%%WWWROOT%%/blogsum/examples/wp2blogsum.pl
-%%WWWROOT%%/blogsum/index.cgi
-%%WWWROOT%%/blogsum/startup.pl
-%%WWWROOT%%/blogsum/themes/default/admin.tmpl
-%%WWWROOT%%/blogsum/themes/default/images/asterisk-green.gif
-%%WWWROOT%%/blogsum/themes/default/images/asterisk-red.gif
-%%WWWROOT%%/blogsum/themes/default/images/check.gif
-%%WWWROOT%%/blogsum/themes/default/images/delete.gif
-%%WWWROOT%%/blogsum/themes/default/images/draft-disabled.gif
-%%WWWROOT%%/blogsum/themes/default/images/draft.gif
-%%WWWROOT%%/blogsum/themes/default/images/play-disabled.gif
-%%WWWROOT%%/blogsum/themes/default/images/play.gif
-%%WWWROOT%%/blogsum/themes/default/images/plus.gif
-%%WWWROOT%%/blogsum/themes/default/images/xml.gif
-%%WWWROOT%%/blogsum/themes/default/index.tmpl
-%%WWWROOT%%/blogsum/themes/default/style.css
-@exec mkdir -p %D %%WWWROOT%%/blogsum/data/
-@dirrm %%WWWROOT%%/blogsum/Blogsum
-@dirrm %%WWWROOT%%/blogsum/data
-@dirrm %%WWWROOT%%/blogsum/docs
-@dirrm %%WWWROOT%%/blogsum/examples
-@dirrm %%WWWROOT%%/blogsum/themes/default/images
-@dirrm %%WWWROOT%%/blogsum/themes/default
-@dirrm %%WWWROOT%%/blogsum/themes
-@dirrm %%WWWROOT%%/blogsum/
+%%WWWDIR%%/Blogsum/Config.pm.dist
+%%WWWDIR%%/admin.cgi
+%%WWWDIR%%/docs/LICENSE
+%%WWWDIR%%/docs/LICENSE.images
+%%WWWDIR%%/docs/README
+%%WWWDIR%%/examples/create_sqlite.sql
+%%WWWDIR%%/examples/httpd-blogsum.conf
+%%WWWDIR%%/examples/httpd2-blogsum.conf
+%%WWWDIR%%/examples/wp2blogsum.pl
+%%WWWDIR%%/index.cgi
+%%WWWDIR%%/startup.pl
+%%WWWDIR%%/themes/default/admin.tmpl
+%%WWWDIR%%/themes/default/images/asterisk-green.gif
+%%WWWDIR%%/themes/default/images/asterisk-red.gif
+%%WWWDIR%%/themes/default/images/check.gif
+%%WWWDIR%%/themes/default/images/delete.gif
+%%WWWDIR%%/themes/default/images/draft-disabled.gif
+%%WWWDIR%%/themes/default/images/draft.gif
+%%WWWDIR%%/themes/default/images/play-disabled.gif
+%%WWWDIR%%/themes/default/images/play.gif
+%%WWWDIR%%/themes/default/images/plus.gif
+%%WWWDIR%%/themes/default/images/xml.gif
+%%WWWDIR%%/themes/default/index.tmpl
+%%WWWDIR%%/themes/default/style.css
+@exec mkdir -p %D %%WWWDIR%%/data/
+@dirrm %%WWWDIR%%/themes/default/images
+@dirrm %%WWWDIR%%/themes/default
+@dirrm %%WWWDIR%%/themes
+@dirrm %%WWWDIR%%/examples
+@dirrm %%WWWDIR%%/docs
+@dirrm %%WWWDIR%%/data
+@dirrm %%WWWDIR%%/Blogsum
+@dirrm %%WWWDIR%%