aboutsummaryrefslogtreecommitdiff
path: root/www/bluefish-devel
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-04-18 06:36:34 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-04-18 06:36:34 +0000
commit0eac55462970d24206f2043faea2d3bcc0f7b43e (patch)
tree062dcd1955aecffb64f3765926d29b24b9848f2c /www/bluefish-devel
parent8a905ff3204fe00d7006820db88ef645fb3d21d3 (diff)
downloadports-0eac55462970d24206f2043faea2d3bcc0f7b43e.tar.gz
ports-0eac55462970d24206f2043faea2d3bcc0f7b43e.zip
Notes
Diffstat (limited to 'www/bluefish-devel')
-rw-r--r--www/bluefish-devel/Makefile6
-rw-r--r--www/bluefish-devel/distinfo2
-rw-r--r--www/bluefish-devel/files/patch-src::bluefish.c10
3 files changed, 14 insertions, 4 deletions
diff --git a/www/bluefish-devel/Makefile b/www/bluefish-devel/Makefile
index e7307f445486..345bb08c0a6e 100644
--- a/www/bluefish-devel/Makefile
+++ b/www/bluefish-devel/Makefile
@@ -6,14 +6,14 @@
#
PORTNAME= bluefish
-PORTVERSION= 0.9.20030223
+PORTVERSION= 0.9.20030308
CATEGORIES= www editors
MASTER_SITES= http://pkedu.fbt.eitn.wau.nl/~olivier/${DOWNLOAD}/ \
ftp://bluefish.advancecreations.com/pub/bluefish/${DOWNLOAD}/ \
http://bluefish.mrball.net/${DOWNLOAD}/ \
ftp://ftp.ratisbona.com/pub/bluefish/${DOWNLOAD}/ \
http://bluefish.shellhung.org/${DOWNLOAD}/
-DISTNAME= ${PORTNAME}-gtk2port-2003-02-23
+DISTNAME= ${PORTNAME}-gtk2port-2003-03-08
EXTRACT_SUFX= .tgz
MAINTAINER= einekoai@chello.nl
@@ -37,7 +37,7 @@ USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --with-gnome2-menu=/${PREFIX}/share/gnome/apps/Applications
+CONFIGURE_ARGS= --with-gnome2-menu=${PREFIX}/share/gnome/apps/Applications
.include <bsd.port.pre.mk>
diff --git a/www/bluefish-devel/distinfo b/www/bluefish-devel/distinfo
index 6bb926a36ab1..105985de0d8f 100644
--- a/www/bluefish-devel/distinfo
+++ b/www/bluefish-devel/distinfo
@@ -1 +1 @@
-MD5 (bluefish-gtk2port-2003-02-23.tgz) = 6a1f8b475b0b5a07f8252eae43ecbb45
+MD5 (bluefish-gtk2port-2003-03-08.tgz) = 3e648b1885aaf638336582cdc9f9df0a
diff --git a/www/bluefish-devel/files/patch-src::bluefish.c b/www/bluefish-devel/files/patch-src::bluefish.c
new file mode 100644
index 000000000000..334093824723
--- /dev/null
+++ b/www/bluefish-devel/files/patch-src::bluefish.c
@@ -0,0 +1,10 @@
+--- src/bluefish.c.orig Sat Mar 8 04:55:40 2003
++++ src/bluefish.c Thu Apr 17 23:04:31 2003
+@@ -21,6 +21,7 @@
+ #include <gtk/gtk.h>
+ #include <unistd.h> /* getopt() */
+ #include <stdlib.h> /* getopt() exit() and abort() on Solaris */
++#include <sys/stat.h>
+
+ #include "bluefish.h"
+