aboutsummaryrefslogtreecommitdiff
path: root/www/bluefish
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2005-01-13 21:26:35 +0000
committerKoop Mast <kwm@FreeBSD.org>2005-01-13 21:26:35 +0000
commit8a8d03df5be351545bf1196a82076be8b7ada2eb (patch)
treec206c6ca23bd76488b5b0a17e80570a41bd9474a /www/bluefish
parente8c46b83702f04c1f9dc097d7708e9570f674936 (diff)
downloadports-8a8d03df5be351545bf1196a82076be8b7ada2eb.tar.gz
ports-8a8d03df5be351545bf1196a82076be8b7ada2eb.zip
Notes
Diffstat (limited to 'www/bluefish')
-rw-r--r--www/bluefish/Makefile72
-rw-r--r--www/bluefish/distinfo4
-rw-r--r--www/bluefish/files/patch-src_parsedtd.h15
-rw-r--r--www/bluefish/pkg-descr7
-rw-r--r--www/bluefish/pkg-plist85
5 files changed, 93 insertions, 90 deletions
diff --git a/www/bluefish/Makefile b/www/bluefish/Makefile
index 9ebe9ce040a2..60a2a8e30338 100644
--- a/www/bluefish/Makefile
+++ b/www/bluefish/Makefile
@@ -1,53 +1,71 @@
# New ports collection makefile for: bluefish
-# Date created: 25 July 1999
-# Whom: Jim Mock <jim@FreeBSD.org>
+# Date created: 23 January 2003
+# Whom: Koop Mast <einekoai@chello.nl>
#
# $FreeBSD$
#
PORTNAME= bluefish
-PORTVERSION= 0.7
-PORTREVISION= 2
+PORTVERSION= 1.0
CATEGORIES= www editors
-MASTER_SITES= http://pkedu.fbt.eitn.wau.nl/~olivier/downloads/ \
- ftp://bluefish.advancecreations.com/pub/bluefish/downloads/ \
- http://bluefish.mrball.net/downloads/ \
- ftp://ftp.ratisbona.com/pub/bluefish/downloads/ \
- http://bluefish.shellhung.org/downloads/
+MASTER_SITES= http://pkedu.fbt.eitn.wau.nl/~olivier/${DOWNLOAD}/ \
+ ftp://bluefish.advancecreations.com/pub/bluefish/${DOWNLOAD}/ \
+ http://bluefish.mrball.net/${DOWNLOAD}/ \
+ ftp://ftp.ratisbona.com/pub/bluefish/${DOWNLOAD}/ \
+ http://bluefish.shellhung.org/${DOWNLOAD}/
MAINTAINER= kwm@FreeBSD.org
COMMENT= HTML editor designed for the experienced web designer
-RUN_DEPENDS= weblint:${PORTSDIR}/www/weblint
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre \
+ aspell.16:${PORTSDIR}/textproc/aspell
-CONFLICTS= bluefish-0.1*
+.if !defined(WITHOUT_WEBLINT)
+RUN_DEPENDS+= weblint:${PORTSDIR}/www/weblint
+.endif
+.if defined(WITH_TIDY)
+RUN_DEPENDS+= tidy:${PORTSDIR}/www/tidy
+.endif
-USE_GMAKE= yes
+DOWNLOAD= downloads
USE_BZIP2= yes
-USE_PERL5_BUILD=yes
+USE_GNOME= gnomehier gtk20 gnomevfs2
USE_X_PREFIX= yes
-USE_GNOME= imlib
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-install-location="${X11BASE}/lib/bluefish"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --with-freedesktop_org-menu=${PREFIX}/share/gnome/applications \
+ --with-freedesktop_org-mime=${PREFIX}/share/mime \
+ --with-gnome2_4-mime=${PREFIX}/share/gnome/mime-info \
+ --with-gnome2_4-appreg=${PREFIX}/share/gnome/application-registry \
+ --with-icon-path=${PREFIX}/share/gnome/pixmaps
-.include <bsd.port.pre.mk>
+# Turns debugging output on
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --with-debugging-output
+.endif
-.if defined(WITH_AUTO_COMPLETE)
-CONFIGURE_ARGS+= --with-autocomplet
+.if defined(WITHOUT_SPLASH)
+CONFIGURE_ARGS+= --disable-splash-screen
.endif
-MANCOMPRESSED= no
MAN1= bluefish.1
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Bluefish has the following tunable option(s):"
+ @${ECHO_MSG} " WITH_DEBUG for debug support"
+ @${ECHO_MSG} " WITHOUT_WEBLINT disable the weblint syntax and style checker"
+ @${ECHO_MSG} " WITH_TIDY for the tidy html cleanup program"
+ @${ECHO_MSG} " WITHOUT_SPLASH disable the splash screen"
+ @${ECHO_MSG} ""
+
post-patch:
- @${PERL} -pi -e 's|gtk-config|${GTK_CONFIG}|g;' ${WRKSRC}/configure
+# @${REINPLACE_CMD} -e 's|/applications/|/apps/Applications/|g' \
+# ${WRKSRC}/data/Makefile.in
post-install:
-.if !defined(NOPORTDOCS)
- @${ECHO} "===> Installing bluefish docs in ${PREFIX}/share/doc/bluefish"
- @${ECHO} "===> A manual is available online at http://bluefish.linuxbox.com/manual/"
- @${MKDIR} ${PREFIX}/share/doc/bluefish && ${CHMOD} a+rx ${PREFIX}/share/doc/bluefish
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/bluefish
-.endif
+ @${INSTALL_SCRIPT} ${WRKSRC}/debian/bluefish.1 ${PREFIX}/man/man1/bluefish.1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/bluefish/distinfo b/www/bluefish/distinfo
index 154f60859bb9..9ca3b69a120a 100644
--- a/www/bluefish/distinfo
+++ b/www/bluefish/distinfo
@@ -1,2 +1,2 @@
-MD5 (bluefish-0.7.tar.bz2) = f3085245839edb278b77f6c3619ed396
-SIZE (bluefish-0.7.tar.bz2) = 1686219
+MD5 (bluefish-1.0.tar.bz2) = a3cf8abd282d850407e8c7eed38d15e7
+SIZE (bluefish-1.0.tar.bz2) = 1372325
diff --git a/www/bluefish/files/patch-src_parsedtd.h b/www/bluefish/files/patch-src_parsedtd.h
deleted file mode 100644
index b1dc1fc0b5c8..000000000000
--- a/www/bluefish/files/patch-src_parsedtd.h
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/parsedtd.h.orig Sat Nov 17 15:32:46 2001
-+++ src/parsedtd.h Sat Nov 22 14:58:35 2003
-@@ -135,10 +135,8 @@
- #define DTD_HTML_4_01T "!DOCTYPE HTML PUBLIC \"-//W3C//DTD HTML 4.01 Transitional//EN\""
- #define DTD_XHTML_1_0 "!DOCTYPE html PUBLIC \"-//W3C//DTD XHTML 1.0//EN\""
- #define DTD_XHTML_1_0S "!DOCTYPE html PUBLIC \"-//W3C//DTD XHTML 1.0 Strict//EN\" \"DTD/xhtml1-strict.dtd\""
--#define DTD_XHTML_1_0F "!DOCTYPE html PUBLIC \"-//W3C//DTD XHTML 1.0 Frameset//EN\"
--\"DTD/xhtml1-frameset.dtd\""
--#define DTD_XHTML_1_0T "!DOCTYPE html PUBLIC \"-//W3C//DTD XHTML 1.0 Transitional//EN\"
--\"DTD/xhtml1-transitional.dtd\""
-+#define DTD_XHTML_1_0F "!DOCTYPE html PUBLIC \"-//W3C//DTD XHTML 1.0 Frameset//EN\" \"DTD/xhtml1-frameset.dtd\""
-+#define DTD_XHTML_1_0T "!DOCTYPE html PUBLIC \"-//W3C//DTD XHTML 1.0 Transitional//EN\" \"DTD/xhtml1-transitional.dtd\""
- #define DTD_XHTML_1_1 "!DOCTYPE html PUBLIC \"-//IETF//DTD XHTML 1.1//EN\""
-
- extern SGML_doctype HTML_doctypes[];
diff --git a/www/bluefish/pkg-descr b/www/bluefish/pkg-descr
index 202951a91d17..0c573e8b771b 100644
--- a/www/bluefish/pkg-descr
+++ b/www/bluefish/pkg-descr
@@ -1,6 +1,5 @@
-Bluefish is an advanced HTML editor that contains functionality for
-PHP, SSI, and RXML. It is designed for the experienced web designer.
+Bluefish is a powerful editor for experienced web designers and programmers.
+Bluefish supports many programming and markup languages, but it focuses on
+editing dynamic and interactive websites
WWW: http://bluefish.openoffice.nl/
-
-- Jim <jim@FreeBSD.org>
diff --git a/www/bluefish/pkg-plist b/www/bluefish/pkg-plist
index a92f27ce8bb3..a811c3fa89c5 100644
--- a/www/bluefish/pkg-plist
+++ b/www/bluefish/pkg-plist
@@ -1,48 +1,49 @@
bin/bluefish
-share/bluefish/frameset.dtd
-share/bluefish/gen_php3_functions
-share/bluefish/gen_php4_functions
-share/bluefish/gen_rxml_functions
-share/bluefish/html-0.dtd
-share/bluefish/html-0s.dtd
-share/bluefish/html-1.dtd
-share/bluefish/html-1s.dtd
-share/bluefish/html-2.1e.dtd
-share/bluefish/html-3.2.dtd
-share/bluefish/html-3.dtd
-share/bluefish/html-3s.dtd
-share/bluefish/html-4-frameset.dtd
-share/bluefish/html-4-strict.dtd
-share/bluefish/html-4.dtd
-share/bluefish/html-s.dtd
-share/bluefish/html.dtd
-share/bluefish/loose.dtd
-share/bluefish/php3_functions
-share/bluefish/php4_functions
-share/bluefish/rxml_functions
-share/bluefish/ssi_functions
-share/bluefish/strict.dtd
-share/bluefish/xhtml1-frameset.dtd
-share/bluefish/xhtml1-strict.dtd
-share/bluefish/xhtml1-transitional.dtd
-share/doc/bluefish/README
-share/locale/de/LC_MESSAGES/bluefish.mo
+share/bluefish/bluefish_splash.png
+share/bluefish/custom_menu.de.default
+share/bluefish/custom_menu.default
+share/bluefish/custom_menu.fr.default
+share/bluefish/encodings.default
+share/bluefish/filetypes.default
+share/bluefish/funcref_css.xml
+share/bluefish/funcref_html.xml
+share/bluefish/funcref_php.xml
+share/bluefish/funcref_python.xml
+share/bluefish/highlighting.default
+share/bluefish/icon_c.png
+share/bluefish/icon_cfml.png
+share/bluefish/icon_dir.png
+share/bluefish/icon_html.png
+share/bluefish/icon_image.png
+share/bluefish/icon_java.png
+share/bluefish/icon_pascal.png
+share/bluefish/icon_php.png
+share/bluefish/icon_python.png
+share/bluefish/icon_r.png
+share/bluefish/icon_unknown.png
+share/bluefish/icon_xml.png
+share/gnome/application-registry/bluefish.applications
+share/gnome/applications/bluefish.desktop
+share/gnome/mime-info/bluefish.keys
+share/gnome/mime-info/bluefish.mime
+share/gnome/pixmaps/bluefish-icon.png
+share/gnome/pixmaps/gnome-application-bluefish-project.png
share/locale/da/LC_MESSAGES/bluefish.mo
-share/locale/fr/LC_MESSAGES/bluefish.mo
-share/locale/ru/LC_MESSAGES/bluefish.mo
-share/locale/ro/LC_MESSAGES/bluefish.mo
-share/locale/cs/LC_MESSAGES/bluefish.mo
+share/locale/de/LC_MESSAGES/bluefish.mo
share/locale/es/LC_MESSAGES/bluefish.mo
-share/locale/el/LC_MESSAGES/bluefish.mo
-share/locale/en/LC_MESSAGES/bluefish.mo
-share/locale/ja/LC_MESSAGES/bluefish.mo
+share/locale/fi/LC_MESSAGES/bluefish.mo
+share/locale/fr/LC_MESSAGES/bluefish.mo
share/locale/it/LC_MESSAGES/bluefish.mo
-share/locale/sv/LC_MESSAGES/bluefish.mo
-share/locale/pt_BR/LC_MESSAGES/bluefish.mo
-share/locale/hu/LC_MESSAGES/bluefish.mo
+share/locale/no/LC_MESSAGES/bluefish.mo
share/locale/pl/LC_MESSAGES/bluefish.mo
-share/locale/nl/LC_MESSAGES/bluefish.mo
-share/pixmaps/bluefish_icon.xpm
-@dirrm share/bluefish/man1
+share/locale/pt/LC_MESSAGES/bluefish.mo
+share/locale/pt_BR/LC_MESSAGES/bluefish.mo
+share/locale/ru/LC_MESSAGES/bluefish.mo
+share/locale/sr/LC_MESSAGES/bluefish.mo
+share/locale/sv/LC_MESSAGES/bluefish.mo
+share/locale/zh_CN/LC_MESSAGES/bluefish.mo
+share/mime/XMLnamespaces
+share/mime/globs
+share/mime/magic
+share/mime/packages/bluefish.xml
@dirrm share/bluefish
-@dirrm share/doc/bluefish