aboutsummaryrefslogtreecommitdiff
path: root/www/bluefish
diff options
context:
space:
mode:
authorBarbara Guida <bar@FreeBSD.org>2014-06-11 23:31:25 +0000
committerBarbara Guida <bar@FreeBSD.org>2014-06-11 23:31:25 +0000
commit389e261e6f9619e57f8c21de9e0556e38e03726b (patch)
tree2e6c0870a1429fd97639c8f901f2510b404b5fa6 /www/bluefish
parent0c2f9bbfced2b072fb9839ba5d5799dfd5a62ddd (diff)
downloadports-389e261e6f9619e57f8c21de9e0556e38e03726b.tar.gz
ports-389e261e6f9619e57f8c21de9e0556e38e03726b.zip
Notes
Diffstat (limited to 'www/bluefish')
-rw-r--r--www/bluefish/Makefile30
-rw-r--r--www/bluefish/pkg-descr2
-rw-r--r--www/bluefish/pkg-plist68
3 files changed, 49 insertions, 51 deletions
diff --git a/www/bluefish/Makefile b/www/bluefish/Makefile
index 522653ed4f70..bbb59ed52e6a 100644
--- a/www/bluefish/Makefile
+++ b/www/bluefish/Makefile
@@ -3,6 +3,7 @@
PORTNAME= bluefish
PORTVERSION= 2.2.3
+PORTREVISION= 1
CATEGORIES= www editors
MASTER_SITES= http://www.bennewitz.com/bluefish/stable/source/ \
http://bluefish.mrball.net/stable/source/ \
@@ -11,16 +12,18 @@ MASTER_SITES= http://www.bennewitz.com/bluefish/stable/source/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= HTML editor designed for the experienced web designer
-LIB_DEPENDS= pcre.3:${PORTSDIR}/devel/pcre \
- enchant.1:${PORTSDIR}/textproc/enchant \
- gucharmap.7:${PORTSDIR}/deskutils/gucharmap
+LICENSE= GPLv2
+
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre \
+ libenchant.so:${PORTSDIR}/textproc/enchant \
+ libgucharmap.so:${PORTSDIR}/deskutils/gucharmap
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
-USE_BZIP2= yes
-USES= gmake pkgconfig
-USE_GNOME= gnomeprefix gtk20 gnomevfs2 gnomemimedata desktopfileutils
+USES= gmake pkgconfig desktop-file-utils shared-mime-info \
+ tar:bzip2 libtool
+USE_GNOME= gnomeprefix gtk20 gnomevfs2 gnomemimedata
WANT_GNOME= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -30,9 +33,7 @@ CONFIGURE_ARGS= --with-gtk2 \
--with-freedesktop_org-mime=${PREFIX}/share/mime \
--with-icon-path=${PREFIX}/share/pixmaps
-MAN1= bluefish.1
-
-OPTIONS_DEFINE= DEBUG TIDY WEBLINT
+OPTIONS_DEFINE= DEBUG NLS TIDY WEBLINT
DEBUG_DESC= Enable debugging output
TIDY_DESC= Include Tidy HTML cleanup program
@@ -40,7 +41,6 @@ WEBLINT_DESC= Include Weblint syntax and style checker
OPTIONS_DEFAULT= WEBLINT
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDEBUG}
@@ -70,13 +70,15 @@ USE_GNOME+= libgnomeui
.endif
pre-install:
- @${MKDIR} ${PREFIX}/share/mime
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/mime
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${MKDIR} ${DOCSDIR}/bflang
- ${INSTALL_DATA} ${WRKSRC}/data/bflang/sample.bflang2 ${DOCSDIR}/bflang
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/bflang
+ ${INSTALL_DATA} ${WRKSRC}/data/bflang/sample.bflang2 \
+ ${STAGEDIR}${DOCSDIR}/bflang
.endif
+ (cd ${STAGEDIR}${PREFIX}/lib/bluefish/ && \
+ ${STRIP_CMD} *.so)
.include <bsd.port.post.mk>
diff --git a/www/bluefish/pkg-descr b/www/bluefish/pkg-descr
index 0c573e8b771b..6a74ccb91382 100644
--- a/www/bluefish/pkg-descr
+++ b/www/bluefish/pkg-descr
@@ -2,4 +2,4 @@ Bluefish is a powerful editor for experienced web designers and programmers.
Bluefish supports many programming and markup languages, but it focuses on
editing dynamic and interactive websites
-WWW: http://bluefish.openoffice.nl/
+WWW: http://bluefish.openoffice.nl/
diff --git a/www/bluefish/pkg-plist b/www/bluefish/pkg-plist
index b8da9e790ab5..49b3b8141fa9 100644
--- a/www/bluefish/pkg-plist
+++ b/www/bluefish/pkg-plist
@@ -1,19 +1,14 @@
bin/bluefish
-lib/bluefish/about.la
lib/bluefish/about.so
-lib/bluefish/charmap.la
lib/bluefish/charmap.so
-lib/bluefish/entities.la
lib/bluefish/entities.so
-lib/bluefish/htmlbar.la
lib/bluefish/htmlbar.so
-lib/bluefish/infbrowser.la
lib/bluefish/infbrowser.so
-lib/bluefish/snippets.la
lib/bluefish/snippets.so
-lib/bluefish/zencoding.la
lib/bluefish/zencoding.so
+man/man1/bluefish.1.gz
share/applications/bluefish.desktop
+share/applications/mimeinfo.cache
%%DATADIR%%/bflang/JQuery.bfinc
%%DATADIR%%/bflang/ada.bflang2
%%DATADIR%%/bflang/all-html.bfinc
@@ -84,25 +79,13 @@ share/applications/bluefish.desktop
%%DATADIR%%/bluefish_splash.png
%%DATADIR%%/default_accelmap
%%DATADIR%%/encodings
-%%DATADIR%%/lorem-ipsum-generator
%%DATADIR%%/lipsum/__init__.py
%%DATADIR%%/lipsum/data/dictionary.txt
%%DATADIR%%/lipsum/data/lipsum.xml
%%DATADIR%%/lipsum/data/sample.txt
+%%DATADIR%%/lorem-ipsum-generator
%%DATADIR%%/plugins/htmlbar/ui/htmlbar_menu_ui.xml
%%DATADIR%%/plugins/zencoding/__init__.py
-%%DATADIR%%/plugins/zencoding/html_matcher.py
-%%DATADIR%%/plugins/zencoding/resources.py
-%%DATADIR%%/plugins/zencoding/utils.py
-%%DATADIR%%/plugins/zencoding/zen_settings.py
-%%DATADIR%%/plugins/zencoding/parser/__init__.py
-%%DATADIR%%/plugins/zencoding/parser/abbreviation.py
-%%DATADIR%%/plugins/zencoding/parser/css.py
-%%DATADIR%%/plugins/zencoding/parser/utils.py
-%%DATADIR%%/plugins/zencoding/parser/xml.py
-%%DATADIR%%/plugins/zencoding/interface/__init__.py
-%%DATADIR%%/plugins/zencoding/interface/editor.py
-%%DATADIR%%/plugins/zencoding/interface/file.py
%%DATADIR%%/plugins/zencoding/actions/__init__.py
%%DATADIR%%/plugins/zencoding/actions/basic.py
%%DATADIR%%/plugins/zencoding/actions/token.py
@@ -118,6 +101,18 @@ share/applications/bluefish.desktop
%%DATADIR%%/plugins/zencoding/filters/single-line.py
%%DATADIR%%/plugins/zencoding/filters/trim.py
%%DATADIR%%/plugins/zencoding/filters/xsl.py
+%%DATADIR%%/plugins/zencoding/html_matcher.py
+%%DATADIR%%/plugins/zencoding/interface/__init__.py
+%%DATADIR%%/plugins/zencoding/interface/editor.py
+%%DATADIR%%/plugins/zencoding/interface/file.py
+%%DATADIR%%/plugins/zencoding/parser/__init__.py
+%%DATADIR%%/plugins/zencoding/parser/abbreviation.py
+%%DATADIR%%/plugins/zencoding/parser/css.py
+%%DATADIR%%/plugins/zencoding/parser/utils.py
+%%DATADIR%%/plugins/zencoding/parser/xml.py
+%%DATADIR%%/plugins/zencoding/resources.py
+%%DATADIR%%/plugins/zencoding/utils.py
+%%DATADIR%%/plugins/zencoding/zen_settings.py
%%DATADIR%%/snippets
%%DATADIR%%/templates/C_header
%%DATADIR%%/templates/C_header_GPL
@@ -149,13 +144,13 @@ share/icons/hicolor/96x96/mimetypes/application-x-bluefish-project.png
share/icons/hicolor/scalable/apps/bluefish-icon.svg
share/icons/hicolor/scalable/mimetypes/bluefish-project.svg
%%NLS%%share/locale/bg/LC_MESSAGES/bluefish.mo
-%%NLS%%share/locale/bg/LC_MESSAGES/bluefish_plugin_zencoding.mo
%%NLS%%share/locale/bg/LC_MESSAGES/bluefish_plugin_about.mo
%%NLS%%share/locale/bg/LC_MESSAGES/bluefish_plugin_charmap.mo
%%NLS%%share/locale/bg/LC_MESSAGES/bluefish_plugin_entities.mo
%%NLS%%share/locale/bg/LC_MESSAGES/bluefish_plugin_htmlbar.mo
%%NLS%%share/locale/bg/LC_MESSAGES/bluefish_plugin_infbrowser.mo
%%NLS%%share/locale/bg/LC_MESSAGES/bluefish_plugin_snippets.mo
+%%NLS%%share/locale/bg/LC_MESSAGES/bluefish_plugin_zencoding.mo
%%NLS%%share/locale/ca/LC_MESSAGES/bluefish.mo
%%NLS%%share/locale/ca/LC_MESSAGES/bluefish_plugin_about.mo
%%NLS%%share/locale/ca/LC_MESSAGES/bluefish_plugin_charmap.mo
@@ -403,23 +398,24 @@ share/pixmaps/application-x-bluefish-project.png
share/pixmaps/bluefish.png
share/xml/bluefish/2.0/bflang2.rng
share/xml/bluefish/catalog.xml
-@dirrm share/xml/bluefish/2.0
-@dirrm share/xml/bluefish
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/bflang
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%DATADIR%%/ui
-@dirrm %%DATADIR%%/templates
-@dirrm %%DATADIR%%/plugins/zencoding/parser
+@dirrm lib/bluefish
+@dirrm %%DATADIR%%/bflang
+@dirrm %%DATADIR%%/bflib
+@dirrm %%DATADIR%%/lipsum/data
+@dirrm %%DATADIR%%/lipsum
+@dirrm %%DATADIR%%/plugins/htmlbar/ui
+@dirrm %%DATADIR%%/plugins/htmlbar
+@dirrm %%DATADIR%%/plugins/zencoding/actions
@dirrm %%DATADIR%%/plugins/zencoding/filters
@dirrm %%DATADIR%%/plugins/zencoding/interface
-@dirrm %%DATADIR%%/plugins/zencoding/actions
+@dirrm %%DATADIR%%/plugins/zencoding/parser
@dirrm %%DATADIR%%/plugins/zencoding
-@dirrm %%DATADIR%%/plugins/htmlbar/ui
-@dirrm %%DATADIR%%/plugins/htmlbar
@dirrm %%DATADIR%%/plugins
-@dirrm %%DATADIR%%/lipsum/data
-@dirrm %%DATADIR%%/lipsum
-@dirrm %%DATADIR%%/bflib
-@dirrm %%DATADIR%%/bflang
+@dirrm %%DATADIR%%/templates
+@dirrm %%DATADIR%%/ui
@dirrm %%DATADIR%%
-@dirrm lib/bluefish
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/bflang
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry share/mime/application
+@dirrm share/xml/bluefish/2.0
+@dirrm share/xml/bluefish