aboutsummaryrefslogtreecommitdiff
path: root/www/bluefish
diff options
context:
space:
mode:
authorJim Mock <jim@FreeBSD.org>2001-12-11 09:45:55 +0000
committerJim Mock <jim@FreeBSD.org>2001-12-11 09:45:55 +0000
commit7f86605c5a86a42098d4a511a0e229234101a233 (patch)
tree13aca3fa658167b60e00b6944d85b034721206aa /www/bluefish
parentf94b04e1b9010539635337b9e1a4da9aa9ce1b50 (diff)
downloadports-7f86605c5a86a42098d4a511a0e229234101a233.tar.gz
ports-7f86605c5a86a42098d4a511a0e229234101a233.zip
Notes
Diffstat (limited to 'www/bluefish')
-rw-r--r--www/bluefish/Makefile16
-rw-r--r--www/bluefish/distinfo2
-rw-r--r--www/bluefish/files/patch-aa92
-rw-r--r--www/bluefish/files/patch-man::Makefile.in11
-rw-r--r--www/bluefish/pkg-plist26
5 files changed, 37 insertions, 110 deletions
diff --git a/www/bluefish/Makefile b/www/bluefish/Makefile
index 48f303cdce9f..b0c90a7ae294 100644
--- a/www/bluefish/Makefile
+++ b/www/bluefish/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bluefish
-PORTVERSION= 0.6
+PORTVERSION= 0.7
CATEGORIES= www editors
MASTER_SITES= http://pkedu.fbt.eitn.wau.nl/~olivier/downloads/ \
ftp://bluefish.advancecreations.com/pub/bluefish/downloads/ \
@@ -23,12 +23,20 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_IMLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-install-location="${X11BASE}/lib/bluefish" \
- --disable-nls
+CONFIGURE_ARGS= --with-install-location="${X11BASE}/lib/bluefish"
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_AUTO_COMPLETE)
+CONFIGURE_ARGS+= --with-autocomplet
+.endif
MANCOMPRESSED= no
MAN1= bluefish.1
+post-patch:
+ @${PERL} -pi -e 's|gtk-config|${GTK_CONFIG}|g;' ${WRKSRC}/configure
+
post-install:
.if !defined(NOPORTDOCS)
@${ECHO} "===> Installing bluefish docs in ${PREFIX}/share/doc/bluefish"
@@ -37,4 +45,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/bluefish
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/bluefish/distinfo b/www/bluefish/distinfo
index 34d8a122fd8e..5b51538f3b3e 100644
--- a/www/bluefish/distinfo
+++ b/www/bluefish/distinfo
@@ -1 +1 @@
-MD5 (bluefish-0.6.tar.bz2) = 29b2da00d3bd72d8bd79e1d7f525e02a
+MD5 (bluefish-0.7.tar.bz2) = f3085245839edb278b77f6c3619ed396
diff --git a/www/bluefish/files/patch-aa b/www/bluefish/files/patch-aa
deleted file mode 100644
index d0fd85d10d90..000000000000
--- a/www/bluefish/files/patch-aa
+++ /dev/null
@@ -1,92 +0,0 @@
---- configure.orig Sun Dec 24 16:31:57 2000
-+++ configure Sun Dec 24 16:32:49 2000
-@@ -3093,8 +3093,8 @@
-
- fi
-
--LIBS="$LIBS `gtk-config --libs`"
--CFLAGS="$CFLAGS `gtk-config --cflags`"
-+LIBS="$LIBS `${GTK_CONFIG} --libs`"
-+CFLAGS="$CFLAGS `${GTK_CONFIG} --cflags`"
-
- # Check whether --with-gtk-prefix or --without-gtk-prefix was given.
- if test "${with_gtk_prefix+set}" = set; then
-@@ -3133,18 +3133,18 @@
- if test x$gtk_config_exec_prefix != x ; then
- gtk_config_args="$gtk_config_args --exec-prefix=$gtk_config_exec_prefix"
- if test x${GTK_CONFIG+set} != xset ; then
-- GTK_CONFIG=$gtk_config_exec_prefix/bin/gtk-config
-+ GTK_CONFIG=$gtk_config_exec_prefix/bin/${GTK_CONFIG}
- fi
- fi
- if test x$gtk_config_prefix != x ; then
- gtk_config_args="$gtk_config_args --prefix=$gtk_config_prefix"
- if test x${GTK_CONFIG+set} != xset ; then
-- GTK_CONFIG=$gtk_config_prefix/bin/gtk-config
-+ GTK_CONFIG=$gtk_config_prefix/bin/${GTK_CONFIG}
- fi
- fi
-
-- # Extract the first word of "gtk-config", so it can be a program name with args.
--set dummy gtk-config; ac_word=$2
-+ # Extract the first word of "${GTK_CONFIG}", so it can be a program name with args.
-+set dummy ${GTK_CONFIG}; ac_word=$2
- echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
- echo "configure:3150: checking for $ac_word" >&5
- if eval "test \"`echo '$''{'ac_cv_path_GTK_CONFIG'+set}'`\" = set"; then
-@@ -3230,16 +3230,16 @@
- (gtk_minor_version != $gtk_config_minor_version) ||
- (gtk_micro_version != $gtk_config_micro_version))
- {
-- printf("\n*** 'gtk-config --version' returned %d.%d.%d, but GTK+ (%d.%d.%d)\n",
-+ printf("\n*** '${GTK_CONFIG} --version' returned %d.%d.%d, but GTK+ (%d.%d.%d)\n",
- $gtk_config_major_version, $gtk_config_minor_version, $gtk_config_micro_version,
- gtk_major_version, gtk_minor_version, gtk_micro_version);
-- printf ("*** was found! If gtk-config was correct, then it is best\n");
-+ printf ("*** was found! If ${GTK_CONFIG} was correct, then it is best\n");
- printf ("*** to remove the old version of GTK+. You may also be able to fix the error\n");
- printf("*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing\n");
- printf("*** /etc/ld.so.conf. Make sure you have run ldconfig if that is\n");
- printf("*** required on your system.\n");
-- printf("*** If gtk-config was wrong, set the environment variable GTK_CONFIG\n");
-- printf("*** to point to the correct copy of gtk-config, and remove the file config.cache\n");
-+ printf("*** If ${GTK_CONFIG} was wrong, set the environment variable GTK_CONFIG\n");
-+ printf("*** to point to the correct copy of ${GTK_CONFIG}, and remove the file config.cache\n");
- printf("*** before re-running configure\n");
- }
- #if defined (GTK_MAJOR_VERSION) && defined (GTK_MINOR_VERSION) && defined (GTK_MICRO_VERSION)
-@@ -3270,10 +3270,10 @@
- printf("*** GTK+ is always available from ftp://ftp.gtk.org.\n");
- printf("***\n");
- printf("*** If you have already installed a sufficiently new version, this error\n");
-- printf("*** probably means that the wrong copy of the gtk-config shell script is\n");
-+ printf("*** probably means that the wrong copy of the ${GTK_CONFIG} shell script is\n");
- printf("*** being found. The easiest way to fix this is to remove the old version\n");
- printf("*** of GTK+, but you can also set the GTK_CONFIG environment to point to the\n");
-- printf("*** correct copy of gtk-config. (In this case, you will have to\n");
-+ printf("*** correct copy of ${GTK_CONFIG}. (In this case, you will have to\n");
- printf("*** modify your LD_LIBRARY_PATH enviroment variable, or edit /etc/ld.so.conf\n");
- printf("*** so that the correct libraries are found at run-time))\n");
- }
-@@ -3304,10 +3304,10 @@
- else
- echo "$ac_t""no" 1>&6
- if test "$GTK_CONFIG" = "no" ; then
-- echo "*** The gtk-config script installed by GTK could not be found"
-+ echo "*** The ${GTK_CONFIG} script installed by GTK could not be found"
- echo "*** If GTK was installed in PREFIX, make sure PREFIX/bin is in"
- echo "*** your path, or set the GTK_CONFIG environment variable to the"
-- echo "*** full path to gtk-config."
-+ echo "*** full path to ${GTK_CONFIG}."
- else
- if test -f conf.gtktest ; then
- :
-@@ -3349,7 +3349,7 @@
- echo "*** The test program failed to compile or link. See the file config.log for the"
- echo "*** exact error that occured. This usually means GTK was incorrectly installed"
- echo "*** or that you have moved GTK since it was installed. In the latter case, you"
-- echo "*** may want to edit the gtk-config script: $GTK_CONFIG"
-+ echo "*** may want to edit the ${GTK_CONFIG} script: $GTK_CONFIG"
- fi
- rm -f conftest*
- CFLAGS="$ac_save_CFLAGS"
diff --git a/www/bluefish/files/patch-man::Makefile.in b/www/bluefish/files/patch-man::Makefile.in
deleted file mode 100644
index 9db80667c0b7..000000000000
--- a/www/bluefish/files/patch-man::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- man/Makefile.in~ Tue Jan 2 18:34:30 2001
-+++ man/Makefile.in Tue Jan 2 18:34:42 2001
-@@ -29,7 +29,7 @@
- exec_prefix = @exec_prefix@
- bindir = $(exec_prefix)/bin
- infodir = $(prefix)/info
--mandir = $(mandirprefix)/man/man1
-+mandir = $(mandirprefix)/man1
- localedir = @localedir@
- gnulocaledir = $(prefix)/share/locale
- aliaspath = $(localedir):.
diff --git a/www/bluefish/pkg-plist b/www/bluefish/pkg-plist
index bed340fa528b..f5eba36a913a 100644
--- a/www/bluefish/pkg-plist
+++ b/www/bluefish/pkg-plist
@@ -1,10 +1,32 @@
bin/bluefish
+share/bluefish/frameset.dtd
+share/bluefish/gen_php3_functions
+share/bluefish/gen_php4_functions
+share/bluefish/gen_rxml_functions
+share/bluefish/html-0.dtd
+share/bluefish/html-0s.dtd
+share/bluefish/html-1.dtd
+share/bluefish/html-1s.dtd
+share/bluefish/html-2.1e.dtd
+share/bluefish/html-3.2.dtd
+share/bluefish/html-3.dtd
+share/bluefish/html-3s.dtd
+share/bluefish/html-4-frameset.dtd
+share/bluefish/html-4-strict.dtd
+share/bluefish/html-4.dtd
+share/bluefish/html-s.dtd
+share/bluefish/html.dtd
+share/bluefish/loose.dtd
share/bluefish/php3_functions
share/bluefish/php4_functions
-share/bluefish/ssi_functions
share/bluefish/rxml_functions
+share/bluefish/ssi_functions
+share/bluefish/strict.dtd
+share/bluefish/xhtml1-frameset.dtd
+share/bluefish/xhtml1-strict.dtd
+share/bluefish/xhtml1-transitional.dtd
share/doc/bluefish/README
share/pixmaps/bluefish_icon.xpm
-@dirrm share/pixmaps
+@dirrm share/bluefish/man1
@dirrm share/bluefish
@dirrm share/doc/bluefish