aboutsummaryrefslogtreecommitdiff
path: root/www/boa
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2003-01-31 13:13:41 +0000
committerPeter Pentchev <roam@FreeBSD.org>2003-01-31 13:13:41 +0000
commitf6941b66534c72e8f24afda41675b076e5baff07 (patch)
tree413e425a1b2c16b1599c63348b3ad3db1033ae7e /www/boa
parent77ab3f6fa6d293ffbd3c0ce9290f18116988bf82 (diff)
downloadports-f6941b66534c72e8f24afda41675b076e5baff07.tar.gz
ports-f6941b66534c72e8f24afda41675b076e5baff07.zip
Notes
Diffstat (limited to 'www/boa')
-rw-r--r--www/boa/Makefile34
-rw-r--r--www/boa/distinfo2
-rw-r--r--www/boa/files/patch-Makefile.in11
-rw-r--r--www/boa/files/patch-docs::Makefile.in11
-rw-r--r--www/boa/files/patch-docs::boa.texi6
-rw-r--r--www/boa/files/patch-examples::boa.conf (renamed from www/boa/files/patch-boa.conf)42
-rw-r--r--www/boa/files/patch-src::boa_grammar.y11
-rw-r--r--www/boa/files/patch-src::defines.h13
-rw-r--r--www/boa/pkg-plist2
9 files changed, 89 insertions, 43 deletions
diff --git a/www/boa/Makefile b/www/boa/Makefile
index 03aaed75ec92..e888554d1760 100644
--- a/www/boa/Makefile
+++ b/www/boa/Makefile
@@ -6,14 +6,15 @@
#
PORTNAME= boa
-PORTVERSION= 0.94.13
+PORTVERSION= 0.94.14.r7
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= http://www.boa.org/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/rc/}
MAINTAINER= sysadmin@alexdupre.com
-WRKSRC= ${WRKDIR}/${DISTNAME}/src
+USE_BZIP2= yes
USE_GMAKE= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
@@ -21,26 +22,25 @@ GNU_CONFIGURE= yes
MAN8= boa.8
post-patch:
- @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/defines.h \
- ${WRKSRC}/../boa.conf
-
-post-build:
- @cd ${WRKSRC}/../docs && ${MAKE} boa.info boa.html boa.txt
+ @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" \
+ ${WRKSRC}/examples/boa.conf ${WRKSRC}/src/defines.h
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/boa ${PREFIX}/sbin
- @${INSTALL_PROGRAM} ${WRKSRC}/boa_indexer ${PREFIX}/sbin
- @${INSTALL_MAN} ${WRKSRC}/../docs/boa.8 ${PREFIX}/man/man8
- @${INSTALL_DATA} ${WRKSRC}/../boa.conf ${PREFIX}/etc/boa.conf.sample
+ @${INSTALL_PROGRAM} ${WRKSRC}/src/boa ${PREFIX}/sbin
+ @${INSTALL_PROGRAM} ${WRKSRC}/src/boa_indexer ${PREFIX}/sbin
+ @${INSTALL_MAN} ${WRKSRC}/docs/boa.8 ${PREFIX}/man/man8
@${MKDIR} ${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/../examples/* ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/examples/boa.conf ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/examples/cgi-test.cgi ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/examples/nph-test.cgi ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/examples/resolver.pl ${EXAMPLESDIR}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/../docs/boa.texi ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/../docs/boa.html ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/../docs/boa.txt ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/../docs/boa_banner.png ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/../docs/boa.info ${PREFIX}/info
+ @${INSTALL_DATA} ${WRKSRC}/docs/boa.texi ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/docs/boa.html ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/docs/boa.txt ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/docs/boa_banner.png ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/docs/boa.info ${PREFIX}/info
@install-info ${PREFIX}/info/boa.info ${PREFIX}/info/dir
.endif
diff --git a/www/boa/distinfo b/www/boa/distinfo
index 81077f818787..35ea8875f61d 100644
--- a/www/boa/distinfo
+++ b/www/boa/distinfo
@@ -1 +1 @@
-MD5 (boa-0.94.13.tar.gz) = c8d6f46f9aa60909f171529068813fe0
+MD5 (boa-0.94.14rc7.tar.bz2) = 0baf8c7454d096c2d43d9f7fce58b3eb
diff --git a/www/boa/files/patch-Makefile.in b/www/boa/files/patch-Makefile.in
new file mode 100644
index 000000000000..e73840a98572
--- /dev/null
+++ b/www/boa/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Mon Nov 25 18:39:27 2002
++++ Makefile.in Mon Nov 25 18:40:07 2002
+@@ -4,7 +4,7 @@
+
+ .PHONY: clean mrclean distclean boa docs
+
+-all: boa
++all: boa docs
+
+ boa:
+ (cd src && $(MAKE) $(MFLAGS))
diff --git a/www/boa/files/patch-docs::Makefile.in b/www/boa/files/patch-docs::Makefile.in
new file mode 100644
index 000000000000..e7856c6a9a2b
--- /dev/null
+++ b/www/boa/files/patch-docs::Makefile.in
@@ -0,0 +1,11 @@
+--- docs/Makefile.in.orig Mon Nov 25 18:38:32 2002
++++ docs/Makefile.in Mon Nov 25 18:38:42 2002
+@@ -3,7 +3,7 @@
+ srcdir = @srcdir@
+ VPATH = @srcdir@
+
+-all: boa.html boa.dvi boa.info boa.txt
++all: boa.html boa.info boa.txt
+
+ boa.info: boa.texi
+ makeinfo --number-sections @ALLSOURCES@
diff --git a/www/boa/files/patch-docs::boa.texi b/www/boa/files/patch-docs::boa.texi
index 13da5e3e8ef0..598c1df5ecf4 100644
--- a/www/boa/files/patch-docs::boa.texi
+++ b/www/boa/files/patch-docs::boa.texi
@@ -1,11 +1,11 @@
---- ../docs/boa.texi.orig Mon Feb 25 12:39:56 2002
-+++ ../docs/boa.texi Mon Feb 25 12:40:28 2002
+--- docs/boa.texi.orig Mon Nov 25 18:28:07 2002
++++ docs/boa.texi Mon Nov 25 18:28:44 2002
@@ -31,7 +31,7 @@
@ifinfo
@dircategory Networking
@direntry
-* Boa: (boa). The Boa Webserver
-+* Boa: (boa). The Boa Webserver
++* Boa: (boa). The Boa Webserver
@end direntry
@end ifinfo
diff --git a/www/boa/files/patch-boa.conf b/www/boa/files/patch-examples::boa.conf
index 647c257d6a9a..6ad8dada8a3b 100644
--- a/www/boa/files/patch-boa.conf
+++ b/www/boa/files/patch-examples::boa.conf
@@ -1,6 +1,17 @@
---- ../boa.conf.orig Fri Mar 22 12:25:29 2002
-+++ ../boa.conf Fri Mar 22 12:28:52 2002
-@@ -108,7 +108,7 @@
+--- examples/boa.conf.orig Mon Nov 25 18:27:13 2002
++++ examples/boa.conf Mon Nov 25 18:33:40 2002
+@@ -45,8 +45,8 @@
+ # User: The name or UID the server should run as.
+ # Group: The group name or GID the server should run as.
+
+-User nobody
+-Group nogroup
++User www
++Group www
+
+ # ServerAdmin: The email address where server problems should be sent.
+ # Note: this is not currently used, except as an environment variable
+@@ -155,7 +155,7 @@
# DocumentRoot: The root directory of the HTML documents.
# Comment out to disable server non user files.
@@ -9,7 +20,7 @@
# UserDir: The name of the directory which is appended onto a user's home
# directory if a ~user request is recieved.
-@@ -127,7 +127,7 @@
+@@ -174,7 +174,7 @@
# DirectoryIndex are commented out, accessing a directory will give
# an error (though accessing files in the directory are still ok).
@@ -18,19 +29,34 @@
# DirectoryCache: If DirectoryIndex doesn't exist, and DirectoryMaker
# has been commented out, the the on-the-fly indexing of Boa can be used
-@@ -161,7 +161,7 @@
+@@ -199,7 +199,7 @@
+ # Set to /dev/null if you do not want to load a mime types file.
+ # Do *not* comment out (better use AddType!)
+
+-MimeTypes /etc/mime.types
++MimeTypes %%PREFIX%%/etc/mime.types
+
+ # DefaultType: MIME type used if the file extension is unknown, or there
+ # is no file extension.
+@@ -208,7 +208,7 @@
# CGIPath: The value of the $PATH environment variable given to CGI progs.
-CGIPath /bin:/usr/bin:/usr/local/bin
-+CGIPath /bin:/usr/bin:%%PREFIX%%/bin
++CGIPath /bin:/usr/bin:%%PREFIX/bin
# SinglePostLimit: The maximum allowable number of bytes in
# a single POST. Default is normally 1MB.
-@@ -190,5 +190,5 @@
+@@ -232,10 +232,10 @@
+ # Aliases: Aliases one path to another.
+ # Example: Alias /path1/bar /path2/foo
+
+-Alias /doc /usr/doc
++Alias /doc /usr/share/doc
+
# ScriptAlias: Maps a virtual path to a directory for serving scripts
# Example: ScriptAlias /htbin/ /www/htbin/
-ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
-+ScriptAlias /cgi-bin/ %%PREFIX%%/www/cgi-bin/
++ScriptAlias /cgi-bin/ %%PREFIX/www/cgi-bin/
diff --git a/www/boa/files/patch-src::boa_grammar.y b/www/boa/files/patch-src::boa_grammar.y
deleted file mode 100644
index ad4a6525e5e7..000000000000
--- a/www/boa/files/patch-src::boa_grammar.y
+++ /dev/null
@@ -1,11 +0,0 @@
---- boa_grammar.y.old Mon Nov 25 16:25:28 2002
-+++ boa_grammar.y Mon Nov 25 16:25:35 2002
-@@ -20,7 +20,7 @@
- *
- */
-
--/* $Id: boa_grammar.y,v 1.14 1999/10/12 14:49:07 jon Exp $*/
-+/* $Id: boa_grammar.y,v 1.14 1999/10/12 14:49:07 jon Exp $ */
-
- #include <string.h>
- #include <stdio.h>
diff --git a/www/boa/files/patch-src::defines.h b/www/boa/files/patch-src::defines.h
index fc74235de3fe..d5e8adbbd503 100644
--- a/www/boa/files/patch-src::defines.h
+++ b/www/boa/files/patch-src::defines.h
@@ -1,5 +1,5 @@
---- defines.h.orig Fri Mar 22 12:30:45 2002
-+++ defines.h Fri Mar 22 12:31:58 2002
+--- src/defines.h.orig Mon Nov 25 18:25:31 2002
++++ src/defines.h Mon Nov 25 18:26:09 2002
@@ -27,7 +27,7 @@
/***** Change this, or use -c on the command line to specify it *****/
@@ -9,3 +9,12 @@
#endif
/***** Change this via the CGIPath configuration value in boa.conf *****/
+@@ -53,7 +53,7 @@
+
+ #define REQUEST_TIMEOUT 60
+
+-#define MIME_TYPES_DEFAULT "/etc/mime.types"
++#define MIME_TYPES_DEFAULT "%%PREFIX%%/etc/mime.types"
+ #define CGI_MIME_TYPE "application/x-httpd-cgi"
+
+ /***** CHANGE ANYTHING BELOW THIS LINE AT YOUR OWN PERIL *****/
diff --git a/www/boa/pkg-plist b/www/boa/pkg-plist
index ec7291a77154..43a43640bb1c 100644
--- a/www/boa/pkg-plist
+++ b/www/boa/pkg-plist
@@ -1,4 +1,3 @@
-etc/boa.conf.sample
etc/rc.d/boa.sh.sample
%%PORTDOCS%%@unexec install-info --delete %D/info/boa.info %D/info/dir
%%PORTDOCS%%info/boa.info
@@ -9,6 +8,7 @@ sbin/boa_indexer
%%PORTDOCS%%share/doc/boa/boa.html
%%PORTDOCS%%share/doc/boa/boa.txt
%%PORTDOCS%%share/doc/boa/boa_banner.png
+share/examples/boa/boa.conf
share/examples/boa/cgi-test.cgi
share/examples/boa/nph-test.cgi
share/examples/boa/resolver.pl